nlight

[1.1] AFBW v1.7-beta (Joystick & controller mod)

Recommended Posts

I'll look at it but I'm useless on this machine. To used to debian. Everything I've tried to build has inexplicably failed in one way or another. Solus is Linux but is NOT a posix system.

Share this post


Link to post
Share on other sites

@taniwha Seemed to work ok, I could adjust sensitivity, and see inputs. I did not see anywhere to reassign buttons, guess you still have to do that from ksp settings. Only log entry with AFBW was for AVC, so I'd say we're good. I' love to help with your project but about all I'm good for with mono is configs, I have actively avoided learning it. Garbage collectors are stupid.

Share this post


Link to post
Share on other sites

@snkiz: all configuration information is in the Data directory (in the source code) or in GameData/AdvancedInput/Plugins/PluginData/AdvancedInput. The deviceconfig.cfg file is meant to hold all the bindings and axis configs (balanced (-1..1) vs unbalanced (0..1), inverted, etc). the saitek_x52.cfg file is what I use to name the axes and buttons. If you edit those appropriately for your controller(you will need to put in the correct device name (shown in the test window), I will include your changes in the repo.

I very much do plan on adding in-game config like what AFBW has (probably AFBW's main selling point, really).

Oh, also, not many button bindings exist yet.

However, thank you for your feedback!

Share this post


Link to post
Share on other sites
13 hours ago, taniwha said:

However, thank you for your feedback!

I was talking about AFBW. you've been a great help however, and I'd like to return the favour. Your gonna have to help me out with the deps to build your AI, or compile one for me, I'll gladly take it for a spin try and come up with a few profiles. But, I'm no pilot. I do what works for me and I have no idea how legit my skills are. 

I've got parts in the mail I'm building a monster ryzen system so I'll be in a much better position to next month. :cool:

Edited by snkiz
Gloating

Share this post


Link to post
Share on other sites

This might get me into flying planes again/at last!

Share this post


Link to post
Share on other sites

 

On 2017-07-10 at 0:31 AM, Grenartia said:

I mean, I don't know what to say, because I tried my Logitech on it with that version, and it didn't even show up.

Having the same problem. 

On 2017-07-10 at 1:47 AM, Drew Kerman said:

try uninstalling/disabling any Logitech controller software that you may have. I don't have any Saitek software installed, just the drivers (altho it did work in previous versions with the Saitek software active as well). I have a Logitech mouse, keyboards, headset, speakers - but I've never been fond of their joysticks. Def recommend the Saitek Pro Flight line

I'm using a Saitek x-55, so doesn't seem to be a Logitech specific issue

On 2017-07-13 at 2:51 AM, taniwha said:

@snkiz: I compiled it for 1.2, but it seems to work in 1.3, so try this zip. If things continue to not work, please get me your log files (generally KSP.log is best). Note that KSP crashing is not worth a log, just a report on when it crashed (eg, during loading, after pressing a high-numbered button, etc).

As a note to all: I don't know i this is Unity in general, or just on Linux, but there seems to be a bug in Unity's joystick support where joysticks with more than twenty buttons (Unity's limit) can cause Unity to crash when some of the excess buttons are pressed. I discovered this because I am writing a new joystick mod (taking many ideas from AFBW), and wasted a day debugging my code only to find that unity with neither my mod nor AFBW installed would still crash with a segfault when I sufficiently played with the hat on my throttle.

That one mentions linux in the file name, could that be why it works for you and not for us? I'm on windows 7, so used the dll posted by Boris

Share this post


Link to post
Share on other sites
On 7/9/2017 at 6:47 PM, Drew Kerman said:

try uninstalling/disabling any Logitech controller software that you may have. I don't have any Saitek software installed, just the drivers (altho it did work in previous versions with the Saitek software active as well). I have a Logitech mouse, keyboards, headset, speakers - but I've never been fond of their joysticks. Def recommend the Saitek Pro Flight line

Sounds expensive. 

Share this post


Link to post
Share on other sites
7 hours ago, Grenartia said:

Sounds expensive. 

not when you're acquiring them all over the course of years

Share this post


Link to post
Share on other sites
15 hours ago, Drew Kerman said:

not when you're acquiring them all over the course of years

That doesn't really help me. 

Share this post


Link to post
Share on other sites

I am trying to make this work. I manually installed the 1.7 release without the toolbar folder. I also replaced the dll with the one posted earlier for windows. Nothing shows up in the toolbar or by pressing shift + L and trying to save settings for control input in the settings menu does nothing. 

I saw while exploring this that linuxgurugamer had a commit 5 days ago....any chance a new working release will be forth coming?

Trying on ksp x64 1.2.2 windows

Edited by Lazy8

Share this post


Link to post
Share on other sites

I have been trying advanced fly-by-wire, and the log file reports to methods not found during loading:

[ERR 21:32:08.261] Error looking up signature for method AdvancedFlyByWire.LoadState

[ERR 21:32:08.261] Error looking up signature for method AdvancedFlyByWire.SaveState
Checking the code, both are their, but LoadState is private so it is unavailable for KSP to use. The second is there and public. I would have thought that it would be visible to the KSP module loader. I would guess that this is the loading problem that keeps it from loading.

 

 

Share this post


Link to post
Share on other sites

Is this a dead mod? Has there been any progress for 1.3+ ? This mod is the only thing making my old school flight stick function. Been watching for ages but no updates, sad :(

Share this post


Link to post
Share on other sites
1 hour ago, ElonsMusk said:

Is this a dead mod? Has there been any progress for 1.3+ ? This mod is the only thing making my old school flight stick function. Been watching for ages but no updates, sad :(

@taniwha may still be considering an update eventually perhaps, but other than that I've not seen any dev activity. It's my goto joystick mod as well for my Saitek X55/X52

Edited by Drew Kerman

Share this post


Link to post
Share on other sites

Windows 7 64 - KSP 1.3.1

Got the mod running using latest build, replacement .dll by Boris and latest Toolbar.

However it does not work as intended:

When I get on EVA all controls still apply to the vessel, not to the Kerbal on EVA!

I can't even get the jet thrusters to work (using the related/mapped AFBW button). Everything remains as if my Kerbal was still in the vessel, although he is already free in space. I can control the Kerbal via keyboard bindings as set in KSP itself, but none of the axes or buttons work for my Kerbal, only for the vessel.

This would be such a great mod, please help!

PS: I've tried other workarounds using UJR, XPadder and stuff, but I couldn't find any better solution than this mod. I was so happy when I got it running and even more disappointed when I found out, that it just doesn't work properly (for me).

 

Share this post


Link to post
Share on other sites

Thank you for trying to help me!

Unfortunately that is exactly the .dll file that I'm using already, so the problem persists, that AFBW doesn't recognize when I am on EVA and still controls the vessel, not the kerbal.

(I'm also using Toolbar continued in the version you linked)

If it's "confirmed" to work there must be something else wrong/different with my KSP install or AFBW install. I have no clue what that could be.

Please keep helping me!

Share this post


Link to post
Share on other sites
On 11/30/2017 at 3:03 PM, bs7599 said:

so the problem persists, that AFBW doesn't recognize when I am on EVA and still controls the vessel, not the kerbal.

I'm betting this is an out of scope issue. I doubt AFBW was ever meant to control kerbals

You can disable AFBW inputs while in the game tho, so a workaround would be to just have a KSP keystrokes profile in your joystick's mapping software you can switch over to while on EVA

Edited by Drew Kerman

Share this post


Link to post
Share on other sites

Hello

I successfully configure AFBW for my X52.

But when i try to test a docking i experience a strange behavior.

So i launch a vessel into orbit , this vessel has 2 sub vessel link by a 2 docking port , so i undock it .

But when i want to rotate one vessel , the other one also rotate !? and this happen only when use the joystick .

Share this post


Link to post
Share on other sites

Is this mod really functional for 1.3.1? I've tried the version on the first page, didn't work so I downloaded the one from the Dropbox link provided on this page (from Boris-Barboris) aswell as the newest Toolbar continued, but it's still not working with 32 nor 64bit version of the game. Hitting Shift+L in-game does nothing and I see no controller icon either. I've checked the advanced_flybywire_config_v21.xml file in my GameData/ksp-advanced-flybywire folder and found that it gets modified during each game, so it must be working to some degree. However, the content has only an empty <controllers /> tag, so it's probably not detecting my HOTAS even although other games can.

I hope it's not because of the newest Logitech drivers instead of the MadCatz SST?

Edited by Hyperion101

Share this post


Link to post
Share on other sites
On 12/21/2017 at 7:33 PM, Hyperion101 said:

Is this mod really functional for 1.3.1?

Yes, I just did a basic control test with my Saitek X55 and everything functioned as normal. To install for KSP v1.2.2+ follow these steps:

  1. Download the latest package from the OP
  2. Overwrite with this DLL
  3. ...
  4. Profit!
Edited by Drew Kerman

Share this post


Link to post
Share on other sites
On 25. 12. 2017 at 4:02 PM, Drew Kerman said:

Yes, I just did a basic control test with my Saitek X55 and everything functioned as normal. To install for KSP v1.2.2+ follow these steps:

  1. Download the latest package from the OP
  2. Overwrite with this DLL
  3. ...
  4. Profit!

That Dropbox link says File not found. I used this one instead https://www.dropbox.com/s/7xz8xcsx9t1bjeb/ksp-advanced-flybywire.dll?dl=0

Tested on both 64 and 32bit versions of the game. Shift + L does nothing, the horrible input delay is still not gone, nor do I see any gamepad button. It still creates that .xml file aswell as PluginData folder but doesn't find my controller. I have a Saitek X52 Pro with newest Logitech drivers.

Share this post


Link to post
Share on other sites
5 hours ago, Hyperion101 said:

I have a Saitek X52 Pro with newest Logitech drivers.

Does Logitech own Saitek now? Why would you have Logitech drivers? If I get some time tomorrow I will test my X52 Pro to see if that is for some reason different, although I had both my X52 and X55 working on v1.2.2 no problems.

Where did you get the link to that DLL? Are you sure it's the same? I've uploaded the one I have here.

Share this post


Link to post
Share on other sites
On 29. 12. 2017 at 7:05 AM, Drew Kerman said:

Does Logitech own Saitek now? Why would you have Logitech drivers? If I get some time tomorrow I will test my X52 Pro to see if that is for some reason different, although I had both my X52 and X55 working on v1.2.2 no problems.

Where did you get the link to that DLL? Are you sure it's the same? I've uploaded the one I have here.

Yeah, Logitech bought Saitek, and I got their drivers because they were newer and I thought it might fix the problem with random characters on my MFD. I also used AFBW on 1.2.x before, where I could at least see the new configuration menu from this mod, although the input lag was still there. If you find it working with the Saitek drivers, I'll try downgrading to Saitek SST.

I've checked the DLL and it's the same file.

Edited by Hyperion101

Share this post


Link to post
Share on other sites

no issues with my X52 either. I'd suggest you nuke your drivers and reinstall. Actually to be honest I can't recall if I even bothered to install drivers for these sticks after I upgraded to Win10. I think I just plugged in and got them through Windows Update - tho I know I did install the control mapping software

Share this post


Link to post
Share on other sites

Logitech doesn't offer to install the drivers and programming software separately anymore, but setups them both in one installer. Did you install the Logitech one (8.0.134.0), or the newest Saitek SST? (7.0.53.6)

Just removed the Logitech drivers, installed Saitek ones, kept the Logitech programming software, restarted, didn't work.
Removed Logitech programming software, installed good ol' Saitek SST, didn't work.
Reinstalled Logitech drivers while retaining the Saitek programming software, getting rid of the Logitech software and keeping only their DirectOutput drivers, didn't work.

Tested on both 64bit and 32bit versions of the game. My AFBW config xml still doesn't list a single controller. How is it possible that it works for everyone else but not me?

Edited by Hyperion101

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.