Jump to content

[1.1.2] FreeEVA 0.6.1


Recommended Posts

Hyomoto: Indeed there is, but should you want to change it in-game, you need to go the the space center, out to the menus, change the setting, back into your save, tracking station, then to your kerbal. Or you can hit Alt-F (or the toolbar button).

Link to post
Share on other sites

Wait, what?!? You updated this 12 days ago, and failed to personally PM me with the good news? LOL. I've been waiting for this update to one of my favorite mods. THANK YOU!! A Forum Rep point to you as well.

Edited by Apollo13
Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

Could be an isolated incident, but I'm getting NullReferenceExceptions, which have crashed my game.

A sample from the output.log file looks like this -

NullReferenceException: Object reference not set to an instance of an object

at FreeEVA.FreeEVAToolbar.OnDestroy () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

If you want the entire output.log and/or additional information, I can provide it.

Link to post
Share on other sites

LordFerret: Hmm, I remember having such an issue in EL (from which I would have copied the code). I'll take a look at EL's logs and FreeEVA's code. Thanks for the heads-up.

[edit]Let me guess, you don't have Toolbar installed, right? If so, I know the fix (indeed. the same bug as in EL is in FreeEVA).

Edited by taniwha
Link to post
Share on other sites
LordFerret: Hmm, I remember having such an issue in EL (from which I would have copied the code). I'll take a look at EL's logs and FreeEVA's code. Thanks for the heads-up.

[edit]Let me guess, you don't have Toolbar installed, right? If so, I know the fix (indeed. the same bug as in EL is in FreeEVA).

I have released 0.5.2 of FreeEVA fixing the above NRE.

Yes, you are correct. I didn't realize it was needed/required(?)

Thank you for addressing the issue so quickly. I will download the update right now and see how things work out. :)

Link to post
Share on other sites
  • 4 weeks later...

Trying to add this into CKAN and I'm finding I can't - your releases on github do not have a "latest" tagged release. Any chance you can do so? If you do, I'll be happy to submit it for you.

Else, someone will have to manually keep the .netkan updated with the download URL and mod version.

Here's what I had written up, if you like:


{
"spec_version" : 1,
"identifier" : "FreeEVA",
"$kref" : "#/ckan/github/taniwha-qf/FreeEVA",
"name" : "FreeEVA",
"author" : "taniwha",
"abstract" : "Control over KSP's automatic orientation of EVA facing",
"license" : "GPL-3.0",
"ksp_version_min" : "1.0.2",
"ksp_version_max" : "1.0.4",
"resources": {
"homepage": "http://forum.kerbalspaceprogram.com/threads/95076"
}
}

Edited by draeath
Link to post
Share on other sites

@taniwha: there is a point! Because even if you rotate you kerbal in random angle, he will switch back to nominal orientation as you touch one of translation buttons. Otherwise, only combination of FreeEVA + EVA Enhancements allows true and total freedom in EVA movement! :)

Also a minor bug report: toggle free EVA mode does not work via toolbar button (but green text says mode on). Nevertheless swiching free EVA mode via Alt-F hotkey works, so this bug is not critical for me :)

Link to post
Share on other sites

ZobrAA: EVA Enhancments has a toggle too. Hmm, though controlling it via SAS? Seems a little awkward, but maybe it makes sense.

Odd that the button doesn't work for you. It works for me. In fact, if you get the green text, then it should be working unless something else is somehow forcing the state.

Link to post
Share on other sites
ZobrAA: EVA Enhancments has a toggle too. Hmm, though controlling it via SAS? Seems a little awkward, but maybe it makes sense.

Oops, I didnt notice that! ^_^

Odd that the button doesn't work for you. It works for me. In fact, if you get the green text, then it should be working unless something else is somehow forcing the state.

Nevermind it must be some kind of counteraction by one of more than 150 of my mods :D

Edited by ZobrAA
Link to post
Share on other sites

Wow, this is actually really cool. Especially because I sometimes suffered from the bug that the Kerbal wouldn't align itself anymore in EVA flight.

And it is also cool that this mod is in CKAN

BUUUT,... unfortunately it is not with the latest version in CKAN

(says no version number, though, but it says that it is incompatible for 1.0.4 and that the highest compatible KSP version is 0.90.99)

which is actually a shame, since less people will install it.

I see forward to the moment when the current version is again in CKAN.

Link to post
Share on other sites
  • 2 months later...
  • 4 months later...
  • 2 weeks later...
On 4/2/2016 at 2:25 AM, taniwha said:

I haven't done any testing, but I expect 0.5.2 will not due to gui changes. However, I won't neglect it :)

I really like this mod.  Since you work for Squad, please encourage them to make this a stock function.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...