Malah

[1.3.0] Malah's Quick mods [2017.05.31]

Recommended Posts

1 minute ago, linuxgurugamer said:

Thanks.  Not pushing, any idea of an ETA?

Soon™ :P (I think this week end).

Share this post


Link to post
Share on other sites

Hello, it's a long time that I haven't posted or updated something, sorry. My dev training takes all my time (the end in 2 weeks) and I've lost some of my motivation with the confirmation that KSP won't be translated to French in the 1.3 :'(

Only QuickExit needs some work for 1.2.9/1.3 (a dialog issue), all others have no issue in the compilation. I've completely reworked how QuickMute mute the game to use the master volume and to add a quick volume edit. I work on new feature for QuickSearch like a search history, it isn't finish. At this time, it works on the editor and needs a little work on RnD. All others mods have been compiled for the pre-release without change. I haven't yet deleted the support of LanguagePatches but I've planned to switch it on the stock feature.

If you want to see what have been done and what is planned: https://github.com/malahx/QuickMods/projects/4

I will release nothing for the pre-release, if you want to have an update, you can download compiled and untested version in the master: https://github.com/malahx/QuickMods/archive/master.zip

Edited by Malah

Share this post


Link to post
Share on other sites

Could you make QuickSearch not check every frame for each single character added?

Either the search should begin when no more key is pressed for a sec or just hit enter ...

Share this post


Link to post
Share on other sites
3 hours ago, Gordon Dry said:

Could you make QuickSearch not check every frame for each single character added?

Either the search should begin when no more key is pressed for a sec or just hit enter ...

It's already done (a month ago) but never released :wink: it will be for the next update.

Share this post


Link to post
Share on other sites

I hope soon, I feel I have to go to the kitchen every time I enter a search ... :rolleyes:

Share this post


Link to post
Share on other sites

Could you also change the QuickSearch in a way that typing anything doesn't trigger keybindings of other mods anymore?

Share this post


Link to post
Share on other sites
3 hours ago, Gordon Dry said:

Could you also change the QuickSearch in a way that typing anything doesn't trigger keybindings of other mods anymore?

It also does this without QuickSearch? If yes, I think the mod which has this, needs to add support of the stock search feature. If not can you send me mods which does this?

Share this post


Link to post
Share on other sites

Hmm. Well, this is the only mod where I literally type anything into a field.

Without QuickSearch it would of course behave like that, because I just would press keys and these would be interpreted by the according mods...

I guess the darn Unity engine and the KSP API are bad to modders (and players), because the wide spread "click-through-issue" and this "get-all-keypresses-interpretation-whatsoever-issue" are really *grmpfl*

Share this post


Link to post
Share on other sites

Got a small problem with QuickSearch.

I have some parts in my game which are depreciated, the normal way is to set the following:

category = none
TechRequired = none

Yet QuickSearch finds these depreciated parts.

Can anything be done to fix this (other than deleting the parts in question)?

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

Got a small problem with QuickSearch.

I have some parts in my game which are depreciated, the normal way is to set the following:


category = none
TechRequired = none

Yet QuickSearch finds these depreciated parts.

Can anything be done to fix this (other than deleting the parts in question)?

Yes I think I can work on it (and I think I will work to update all my mods this week, I finished all my exam this day ... with an happy ending).

Edited by Malah

Share this post


Link to post
Share on other sites

QuickContracts is working with 1.3 in english version with no changes needed.

Go to Kerbal Space Program\GameData\QuickMods\QuickContracts , edit QuickContracts.version (notepad will do) , and change the KSP_VERSION_MAX 's "MINOR" from a 2, to a 3,

Might not work with other languages, haven't tested.

Share this post


Link to post
Share on other sites

Hello, the update of all my mods is really soon :wink: I think for this week. I dropped support of LanguagePatches, but all my mods will supported the stock localisation, only for English at this time ... and French when Squad will localised KSP to French ... If you want to translate my mods to your native language I will be happy to integrate it.

Only QuickSearch & QuickMute will have new features, more screen, less speak.

d5id1u3.png

Edited by Malah

Share this post


Link to post
Share on other sites

Hello, I updated the QuickMods :wink:

As explained before, I dropped support of LanguagePatches and added support of the stock localisation on all my mods (only in English at this time).
Nothing new for QuickGoTo, QuickContracts, QuickExit, QuickRevert, QuickIVA, QuickHide, QuickCursorHider, QuickFineControl, QuickSAS .

 


QuickSearch

Download:

SpaceDock
GitHub

Changelog - v3.20 - 2017.05.31

  • New: Added an history of the last search (requested by RealKolago),
  • New: Added a search button on the RnD,
  • New: Added an option to search only when you type Enter or click outside the text field (requested by RealKolago),
  • New: Added support of the stock localisation,
  • New: Deleted support of the LanguagePatches,
  • Compiled against KSP 1.3.0.1804

 


QuickMute

Download:

SpaceDock
GitHub

Changelog - v1.30 - 2017.05.31

  • New: Added an option to show/hide mute icon,
  • New: Added easy volume control,
  • New: Added mouse scroll hover for volume control,
  • New: Added support of the stock localisation,
  • New: Deleted support of the LanguagePatches,
  • Fix: Rewrite mute to only use master volume,
  • Fix: Corrected icon path,
  • Fix: Corrected new key to set,
  • Fix: Refactor,
  • Compiled against KSP 1.3.0.1804

 


QuickStart

Download:

SpaceDock
GitHub

Changelog - v2.14 - 2017.05.31

  • New: Added an option to disable black screen,
  • New: Added a keyboard shortcut to stop QuickStart (Escape by default),
  • New: Added support of the stock localisation,
  • New: Deleted support of the LanguagePatches,
  • Fix: Refactorize,
  • Compiled against KSP 1.3.0.1804

Share this post


Link to post
Share on other sites

Your Quick modlets are absolutely essential for KSP, Malah!

While using QuickGoTo on 1.2.2 I've had a bug occor: When changing from the SPH to the VAB, it does load into the VAB. However, the mission flag is not mine, the previously edited vehicle is not there and worst of all: I can't click any buttons at all. Thus I have to forcefully quit KSP and restart it again, where everything is working fine again.

Considering KSP takes 5 to load, this bug feels rather severe.

Share this post


Link to post
Share on other sites
2 minutes ago, FasterThanFlourite said:

Your Quick modlets are absolutely essential for KSP, Malah!

While using QuickGoTo on 1.2.2 I've had a bug occor: When changing from the SPH to the VAB, it does load into the VAB. However, the mission flag is not mine, the previously edited vehicle is not there and worst of all: I can't click any buttons at all. Thus I have to forcefully quit KSP and restart it again, where everything is working fine again.

Considering KSP takes 5 to load, this bug feels rather severe.

Hello, can you send me your log of the bug?

Share this post


Link to post
Share on other sites

I had an issue with QuickToGo on my fresh 1.3 install - as soon as the menu popped up, all stock buttons greyed out. I had to kill the process to get out.

I didn't see any exception thrown in the log at runtime. So I can't provide a log.

Because I wanted to have a fresh install to play with only compatible mods I just removed the mod to do me a favour: playability.

Share this post


Link to post
Share on other sites
19 minutes ago, Gordon Dry said:

I had an issue with QuickToGo on my fresh 1.3 install - as soon as the menu popped up, all stock buttons greyed out. I had to kill the process to get out.

I didn't see any exception thrown in the log at runtime. So I can't provide a log.

Because I wanted to have a fresh install to play with only compatible mods I just removed the mod to do me a favour: playability.

no log no help ...

Share this post


Link to post
Share on other sites

I suggest that QuickSearch should read the PartDatabase.cfg or convert it to its own version on game launch.

The more parts, the longer each search is. Like each search is from scratch, searching again through all parts like it never happened before.

And the QuickSearch History window often does not close, so I have to click into the search field - wait - press ESC - wait - to get it closed.

The setting "enableEnterToSearch = True" inside GameData\QuickMods\QuickSearch\Config.txt is helpful but not very prominent ...

Share this post


Link to post
Share on other sites
5 minutes ago, Gordon Dry said:

I suggest that QuickSearch should read the PartDatabase.cfg or convert it to its own version on game launch.

The more parts, the longer each search is. Like each search is from scratch, searching again through all parts like it never happened before.

And the QuickSearch History window often does not close, so I have to click into the search field - wait - press ESC - wait - to get it closed.

The setting "enableEnterToSearch = True" inside GameData\QuickMods\QuickSearch\Config.txt is helpful but not very prominent ...

Thanks for this return.

I will planned to work on the search speed but I won't have many time soon ...

For the QuickSearch History, if you found at which moment the window is kept opened it will be really helpful.

Share this post


Link to post
Share on other sites

I just recognized something else:

I changed the setting "enableEnterToSearch" to "True", went back to SPC and then into VAB again.

The settings was not re-readed - I hoped this would happen on scene change at least.

Edit:

Then I just entered a senseless phrase (some random characters) - it needs ages...

I was able to ALT-TAB out (and I thought it was finished), but now, after about 4 minutes, I can't quickly ALT-TAB back in, so it seems it's still "searching" ...

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
Just now, Gordon Dry said:

I just recognized something else:

I changed the setting "enableEnterToSearch" to "True", went back to SPC and then into VAB again.

The settings was not re-readed - I hoped this would happen on scene change at least.

Yes, QuickMods settings are only loaded at start of the game but if you use the QuickSearch window settings you can enable/disable this feature without reload.

Share this post


Link to post
Share on other sites
29 minutes ago, Malah said:

For the QuickSearch History, if you found at which moment the window is kept opened it will be really helpful.

I had a search phrase in the field, chose some categories (Filter Extensions are installed), clicked into the search field and pressed ESC - after some waiting the entry disappeared but the history was still open.

24 minutes ago, Malah said:

but if you use the QuickSearch window settings you can enable/disable this feature without reload

Thanks, ashes on my head.
I recognized that applying the settings also needs about a minute until the GUI is responding again...

Edit:

bummer! I changed the setting to "enableEnterToSearch = True" but pressing ESC inside the search field still makes the process unresponsive for a long time ...

Edit:

since I applied the new setting this was written to the log:

QuickSearch(QSettings)[3.20]: Settings Saved
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QGUI)[3.20]: HideSettings
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QEditor)[3.20]: setSearchFilter
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QEditor)[3.20]: InitSearch
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QEditor)[3.20]: SearchField_OnClick
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Caught error in PartModuleList.Contains()
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QEditor)[3.20]: SearchField_OnEndEdit
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

QuickSearch(QGUI)[3.20]: HideHistory
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Edit:

something is borked.

After I changed the setting, everything makes me wait.

I went back to SPC and had a bigger delay than used to.

Then I went to RnD, had a bigger delay and the log is spammed with

QuickSearch(QRnD)[3.20]: Find: 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Now it's time for the full log:
https://www.dropbox.com/s/oj8z8qomy3lsfhj/2017-06-27-2 KSP.log.zip?dl=1

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

I'd like to suggest a new mod QuickNavball (or something along those lines) that would change the navball behavior to not autohide on the flight map. There were other mods that did this but they didn't survive the 1.3 update.

Share this post


Link to post
Share on other sites

In the game settings you can already set it up like that.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.