Paul Kingtiger

KScale64 v1.2.2 16th April 2017

Recommended Posts

Hi all

So with reference to the heating issues, I've shamelessly ripped off NathanKell's MM patch to bring 64K heating more in line with RO/what (I think) it should be. The value you want to look at is machTemperatureScaler, it's set to a value giving earth like heating (64K is obviously a little smaller/slower orbital velocity, so this is a little easier).

With this patch I've been able to bring back a 1.25m pod with 1.25m heat shield, with an apoapsis of 150km and a periapsis of 50km and have 6.5 ablator left on a stock heatshield.


@PHYSICSGLOBALS:FOR[64K]{
// AeroFX
@aeroFXScalar = 1.0
@aeroFXDensityExponent = 0.7
@aeroFXStartThermalFX = 2
@aeroFXFullThermalFX = 3.5
@aeroFXExponent = 3.0

// CONSTANTS
@spaceTemperature = 4
@solarLuminosityAtHome = 1360
@solarInsolationAtHome = 0.15
@standardSpecificHeatCapacity = 800
@internalHeatProductionFactor = 0.025
@aerodynamicHeatProductionFactor = 1.0

// CONVECTION
// Convection areas
@fullConvectionAreaMin = -0.1
@fullToCrossSectionLerpStart = 0.8
@fullToCrossSectionLerpEnd = 1.5

// Newtonian-To-Hypersonic transition
@machConvectionStart = 2
@machConvectionEnd = 4.0
@machConvectionExponent = 3
@convectionFactorSplashed = 5000

// Turbulent convection (total guesses)
@turbulentConvectionStart = 100
@turbulentConvectionEnd = 400
@turbulentConvectionMult = 25

// Newtonian Convection
@newtonianConvectionFactorBase = 1.0
@newtonianConvectionFactorTotal = 1.0
@newtonianDensityExponent = 0.5
@newtonianVelocityExponent = 1.0

// Hypersonic Convection
@convectionDensityExponent = 0.5
@convectionVelocityExponent = 3.0
@convectionFactor = 1.1
@machTemperatureScalar = 7.5 // ~6000 at 7.3km/sec
@machTemperatureVelocityExponent = 0.75

// CONDUCTION
@conductionFactor = 5
@skinSkinConductionFactor = 0.06
@skinInteralConductionFactor = 0.25
@shieldedConductionFactor = 0.01

// RADIATION
@partEmissivityExponent = 4
@radiationFactor = 1
}

If you want to increase the heating, or just give a better margin for error, I've also written this patch which will increase all heatshields ablator resource.


@PART
[*]
{
@RESOURCE[Ablator]
{
@amount *= 1.5
@maxAmount *= 1.5
}
}

If you want to use them, just chuck them in .cfg files under the gamedata folder.

Share this post


Link to post
Share on other sites
Hi all

So with reference to the heating issues, I've shamelessly ripped off NathanKell's MM patch to bring 64K heating more in line with RO/what (I think) it should be. The value you want to look at is machTemperatureScaler, it's set to a value giving earth like heating (64K is obviously a little smaller/slower orbital velocity, so this is a little easier).

With this patch I've been able to bring back a 1.25m pod with 1.25m heat shield, with an apoapsis of 150km and a periapsis of 50km and have 6.5 ablator left on a stock heatshield.


@PHYSICSGLOBALS:FOR[64K]{
// AeroFX
@aeroFXScalar = 1.0
@aeroFXDensityExponent = 0.7
@aeroFXStartThermalFX = 2
@aeroFXFullThermalFX = 3.5
@aeroFXExponent = 3.0

// CONSTANTS
@spaceTemperature = 4
@solarLuminosityAtHome = 1360
@solarInsolationAtHome = 0.15
@standardSpecificHeatCapacity = 800
@internalHeatProductionFactor = 0.025
@aerodynamicHeatProductionFactor = 1.0

// CONVECTION
// Convection areas
@fullConvectionAreaMin = -0.1
@fullToCrossSectionLerpStart = 0.8
@fullToCrossSectionLerpEnd = 1.5

// Newtonian-To-Hypersonic transition
@machConvectionStart = 2
@machConvectionEnd = 4.0
@machConvectionExponent = 3
@convectionFactorSplashed = 5000

// Turbulent convection (total guesses)
@turbulentConvectionStart = 100
@turbulentConvectionEnd = 400
@turbulentConvectionMult = 25

// Newtonian Convection
@newtonianConvectionFactorBase = 1.0
@newtonianConvectionFactorTotal = 1.0
@newtonianDensityExponent = 0.5
@newtonianVelocityExponent = 1.0

// Hypersonic Convection
@convectionDensityExponent = 0.5
@convectionVelocityExponent = 3.0
@convectionFactor = 1.1
@machTemperatureScalar = 7.5 // ~6000 at 7.3km/sec
@machTemperatureVelocityExponent = 0.75

// CONDUCTION
@conductionFactor = 5
@skinSkinConductionFactor = 0.06
@skinInteralConductionFactor = 0.25
@shieldedConductionFactor = 0.01

// RADIATION
@partEmissivityExponent = 4
@radiationFactor = 1
}

If you want to increase the heating, or just give a better margin for error, I've also written this patch which will increase all heatshields ablator resource.


@PART
[*]
{
@RESOURCE[Ablator]
{
@amount *= 1.5
@maxAmount *= 1.5
}
}

If you want to use them, just chuck them in .cfg files under the gamedata folder.

This looks like the sort of thing we should include in our default configs. Would you mind tuning a version for a 3-man capsule Mun return and submitting it as a pull request to the repository in the Compatiblity directory? If you need help with any of that, let me know!

Share this post


Link to post
Share on other sites

You'll probably want 1 and 1 for the machTemp settings. Also 4 for newtonianBase. Also, you might check out the latest changes in RO to AeroFX.

Share this post


Link to post
Share on other sites
This looks like the sort of thing we should include in our default configs. Would you mind tuning a version for a 3-man capsule Mun return and submitting it as a pull request to the repository in the Compatiblity directory? If you need help with any of that, let me know!

Yeah no problem, I'll try and get it together tonight.

You'll probably want 1 and 1 for the machTemp settings. Also 4 for newtonianBase. Also, you might check out the latest changes in RO to AeroFX.

Will do thanks 😊

Edited by NathanKell

Share this post


Link to post
Share on other sites

With 64 k installed, Kerbin slowly loses its textures the higher you go. By that, I mean that the farther you go from Kerbin, the more it stops looking like a planet and starts looking like a white sphere. What did I do wrong? Is there something I missed in the downloading procedure? I copied the 64k folder into gamedata as I was told to do so, so I do not know what happened.

Share this post


Link to post
Share on other sites
With 64 k installed, Kerbin slowly loses its textures the higher you go. By that, I mean that the farther you go from Kerbin, the more it stops looking like a planet and starts looking like a white sphere. What did I do wrong? Is there something I missed in the downloading procedure? I copied the 64k folder into gamedata as I was told to do so, so I do not know what happened.

I can't recreate this, but it sounds like something went wrong in the install.

Download the latest version from Kerbal Stuff and install it from scratch. You shouldn't need to delete any existing files, just overwrite everything.

Also, just in case that doesn't work, what version of KSP and what are you running it on?

Share this post


Link to post
Share on other sites

Didn't work. I initially installed via CKAN, later, deleted the mod and installed it from Kerbal Stuff. Neither worked.

I'm running 1.0.4 currently

Share this post


Link to post
Share on other sites
Didn't work. I initially installed via CKAN, later, deleted the mod and installed it from Kerbal Stuff. Neither worked.

I'm running 1.0.4 currently

"Didn't work" helps little in diagnosing the issue... Follow this thread and people will actually be able to find out where the problem lies - or, equally likely, you will yourself.

Share this post


Link to post
Share on other sites

I've balanced out a version of the Heat tweak that allows a mun direct reentry. I've tried to tune it so that a direct reentry from the Mun with a 3 man pod is at the limit of heat shield endurance. A single pass re-entry needs to drop to a pa of 30km, and leaves about 30 ablator left from 1200. That's with a reentry velocity of over 8km/s.

If that sounds ok I'll try and put the pull request in later.

Share this post


Link to post
Share on other sites
That will make interplanetary returns impossible, no?

3 Man capsule direct returns, yes. I've tried to make a reentry where you go straight from Mun oribt to landing on Kerbin close to the maximum possible, anything more would need some attempt to slow down before reentry.

So for interplanetary returns you'd need to aerobrake in the upper atmosphere, or do an insertion burn to get into orbit before reentry. Or put multiple or larger heatshields on your reentry capsule. That to me seems to be the way you'd want to do it anyway, returning from Duna you'd want to gain orbit and probably separate a reentry capsule rather than land the whole craft anyway.

Share this post


Link to post
Share on other sites

Can someone write some general instructions on installing EVE? Tried few different combos with some peculiar results.

Share this post


Link to post
Share on other sites
Can someone write some general instructions on installing EVE? Tried few different combos with some peculiar results.

I would second that question.:)

Share this post


Link to post
Share on other sites
I would second that question.:)

I'm not going to try and outline any kind of installing instructions, but I did find that with EVE and 64k installed your clouds will be inside of the ground and look reallly, realllllly bad. I went into the configuration file for EVE and just set the cloud layer to 12,000m.

- Navigate to "......Kerbal Space Program/GameData/BoulderCo/Clouds/cloudLayers.cfg".

- Open the .cfg and press "Ctrl + F" to open the search dialogue.

- Search for "body = kerbin" or just find it manually in the .cfg file.

- Right under this line you will see "altitude = xxxxx" I think 4000 is default. Change this to 12000 or whatever you find suits you.

I would second that question.:)

I'm not going to try and outline any kind of installing instructions, but I did find that with EVE and 64k installed your clouds will be inside of the ground and look reallly, realllllly bad. I went into the configuration file for EVE and just set the cloud layer to 12,000m.

- Navigate to "......Kerbal Space Program/GameData/BoulderCo/Clouds/cloudLayers.cfg".

- Open the .cfg and press "Ctrl + F" to open the search dialogue.

- Search for "body = kerbin" or just find it manually in the .cfg file.

- Right under this line you will see "altitude = xxxxx" I think 4000 is default. Change this to 12000 or whatever you find suits you.

Also, I always delete the city lights folder from BlouderCo and EVE folder in Gamedata. I think they look crummy but that is personal preference.

When all else fails "RTFM"

FAQ:

Is this where all the awesome cloud Reddit photos are from?

Yes.

Does it confilict with Universe/Texture Replacer?

No.

Why do the city light flicker and have weird patterns sometimes (LKO)?

It's called Z-fighting, and for now, you have to live with it until I find a better way to fix it.

What if I only want lights or clouds?

You can delete the plugins you don't want in GameData/EnvironmentalVisualEnhancements/Plugins

How do I install?

Dump the contents of the zip file into your KSP install folder. Make sure to MERGE contents.

What do I do if I don't get clouds/lights?

Probably installed incorrectly. Double check this first. If still nothing, go into KSP_Data and send me the output_log.txt file via dropbox or google docs so i can narrow down the issue. But PLEASE double check that everything was installed correctly first. (you should have BoulderCo and EnvironmentalVisualEnhancements folders in GameData)

I'm running KSP on a Mac and it looks all weird and has splits and stuff.

You will have to use Low-res. Macs don't support the 8K textures.

Edited by Arsonik

Share this post


Link to post
Share on other sites

I've submitted the pull request for the heating tweak. If it's too aggressive I can tone it down, let me know.

I've also created a Launch Site config for the KSC Switcher plugin, that seems to work with 64K and KSP 1.04.

bkzDe1K.png

This code replaces "LaunchSites.cfg" in the KSCSwitcher directory.


KSCSWITCHER{
DefaultSite = ksc
LaunchSites
{
Site
{
name = ksc
displayName = Kerbal Space Center
PQSCity
{
KEYname = KSC
latitude = 0
longitude = -74.6
repositionRadiusOffset = 38
repositionToSphereSurface = false
lodvisibleRangeMult = 6
}
PQSMod_MapDecalTangent
{
radius = 40000
heightMapDeformity = 65
absoluteOffset = 0
absolute = true
latitude = -0.076
longitude = -74.65
}
}
Site
{
name = CapeKanaveral
displayName = Cape Kanaveral
PQSCity
{
KEYname = KSC
latitude = 28.608389
longitude = 89.45
repositionToSphereSurface = false
repositionRadiusOffset = 102
reorientFinalAngle = 57
lodvisibleRangeMult = 6
}
PQSMod_MapDecalTangent
{
radius = 10500
heightMapDeformity = 81
absoluteOffset = 50
absolute = true
latitude = 28.608389
longitude = 89.45
}
}
Site
{
name = BaikonurKosmodrome
displayName = Baikonur Kosmodrome
PQSCity
{
KEYname = KSC
latitude = 45.920
longitude = -167
repositionToSphereSurface = false
repositionRadiusOffset = 1150
reorientFinalAngle = 300
lodvisibleRangeMult = 6
}
PQSMod_MapDecalTangent
{
radius = 20000
heightMapDeformity = 133
absoluteOffset = 1050
absolute = true
latitude = 45.920
longitude = -167
}
}
}
}

And the RT stations:


STATION
{
Guid = 12ef84b3-d7b3-45de-bb3d-287655c46410
Name = Cape Kanaveral
Latitude = 28.608389
Longitude = 89.45
Height = 81
Body = 1
MarkColor = 0.996078,0,0,1
Antennas
{
ANTENNA
{
Omni = 7.5E+07
}
}
}
STATION
{
Guid = a3957d31-b3cb-4c64-863b-a1578ac49aa9
Name = Baikonur Kosmodrome
Latitude = 45.920
Longitude = -167
Height = 133
Body = 1
MarkColor = 0.996078,0,0,1
Antennas
{
ANTENNA
{
Omni = 7.5E+07
}
}
}

  • Like 1

Share this post


Link to post
Share on other sites

Is career still broken in all the Kopernicus variants?

Share this post


Link to post
Share on other sites

With regard to the career mode crash, if the first orbit is acheived prior to installing this mod, will it work properly in career mod?

Share this post


Link to post
Share on other sites

The sky texture seems to be missing for me, the sky is just black 24/7

Share this post


Link to post
Share on other sites
I've submitted the pull request for the heating tweak. If it's too aggressive I can tone it down, let me know.

Will try to test a little when I get to playing - this is meant to be used standalone, right? Meaning without RealHeat and related mods.

Share this post


Link to post
Share on other sites
Will try to test a little when I get to playing - this is meant to be used standalone, right? Meaning without RealHeat and related mods.

That's right yeah. I've tested it and balanced it with just stock heating.

Is it just me or is it harder to put things in orbit in this version, compared to the older ones?

I've been finding that. I don't know what it is, but I've been finding it much harder than I remember from 0.90. Though it could be because I've been using stock atmosphere.

Share this post


Link to post
Share on other sites
That's right yeah. I've tested it and balanced it with just stock heating.

Hm. I had a MK1-2 Pod burn up several times during a 8km/s 40km pe reentry last night. The heatshields were definitely patched, so I am guessing the physics patch was applied too... Will test more today.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now