Jump to content

[KSP 1.8.1] SCANsat [v19.1] -- Dev version [February 20, 2020]


Recommended Posts

Is this just me or is anyone else having a really hard time seeing karbonite on the map. I cant discern it from the altimitry map, is there a setting I'm missing?

KZTqzjL.png

- - - Updated - - -

Disregard my previous post, I just scanned the mun, which is a more karbonite rich body and found the karbonite much easier to read

Link to post
Share on other sites

I cant see the resources on the settings menu, just the big map. And I cant get any color to differentiate them on the big map (or any). when I select karbonite, water, etc, i get "percents" where my cursor is but no color change with anything except elevations. What am I doing wrong? Am I missing another mod or dll? Just using this version of scansat, karbonite, k+, and mks..and mechjeb. I feel like Im missing a .dll or something to have resources not on the menu at all.

Link to post
Share on other sites

Clicking the SCAN button on the toolbar doesn't open the menu or anything. As you can see, I have a RADAR on the probe and yet, no dice. I tried accessing it from the small/big map button directly with no luck. It's worth noting that the only options in the right click menu of the scanner are Start RADAR Scan and Analyse Data. It shows only these two options, despite the scanner already being extended. Reloading doesn't change things.

66grKU4.jpg

Here is the output log. It's huge as I've done a load of launches and contracts and stuff before this launch but the relevant lines from this launch (KerbSat1, right at the end) are as follows:

[SCANsat] using animation #1 out of 1 animations named 'Collapse_Antenna'

[SCANsat] sensorType: 1 fov: 5 min_alt: 5000 max_alt: 500000 best_alt: 5000 power: 0.1

[SCANsat] Warning: SCANsat scenario module not initialized; Shutting down

What could be causing this? I'm using v9rc4 and KSP 0.90 x86 (obviously). Before, I had a MM config that added the BTDT scan to every ModuleCommand (I removed that a while ago, way before I even started this save), but wasn't the MapTraq functionality added to command pods by default in v7 or 8 or something? So the map should be available at all times, right? Even if that weren't the case, I have a RADAR so the map should be viewable anyway... Or am I missing something? Thanks in advance.

Edited by ObsessedWithKSP
Link to post
Share on other sites

Something called Kerbanomics is breaking during its scenario module loading process. This interrupts the loading process for all subsequent scenario modules and causes all sorts of problems. Your log file is filled with log spam from Enhanced Nav Ball, but that is most likely a side effect of the Kerbanomics problem (SCANsat was recently changed to avoid spamming the log file in just this kind of situation, that's why all you see is that one line about the scenario module).

Get rid of Kerbanomics and try it again.


FormatException: Input string was not in the correct format
at System.Int32.Parse (System.String s) [0x00000] in <filename unknown>:0
at Kerbanomics.KerbanomicsMain.LoadData () [0x00000] in <filename unknown>:0
at Kerbanomics.KerbanomicsScenario.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioRunner.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at ProtoScenarioModule.Load (.ScenarioRunner host) [0x00000] in <filename unknown>:0
at ScenarioRunner+ .MoveNext () [0x00000] in <filename unknown>:0

Link to post
Share on other sites
Can I add Karbonite scanning to the MKS_Antenna(Planetary Survey Camera) ?

I added the module to the part:

MODULE

{

name = REGO_ModuleResourceScanner

ScannerType = 0

ResourceName = Karbonite

MaxAbundanceAltitude = 500000

}

Karbonite shows up on the right click menu, but doesn't show up in the scansat maps, unless I use the Karbonite Scanner. I have an existing save with Probes all over the place, and would rather not have to send out a bunch of new probes.

Thanks for any assistance!

I'm not sure. I haven't actually tried using my modded scanOmatic yet, I just did a dry run of my first manned soil return mission to the mun and messed up the landing. Now that I know where my dV tunning needs to be I'll likely get a chance to play with my new toy tonight. Let me know how things go with your mods.
Can anyone tell me what the scannertype variable does? I'm trying to add resource readouts to the right click menu of the scan-o-matic soil sample part from MKS like it used to have, because it's .cfg files are still seeking orsx...

Sensortype determines the typ of resource/s which is /are scanned. Look in ScanResource.cfg for more info. If you want to add a Sensortype simply add the number of the desired resource to your existing sensortype. Final Sensortype would be the sum of all desired resources.

I've done some cfgs a while ago... look here for code for your new cfgs... this will just add functionality without changing the original files except SCANResource.cfg

http://forum.kerbalspaceprogram.com/threads/96859-0-90-SCANsat-v9-0rc4-1-Dev-version-UI-Updates-Dec-22?p=1631279&viewfull=1#post1631279

http://forum.kerbalspaceprogram.com/threads/79588-0-90-USI-Kolonization-Systems-%28MKS-OKS%29-%280-22-3%29-2014-12-27?p=1629896&viewfull=1#post1629896

Edited by funk
Link to post
Share on other sites

How do you view the large map, with the karbonite? Do you need to have 100% of the planet scanned, so far I just get a blank unmovable page. The settings are also not recognizingy any resources even though I have karbonite.

Edited by locustgate
Link to post
Share on other sites

Make sure you have the correct body selected, you have a vehicle with a scansat part attached focused, and that you have the resources layer turned on with a resource type selected. This version does progressively scan. If you are having trouble seeing things with the large map try refreshing the view with the arrows running in a circle, center top, or by resizing the map with the "//" button in the bottom right hand corner.

Link to post
Share on other sites
Make sure you have the correct body selected, you have a vehicle with a scansat part attached focused, and that you have the resources layer turned on with a resource type selected. This version does progressively scan. If you are having trouble seeing things with the large map try refreshing the view with the arrows running in a circle, center top, or by resizing the map with the "//" button in the bottom right hand corner.

Tried all that...well I can't refresh coz there is no "//" button. Still got as Locustgate got as well a blank unmovable big map.

Link to post
Share on other sites

Get the newest version from github it shoud be RC4.1 (i downloaded form the link on the first page and got RC1 with the problem in big map you described).

Another problem .. after rc1->rc4.1 upgrade parts are no longer present in research tree in carrier mode. The sats that are already in orbit work fine but the parts went puff... Deleting SCANsat_CommunityTechTree.cfg fixed that. parts are back in tech tree.

Link to post
Share on other sites
Get the newest version from github it shoud be RC4.1 (i downloaded form the link on the first page and got RC1 with the problem in big map you described).

Another problem .. after rc1->rc4.1 upgrade parts are no longer present in research tree in carrier mode. The sats that are already in orbit work fine but the parts went puff... Deleting SCANsat_CommunityTechTree.cfg fixed that. parts are back in tech tree.

This will happen if you have CTT installed, but dont have it selected as the active Tech tree. (or if your using CTT, and havnt unlocked the nodes the parts were placed in)

The CFG only applies itself if you have CTT, and TechManager installed. So if you've got it installed but arnt using it as the default tree for career mode, you probably wanna delete CTT (or you'll run into the same issue other mods that use the CTT)

Link to post
Share on other sites

I have a problem with the version 9 rc 4-1, I have no "Resource" button like there is in the screenshot in this thread, is it supposed to miss or there should be one and I'm missing something?(I've tried also using the rc3 version that is the one used in the screenshots, but the map is not loading and the buttons are all in a corner)

Edit. Installing Kerbonite made the button appear, so I think that Kethane is still not working, why not consider adding a paragraph with unsupported mods?

Edited by gdvhev
Link to post
Share on other sites

Hi,

I have a problem. Everything works correctly in Sandbox mode (scanning, viewing map, all the stuff), however it does not work in in Career.

I mount the module (radar), go to needed height and click start scan (all good till now). It does open (animation ok) but no scan begins and when right clicking, it shows no more info (like in sandbox)

I am unable to display maps (neither big nor small), nor options - when I click on toolbar button where the drobdown should appera, it does not. The buttons are there, but none of them work.

All of it works in sandbox without a problem.

I tried updating to this newest dev build (with the 8.0 the antenna didn't even open), but it didn't help.

Since I noticed most people have problems with recource plugins; I do not use any of those.

I would love to attach output_log.txt, however I am new to this forum and can't seem to find any way to do this... is there some email adress I can email it to instead?

Toolbar
ActiveTextureManagement
ASET (Alcor landing module)
BoulderCo (clouds)
CIT (active struts)
CustomAsteroids
DistantObject
EnvironmentalVisualEnhancements
HullCameraVDS
JSI (Raster Prop Monitor)
Kerbal Isp Difficulty Scaler
KittopiaSpace
MagicSmokeIndustries
Mechjeb2
NEAR
ProbeControlRoom
Procedural Fairings
RemoteTech
RoverScience
SCANsat (naturally)
TarsierSpaceTech
TextureReplacer
TriggerTech
TweakScale
ModuleManager

Thanks in advance.

Link to post
Share on other sites
Hi,

I have a problem. Everything works correctly in Sandbox mode (scanning, viewing map, all the stuff), however it does not work in in Career.

Remove Tarsier Space Tech. It is broken and breaks other addons along with it. There is an updated version of it floating around somewhere, but I can't guarantee that it doesn't have similar problems. Other mods have had this same problem though, so without the log files I can't say for sure.

Link to post
Share on other sites
Any suggestions or requests for this type of methods should be submitted as issues to the SCANsat repo, or as a pull request, preferably to my active branch found here.

I'll take this discussion here instead of the Contract Configurator thread...

I'll add pretty much anything within reason. Just keep in mind that the simplest methods (especially if you are using reflection) don't use any non-generic types. So something that returns results using only common types (string, bool, lists, etc...) will be much easier to use.

For more examples of reflection stuff using these simple static methods you can check out how SCANsat handles Regolith interaction. It is very easy to set up when you have methods designed specifically for it.

Five minutes ago, I was singing and dancing because my dll got loaded and I saw my "OnLoad" and "OnSave" events in the KSP.log :)

Now, my stumbling block: I would need access to the anomalies, but both the SCANanomaly class and the accessor method are marked "internal". Would you accept a PR making those externally visible?

I would also need a list of the already scanned bodies, but I did not find anything in the SCANutil for that purpose yet. That might take some more hunting.

Link to post
Share on other sites

Now, my stumbling block: I would need access to the anomalies, but both the SCANanomaly class and the accessor method are marked "internal". Would you accept a PR making those externally visible?

Taken care of. This was kind of an oversight anyway, as I've been moving these nested classes into their own class and making sure there are public accessors for most things.

The SCANanomaly class, all of it's members and the SCANdata.Anomalies[] will all be publicly available.

I would also need a list of the already scanned bodies, but I did not find anything in the SCANutil for that purpose yet. That might take some more hunting.

If you just want the SCANdata instance for each body then SCANUtil.getData will give it to you. If you have visited the planet with SCANsat installed (whether or not you have SCANsat parts or did any scanning doesn't matter) it will return the SCANdata. If you haven't it will return a null SCANdata, so make sure you account for that.

This won't tell you anything about what has been scanned, but SCANUtil.getCoverage can give you that for any given SCANsat scanner type. It will return 0% if there isn't a SCANsat instance for that planet. You probably won't get any meaningful results for the AnomalyDetail scanner (the BTDT), but you can get coverage results for the Anomaly scanner, then use the SCANanomaly array to get any extra info about anomalies.

Link to post
Share on other sites
Taken care of. This was kind of an oversight anyway, as I've been moving these nested classes into their own class and making sure there are public accessors for most things.

The SCANanomaly class, all of it's members and the SCANdata.Anomalies[] will all be publicly available.

Thank you. I closed my PR https://github.com/S-C-A-N/SCANsat/pull/107 against the main repository as your solution is even better :)

Out of curiosity though, what is the "canonical" source tree for SCANsat if I should want to provide more PRs?

And secondly, could you build a new 9.0 release candidate with this change in it? I can build it myself, but having a canonical distribution is always nicer :)

If you just want the SCANdata instance for each body then SCANUtil.getData will give it to you. If you have visited the planet with SCANsat installed (whether or not you have SCANsat parts or did any scanning doesn't matter) it will return the SCANdata. If you haven't it will return a null SCANdata, so make sure you account for that.

This won't tell you anything about what has been scanned, but SCANUtil.getCoverage can give you that for any given SCANsat scanner type. It will return 0% if there isn't a SCANsat instance for that planet. You probably won't get any meaningful results for the AnomalyDetail scanner (the BTDT), but you can get coverage results for the Anomaly scanner, then use the SCANanomaly array to get any extra info about anomalies.

Thank you, my intention is actually creating missions for people so they have to run a basic scan first, and then get specific instructions to visit areas A, B, C to analyse the strange readings they got from those spots... Or something like that :)

Link to post
Share on other sites

Out of curiosity though, what is the "canonical" source tree for SCANsat if I should want to provide more PRs?

And secondly, could you build a new 9.0 release candidate with this change in it? I can build it myself, but having a canonical distribution is always nicer :)

My dev branch is the one I update. That way I'm not interfering with code for the publicly released version. The main Release and Master branches are a mess and are out of sync, so any pull requests to those just get added manually if I'm going to use them.

I haven't tested anything for the last 15 or so commits, so I have no idea if my build is actually working right now (I also haven't update the .csproj, so there are a lot of files that would need to be added and moved around in the solution), and for sure the orbit overlays are screwed up. But I should have something a little more stable by the end of this weekend that I can send you.

Link to post
Share on other sites
You can upload it to Dropbox, Google Drive or Mediafire (or any similar filesharing site), then post the download link here.

Thanks... I got the idea just after submitting my request, but since this was my 2nd post I couln't edit it before it was approved.

Log: www.kalko.sk/documents/output_log.txt

Screen: http://www.kalko.sk/documents/scansat_probe.png

I will try removing the Tarsier Space tech, thanks for the advice.

Link to post
Share on other sites
Thanks... I got the idea just after submitting my request, but since this was my 2nd post I couln't edit it before it was approved.

Log: www.kalko.sk/documents/output_log.txt

Screen: http://www.kalko.sk/documents/scansat_probe.png

I will try removing the Tarsier Space tech, thanks for the advice.

NullReferenceException: Object reference not set to an instance of an object
at TarsierSpaceTech.TSTProgressTracker.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

at ScenarioModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

at ScenarioRunner.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0

at ProtoScenarioModule.Load (.ScenarioRunner host) [0x00000] in <filename unknown>:0

at ScenarioRunner+ .MoveNext () [0x00000] in <filename unknown>:0

Looks similar to the problem I had a few weeks ago:

Something called Kerbanomics is breaking during its scenario module loading process. This interrupts the loading process for all subsequent scenario modules and causes all sorts of problems. Your log file is filled with log spam from Enhanced Nav Ball, but that is most likely a side effect of the Kerbanomics problem (SCANsat was recently changed to avoid spamming the log file in just this kind of situation, that's why all you see is that one line about the scenario module).

Get rid of Kerbanomics and try it again.


FormatException: Input string was not in the correct format
at System.Int32.Parse (System.String s) [0x00000] in <filename unknown>:0
at Kerbanomics.KerbanomicsMain.LoadData () [0x00000] in <filename unknown>:0
at Kerbanomics.KerbanomicsScenario.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0
at ScenarioRunner.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0
at ProtoScenarioModule.Load (.ScenarioRunner host) [0x00000] in <filename unknown>:0
at ScenarioRunner+ .MoveNext () [0x00000] in <filename unknown>:0

The Scenario module loading is being broken by TST so yeah, pretty confident that removing it will fix things. Shame, it's a good mod, but causes a lot of problems for a lot of other mods a lot of the time :/

Link to post
Share on other sites

I just encountered a weird bug which I'm assuming is with SCANSat. I'm using the latest dev release.

Got to 50% LoRes coverage over Kerbin with no problems. Hopped out of the ship to the KSC for 20 seconds, hopped back in and now its not recording new data and the "LO" text on the small map is Orange suggesting I'm too high, but right clicking on the actual RADAR Altimetry Sensor it says I'm at the ideal altitude.

Tried turn it off and on again, tried rebooting KSP, tried changing altitudes. Nothing shifts it.

I did just try to post the log but for some reason it didn't work. I do have a video of it though.

Link to post
Share on other sites

I really like the new biome maps visible in map mode 0.90 with the Alt+F12 cheat menu because it's very easy to distinguish between "this is a new biome" and "this is yet another area of Midlands".

My SCANsat biome map looks exactly like it did in 0.25, though, same as on one of the example images: http://i.imgur.com/xJS1muQ.jpg Is that slightly-more-green blob on the left a different biome, or yet another area of Midlands? It's really hard to tell without mousing over every spot.

I played with the color settings but they only seem to affect the altimetry maps, not the biome map.

Am I doing something wrong, or can we not change the biome colors? Is there any way to get the 0.90 biome colors? Do I need to reset my database?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...