Claw

[KSP v1.1.3] Stock Bug Fix Modules (Release v1.1.3b.1 - 10 Jul 16)

Recommended Posts

Does this mod fix the messed up aero changes in 1.1 & 1.2 or do I need to still manually revert them in the settings.cfg?

Those are not bugs. They're differences of opinion.

Share this post


Link to post
Share on other sites
I've started the new StockPlus add on. It will eventually incorporate my fixes as well as some minor polish fixes for stock.

Click here to go to the first release of StockPlus.

Instructions: Unzip into your GameData folder (as usual). If you are using the stock bug fix modules, delete the "ModuleProceduralFairingFix" from your StockBugFixes directory. As this matures, it will include all the fixes so you only have to do one download.

Cool, I can't wait to see where this goes in the future.

Share this post


Link to post
Share on other sites
I never had enough lift to begin with. :confused:

No worries. :)

Does this mod fix the messed up aero changes in 1.1 & 1.2 or do I need to still manually revert them in the settings.cfg?

Other than a (somewhat) minor change to a heating constant, I've not changed anything with the aero settings.

In my opinion, there are a few deeper seated issues that need to be adjusted in aero beyond just moving the sliders. Although moving things back to 1.0.0 type settings certainly helps aeroplanes feel a bit better. I do share the opinion with 5th Horseman in that this is more of a preference issue at the moment (between the two settings) rather than a pure "bug." Like you, I'm holding my breath a bit to see what happens with 1.1 / 1.0.3 (or whatever the next thing will be). I'm not sure if that's the answer you want to hear, but you can find the settings for 1.0.0 here: http://forum.kerbalspaceprogram.com/threads/118633-1-0-Aerodynamics

Cheers,

~Claw

Share this post


Link to post
Share on other sites

What all does stockplus do right now?

EDIT: Nvm it says so in the readme like it should... Silly me!

Edited by Avera9eJoe

Share this post


Link to post
Share on other sites
What all does stockplus do right now?

EDIT: Nvm it says so in the readme like it should... Silly me!

And I will hopefully have a new release soon. I'm nearly done with the interface between stockplus and the Stock Bug Fixes. :D

Possibly a release later today with some more fixes and initial stockplus components, but no promises yet...

Cheers,

~Claw

Share this post


Link to post
Share on other sites

Updated Release for StockBugFixModules. Also, I've started the new StockPlus add on, which are some minor polish fixes for stock. It is now incorporated directly into the stock bug fixes and can be selectively disabled.

Fixes for this release include: Disabling crossfeed on anchored decouplers, Engine gimbals now have speed that is similar to flight controls (limiting rocket oscillations), some minor fixes to parachutes, and proper symmetric copying of procedural fairings.

Stock Plus this release: Radial mounted parachutes placed in symmetry spread out, chute deploy and semi-deploy times are tweakable, the number of panels around on a fairing can be controlled, fairing ejection force is adjustable, and rover wheel grip is tweakable.

If you want to disable the StockPlus additions, instructions are included in the Readme (and consists of deleting one file).

- - - Updated - - -

If you managed to download 1.0.2c.1, please redownload. I included an incorrect config file and .dll. The most current release is now 1.0.2c.2.

Cheers,

~Claw

ylkaUGu.jpg

Edited by Claw

Share this post


Link to post
Share on other sites

the number of panels around on a fairing can be controlled

Didn't 1.0 have this stock? If so, why did they remove it in 1.0.1 or 1.0.2?

Will Realchutes still work with the parachute tweaks? I know that is a novice question, I am a gamer and artist, not coder.

Thanks!

Share this post


Link to post
Share on other sites
Didn't 1.0 have this stock? If so, why did they remove it in 1.0.1 or 1.0.2?

No. If you saw this before, it's probably because it was in my fixes previously. I have since moved it to StockPlus, since it's not exactly a bug fix.

Will Realchutes still work with the parachute tweaks?

Previously there was a problem, but I've changed the interface a bit. RealChutes should override the parachute tweaks. If you find they are still conflicting, please let me know.

Cheers,

~Claw

Share this post


Link to post
Share on other sites
No. If you saw this before, it's probably because it was in my fixes previously. I have since moved it to StockPlus, since it's not exactly a bug fix.

Previously there was a problem, but I've changed the interface a bit. RealChutes should override the parachute tweaks. If you find they are still conflicting, please let me know.

Cheers,

~Claw

OK, then thats where I saw those fairing features, I like them. I will let you know if I have a problems with RealChutes, I am by far not a expert with it, I am sure someone else will help out in that area.

Thanks for the answers.

Share this post


Link to post
Share on other sites

Have you considered something that defaults the temperature gauges to disabled in order to prevent people who use your fixes from hitting the memory leak? Perhaps not worth it if a patch is forthcoming.

It is a bug that can really get ya. Despite knowing about the leak myself I managed to ruin a mission of mine because my plane's landing gear began to overheat unknowingly to me. When I saw the gauges were on I was shocked I was experiencing heat while flying to a survey location. So I turned them off. Then of course they came back when I landed and reloaded. I turned them off again. Then the game crashed. Then began a cycle where I would load the craft, turn off the gauges as quickly as possible, fly as far as I could, then the game would crash. Other than this one mission I've never had crashing (despite quite a few hours of play). If I understand correctly the following was happening:

  1. That craft had developed a lot of memory that it needed to have loaded in order to have that craft loaded - this didn't go away when restarting the game
  2. I quite likely was making it worse everything I would re-load that particular craft because the gauges were defaulted to on
  3. I never made it back to KSC where I could recover the craft because after every crash I would lose my progress (no auto-save while in flight)
  4. Eventually I recovered the plane from where it had landed on the other side of Kerbin - missing out on my other survey points and the part recovery efficiency.

Anyway, just an idea if you think it'll be awhile longer before an official fix.

Share this post


Link to post
Share on other sites
Have you considered something that defaults the temperature gauges to disabled in order to prevent people who use your fixes from hitting the memory leak? Perhaps not worth it if a patch is forthcoming.

It is a bug that can really get ya. Despite knowing about the leak myself I managed to ruin a mission of mine because my plane's landing gear began to overheat unknowingly to me. When I saw the gauges were on I was shocked I was experiencing heat while flying to a survey location. So I turned them off. Then of course they came back when I landed and reloaded. I turned them off again. Then the game crashed. Then began a cycle where I would load the craft, turn off the gauges as quickly as possible, fly as far as I could, then the game would crash. Other than this one mission I've never had crashing (despite quite a few hours of play). If I understand correctly the following was happening:

  1. That craft had developed a lot of memory that it needed to have loaded in order to have that craft loaded - this didn't go away when restarting the game
  2. I quite likely was making it worse everything I would re-load that particular craft because the gauges were defaulted to on
  3. I never made it back to KSC where I could recover the craft because after every crash I would lose my progress (no auto-save while in flight)
  4. Eventually I recovered the plane from where it had landed on the other side of Kerbin - missing out on my other survey points and the part recovery efficiency.

Anyway, just an idea if you think it'll be awhile longer before an official fix.

I think that is a great candidate for Claw's work, but in the meantime there is a mod that disables the temp gauges It's KerboKatz-SmallUtilities

Share this post


Link to post
Share on other sites

...

Fixes for this release include: Disabling crossfeed on anchored decouplers, Engine gimbals now have speed that is similar to flight controls (limiting rocket oscillations), some minor fixes to parachutes, and proper symmetric copying of procedural fairings.

Stock Plus this release: Radial mounted parachutes placed in symmetry spread out, chute deploy and semi-deploy times are tweakable, the number of panels around on a fairing can be controlled, fairing ejection force is adjustable, and rover wheel grip is tweakable.

...

Thanks Claw. Can see goodies are back in full swing, and fixes are better than ever :).

Share this post


Link to post
Share on other sites

Hey Claw, I was wondering if you have met the following bug on your stock bugfixing adventure(please disregard the debug log, it is not related to the problem):

https://bg3.biz/cloud/index.php/s/Itfe2iTJ2cBtziR

What actually happens is that sometimes on scene change (Flight to Map then back to Flight, or Flight to Space Center to Flight), the stock Heat Shield(and non-stock "fake" fairing parts) disappear completely, leaving the Heat Shield(and non-stock stuff like the crew pod on the shot) looking like it's not sitting flush with the stack attacked parts.

The part is still attached completely, so the bug is simply a visual one. I can't exactly reproduce it successfully, it seems to happen randomly.

There is an output log for a session in which it occured, in case you can find something during/shortly after scene change that would cause such behaviour:

https://bg3.biz/cloud/index.php/s/aUmtubT9mwmo09c

Also, restarting the game after this happens does not fix the craft, the fairing just disappears. Maybe it is related to this non-stock crew pod and it's own "fake" fairing?

Share this post


Link to post
Share on other sites
I think that is a great candidate for Claw's work, but in the meantime there is a mod that disables the temp gauges It's KerboKatz-SmallUtilities

Wow, that's a nice little mod pack. I was also going to include an afterburner type module but looks like it's already been done. :P

Maybe I will work toward a fix that allows use of the temp gauges, but doesn't leak memory.

Thanks Claw. Can see goodies are back in full swing, and fixes are better than ever :).

As much as I can anyway. Thanks dio. :D

I love you, Claw. :kiss:

Haha. I take it that you like the StockPlus pieces. :D

Hey Claw, I was wondering if you have met the following bug on your stock bugfixing adventure(please disregard the debug log, it is not related to the problem):

Yes, I have seen that one posted but haven't experienced it myself. It is certainly a good candidate for another round of fixes. I will write it down and look into it.

Cheers,

-Claw

Share this post


Link to post
Share on other sites

Wow, I've apparently been using RealChutes for so long that I forgot that the stock radial chutes didn't have any risers. Anyway, the parachute angle probably needs to depend on the mesh geometry somehow, because if you use parachute models with risers (i.e. Ven's Stock Revamp) they stick out at ridiculous angles. If that's not possible it's probably enough just to make the angle configurable.

Even better if the angle would change between reefed and unreefed.

Edited by NonWonderDog

Share this post


Link to post
Share on other sites

Is it possible to include a fix for the fuel not draining evenly when you have multiple tanks connected via fuel lines? It's noticeable with asparagus staging or with side tanks that are connected to each other via fuel lines.

This bug screws up asparagus staging, especially if you have several substages to it, it ends up with one of the booster pair tanks not draining evenly and thus unbalances the whole rocket.

Edited by smjjames

Share this post


Link to post
Share on other sites

Just an FYI Claw, your gimbal fix, while very much needed in the stock game, slightly messes things up in modded game. For example, in Vens Stock Revamp, all engines are already given a response speed. I don't know if ModuleManager still processes things alphabetically, but to futureproof it (against mods that come before SBFM that this would possibly mess with), the following would force the patch to run before every other one which means goodness for everyone (literally every single gimballed engine ever gets this patch and it should then be on the engines author to ensure their patch is correctly syntaxed (changes/removes their desired gimbal response speed - in most if not all cases, they aren't run on FIRST so if their patch is set up as normal, it'll run after this one and overwrite it anyway. But for patches that change existing gimbals in other engines (like VSR), they would overwrite this as well. If no patches exist for a gimballing engine, this patch will remain). So yeah, there's a massively long explanation for why your patch should ideally be run on FIRST :)

@PART[*]:HAS[@MODULE[ModuleGimbal]][B]:FIRST[/B]
{
@MODULE[ModuleGimbal]
{
useGimbalResponseSpeed = true
gimbalResponseSpeed = 2
}
}

Share this post


Link to post
Share on other sites

Hmmm, maybe I'm just Doing It Wrong (probably, in fact), but since adding the Gimbal Fix to my mostly unmodded install (just KER, and some parts mods none of which are in use in problem crafts) I've found my ships wobble a hell of a lot more, and more importantly cannot get and hold Prograde/Retrograde via SAS at all when the engines are firing. Any idea of what I'm missing?

Share this post


Link to post
Share on other sites
Maybe I will work toward a fix that allows use of the temp gauges, but doesn't leak memory.

Claw, I love it - but I have to admit, I've found new options springing up all weekend as alternatives. I wouldn't mind something in your set of fixes just because I think people trust them and get a lot of value. If nothing else perhaps point in your thread to these wonderful StockFixes and StockPlus options - they just feel too good to not be stock? I realize StockPlus is a slippery slope...

Thermal stuff -

https://kerbalstuff.com/mod/775/Temperature%20Gauge%20Killer - Just released

https://kerbalstuff.com/mod/719/Thermometer - There are others but I like this one at the moment

Other fixes -

https://kerbalstuff.com/mod/725/Fairing%20With%20Mass - Fairing mass has correct CoM

Pretty borderline (fix or plus) -

http://forum.kerbalspaceprogram.com/threads/119561-1-0-2-Menu-Stabilizer - I've used it for 15 minutes and am already in love

Other StockPlus mods worth pointing out -

http://forum.kerbalspaceprogram.com/threads/80683-0-23-5-MapShowNavBall-show-navball-by-default - Pretty sure you're already aware of this one

http://forum.kerbalspaceprogram.com/threads/106710-SAS-Reset - Reset SAS to stability once it is off and being turned back on

https://kerbalstuff.com/mod/764/QuickBrake - Set brake when starting something on the runway

https://kerbalstuff.com/mod/472/QuickSearch - Search parts

http://forum.kerbalspaceprogram.com/threads/54303-1-0-Navball-docking-alignment-indicator-v6 - Docking indicator that matches stock navball functionality perfectly, too much for StockPlus?

- - - Updated - - -

Once you start you can't stop...one more for StockPlus recommendation consideration:

http://forum.kerbalspaceprogram.com/threads/102373-1-0-Crowd-Sourced-Science-Biome-Reports-Everywhere%21-%28May-3rd%29

Share this post


Link to post
Share on other sites
Guest
Is it possible to include a fix for the fuel not draining evenly when you have multiple tanks connected via fuel lines? It's noticeable with asparagus staging or with side tanks that are connected to each other via fuel lines.

This bug screws up asparagus staging, especially if you have several substages to it, it ends up with one of the booster pair tanks not draining evenly and thus unbalances the whole rocket.

I haven't had any problems with any of my rockets that use asparagus style staging as of yet. It might help if you would upload the craft file somewhere so others can download and test to see if it's an issue with the craft design. Fuel flow can be a bit quirky sometimes.

Share this post


Link to post
Share on other sites

Sidebar: @ObsessedWithKSP: I just caught your KSPX website in your signature. I'll definitely start stealing...uh, I mean...examining in greater detail many of those craft models.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.