Claw

[KSP v1.1.3] Stock Bug Fix Modules (Release v1.1.3b.1 - 10 Jul 16)

Recommended Posts

The reason you wobble with SAS is because SAS keeps accelerating until it hits hits mark.

No, actually it doesn't "just" accelerate all 10 degrees (if it did that it'd always reach the same amplitude on the opposite end of it's swing), as you move faster it applies a counter torque and as you get closer it applies reduced torque (if your acceleration is high enough it will go control neutral/start decelerating a long way from it's target). It will overshoot slightly but under normal circumstances it will overshoot in a decaying fashion (ie. less each time). SAS instabilities are also contributed to by a flexing rocket because it uses the command pod facing to determine it's reaction (and that's typically one of the parts with the greatest amplitude of flex)

The issue is one of sensitivity and the fact that stock SAS has a fixed setup. Adding a reaction delay to gimbals reduces their apparent sensitivity and alters the torque/MOI ratio that SAS can cope well with (slower = greater levels of torque required for the same effect). If you try the fix with one of the alternate SAS modes (eg. hold prograde) which just happens to be ~4x more aggressive than the stability assistance mode, you'll probably find that it works perfectly (whereas in stock it tends to be far too twitchy). This problem will continue to exist until someone decides that a constant sensitivity is wrong and writes something that changes with available torque and current MOI (or just copies it out of MJ :P)

Edited by Crzyrndm

Share this post


Link to post
Share on other sites
just copies it out of MJ

:D Yes, that^.

I have never had MechJeb over shoot in space and very rarely will it wobble in atmosphere flight.

Any chance of that happening?

Share this post


Link to post
Share on other sites
Wobbly wheels, you fixed wobbly wheels!

Yes indeed. That's actually one of my favorite fixes. :)

The next version will be a bit better, though I'm not sure if it will be very obvious to the user.

Maybe if too many people are complaining, leave it disabled by default.
Do you think you could put slower gimbals in a separate download?
This problem will continue to exist until someone decides that a constant sensitivity is wrong and writes something that changes with available torque and current MOI (or just copies it out of MJ :P)

Well, then I'm not 100% certain what I will do with this. I think what I might do as an easier way to fix this is to have it disabled by default, but have a tweakable in-game that the user can activate and adjust.

:D Yes, that^.

Any chance of that happening?

As for "copying MJ's code" into stock, idk... ¯\_(ツ)_/¯

Cheers,

~Claw

Share this post


Link to post
Share on other sites

Is anyone else noticing what seems like a weak connection between the Mark 3 to 2 sloped adapter and the mark 2 bicoupler? In not sure if its my crappy design or what. I will say the mk3 to 3 connections are working great now! Thanks for these fixes Claw!

Share this post


Link to post
Share on other sites
Is anyone else noticing what seems like a weak connection between the Mark 3 to 2 sloped adapter and the mark 2 bicoupler? In not sure if its my crappy design or what. I will say the mk3 to 3 connections are working great now! Thanks for these fixes Claw!

You are indeed correct. Having taken a look, those connections also need to be improved a bit. Expect that to be fixed in my next release.

And you are quite welcome! :D

Cheers,

~Claw

Share this post


Link to post
Share on other sites

WOOOOO! Space Truck may actually fly one day! So far it cant make it down the runway without shooting its jet engines up its own butt.

Edited by Temeriki
backstory

Share this post


Link to post
Share on other sites
Any chance of that happening?
As for "copying MJ's code" into stock, idk... ¯\_(ツ)_/¯

Considering it (although it won't be exactly MJ's code if I do it, I have "issues" with how that is setup). It would be advantageous for some of my other mods if I could interact easier with the stock SAS system and creating it won't be that difficult

Share this post


Link to post
Share on other sites
You are indeed correct. Having taken a look, those connections also need to be improved a bit. Expect that to be fixed in my next release.

I'm interested at tweaking the connection between parts.

In my research, I've seen that breakingForce and breakingTorque in the AttachNode are not used. Looking to your Mk3StrengthFix.cfg, i can see it's the part's breakingForce and breakingTorque that were used.

I see you use a "Mk3StrengthFix.dll" but I can't find the source. Can you link it to me?

Share this post


Link to post
Share on other sites

Anybody going to look at the two craft files that I posted? Or maybe I'll just go and make a thread on gameplay questions and tutorials, probably more constructive there anyhow.

Share this post


Link to post
Share on other sites
I'm interested at tweaking the connection between parts.

I see you use a "Mk3StrengthFix.dll" but I can't find the source. Can you link it to me?

The .dll isn't currently in use. If it's in the download, then that is an error. It shouldn't interfere, but it isn't needed either. The Mk3 parts are using the defauld (and quite low) breaking numbers.

Anybody going to look at the two craft files that I posted? Or maybe I'll just go and make a thread on gameplay questions and tutorials, probably more constructive there anyhow.

That's probably the best bet. It's not that I (or others) don't want to help, but you are likely to get faster responses for your specific question in the Gameplay Questions forum. (Unfortunately, my list of stuff to look into is quite long atm.)

Cheers,

-Claw

Share this post


Link to post
Share on other sites

I experienced a problem with the chute fix.

I installed the mod via CKAN (which meant, everything got installed, although i manually deleted the symmetry thing), and when using chutes, they didn't show up in the staging area. They DID get staged, though (which means my first crafts all simultaneously fired their engines and chutes).

Deleting the chute fix "fixed" that problem. So seems to be some kind of bug there...

Share this post


Link to post
Share on other sites

Might be a good time to bring this up too:

The stability assist stuff, hold prograde retrograde and such, seems to behave much differently than the standard SAS. For example it twitches a lot a holds at a angle way from the actual target.

Using Crzyrndm tool to tweak the standard SAS response values does nothing. And so it seems to be using a entirely different module.

Share this post


Link to post
Share on other sites
The .dll isn't currently in use. If it's in the download, then that is an error. It shouldn't interfere, but it isn't needed either. The Mk3 parts are using the defauld (and quite low) breaking numbers.

Ok, thanks.

(I found it in the git)

Share this post


Link to post
Share on other sites
Using Crzyrndm tool to tweak the standard SAS response values does nothing. And so it seems to be using a entirely different module.

It is an entirely different mode and you will get different numbers showing up in the tuner when you are using one of those modes (numbers which you will have to reduce quite aggressively most of the time)

Share this post


Link to post
Share on other sites
although i manually deleted the symmetry thing

What specifically did you delete?

Might be a good time to bring this up too:

The stability assist stuff, hold prograde retrograde and such, seems to behave much differently than the standard SAS.

Yes, it does use different code. There are so many mods that help with craft control, that I've been slow to deal with this.

Cheers,

-Claw

Share this post


Link to post
Share on other sites
Okay. Looks like too many things are tuned to deal with instant gimbals. I will remove that fix in the next download and see if there is another way to reduce SAS wobble. Until I can fix the download, please delete the EngineGimbalFix directory.

It seems this is mostly just a problem with the chosen speed, not the gimbal speed limit in the abstract. 2 degrees per second is unrealistically slow and eats up too much stability margin in the controller, but with it set to 10 degrees per second I don't really have any issues. It certainly looks better than instant movement, too.

You should also probably use the '%' syntax so module manager doesn't add the keys twice if another mod adds these first. i.e.:

@PART[*]:HAS[@MODULE[ModuleGimbal]]
{
@MODULE[ModuleGimbal]
{
%useGimbalResponseSpeed = true
%gimbalResponseSpeed = 10
}
}

Although as this is a bug fix mod, all the module manager configs should probably be tagged ':FIRST' anyway. The '%' or not doesn't really make a difference then.

Edited by NonWonderDog

Share this post


Link to post
Share on other sites
Although as this is a bug fix mod, all the module manager configs should probably be tagged ':FIRST' anyway. The '%' or not doesn't really make a difference then.

Thanks for the tip. I will do that.

I'm thinking of making this option something in StockPlus, vice the Stock Bug Fixes. And implementing it as a tweakable. Would that be preferable?

Also, I'm still feeling very stuck here with the StockPlus. I'm nearly certain that if I split this into two mods, there is so much overlap that I will likely abandon StockPlus due to the time involved with updating and testing everything. I'm thinking of shipping the StockBugFixes with StockPlus disabled, and you'd have to download a config file to activate it. I'm still not sure yet, and it's already causing me a slow down in releasing the next update (Flight controls, air brakes, Mk3 adapters)... and delaying work on other subjects...

Cheers,

~Claw

Share this post


Link to post
Share on other sites

Also, I'm still feeling very stuck here with the StockPlus. I'm nearly certain that if I split this into two mods, there is so much overlap that I will likely abandon StockPlus due to the time involved with updating and testing everything. I'm thinking of shipping the StockBugFixes with StockPlus disabled, and you'd have to download a config file to activate it. I'm still not sure yet, and it's already causing me a slow down in releasing the next update (Flight controls, air brakes, Mk3 adapters)... and delaying work on other subjects...

Cheers,

~Claw

I like the idea of one download. Keeping it simple is never a bad thing.

Share this post


Link to post
Share on other sites
I like the idea of one download. Keeping it simple is never a bad thing.

And then you can call it Stock+Plus ;']

Share this post


Link to post
Share on other sites

I would prefer to keep them together indeed, if people are complaining they could just remove the specific part.

But since I understand people like to complain a lot without actually doing anything, and its bad for you to cause turmoils.

Then just keep them disabled (with the config included), and with a useful read-me for those who seek.

(basically what I did even before coming to this thread, read the read-me and removed what I didn't want)

Share this post


Link to post
Share on other sites

Version 1.0.2d.1 is out.

This release also includes fixes to flight control surfaces (which didn't retain deployment status) and Airbrake action group fixes, among a few other things.

I've had many reports of the Engine Gimbal Fix causing wobbly rockets, especially for longer rockets. I have adjusted the Engine Gimbal response speed based on user input. I may turn this into a StockPlus tweakable for those who want it.

StockPlus is still embedded within the download, but is disabled by default. Please see the readme on how to enable, if you want to use stock plus.

Cheers,

~Claw

Share this post


Link to post
Share on other sites

I have a question/request. The stock fairings, have no ejection sound, and it bugs me to no end, how hard would it be to make the fairing ejection make sound? even if it was the standard decoupler sound?

Share this post


Link to post
Share on other sites
Version 1.0.2d.1 is out.

This release also includes fixes to flight control surfaces (which didn't retain deployment status) and Airbrake action group fixes, among a few other things.

I've had many reports of the Engine Gimbal Fix causing wobbly rockets, especially for longer rockets. I have adjusted the Engine Gimbal response speed based on user input. I may turn this into a StockPlus tweakable for those who want it.

StockPlus is still embedded within the download, but is disabled by default. Please see the readme on how to enable, if you want to use stock plus.

Cheers,

~Claw

You've fixed the airbrake action groups and flap deployment!! Awesome. You are literally a lifesaver.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.