Claw

[KSP v1.1.3] Stock Bug Fix Modules (Release v1.1.3b.1 - 10 Jul 16)

Recommended Posts

Now, I still don't think that gets down to your other question. You're asking about the wheel brakes resetting (turning off) when getting back into a vessel. I see what you are saying, since the brakes were on while out of the vessel, why should they turn off when getting back in? I will also take a look at that. Sounds like something I could put into the generic "UI Fixes" I'm thinking of working on.

Yes that.

Share this post


Link to post
Share on other sites

I'm a little confused as to enabling StockPlus - if I understand the OP instructions correct, I need to globally enable StockPlus (via StockPlusController) as well as individually enabling discrete modules with True as well? If StockPlusController is missing or set to false, no StockPlus modules are enabled at all, regardless of individual setting?

Share this post


Link to post
Share on other sites
I'm a little confused as to enabling StockPlus - if I understand the OP instructions correct, I need to globally enable StockPlus (via StockPlusController)...

Yes, this. Download the StockPlusController.cfg and put it in your GameData directory. StockPlus will then be enabled, including each individual module.

Once enabled globally, by default the individual modules are enabled. But if you don't want one of the StockPlus modules enabled, you can go in and selectively disable it.

Cheers,

-Claw

Share this post


Link to post
Share on other sites
"Extend" is exactly that. If you assign "Extend" to an action group, that action group will only extend (or deploy) the control surface. It's like with engines. You have the choice to "Activate," "Shutdown," or "Toggle." Activate always activates, even if you toggle it.

Problem is, I never assigned "extend" to airbrakes. In fact, I never manually assign actions to them - stock assigns "toggle" on "brake" action on default. And this was the way all already flying ships had. But after I installed this add-on, default action in editor became "extend" and also *assigned* action changed to "extend" on all already flying ships. It reverted back when I deleted the mod.

Share this post


Link to post
Share on other sites
Problem is, I never assigned "extend" to airbrakes. In fact, I never manually assign actions to them - stock assigns "toggle" on "brake" action on default. And this was the way all already flying ships had. But after I installed this add-on, default action in editor became "extend" and also *assigned* action changed to "extend" on all already flying ships. It reverted back when I deleted the mod.

I have also encountered this. Basically, the default action for airbrakes has changed from "toggle" to "extend". I have not confirmed that this mod is at fault, though.

Share this post


Link to post
Share on other sites
I have not confirmed that this mod is at fault, though.

It's the mod. I can't actually remember now if I did it that way on purpose, or if it was a midnight coding mistake. But I can say that it doesn't make sense to me now, so I will fix it in the next release. I might just do a quick update for this, because I don't know why I would have done it this way. I'm going to go with the "it was late, and I made a poor choice" excuse. :P

Cheers,

~Claw

Share this post


Link to post
Share on other sites
It's the mod. I can't actually remember now if I did it that way on purpose, or if it was a midnight coding mistake. But I can say that it doesn't make sense to me now, so I will fix it in the next release. I might just do a quick update for this, because I don't know why I would have done it this way. I'm going to go with the "it was late, and I made a poor choice" excuse. :P

Cheers,

~Claw

Useful for me in this one case: non-spaceplane, craft re-entry. I disable pitch/yaw to begin with, and "turn on the brakes" when I hit atmo, and don't need to turn them off, until I land ;) But I'll use an action group for it, np ;)

Share this post


Link to post
Share on other sites
It is still a bug with Ven's stock revamp canard parts.

I don't know. I've installed Ven's revamp (which is pretty awesome) and it seems to be working just fine for me. I can adjust all the options and things seem to respond properly. They also don't blink in and out of existence. I want to help, but there must be more going on in the background here. I'd need more narrowing down and some log files.

s2znb2u.jpg

Cheers,

~Claw

Share this post


Link to post
Share on other sites

Hi there

thanks for bug fixes. Certainly a stupid question but what is Stockplus controller ?

THanks

Share this post


Link to post
Share on other sites

[EXC 18:01:15.956] IndexOutOfRangeException: Array index is out of range.

ClawKSP.StockPlusController.Start ()

is in my ksp.log many times, above shows just once loading to main menu

but playing through the game it starts to spam the log

Share this post


Link to post
Share on other sites

when I put a heat shield on and a decoupler or something beneath it a fairing forms, and when I go back to the space center and back to the craft again the fairing disappears making it look like the ship is floating on top, can you possibly fix that?

Share this post


Link to post
Share on other sites

Ditto to both of the above. No big deal, but annoying.

Share this post


Link to post
Share on other sites

I've tried to reproduce missing heat shield fairing problem, with simple scenario of mk1 command pod, 1.25m shield, TR-18A decoupler, and FL-T400 tank for those to sit on. Switched several times between launchpad and space center scene, then back to VAB and out to space center scene to reload original craft at Launchpad. No problems seen. I've not added any mod parts or textures to my KSP.

WalkingShadow89 - are you running KSP on Mac OSX? I ask, because steve_v made a post elsewhere suggesting he runs KSP on OSX.

If not OSX, I also wonder if it is a low memory situation, are "lots of mods" are being used?

Share this post


Link to post
Share on other sites
Hi there

thanks for bug fixes. Certainly a stupid question but what is Stockplus controller ?

THanks

Well, that's not a stupid question. The StockPlusController is what the Fix modules look to when they are checking to see if they should activate the Plus features. StockPlus features are minor changes or additions that I've done (in addition to pure bug fixes). I've included the Controller as a way to allow users to decide if they want just the pure bug fixes, or if they want to activate these minor features. StockPlus includes things like spreading out radial chutes attached in symmetry and unlocking the grip rating of stock rover wheels (so you can improve their grip on low gravity worlds).

The StockPlus features are annotated in the Readme with (Plus). To activate StockPlus, you'll need to download the StockPlusController.cfg from the first post.

[EXC 18:01:15.956] IndexOutOfRangeException: Array index is out of range.

ClawKSP.StockPlusController.Start ()

is in my ksp.log many times, above shows just once loading to main menu

but playing through the game it starts to spam the log

Should be harmless, but I'm fixing it. When you say "spam," is it rolling through constantly (which is what I think of as spam) or just on scene changes?

This log entry results from not having the StockPlusController.cfg file present (whether enabled or not). Edit: This is fixed in 1.0.2d.4

when I put a heat shield on and a decoupler or something beneath it a fairing forms, and when I go back to the space center and back to the craft again the fairing disappears making it look like the ship is floating on top, can you possibly fix that?

I know what you are talking about, but I haven't replicated it yet myself. So it could be a simple fix, or it might be something more involved.

Cheers,

~Claw

Edited by Claw

Share this post


Link to post
Share on other sites

Version 1.0.2d.4 is out. This includes minor fixes. The most major one being fixing the default aero surface action group to be "toggle" vice "extend". (Also fixed the IOOR Exception posted by Scientist.)

If you already have StockPlusController.cfg in your GameData directory, downloading the update should not overwrite it.

ModuleGimbalFix has StockPlus selectively disabled. If you want to enable it, you must edit the ModuleGimbalFix.cfg.

Cheers,

~Claw

Share this post


Link to post
Share on other sites
steve_v made a post elsewhere suggesting he runs KSP on OSX.

Nope, no Apple products here ;)

The disappearing heatshield fairing may, I suspect, be the fault of tweakscale... i.e. no tweakscale & so far no problem.

Edited by steve_v
Not actally running latest yet, so can't comment.

Share this post


Link to post
Share on other sites
Nope, no Apple products here ;)

The disappearing heatshield fairing may, I suspect, be the fault of tweakscale... i.e. no tweakscale & so far no problem.

I've had it happen to me, and I don't use TS. I do recall it happening several times when a heatshield was placed directly under the new service bay.

Share this post


Link to post
Share on other sites
Version 1.0.2d.4 is out. This includes minor fixes. The most major one being fixing the default aero surface action group to be "toggle" vice "extend". (Also fixed the IOOR Exception posted by Scientist.)

If you already have StockPlusController.cfg in your GameData directory, downloading the update should not overwrite it.

ModuleGimbalFix has StockPlus selectively disabled. If you want to enable it, you must edit the ModuleGimbalFix.cfg.

How ModuleGimbalFix behave with FAR ? I mean latest FAR already increase gimbal trough MM by 1.5 multiplicator. Is it ModuleGimbalFix stackable with FAR, meaning, both MM configs increase gimbals ?

If it does than FAR users should avoid to enable ModuleGimbalFix, only stock users should get increasing gimbals.

Thanks for all your effort and time taken to make those fixes.

Share this post


Link to post
Share on other sites
Is it ModuleGimbalFix stackable with FAR, meaning, both MM configs increase gimbals ?

Stock Plus doesn't change gimbal range, just forces them to be less sensitive, by converting them to use useGimbalResponseSpeed. FAR also does this but is run on Final which would overwrite any changes made by StockPlus. So, if I'm right, you'd end up with StockPlus's speed tweaking slider and FARs numbers for said speed. Shouldn't break the game, but may result in weirdness. I would say FAR users avoid activating ModuleGimbalFixPlus (I haven't activated it) because of the redundancy.

Share this post


Link to post
Share on other sites

As Obssessed says, the ModuleGimbalFix doesn't increase the gimbal range.

The Fix portion makes sure that engines gimbal when activated via the right click menu (not just when staging). They also gimbal before activation, which I think looks neat on lower stages but might look odd on exposed upper stages. So a bit of personal choice there.

The StockPlus additions is where you can activate gimbal response speed. It can cause vessels to react badly (or better) with SAS, but takes some playing with. It was causing problems/confusion, which is why it is disabled by default.

Cheers,

-Claw

Share this post


Link to post
Share on other sites

In the overcontrol bug, it says that there is an easy workaround. Do you know where I can find this workaround, because this bug is making docking impossible for me.

Share this post


Link to post
Share on other sites
In the overcontrol bug, it says that there is an easy workaround. Do you know where I can find this workaround, because this bug is making docking impossible for me.

Clear trim with Alt-X. Then make sure you have a probe/kerbal that can enable SAS on the other ship.

Share this post


Link to post
Share on other sites

I don't know if it's a bug or a shortcoming of stock KSP, but the interstage fairing doesn't stick to where it was closed.

I made an interstage fairing which goes downwards from the tip, so that I can decouple that heavy base later. But the fairing is making some ringing bell motions:

oh3p8sh.png

Edited by Enceos

Share this post


Link to post
Share on other sites
Clear trim with Alt-X. Then make sure you have a probe/kerbal that can enable SAS on the other ship.

To be clear, you have to ALT+X (or MOD+X) on the target ship (the one you aren't controlling). If you only ALT+X on the ship you are controlling, it won't stop the other ship from spinning (if that ship has trim input).

I don't know if it's a bug or a shortcoming of stock KSP, but the interstage fairing doesn't stick to where it was closed.

I made an interstage fairing which goes downwards from the tip, so that I can decouple that heavy base later. But the fairing is making some ringing bell motions:

http://i.imgur.com/oh3p8sh.png

Huh, that's strange. I haven't seen that one yet. Has this been jettisoned? It looks like it is disconnected from the base, and I guess the interstage joint isn't strong enough??

Cheers,

~Claw

Share this post


Link to post
Share on other sites
I've tried to reproduce missing heat shield fairing problem, with simple scenario of mk1 command pod, 1.25m shield, TR-18A decoupler, and FL-T400 tank for those to sit on. Switched several times between launchpad and space center scene, then back to VAB and out to space center scene to reload original craft at Launchpad. No problems seen. I've not added any mod parts or textures to my KSP.

WalkingShadow89 - are you running KSP on Mac OSX? I ask, because steve_v made a post elsewhere suggesting he runs KSP on OSX.

If not OSX, I also wonder if it is a low memory situation, are "lots of mods" are being used?

I think this problem happens only in Linux, and maybe only with radeon cards. I'm also experiencing it.

In the Linux thread there are more info about it.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.