Jump to content

[KSP v1.1.3] Stock Bug Fix Modules (Release v1.1.3b.1 - 10 Jul 16)


Recommended Posts

Hmm. Well then I think I misunderstood what was going on there. This might be something I'll have to fiddle with to understand what's even happening. I thought I saw at the end of the videos that power was completely lost. So I thought that's what you were talking about.

Exactly, the problem is only when in time warp! no matter how many RTG's,Nuclear reactors etc etc you add the EC will drain at high time warp,

stopping it the EC goes back up but by then if you use a life-support mod you are done :D

anyway thx for taking an interest and it would be nice to have some kind of a workaround for this if of course you have the time for it and the will :)

in any case thx :)

Link to post
Share on other sites
As of .24, that bug with ModuleGenerator was indeed finally fixed. :)

hmmm then i;am totally wrong... i'am using USI Converter module (from Kerbonite mod) and ECLSS then it seems that this is not an error but just the wrong thread :)

thx NathanKell for the info, ill try replacing the USI module with Module generator and see what happens :)

Link to post
Share on other sites

Haven't read a post if anyone is having a similar issue at the Launchpad... While waiting for a launch window, e.g. for a missing kerbal in orbit, I use timewarp until the target is over KSC, but when leaving warp the craft explodes and destroys the launchpad.

Perhaps it is an issue with KJR, like the one with big crafts/low fps mentioned above.

Link to post
Share on other sites
Haven't read a post if anyone is having a similar issue at the Launchpad... While waiting for a launch window, e.g. for a missing kerbal in orbit, I use timewarp until the target is over KSC, but when leaving warp the craft explodes and destroys the launchpad.

Perhaps it is an issue with KJR, like the one with big crafts/low fps mentioned above.

Was that with or without my fix? My fix "should" work with craft coming out of warp. If it's not, let me know and I'll have another look. And sorry, I've been slow about addressing KJR due to other projects.

Cheers,

~Claw

Link to post
Share on other sites
AsymmetricFlameoutFix – STATUS: Replicated, Under Build

- Air breathing engines roll back and flame out asymmetrically, causing aircraft to spin

I'm interested in this.

I have been successfully circumventing this bug by adding intakes and engines in groups (intakes-engine-intakes-engine) according to Kasuha's fuel flow rules thread.

The down side is that the intakes and engines need to be the last things placed on the vessel, so tweaking or changing a SSTO's payload means pulling off and reattaching the intakes and engines... which is a monumental ballache.

How's the fix progressing and what approach are you taking?

I assumed any fix would need to alter the placement order of parts (meaning a plugin or some sort).

Link to post
Share on other sites
OvercontrolFix – STATUS: Replicated, In the queue to fix (Low priority with easy workaround)

- Controlling a craft while within physics range of another craft causes all craft not under control to unlock SAS. Causes problems if craft have a non-zero trim state.

Wait, is this why whenever I get out and push, the capsules SAS doesn't hold attitude? I thought I was just going crazy as I could have sworn SAS stayed on and active when I got out and pushed in 0.23.5.. thanks for saving my sanity!

Link to post
Share on other sites
While I understand your concern, please also understand that I'm doing my best to help Squad get to the root of these problems. If my fixes enable Squad to fix the problem, then great! If they never get around to fixing the problem, then at least these things are available. Either way, it's a win for everyone.

Up to this point, Squad has been very focused on adding content to the game. As KSP moves into "beta," we will hopefully see more of these things getting fixed. :D

Cheers,

~Claw

I see these fixes as a temporary workaround and a little sign for SQUAD saying "some reported issues here, maybe have a look and consider action". Like you say, we win now as the issues are addressed and we may win later as these fixes are already designed and a good sign for where to pay attention to when the main code gets looked at.

Link to post
Share on other sites
Was that with or without my fix? My fix "should" work with craft coming out of warp. If it's not, let me know and I'll have another look. And sorry, I've been slow about addressing KJR due to other projects.

Cheers,

~Claw

I'm using LargeCraftLaunchFix.dll in the latest version. I'm not sure but it seems like that the ship explodes first and this causes the damage at the launchpad. In case of heavy crafts some parts of the crafts are still there, but in my case all is blown away.

Link to post
Share on other sites

Sorry for the delayed responses. I've been involved in something else and forgot to check this the last couple days.

How's the fix progressing and what approach are you taking?

I assumed any fix would need to alter the placement order of parts (meaning a plugin or some sort).

I have a working concept that fixes asymmetric flameout. It doesn't alter part order in any way. I'm actually taking control of the IntakeAir resource pool and parceling it out to the engines. I don't do anything to the code that produces IntakeAir, and I don't do anything to the code that consumes IntakeAir. I am capturing the air as it is produced and effectively hiding it from the craft. The required consumption for the engines is tracked and each engine receives a share of the available pool based on it's need. If there's enough air for everyone, then an engine gets what it asks for. If there isn't enough air available for everyone, then the engine only gets a percentage of it's request. This ensures equal percentages are available for all the active engines.

Wait, is this why whenever I get out and push, the capsules SAS doesn't hold attitude? I thought I was just going crazy as I could have sworn SAS stayed on and active when I got out and pushed in 0.23.5.. thanks for saving my sanity!

Quite likely. It's a very non-obvious bug that took me a few weeks (and several user's save files) to figure out.

I see these fixes as a temporary workaround and a little sign for SQUAD saying "some reported issues here, maybe have a look and consider action". Like you say, we win now as the issues are addressed and we may win later as these fixes are already designed and a good sign for where to pay attention to when the main code gets looked at.

Indeed. Before I started writing these fixes, I didn't have the slightest clue how to write an add-on for KSP. If you enjoy something enough, I suppose you find the motivation to help out rather than lamenting about the bad stuffs. :D

I'm using LargeCraftLaunchFix.dll in the latest version. I'm not sure but it seems like that the ship explodes first and this causes the damage at the launchpad. In case of heavy crafts some parts of the crafts are still there, but in my case all is blown away.

Thanks for the feedback. Does this happen when exiting time warp? Or all the time? Also, (in case you're using it)...It seems that my fix doesn't play perfectly well with KJR because of the way KJR handles physics onset. I haven't had the opportunity to download KJR and work on compatibility.

If you can provide just a bit more detail that would help me out.

And my fix doesn't do anything to the ship. So if your ship is exploding (and coming apart), then you might need to strengthen your ship a little.

Cheers!

~Claw

Link to post
Share on other sites
Does this happen when exiting time warp? Or all the time? Also, (in case you're using it)...It seems that my fix doesn't play perfectly well with KJR because of the way KJR handles physics onset. I haven't had the opportunity to download KJR and work on compatibility.

Just a quick 'me too'

Occurs pretty much instantly (AFAIK) when exiting timewarp on the pad, KJR also installed.

Link to post
Share on other sites

Thanks for the feedback. Does this happen when exiting time warp? Or all the time? Also, (in case you're using it)...It seems that my fix doesn't play perfectly well with KJR because of the way KJR handles physics onset. I haven't had the opportunity to download KJR and work on compatibility.

If you can provide just a bit more detail that would help me out.

And my fix doesn't do anything to the ship. So if your ship is exploding (and coming apart), then you might need to strengthen your ship a little.

~Claw

So, I think the best is to show... http://youtu.be/X2RRYtqdpI8 ... Watch out for the little jump after exiting timewarp. Maybe it's a kraken thing.

Link to post
Share on other sites
Haven't read a post if anyone is having a similar issue at the Launchpad... While waiting for a launch window, e.g. for a missing kerbal in orbit, I use timewarp until the target is over KSC, but when leaving warp the craft explodes and destroys the launchpad.

I've had this problem multiple times as well. It pre-dates v 0.25.

Was that with or without my fix? My fix "should" work with craft coming out of warp.
Without your fix. I'll try that. I use KJR, so we'll see how that goes.

Thank you for taking the lead to fix these bugs, rather than awaiting (hopefully) for Squad to fix in next release.

Edited by Apollo13
Link to post
Share on other sites

Okay. Thanks everyone for helping me see all the issues with the LargeCraftLaunchFix and KJR. LargeCraftLaunchFix has been updated to work correctly when KJR is installed. It worked for me for initial launches and during time warp on the launch pad / runway. Please let me know if you are still having problems.

Whoops. Wait a second before downloading. I had problems getting a good sync with GitHub. It's now updated correctly. Download away!

Cheers,

~Claw

Edited by Claw
Link to post
Share on other sites

v0.1.5 is out with the initial release of KerbalDebrisFix.dll.

This fixes a problem where kerbals would turn into debris under certain conditions when crashing a vehicle with a kerbal in a command chair.

Cheers,

~Claw

Link to post
Share on other sites
I have a working concept that fixes asymmetric flameout. It doesn't alter part order in any way. I'm actually taking control of the IntakeAir resource pool and parceling it out to the engines. I don't do anything to the code that produces IntakeAir, and I don't do anything to the code that consumes IntakeAir. I am capturing the air as it is produced and effectively hiding it from the craft. The required consumption for the engines is tracked and each engine receives a share of the available pool based on it's need. If there's enough air for everyone, then an engine gets what it asks for. If there isn't enough air available for everyone, then the engine only gets a percentage of it's request. This ensures equal percentages are available for all the active engines.

Well, that all sounds awesome! "Working concept", you say? Looking forwards to seeing that released.

Link to post
Share on other sites

Version 0.1.5b is out. Includes some minor fixes, the most useful of which is that EVAEjectionFix now nullifies ladder slide bug when going on the initial EVA. Turns out doing a full ladder slide fix has been more difficult than I expected.

Wonderful! Thanks for all those fixes of annoying bugs! Just experienced Kerbals in external seats becoming debris bug!

Great! I'm glad I got it out just in time. :D

Well, that all sounds awesome! "Working concept", you say? Looking forwards to seeing that released.

Yeah, this is a longer term fix though. It's a bit more complex than the rest of the fixes, and I'm not excited about how the IntakeAir pool is being managed right now. It does seem to work though. So I suppose it's a matter of if I can hide the ugly (albeit functional) parts.

Maybe I'll release it as a separate work in progress for people to try (and I can see if there's interest).

Cheers!

~Claw

Link to post
Share on other sites

Regarding symmetric flameouts, have a chat with LordFjord, see what he did with his (it looks good, but I'm unsure if I want it to require a keypress combo thing.. I'd rather it just did it upon launch or something).

EDIT: Sweet lawdy lawd, you just fixed one of my biggest bugbears with KSP!

This fixes a problem where kerbals would turn into debris under certain conditions when crashing a vehicle with a kerbal in a command chair.
Edited by ObsessedWithKSP
Link to post
Share on other sites

Thanks a lot for Large Craft Launch Fix ! Works nice along with KJR. Although my craft are still oversized, but I have found a safe limits for runway aircrafts.

Depending on weight distribution trough wheels, safe craft weight is somwhere between 600 - 650t without destroying runway.

Well, at least I know limits for SSTOs and my planes still can be usefull.

Link to post
Share on other sites
Regarding symmetric flameouts, have a chat with LordFjord, ...

Hmm. That's a completely different approach than what I'm taking. I'm not sure if I will abandon mine and let him take the lead on this. Or maybe I will clean mine up for release and let the masses decide. I'm not necessarily looking to compete with others if they are finding workable solutions. Unless people are looking for another way to handle it. (As you say, mine just "goes.")

Thanks a lot for Large Craft Launch Fix ! Works nice along with KJR. Although my craft are still oversized, but I have found a safe limits for runway aircrafts.

Excellent, I'm glad it's working for you! :D

And I would assume with the upgradeable buildings that are on the way, we will end up with launch platforms that are capable of different sized craft.

Cheers,

~Claw

Link to post
Share on other sites

I would definitely encourage you to continue on the asymmetric issue.

The approach being taken by the other guy is essentially reordering parts, as I described in one of my previous posts. While that will appear to work, it will have inherent limitations due to it being a workaround how craft files are currently read, rather than a solution.

Firstly, it will only ever work for even equivalent ratios of intakes to engines - it will never be able to handle three intakes and two engines. Secondly, the part reordering approach doesn't actually prevent asymmetric burnout - it just delays it to a point where your atmo thrust is so low anyway, that it's not a significant problem.

The approach you describe is superior and would appear to not have the above limitations. More importantly, as you have discussed with others, it is more in keeping with another aim of this bugfix pack: to provide examples of how the stock game should work. Squad would never implement a part reordering solution. They would implement a different way of pooling and distributing the intake resource.

Link to post
Share on other sites

As much as I hate to be the bearer of bad news, It appears that the latest version breaks the FAR flight GUI.

With 0.1.5a installed, the FAR gui won't open, no matter how many times you click the clicky thing :(

Linux x64, only FAR, MJ and this lot installed.

I get this at vessel load:

ArgumentOutOfRangeException: startIndex + length > this.length
Parameter name: length
at System.String.Substring (Int32 startIndex, Int32 length) [0x00000] in <filename unknown>:0
at ClawKSP.KerbalDebrisFix.OffRails (.Vessel VesselToFix) [0x00000] in <filename unknown>:0
at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0
at Vessel.GoOffRails () [0x00000] in <filename unknown>:0
at OrbitPhysicsManager.LateUpdate () [0x00000] in <filename unknown>:0

Complete log.

Edited by steve_v
Link to post
Share on other sites
Was that with or without my fix? My fix "should" work with craft coming out of warp.

Without your fix. I'll try that. I use KJR, so we'll see how that goes.

UPDATE: tried with the fix. Boosters separated PERFECTLY during launch, including KJR and FAR. Did not even have Seperatrons on boosters. They slid right off without bumping the rocket engine. Even a rocket engine that has a larger diameter than the core rocket (boosters attached with the extended radial decoupler). Craft was not in warp.

Thanks, again, for the "AnchoredDecouplerFix.dll" fix.

Edited by Apollo13
Link to post
Share on other sites

ArgumentOutOfRangeException: startIndex + length > this.length
Parameter name: length
at System.String.Substring (Int32 startIndex, Int32 length) [0x00000] in <filename unknown>:0
at ClawKSP.KerbalDebrisFix.OffRails (.Vessel VesselToFix) [0x00000] in <filename unknown>:0
at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0
at Vessel.GoOffRails () [0x00000] in <filename unknown>:0
at OrbitPhysicsManager.LateUpdate () [0x00000] in <filename unknown>:0

Hey steve_v,

Try downloading v0.1.5b. That was one of the things I fixed in that release.

Although I now see that I forgot to update the OP to reflect the new version. You can still get to the v0.1.5b by clicking on the releases link.

I'll update the OP in a bit, when I get back to my computer. Updated. Sorry for the confusion...

Cheers,

-Claw

Edited by Claw
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...