K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

11 hours ago, JadeOfMaar said:

Heh. :D All OPT's engines are gorgeous, but I must tell you they will not return to the main pack. The "other" Mk2 engines on the Duna plane are the new HAE-02 which directly replaces the J-61 (from which I made the S.A.G.E.)

Alongside the HAE-02, K. Yeon proposed an alternate model which was also short but had twin nozzles like the J-60 and S.U.R.G.E. and which may have directly replaced the J-60.

Ah yes I do recall that being brought up back when those engines were introduced.  Still though it would be nice to get some high performance engines in the main pack like the ones in the legacy pack.

Share this post


Link to post
Share on other sites

TL;DR : In OPT Legacy, k_oms is somehow bugged and interferes game-wide with, apparently, water physics (don't ask me how and why), commenting out ModuleAnimateGeneric and ModuleCargoBay on it is the only cure I've found yet.

Let me tell you a little tale :

Once upon a time, a brave soul wanted to design a seaplane, but no matter what he did, clever geometry, cunning aerodynamics, overwhelming thrust, no design would reach a speed allowing it to leave Kerbin bright blue waters. The curious little designer then turned to his wise ancestors for guidance and took a look at how Squad's seaplanes were designed and was surprised to find out that they suffered from the exact same problem, he then embarked on a journey to find which of his 350+ installed mods broke seaplanes.

Very long story short, after a few dozen hours (testing each mod individually, testing interactions, testing individual files), I've pinpointed it to two culprits on my install, one being OPT Legacy's k_oms part (the solid one), specifically the ModuleAnimateGeneric and ModuleCargoBay Modules. I first thought it was only due to the referred to nodes being commented out, but that didn't fix the problem, I had to comment out both modules to fix the problem. How that fixes a game-wide problem affecting planes not using this part, I have no clue (yet), but I've now tested it dozens of time, with the same result. With these two modules active on k_oms, Squad's Gull's maximum speed in water is around 22m/s, not enough for take-off, without them, it's about 42m/s, with take-off possible starting from 30m/s.

For the curious, the other culprit was SM Marine's HeliDeckDecal, limiting the Gull to 26m/s, seemed somehow linked to ModuleAnimateGeneric too, but I'd had enough of testing done for the month so since I didn't use the part, I just deactivated it.

Edited by EthanKerbman
  • Like 1

Share this post


Link to post
Share on other sites

@EthanKerbman Thanks for revealing that (and for the amount of effort you invested in it). Those modules shouldn't have been there. Your fix will be present in the next update.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

No trouble, I like this kind of tedious fun... the "funny" undisclosed end of the story is that after all that work, my seaplane still doesn't take off, but now I'm entirely sure it's the design's fault.

  • Like 1

Share this post


Link to post
Share on other sites

I really love this mod, have made a really cool SSTO with it. Only wish that the windows were blue, to fit better with stock parts. I have seem screenshots out there with blue windows, is a replacer or old version?

Thanks!

Share this post


Link to post
Share on other sites

Quick question, is there a cockpit for the H fuselage?  I can only find a drone core in that particular size on the CKan pack version. 

Share this post


Link to post
Share on other sites
9 hours ago, kerbalfreak said:

I really love this mod, have made a really cool SSTO with it. Only wish that the windows were blue, to fit better with stock parts. I have seem screenshots out there with blue windows, is a replacer or old version?

Thanks!

I'm not aware of this. It could have been the work of Windowshine or that stock parts had the same colors as OPT's windows back then (I know those changed).

2 hours ago, RogueWraith909 said:

Quick question, is there a cockpit for the H fuselage?  I can only find a drone core in that particular size on the CKan pack version. 

There is no H cockpit. Due to the underlying vision for the H class parts, none is to be expected. :/ 

Share this post


Link to post
Share on other sites

@The-Doctor This? Interestingly, it indeed strongly resembles OPT H or K series parts. But parts are missing from both H and K to complete this design.

x055.jpg.pagespeed.ic.76GF6KhrPl.jpg

Edited by JadeOfMaar
  • Like 1

Share this post


Link to post
Share on other sites

Hey

As an OPT fan I discovered new OPT engines as the Warpjet engines.

Can someone explain how to use them? Do I need only tons of electricity and whatever atmosphere to use them ? Do I need initial speed?

Some wiki about those engines would be helpful

An OPT wiki could also be great

Share this post


Link to post
Share on other sites

So I think the OPT Legacy messed up my game.  I love all the parts especially the engines however it seemed like all of a sudden my existing SSTOs had some serious new issues hitting speeds to leave orbit, especially the ones with the normal OPT parts that I never had issues with.  No matter what I tried it seemed like getting past the 400 m/s mark was difficult.  So I removed the Legacy folder and everything went back to normal.  Could the mod have messed with my game that much or am I imagining it all together?
 

For example my small SSTO with two OPT Turbo-ramjets and  two B9 Sabre S engines couldn't even break 400 m/s with the legacy pack installed yet have no issue after I removed it. TbAtmCu.jpg

 

Share this post


Link to post
Share on other sites
On 02/11/2017 at 8:07 PM, EthanKerbman said:

TL;DR : In OPT Legacy, k_oms is somehow bugged and interferes game-wide with, apparently, water physics (don't ask me how and why), commenting out ModuleAnimateGeneric and ModuleCargoBay on it is the only cure I've found yet.

Let me tell you a little tale :

Once upon a time, a brave soul wanted to design a seaplane, but no matter what he did, clever geometry, cunning aerodynamics, overwhelming thrust, no design would reach a speed allowing it to leave Kerbin bright blue waters. The curious little designer then turned to his wise ancestors for guidance and took a look at how Squad's seaplanes were designed and was surprised to find out that they suffered from the exact same problem, he then embarked on a journey to find which of his 350+ installed mods broke seaplanes.

Very long story short, after a few dozen hours (testing each mod individually, testing interactions, testing individual files), I've pinpointed it to two culprits on my install, one being OPT Legacy's k_oms part (the solid one), specifically the ModuleAnimateGeneric and ModuleCargoBay Modules. I first thought it was only due to the referred to nodes being commented out, but that didn't fix the problem, I had to comment out both modules to fix the problem. How that fixes a game-wide problem affecting planes not using this part, I have no clue (yet), but I've now tested it dozens of time, with the same result. With these two modules active on k_oms, Squad's Gull's maximum speed in water is around 22m/s, not enough for take-off, without them, it's about 42m/s, with take-off possible starting from 30m/s.

For the curious, the other culprit was SM Marine's HeliDeckDecal, limiting the Gull to 26m/s, seemed somehow linked to ModuleAnimateGeneric too, but I'd had enough of testing done for the month so since I didn't use the part, I just deactivated it.

 

3 minutes ago, KSPNoob said:

So I think the OPT Legacy messed up my game.  I love all the parts especially the engines however it seemed like all of a sudden my existing SSTOs had some serious new issues hitting speeds to leave orbit, especially the ones with the normal OPT parts that I never had issues with.  No matter what I tried it seemed like getting past the 400 m/s mark was difficult.  So I removed the Legacy folder and everything went back to normal.  Could the mod have messed with my game that much or am I imagining it all together?
 

For example my small SSTO with two OPT Turbo-ramjets and  two B9 Sabre S engines couldn't even break 400 m/s with the legacy pack installed yet have no issue after I removed it. TbAtmCu.jpg

 

Try the quick fix that @EthanKerbman mentions in this quoted post and let me know if that solves the issue.

Share this post


Link to post
Share on other sites
1 minute ago, KSPNoob said:

Thanks but not sure how to comment out something to fix it.

Put # at the start of the line OR it will be within its own block of bracers {} just delete the block that its in

Share this post


Link to post
Share on other sites
3 hours ago, KSPNoob said:

Thanks but not sure how to comment out something to fix it.

Open the part config and just delete ModuleAnimateGeneric, ModuleCargoBay, and their respective curly brackets { } and everything inside them, and let us know how it works out.

5 hours ago, gilflo said:

Hey

As an OPT fan I discovered new OPT engines as the Warpjet engines.

Can someone explain how to use them? Do I need only tons of electricity and whatever atmosphere to use them ? Do I need initial speed?

Some wiki about those engines would be helpful

An OPT wiki could also be great

The WarpJet engines are mine. Yes, they only need atmosphere and lots of electricity. They turn the air itself into plasma and shoot it out like any ion engine but with the power of a liquid engine, and are meant for use in upscaled systems and on any planet that has atmosphere but no Oxygen.

Only atmosphere pressure matters to them, not initial speed, so you can climb sharply to get to ideal altitudes, then cruise at the altitudes where they work best and you may no longer need your other air-breathing engines. They can accelerate infinitely (far, far beyond Mach 6) provided they still get enough IntakeAtm and don't explode from overheating themselves. Near Future reactors and Heat Control radiators are recommended for powering them.

  • The S.U.R.G.E. engine is a heavy lifter, awkward to place, but enables spaceplanes to carry less fuel mass and return from sea level on Eve and even harder planets with atmosphere. It pushes harder in thicker atmosphere and near the edge of space, and will need increasing amounts of EC at those extremes. It works where no other jet engine can work.
    Furthermore, with its size it holds lots of IntakeAtm. Close its intake during ascent just before the point where the IntakeAtm would bleed out and you can use it in vacuum for free dV as a pure but super inefficient ion drive.
  • The S.A.G.E. engine is a booster and upper stage sort, with the same nature as the S.U.R.G.E. but is more like a true scramjet engine. It's all you need for aircraft to get off the ground on Duna, but doesn't have the volume to produce much thrust at Kerbin or Laythe sea level. It even flames out in Eve's lower atmosphere. This engine works in vacuum like the S.U.R.G.E. and is slightly more efficient but needs the big engine's tankage.

Since you're only now noticing these, you may want to cast your eyes on the ARI-73 engine. If you don't already know, it now replaces nuclear jet and nuclear rocket engines.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
2 minutes ago, KSPNoob said:

 

So Everything I have highlighted should be deleted?

 

CBol6Io.png

 

Yep

  • Like 2

Share this post


Link to post
Share on other sites

The MockingJay

The MockingJay is the first multipurpose, amphibious, SSTO VTOL. Built by the greatest engineers in history, able to get you to and from orbit . Warranty void if atmospheric entry is too steep or autolanding is attempted. Available on KerbalX

https://kerbalx.com/The-Doctor/MockingJay

9UlRmjX.png

CeJH81i.png

 

Edited by The-Doctor
  • Like 1

Share this post


Link to post
Share on other sites
14 minutes ago, The-Doctor said:

I don't think ANYONE has ever built such a versatile SSTO.

My dude, I guess you've never been to the Showroom. (Link in my signature)

Nonetheless you have an intriguing thing going on. :rep: 

Edited by JadeOfMaar
  • Like 1

Share this post


Link to post
Share on other sites

Mines is still unique. It's an SSTO, VTOL, SMALL, Amphibious spacecraft that can work in FAR and stock. I've got 5 versions and 5 duplicate of each of those capable of working in FAR.

Share this post


Link to post
Share on other sites

For some reason KSP stops loading when it tries to load the SAGE engine in the OPT legacy file.

It doesn't crash the game it just stops loading.

I'm running KSP 1.3.0 and using OPT legacy 1.0.8a and have had the same problem with OPT legacy 1.0.9

If anyone has a fix for this I would appreciate it

Share this post


Link to post
Share on other sites
22 minutes ago, memeconnoiseur said:

For some reason KSP stops loading when it tries to load the SAGE engine in the OPT legacy file.

It doesn't crash the game it just stops loading.

I'm running KSP 1.3.0 and using OPT legacy 1.0.8a and have had the same problem with OPT legacy 1.0.9

If anyone has a fix for this I would appreciate it

The SAGE and SURGE engines use a non-stock resource. Install Community Resource Pack.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now