K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

so, since opt (main) currently works in 1.4.2, soon to be 1.4.3 (damnet) what is the installation procedure? do i install main, then legacy, then reconfig? and even then, where do i install the latter 2 to?

Share this post


Link to post
Share on other sites
42 minutes ago, Modding Maniac said:

so, since opt (main) currently works in 1.4.2, soon to be 1.4.3 (damnet) what is the installation procedure? do i install main, then legacy, then reconfig? and even then, where do i install the latter 2 to?

All 3 go into the root (top level) of GameData. Many mod downloads have a GameData folder inside as a guide.

OPT Legacy needs OPT Reconfig (not optional)

OPT Main needs OPT Reconfig (optional, but then your OPT won't integrate well with other things).

Share this post


Link to post
Share on other sites
53 minutes ago, Modding Maniac said:

so, since opt (main) currently works in 1.4.2, soon to be 1.4.3 (damnet) what is the installation procedure? do i install main, then legacy, then reconfig? and even then, where do i install the latter 2 to?

I would guess, that you first install the main mod, then the configs. Usually all the established mod developers are providing you with an archive that is to be dropped into your KSP folder, merging it with the GameData-folder. Or you drop the actual mod itself into GameData, making sure that only the mod is there without any nested folders (i.e. a GameData folder inside gamedata). That's usually all there is to it... :D

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, JadeOfMaar said:

[1.4.2] OPT Legacy v1.1.0

  • Added dependency/migrated most MM patches to --> OPT Reconfig mod
  • Added LFO version of aerodynamic OMS blocks
  • Added Mk2 ram intake (it will not cause any game or craft issues, and Legacy had it first)
  • Fixed 
    • CCK support (OPT category will show if OPT Legacy without OPT Main is installed)
    • Manufacturer in blade antenna and some tanks
    • bulkhead profile in J-81 engine, spotted by Kolago
    • Stail lab science cap, is 1050 now, not 500
  • Added Tweakscale for all the surface-attached RCS
  • Replaced FS dependency in Stail docking and utility bay with stock module
  • Configured engines:
    • Retuned WarpJets and fixed Isp problem. SAGE is a little stronger now and will flameout at 9 atm, not 3 atm
    • Adjusted particles for all engines (again =D )
    • Use cases
      • J-61 is no longer as wasteful or wildly OP but is a dynamic scramjet now (endless acceleration with Isp falloff)
      • J-60 is also a dynamic scramjet (endless acceleration with Isp falloff)
      • J-60D requires EC in ClosedCycle, Isp lowered so the J-81 stands alone as highest Isp vac engine (like Dark Drive) but J-60D in closed cycle remains very powerful near sea-level in atmo unlike J-81
      • J-81 requires EC in ClosedCycle and is poor near sea level, gets a boost at 0.3 atm pressure
      • J-81 airbreathing mode adjusted for thick atmosphere
      • Stail Linear Aerospike has better thrust and Isp
    • Gimbals
      • J-81 visibly animates: given plenty Yaw authority and slight Pitch authority due to dual nozzle (emulate differential thrust)
      • J-60 and J-60D same as J-81 but do not animate
      • WarpJet SURGE given half gimbal ranges of J-60, J-60D
      • Stail Linear Aerospike does not animate but is given plenty Pitch authority

Get OPT Legacy :: SpaceDock

Get OPT Reconfig :: SpaceDock

You are my hero!!!!

Now I just have to wait patiently for GPP (with all its dependencies, I'm afraid), Ursa Minor's sunflare (my screenshots aren't the same without it), and a few more mods. Then I will start a new career in 1.4.2, hopefully more stable than 1.3.1.

I have bought Kerbal's DLC to support developers, but community content it's by far more valuable. I think developers should improve the base game: performance, stability, graphics, etc.

 

  • Like 1

Share this post


Link to post
Share on other sites

Best news of the week and probably lost weekend - my 1.4 career have paused at point where I invented OPT parts, so now I can continue )) many thanks! 

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, JadeOfMaar said:

All 3 go into the root (top level) of GameData. Many mod downloads have a GameData folder inside as a guide.

OPT Legacy needs OPT Reconfig (not optional)

OPT Main needs OPT Reconfig (optional, but then your OPT won't integrate well with other things).

what do you mean by not integrate well? 

Share this post


Link to post
Share on other sites

heres the installation procedure im doing-install opt main into the ksp folder and install legacy into the gamedata folder and then install the reconfig in to gamedata, everytime i load ksp it says the b9 partswitch had a fatal error and that optox tank type could not be found, what do i do?

Share this post


Link to post
Share on other sites
5 hours ago, Modding Maniac said:

heres the installation procedure im doing-install opt main into the ksp folder and install legacy into the gamedata folder and then install the reconfig in to gamedata, everytime i load ksp it says the b9 partswitch had a fatal error and that optox tank type could not be found, what do i do?

Try moving OPT main to /GameData. 

 

Share this post


Link to post
Share on other sites
9 hours ago, Modding Maniac said:

what do you mean by not integrate well? 

It means OPT main won't get proper or better integration with other things that players need and want like life support and fuel options.

15 hours ago, pr4ger said:

Best news of the week and probably lost weekend - my 1.4 career have paused at point where I invented OPT parts, so now I can continue )) many thanks! 

Aww yeah. you're welcome. :) 

6 hours ago, Modding Maniac said:

heres the installation procedure im doing-install opt main into the ksp folder and install legacy into the gamedata folder and then install the reconfig in to gamedata, everytime i load ksp it says the b9 partswitch had a fatal error and that optox tank type could not be found, what do i do?

I think I know what the problem is. Do you have Nertea's Cryo Tanks/Engines installed? The tank type is conditional (and should not appear if you have CryoTanks) but the subtype (tank option) is not aware and always expects the OPTOX tank type. I should fix that.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
1 minute ago, JadeOfMaar said:

It means OPT main won't get proper or better integration with other things that players need and want like life support and fuel options.

Aww yeah. you're welcome. :) 

I think I know what the problem is. Do you have Nertea's Cryo Tanks/Engines installed? The tank type is conditional (and should not appear if you have CryoTanks) but the subtype (tank option) is not aware and always expects the OPTOX tank type.

I am having the same exception. I have Cryo tanks and engines installed. Any sollution?

Share this post


Link to post
Share on other sites
3 minutes ago, JadeOfMaar said:

It means OPT main won't get proper or better integration with other things that players need and want like life support and fuel options.

Aww yeah. you're welcome. :) 

I think I know what the problem is. Do you have Nertea's Cryo Tanks/Engines installed? The tank type is conditional (and should not appear if you have CryoTanks) but the subtype (tank option) is not aware and always expects the OPTOX tank type. I should fix that.

yes, i have cryotanks installed. and thank you!

Share this post


Link to post
Share on other sites

It's an easy solution. Open GameData/OPT_Reconfig/OPT_B9PS.cfg and look for B9_TANK_TYPE:NEEDS[!CryoTanks] (practically at the top).

Delete this part: :NEEDS[!CryoTanks]

  • Like 1

Share this post


Link to post
Share on other sites
Just now, JadeOfMaar said:

It's an easy solution. Open GameData/OPT_Reconfig/OPT_B9PS.cfg and look for B9_TANK_TYPE:NEEDS[!CryoTanks] (practically at the top).

Delete this part: :NEEDS[!CryoTanks]

will that do anything negative regarding cryotanks?

Just now, Modding Maniac said:

will that do anything negative regarding cryotanks?

or anything else?

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Modding Maniac said:

will that do anything negative regarding cryotanks?

Nope. nothing at all. :) 

Update/Fix published. :) 

  • Like 1

Share this post


Link to post
Share on other sites
45 minutes ago, JadeOfMaar said:

Nope. nothing at all. :) 

Update/Fix published. :) 

sorry if i sound moronic, but which mod is it in? (opt main, legacy, reconfig) and how do i find it?

wait nevermind, found it, testing now

Edited by Modding Maniac

Share this post


Link to post
Share on other sites
23 minutes ago, Modding Maniac said:

sorry if i sound moronic, but which mod is it in? (opt main, legacy, reconfig) and how do i find it?

wait nevermind, found it, testing now

did not work, still get the error

Share this post


Link to post
Share on other sites

I really like all of the parts in this mod, I was trying so hard to make the kinds of spaceplanes I wanted to fly in stock but it just wasn't ever right. However, I'm experiencing an issue where some of the parts, namely the large inline docking port and the deployment bay, are causing the craft to spawn 1050m in the air. I haven't tested every part to see which ones have this bug but those are the two I really wanted to use in VTOL designs. I'm running KSP 0.1.4 (I know this mod has not been patched for .4), FAR (with OPT patch), MechJeb, and KER. Not sure if this is a mod compatibility issue or if it pertains to the 0.1.4 KSP version. Any help with this issue would be greatly appreciated!

Edited by RokkyRaccoon

Share this post


Link to post
Share on other sites
18 hours ago, RokkyRaccoon said:

KSP 0.1.4

You will get no support there. I don't think Squad even released a version less than 0.2 lol!

In seriousness, those are known issues and unfortunately they aren't going to be fixed anytime soon. Parts with certain complex colliders in any mods will trigger this problem. Either install this or try not to use those parts. Sorry. :/ 

Speaking of patches and FAR, you may want to grab this if you haven't already. It enables OPT to integrate with newer/better/more mods. 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, JadeOfMaar said:

You will get no support there. I don't think Squad even released a version less than 0.2 lol!

In seriousness, those are known issues and unfortunately they aren't going to be fixed anytime soon. Parts with certain complex colliders in any mods will trigger this problem. Either install this or try not to use those parts. Sorry. :/ 

 

Yeah not sure what I was thinking there.. :huh:

However, WorldStabilizer worked perfectly for me and I just completed the first successful flight of the VTOL SSTO I was trying to build, thanks for the help!

Also I noticed this was discussed just a few pages ago in this thread, my bad.

  • Like 1

Share this post


Link to post
Share on other sites

I seem to be having a unique problem exclusive to the OPT-J Deployment Bay. 

Any time I include the OPT-J Deployment Bay on one of my ships, the ship "launchs" at ~1,100 meters in the air and proceeds to fall immediately to its death.

I tried troubleshooting down to the point where I removed all of my other mods (I use about 15, mostly graphical), tested them against each other for conflicts, and then uninstalled/reinstalled a clean KSP, and then added OPT. It's the strangest bug I've ever encountered.

Is this happening to anyone else? A known bug? Any fixes? I was looking forward to using that part for VTOL projects.

  • Like 1

Share this post


Link to post
Share on other sites
58 minutes ago, redsunrising15 said:

A known bug? Any fixes?

Yes and yes. 

Share this post


Link to post
Share on other sites

Yes i am currently also experiencing this issue, i haven't found a fix either. If anyone else has any ideas please tell.

Share this post


Link to post
Share on other sites
1 hour ago, mr mun said:

Yes i am currently also experiencing this issue, i haven't found a fix either. If anyone else has any ideas please tell.

You might want to read a little more closely in forum threads. I answered the problem right above you. ;) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now