Jump to content

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017


Recommended Posts

2 hours ago, doggonemess said:

Awesome! Thanks so much guys, I appreciate the suggestions. I'm going to try the vertical placement method. And definitely going to put the completed assemblies in subassemblies. I can't believe I didn't think of that! :rolleyes:

I didn't even think of putting them in subassemblies... must be the creeping senilitiez setting in again

Link to post
Share on other sites

@K.Yeon - what settings are you using when you save your textures as DDS? I am gonna start experimenting with the OPT 'night' skins again and I know you can MM patch them to make them interchangable but I want the file sizes to be the same size you use.

 

Test run #1: Starting with the Stail parts, namely because they were simpler textures.  

 

Basically opened the DDS in photoshop

Then duplicated the layer

Inverted the copy (made it a negative)

Some sections needed to be reinverted back to original (cockpit windows)

Set the opacity of the layer to 50%

Then I created a new layer and painted it a solid colour (in the screenshots I am posting its 100,100,100) and positioned it UNDER the inverted layer

Then saved the texture under a new name

 

The next part was trickier.  Ended up getting KerbalObjectInspector so I knew what object in the .mu I would be texture swapping and then used @Stone Blue's Deadskins MM patch to work out how to tell KSP to change between the Normal colours and the Night colours.  What I also notices which excites me is in your old textures where you incorporated an amount of texture swapping already is that all the decals etc remain unaffected.

 

I believe that the current colour setting needs to be darker and and I may try straight black for the backing layer next time.  No matter what it needs that opacity reduction AND the backing layer otherwise the lighter parts in the screenshots are blindingly white.

 

 http://imgur.com/a/sXxkd

Edited by stali79
Link to post
Share on other sites
2 hours ago, Kolago said:

The texture for the "OPT K - tri 2.5m Engine Mount" (k_3m_tricoupler.dds ) is missing. Part is pink in the game.

is that the only part appears pink?
the K tri 2.5m part shares the texture file "k_texture_2.dds" with a few other k parts.

parts becomes pink when the texture is missing, which means all of the sharing texture parts should be pink  (jk adaptor 3m, k bicoupler and k cargo bay).
if that's not the case, you might of misplaced the folders, just try re install

or you ran out of ram? unlikely if you have 4gb+ ram and using ksp64bit...

 

Link to post
Share on other sites
On 05/02/2017 at 1:28 AM, stali79 said:

@K.Yeon - what settings are you using when you save your textures as DDS? I am gonna start experimenting with the OPT 'night' skins again and I know you can MM patch them to make them interchangable but I want the file sizes to be the same size you use.

----------

For pre 1.8 textures if i remember correctly they were exported as png files, and converted to dds by a simple program (i think it was DDS4KSP).
It caused the texture's quality dropped even more..

Let me see if i can find the old psd files for the legacy parts, most of them should have separate layers for colors and panelline details, so you just need to change the color layer without needing to invert the panellines (which looks abit strange).

Link to post
Share on other sites
38 minutes ago, K.Yeon said:

is that the only part appears pink?
the K tri 2.5m part shares the texture file "k_texture_2.dds" with a few other k parts.

parts becomes pink when the texture is missing, which means all of the sharing texture parts should be pink  (jk adaptor 3m, k bicoupler and k cargo bay).
if that's not the case, you might of misplaced the folders, just try re install

or you ran out of ram? unlikely if you have 4gb+ ram and using ksp64bit...

 

Its the only pink OPT part. I am running with 16GB RAM and KSP 64bit.

No load error in the output_log.txt for the "k_texture_2" texture or "k_3m_tricoupler" model.

"Config(PART)" is ok. "PartLoader: Compiling Part" is ok.

I see this problem:

Load(Model): OPT/Parts/main/k_cargoRamp
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "k_cargoRamp/k_cargoRamp/ramp_base.001/ramp_extension.001/bottomCollider"
 
(Filename:  Line: 0)

Load(Model): OPT/Parts/main/k_cargoRamp_variant
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "k_cargoRamp_variant/k_cargoRamp_smooth/ramp_base.001/ramp_extension.001/bottomCollider"
 

 

At a closer look at the "OPT K - tri 2.5m Engine Mount", the ships side has a texture, the hull and engine side is pink.

Edited by Kolago
Link to post
Share on other sites
21 minutes ago, Kolago said:

Its the only pink OPT part. I am running with 16GB RAM and KSP 64bit.

No load error in the output_log.txt for the "k_texture_2" texture or "k_3m_tricoupler" model.

"Config(PART)" is ok. "PartLoader: Compiling Part" is ok.

I see this problem:

Load(Model): OPT/Parts/main/k_cargoRamp
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "k_cargoRamp/k_cargoRamp/ramp_base.001/ramp_extension.001/bottomCollider"
 
(Filename:  Line: 0)

Load(Model): OPT/Parts/main/k_cargoRamp_variant
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

BoxColliders does not support negative scale or size.
The effective box size has been forced positive and is likely to give unexpected collision geometry.
If you absolutely need to use negative scaling you can use the convex MeshCollider. Scene hierarchy path "k_cargoRamp_variant/k_cargoRamp_smooth/ramp_base.001/ramp_extension.001/bottomCollider"
 

 

At a closer look at the "OPT K - tri 2.5m Engine Mount", the ships side has a texture, the hull and engine side is pink.

Download these 3 files:
k_3m_tricoupler.cfg
k_3m_tricoupler.mu
k_texture_2.dds
and place them in: Kerbal Space Program\GameData\OPT\Parts\main\
replace the original files.

These 3 files definitely works, if this fails to fix the problem, i really have no idea what caused the problem...

Link to post
Share on other sites
1 hour ago, joker169 said:

Sorry if this has already been addressed but, can't seem to find solution(searched for at least 20 min). Elevon for the Main wings will not snap in holes, Radial attach on as well as surface attach. Tried holding down ALT as well.

Output Log

KSP log

IMG

There is no 'snap' for those. Make sure angle attachment is off. There is a sweet spot where they will kinda want to go then you just rotate it into place. Put the wing vertically first and it makes it easier

Link to post
Share on other sites

Kladies and Kentlemen, The OPT Legacy Division would like to introduce the latest in Kerbal technology.

 

From a secret lab in the Kerbalayas scientists have mastered STEALTH technology.  They totally didn't mix up a can of black paint with a can of white paint and decided to call it a Stealth coating.

 

OPT Night OPS Pack now Available on Spacedock.

 

http://imgur.com/a/MQxUF

 

Installation: Just copy the OPT_Night folder to your GameData folder and you are good to go. Currently 1.0 only has Stail parts from the legacy pack done.

 

Edited by stali79
Link to post
Share on other sites
3 hours ago, stali79 said:

There is no 'snap' for those. Make sure angle attachment is off. There is a sweet spot where they will kinda want to go then you just rotate it into place. Put the wing vertically first and it makes it easier

Thanks for the quick reply. I final got it the way you said vertical and tried horizontal(didn't seem to make much difference). that sucks big time. Is there a way to add configurable attachment nodes to the said areas to make it easier?

Like this?

configure

Link to post
Share on other sites

Hi, love the mod, looks really fun but i have a problem. I downloaded it and found all the parts etc but my game has been crashing ALOT since i downloaded this, especially when i try to launch things. I don´t have that many mods other than this and i would love to get this resolved because i really want to try the parts ;(

Link to post
Share on other sites
6 hours ago, joker169 said:

Thanks for the quick reply. I final got it the way you said vertical and tried horizontal(didn't seem to make much difference). that sucks big time. Is there a way to add configurable attachment nodes to the said areas to make it easier?

Like this?

configure

I tried this when i first made those wings but it doesn't work because the control surface doesn't get mirrored the correct way :( The current configuration is the only way it works... perhaps i will re make the wings to make them easier to attach in the distant future.

3 hours ago, NyaN200 said:

Hi, love the mod, looks really fun but i have a problem. I downloaded it and found all the parts etc but my game has been crashing ALOT since i downloaded this, especially when i try to launch things. I don´t have that many mods other than this and i would love to get this resolved because i really want to try the parts ;(

OPT is simply a parts pack, it doesn't causes crash. Without a log, i can only suspect it maybe caused by outdated firespitter or RPM?
Post the last couple of hundred lines of the ksp log file (Steam\steamapps\common\Kerbal Space Program\KSP.log) right after you encountered a crash, it usually tells the cause.

Link to post
Share on other sites
2 hours ago, K.Yeon said:

I tried this when i first made those wings but it doesn't work because the control surface doesn't get mirrored the correct way :( The current configuration is the only way it works... perhaps i will re make the wings to make them easier to attach in the distant future.

OPT is simply a parts pack, it doesn't causes crash. Without a log, i can only suspect it maybe caused by outdated firespitter or RPM?
Post the last couple of hundred lines of the ksp log file (Steam\steamapps\common\Kerbal Space Program\KSP.log) right after you encountered a crash, it usually tells the cause.

Thanks for the reply. Love the mod minus that one minor issue, look forward to the future of this mod. if help is needed test or help in some other way :wink: in the future, i'd be more that happy to contribute.

Link to post
Share on other sites

hello,

i got a question regarding the IVA's in version 1.9.2 - for the 2.5meters an the MK2 pod the complete props in the interiors are missing. in the external view the backround of the portraits is plain black without any geometry whatsoever...

is this known? are the intreiors being redone and not finished? is my installation borked? any other mistakes on my side?

the Interiors of the big parts work flawlessly.

please forgive me if this was answered before (but buried in this 100 pages tread)  thank you.

Link to post
Share on other sites
1 hour ago, ugly1 said:

hello,

i got a question regarding the IVA's in version 1.9.2 - for the 2.5meters an the MK2 pod the complete props in the interiors are missing. in the external view the backround of the portraits is plain black without any geometry whatsoever...

is this known? are the intreiors being redone and not finished? is my installation borked? any other mistakes on my side?

the Interiors of the big parts work flawlessly.

please forgive me if this was answered before (but buried in this 100 pages tread)  thank you.

Not all IVAs are complete yet

Link to post
Share on other sites

Is it just me or do the OPT fuselages make it near impossible to get the CoM ahead of the CoL?  I pretty much can't use these parts for spaceplanes, at all, since the bodies produce too  much lift to get it balanced correctly.  It could be because I'm using the [dev build of] FAR.. are people using stock aero *not* seeing this problem?

Link to post
Share on other sites
7 minutes ago, ss8913 said:

Is it just me or do the OPT fuselages make it near impossible to get the CoM ahead of the CoL?  I pretty much can't use these parts for spaceplanes, at all, since the bodies produce too  much lift to get it balanced correctly.  It could be because I'm using the [dev build of] FAR.. are people using stock aero *not* seeing this problem?

I have the issue with stock, but I just get creative in wing placement.  What I struggle with is getting my CoL behind my DCoM

 

https://kerbalx.com/stali79/craft

Edited by stali79
Link to post
Share on other sites

Night Ops Pack 1.1 On Spacedock.

 

1.1

* Stail Aerospike
* Stail - Avatar Adapters (both)
* Stail Drone Core
* Stail - 2.5m Adaptors (Broken)
* Stail BiCoupler (Broken)
* Stail QS Cockpit
* Stail Engine Mount

 

** Known Issues

* Door on the 6m Cockpit
* Both Stail - 2.5m Adaptors not changing
* Stail Bicoupler not changing

 

@K.Yeon - with parts having issues, can you check the mesh names for me please.  I have the Patch correct but its not changing for some unknown reason

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...