K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

4 hours ago, EpicShadow223 said:

I really would like to use this mod, but there is one part that makes my game crash every time. It's wing_c_elevon_2/opt_wing_c_elevon2 is there any way to fix it?

It wont be the part causing your crashes. Cant identify the cause without your logs mate. Please click the link in my signature.

Edited by stali79

Share this post


Link to post
Share on other sites

Guys , just wanted to say  many thanks for spending your time and effort working on this mod. by far my favorite wings for anything plane/spaceplane I build . 

Got it to work with the 1.3, got through my share of crashes.  now I can finally migrate my game to latest.  

 

Share this post


Link to post
Share on other sites
2 hours ago, EpicShadow223 said:

So it turns out the mod conflicts with the BDarmory Mod. Well, now I got the game working again! :)

OPT is a parts only mod, it is almost impossible for it to cause crashes, sounds more like your version of BDA was old and its .dll file was causing the crashes.

Share this post


Link to post
Share on other sites

Hi everyone, I've recently updated ksp to 1.3, and I've got some issues with OPT parts. When I turn to IVA view, no matter what cockpit type it is, most of the buttons were missing, only the main display was left. Is there anyone who's experiencing this problem? Thanks. 

Share this post


Link to post
Share on other sites
5 hours ago, jasperhome1998 said:

Hi everyone, I've recently updated ksp to 1.3, and I've got some issues with OPT parts. When I turn to IVA view, no matter what cockpit type it is, most of the buttons were missing, only the main display was left. Is there anyone who's experiencing this problem? Thanks. 

Are you using the latest version of RPM? And some cockpits don't have buttons etc.

Share this post


Link to post
Share on other sites
1 minute ago, stali79 said:

Are you using the latest version of RPM? And some cockpits don't have buttons etc.

Yes I'm using the latest version of RPM, and OPT-K and J cockpit don't have cockpit buttons as I played before in ksp 1.2.2.

Share this post


Link to post
Share on other sites
8 minutes ago, jasperhome1998 said:

Yes I'm using the latest version of RPM, and OPT-K and J cockpit don't have cockpit buttons as I played before in ksp 1.2.2.

reinstall RPM and OPT

 

Share this post


Link to post
Share on other sites

@stali79 I discovered something far more serious than broken IVA controls. The Humpback cockpit's intake is broken (or terribly misaligned). :( Once the cockpit is moving, the intake rate falls. This is definitely on my list of things to deal with once I learn to edit an mu directly. The WarpJet engines on my Humpback test plane starve at Mach 6 or 7 because they're not getting the expected support from the equivalent of 2 more OPT ram intakes. 

Share this post


Link to post
Share on other sites
6 minutes ago, JadeOfMaar said:

@stali79 I discovered something far more serious than broken IVA controls. The Humpback cockpit's intake is broken (or terribly misaligned). :( Once the cockpit is moving, the intake rate falls. This is definitely on my list of things to deal with once I learn to edit an mu directly. The WarpJet engines on my Humpback test plane starve at Mach 6 or 7 because they're not getting the expected support from the equivalent of 2 more OPT ram intakes. 

You don't lol, you get the mu importer for blender and import the mu into blender lol. but thats the extent of my knowledge. My guess is the Humpback wasn't completed

Share this post


Link to post
Share on other sites

@stali79 I have a feeling that it's not going to be as tedious to do as I think.... But there's no doubting the Humpback series is incomplete. :/ It's indeed fairly confined which is why the KH series exists. Nonetheless I'm visually biased in this case and much prefer the smoother curves of the Humpback profile to KH. :blush: 

Share this post


Link to post
Share on other sites
5 minutes ago, JadeOfMaar said:

@stali79 I have a feeling that it's not going to be as tedious to do as I think.... But there's no doubting the Humpback series is incomplete. :/ It's indeed fairly confined which is why the KH series exists. Nonetheless I'm visually biased in this case and much prefer the smoother curves of the Humpback profile to KH. :blush: 

Same. But i never had issues with it in the past

Share this post


Link to post
Share on other sites

@stali79 I understand that. I never did think much of any cockpit's built-in intake until I made the OPT_USI patch. And now the WarpJets make this a real issue-- just to me anyway. On that note I think all the legacy jet engines are a bit thirsty for air now... :ph34r:  

Share this post


Link to post
Share on other sites

Hello

Is OPT mod working on 1.3? Maybe same small problem? As i have a lot of OPT planes in my game, i don't want to go to 1.3 if i am not sure it will work....

Share this post


Link to post
Share on other sites
1 hour ago, gilflo said:

Hello

Is OPT mod working on 1.3? Maybe same small problem? As i have a lot of OPT planes in my game, i don't want to go to 1.3 if i am not sure it will work....

OPT is entirely a parts pack. If OPT and its dependencies are installed properly and up-to-date, it should work.

Note that it's actually two sets of parts mods. The main mod should be installed in /GameData/OPT while the legacy pack should be installed in /GameData/OPT_Legacy . Check the OP for more details.

Share this post


Link to post
Share on other sites

@gilflo There's no risk of your existing craft breaking. OPT works just fine. Just make sure your Firespitter is up to date. The most you'll have to do is reconfigure OPT tanks.

Share this post


Link to post
Share on other sites
1 hour ago, KerBlitz Kerman said:

So can you put 'x1.3' in da title please @JadeOfMaar?

Only the owner of a given thread can do that.

Your best bet is to keep your eyes on the changelog and the version info field(s) on the SpaceDock pages.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
9 minutes ago, KerBlitz Kerman said:

Sorry, thought you were the owner. New thread then plz?

No need for a new thread. @K.Yeon Still runs the mod, due to his work commitments there is often delays in his updating. BOTH OPT and OPT_Legacy are purely parts mods so the chance of them EVER causing crashes is almost nothing. If a new thread were to be made it would be for the Legacy pack ONLY and it would be made by me, and at this stage I have no intention of starting a new thread as there is simply no need. Rest assured that these 2 mods work perfectly fine in 1.3 as long as IFS, FS and RPM are up to date.

Share this post


Link to post
Share on other sites

Ah. I misunderstood because @K.Yeon seemed not online often. Well, @K.Yeon I am sorry, and as soon as you get back on can you fix the title?

Edited by KerBlitz Kerman

Share this post


Link to post
Share on other sites
On 7/17/2017 at 6:57 PM, King Something said:

OPT is entirely a parts pack. If OPT and its dependencies are installed properly and up-to-date, it should work.

Maybe I installed it incorrectly, but it isn't working. I just downloaded the latest version and when I loaded ksp it crashed.

Share this post


Link to post
Share on other sites
Just now, occ said:

Maybe I installed it incorrectly, but it isn't working. I just downloaded the latest version and when I loaded ksp it crashed.

did you recently upgrade from 1.2 to 1.3? Logs?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.