K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

I just want to show my appreciation for this mod! The parts look great!

I have attempted a CFG edit to bring them to the Realism Overhaul realm, but sadly without much success (ending up with negative mass in some parts, unable to introduce Real Fuels modules, etc.)

Has anyone developed their own Realism Overhaul configs and by any chance would care to share them with the world? :$

Many thanks in advance!

Edited by hypervelocity

Share this post


Link to post
Share on other sites

(regarding previous question: thank you for recommending Joint Reinforcement mod)

I am building OPT KH spaceship and noticed that there is no way of going from K cockpit to KH cargobay seamlessly, there is no adapter for it. Would anyone be up to adding a new part, an adapter?

 

Share this post


Link to post
Share on other sites
19 hours ago, agrock said:

(regarding previous question: thank you for recommending Joint Reinforcement mod)

I am building OPT KH spaceship and noticed that there is no way of going from K cockpit to KH cargobay seamlessly, there is no adapter for it. Would anyone be up to adding a new part, an adapter?

 

I just slap an H fuel tank on top of the last K fuselage before the KH cargo bay.

Share this post


Link to post
Share on other sites
2 hours ago, kraden said:

I just slap an H fuel tank on top of the last K fuselage before the KH cargo bay.

Ahhh... K+H = KH   :D  Now I understand what those wierd looking H components are for. 

Share this post


Link to post
Share on other sites
23 minutes ago, Rulingmoss55 said:

My game just stops loading after trying to load the "Sage" engine in the legacy pack, anyone know why my game is doing this?

SAGE and SURGE use non stock resources. You need the Community Resource Pack installed

Share this post


Link to post
Share on other sites
14 minutes ago, stali79 said:

SAGE and SURGE use non stock resources. You need the Community Resource Pack installed

Alright, I will try that, thank you!

Share this post


Link to post
Share on other sites
9 minutes ago, stali79 said:

guys can someone help me figure out what is going on with my install please.

 

Everything appears to be loading fine but the crash happens at the point where the game goes from loading screen to menu screen.

 

https://www.dropbox.com/s/qjh7jcw69npn013/output_log.txt?dl=0

 

https://www.dropbox.com/s/xrxqp5j6qbz6b9l/KSP.log?dl=0

 

Sounds like a 1.3.1 install with some old 1.3.0 mods.

If you are running steam, check to see if the game didnt update

Share this post


Link to post
Share on other sites
49 minutes ago, stali79 said:

guys can someone help me figure out what is going on with my install please.

 

Everything appears to be loading fine but the crash happens at the point where the game goes from loading screen to menu screen.

 

https://www.dropbox.com/s/qjh7jcw69npn013/output_log.txt?dl=0

 

https://www.dropbox.com/s/xrxqp5j6qbz6b9l/KSP.log?dl=0

 

what did you change between the last time it started and this crash?

Share this post


Link to post
Share on other sites
9 minutes ago, Space Kadet said:

what did you change between the last time it started and this crash?

Technically ksp hasnt gotten this far in over 6 months. I removed all old mods except for OPT. Then downloaded the 1.3.1 versions of the mods I use. Yes there is a couple of 1.3 mod but they are parts packs. In essence this is a fresh install

 

@linuxgurugamer it passes the loading phase, but crashes AFTER the scene change to main menu.

Edited by stali79

Share this post


Link to post
Share on other sites
1 hour ago, stali79 said:

Technically ksp hasnt gotten this far in over 6 months. I removed all old mods except for OPT. Then downloaded the 1.3.1 versions of the mods I use. Yes there is a couple of 1.3 mod but they are parts packs. In essence this is a fresh install

 

@linuxgurugamer it passes the loading phase, but crashes AFTER the scene change to main menu.

*sniped for not researching*, i think your going to have to pull all 1.3 or lower mods and do a mod by mod reinstall

Edited by Space Kadet

Share this post


Link to post
Share on other sites
39 minutes ago, Space Kadet said:

*sniped for not researching*, i think your going to have to pull all 1.3 or lower mods and do a mod by mod reinstall

stripped all the 1.3 mods, except OPT, Airline Kuisine.  still crashing

Share this post


Link to post
Share on other sites
1 hour ago, stali79 said:

stripped all the 1.3 mods, except OPT, Airline Kuisine.  still crashing

opt is 1.3.1  
my best advice is to pull everything, and then use ckan to install everything you can thats on the updated list. and if that nothing crashes go from there installing the other mods you want manually one at a time till you find the culprit.

also make sure everything is re-downloaded.

Share this post


Link to post
Share on other sites
Just now, Space Kadet said:

opt is 1.3.1  
my best advice is to pull everything, and then use ckan to install everything you can thats on the updated list. and if that nothing crashes go from there installing the other mods you want manually one at a time till you find the culprit.

also make sure everything is re-downloaded.

CKAN is not an option, last time i tried it it took 8 hours to install my mods, a single failure of any kind would lock my pc up for 5 minutes.

 

All mods were freshly downloaded today from spacedock and installed correctly.

 

Trust me I know what version opt is for :wink:

Share this post


Link to post
Share on other sites

Did you start with a completely fresh install?  It's quite possible that there is a rogue file somewhere which you aren't aware of.

3 hours ago, stali79 said:

@linuxgurugamer it passes the loading phase, but crashes AFTER the scene change to main menu.

Do you see the main menu, or is it crashing when trying to switch to the main menu?

Share this post


Link to post
Share on other sites
3 minutes ago, linuxgurugamer said:

Did you start with a completely fresh install?  It's quite possible that there is a rogue file somewhere which you aren't aware of.

Do you see the main menu, or is it crashing when trying to switch to the main menu?

Loading progress bar ends and screen then shows the planetary loading thingy on the bottom right of the screen then crashes. In the log you can see it changing scene to main menu. 

 

I didnt do a full wipe this time no.

Share this post


Link to post
Share on other sites

think your out of luck then, last time this happened to me the only recourse was to pull all mods, and do a fresh install one at a time, 3 days of work with restarts between every mod. althow start by pulling IFS, it seems to cause some funny issues at the moment.

Share this post


Link to post
Share on other sites

Your log file has 99 dlls listed.

5 minutes ago, stali79 said:

Loading progress bar ends and screen then shows the planetary loading thingy on the bottom right of the screen then crashes. In the log you can see it changing scene to main menu. 

 

I didnt do a full wipe this time no.

then I suggest  you do.  Only install OPT and see what happens.

The error is exactly what happens when an old mod (ie:  a 1.3.0 or earlier) uses the stock settings code.  I looked at your log file, but there are just too many things installed for me to even begin to figure out what's going on, other than by going with past experience.

1 minute ago, Space Kadet said:

think your out of luck then, last time this happened to me the only recourse was to pull all mods, and do a fresh install one at a time, 3 days of work with restarts between every mod. althow start by pulling IFS, it seems to cause some funny issues at the moment.

You can install several at a time.  It is most unlikely that all the mods are bad, so install 10 at a time, start up, and if/when it crashes, you will know it has to be one of the last 10 mod installed

Share this post


Link to post
Share on other sites

@stali79 Your logs give me reason to suspect the retired parts folder within the REKT mod (see SHED main folder). As Linux hinted, at, also scrutinize any mod that installs a tab in Difficulty Settings, like TAC, DeepFreeze, Wild Blue, DMagic...

I also suspect KSPModFileLocalizer.dll, it feels like a wide-reaching hack kind of mod and possibly unstable.

Share this post


Link to post
Share on other sites

Hello
First of all my apologies, speaking bad English I use google trad.

My concern: since the transition from KSP to 1.3.1, LH2 fuel is no longer available on OPT parts. Only LF / LFO.

Normally: http://www.noelshack.com/2017-46-7-1511051369-20171119010203-1.jpg
Now: http://www.noelshack.com/2017-46-7-1511051434-20171119005858-1.jpg

I completely emptied the GameData folder and installed only OPT, but the problem is still present.
What does it come from?

Thank you in advance for your help! :-)

Share this post


Link to post
Share on other sites
41 minutes ago, Nodragdare said:

Hello
First of all my apologies, speaking bad English I use google trad.

My concern: since the transition from KSP to 1.3.1, LH2 fuel is no longer available on OPT parts. Only LF / LFO.

Normally: http://www.noelshack.com/2017-46-7-1511051369-20171119010203-1.jpg
Now: http://www.noelshack.com/2017-46-7-1511051434-20171119005858-1.jpg

I completely emptied the GameData folder and installed only OPT, but the problem is still present.
What does it come from?

Thank you in advance for your help! :-)

Is LH2 a stock resource?

Share this post


Link to post
Share on other sites
33 minutes ago, stali79 said:

Is LH2 a stock resource?

I assumed that the LH2 was one of OPT's basic options, or that OPT was fully compatible with "Interstellar FuelSwitch" or "Cryogenic Engines". Because before 1.3.1 I always had this option for OPT parts.
Moreover by installing only OPT I have the option "LiquidFuel, Oxidizer" to double, as if a bug prevented to have LH2 instead of one of the two.

But if not, does anyone know how to recover the LH2 for OPT parts? Because half of my ships are stuck without fuel in the space vacuum ^^'

Share this post


Link to post
Share on other sites
1 hour ago, Nodragdare said:

I assumed that the LH2 was one of OPT's basic options, or that OPT was fully compatible with "Interstellar FuelSwitch" or "Cryogenic Engines". Because before 1.3.1 I always had this option for OPT parts.
Moreover by installing only OPT I have the option "LiquidFuel, Oxidizer" to double, as if a bug prevented to have LH2 instead of one of the two.

But if not, does anyone know how to recover the LH2 for OPT parts? Because half of my ships are stuck without fuel in the space vacuum ^^'

Which mod adds the LF2? I just checked the configs and it is something we have never patched, so if its been added to our parts int he past then its the other mod that has their own patch which is what is breaking.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.