K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

1 minute ago, Nio9345 said:

Ok new problem ... All cockpits and connectors are treated as wings and they mess the CoL really bad and the elerons and lift surfaces freak out and when I try to go up the wings go down and I crash.

Why don't you post your questions in the proper forum?  @JadeOfMaar actually listed the correct forum for what you need.  

Posting in the correct thread both makes it easier for the current author to follow, and puts your question where others can see it and either answer it or learn from other answers

Share this post


Link to post
Share on other sites
7 minutes ago, linuxgurugamer said:

Why don't you post your questions in the proper forum?  @JadeOfMaar actually listed the correct forum for what you need.  

Posting in the correct thread both makes it easier for the current author to follow, and puts your question where others can see it and either answer it or learn from other answers

1) Thank you for the correction, I didn't know and still don't know where to post those issues as it seems to affect Legacy/Main and/or ReConfig

2) He replied immediately here and I thought I posted on the correct forum and in his last reply he posted the ReConfig thread, but I thought he was meaning to tell me to download the latest update of those mods.

3) Reposting the issue there seems a bit overboard now since I started here, unless there is a way to move my last replies there and avoid flooding his inbox, in which case I would gladly do it.

Share this post


Link to post
Share on other sites
1 hour ago, Nio9345 said:

1) Thank you for the correction, I didn't know and still don't know where to post those issues as it seems to affect Legacy/Main and/or ReConfig

2) He replied immediately here and I thought I posted on the correct forum and in his last reply he posted the ReConfig thread, but I thought he was meaning to tell me to download the latest update of those mods.

3) Reposting the issue there seems a bit overboard now since I started here, unless there is a way to move my last replies there and avoid flooding his inbox, in which case I would gladly do it.

If it's affecting the original as well as the ReConfig, then I suppose it's ok here.  AFAIK, @K.Yeon hasn't been around since Sept. 2017, so this thread is essentially mostly unwatched.  As long as @JadeOfMaar is ok with it here, then just stay here.

 

Share this post


Link to post
Share on other sites

@Nio9345 I assume you're not familiar to how OPT works without FAR, so here's a heads-up. Nearly all OPT parts are either wings or lifting bodies (possessing lots of surface area on one axis so that they have the basic ability of a wing) like Mk2 but not Mk3 parts. In addition to that, tweakscaled engines get very heavy very fast, easily dragging your CoM to the back and making things hard for you if you simply put all your engines at the back. But this is a basic principle that everyone should already know soon enough. The way you approach plane parts needs to change.

Actually I linked the OPT Reconfig thread specifically to show you the changelog featuring the change/adaptation of OPT engines into CryoEngines, not for anything else. Though, as  @linuxgurugamer suggested, since OPT Legacy and Reconfig are involved, and I own that thread, it's more appropriate to bring support requests there. (I still watch this thread actually, mainly to point people to Reconfig when they come asking for X fix or Y compatibility.)

Share this post


Link to post
Share on other sites

@AlexPlaysKSP Does the loading bar say something like "SAGE Engine" when KSP hangs? If so then you're using OPT Reconfig and should need to install Community Resource Pack. If you're using KSP 1.8 then I can't help you but I can tell you that there's something unique to players in the EU that causes KSP to fail to start for them.

Share this post


Link to post
Share on other sites
On 9/27/2019 at 3:34 PM, JadeOfMaar said:

@Cloakedwand72 You're welcome. :)

@gilflo Ah. Well insert the ModuleCryoTank module into GameData/OPT_Reconfig/CRP/OPT_B9PS_Cryo.cfg before the line that says "// Cabins" so that it looks like this. Please do not accidentally duplicate the existing stuff around it. When you restart KSP, all OPT tanks will be applied to.


// Apply subtypes
@PART:HAS[#manufacturer[OPT*Division],@MODULE[ModuleB9PartSwitch]]:NEEDS[B9PartSwitch,CryoEngines,!Pathfinder]
{
	MODULE // The cooling/boiloff module
	{
		name =  ModuleCryoTank
		// in Ec per 1000 units per second
		CoolingEnabled = True
		BOILOFFCONFIG
		{
			FuelName = LqdHydrogen
			// in % per hr
			BoiloffRate = 0.05
			CoolingCost = 0.05
		}
		BOILOFFCONFIG
		{
			FuelName = LqdMethane
			// in % per hr
			BoiloffRate = 0.005
			CoolingCost = 0.02
		}
	}
	// Cabins
	@MODULE[ModuleB9PartSwitch]:HAS[#moduleID[OPTcabin]]
	{
		SUBTYPE
		{
			name = LH2
			tankType = OPTLH2
			title = OPT LH2
		}
		SUBTYPE
		{
			name = Hydrolox
			tankType = OPTLH2O
			title = OPT Hydrolox
		}
		SUBTYPE:NEEDS[CryoTanksMethalox]
		{
			name = Methane
			title = #LOC_CryoTanks_switcher_fuel_methane
			tankType = LM
		}
		SUBTYPE:NEEDS[CryoTanksMethalox]
		{
			name = Methalox
			title = #LOC_CryoTanks_switcher_fuel_methalox
			tankType = LMOx
		}
	}

I would really like to know how Thor Tech is involved with Cryo Engines. I assume you've patched its LiquidFuel engines to burn LH2.

@JadeOfMaar

Here is a study with OPT engines using LH2 on RSS (not RSS/RO with FAR)

I insert the ModuleCryoTank module as recommended after having updated OPT Legacy and OPT Reconfig.

What is important to notice is that, in this case, I got all OPT engines working only on LH2O. There's no more possibility to have a choice between LH2O or LFO.

Then I compared performance of my Raptor 4546 which is designed to be launch in high atmosphere by Stratolauncher in RSS mod  and OPT mods before the last update, the last update not working with LFO OPT engines and Tweakscale.

So here are 2 screens in high atmosphere where the spaceplane is launch: Engines are J81 hybride engines

1/ with LFO , closed cycle: Weight 151T , DV 13800 and TWR 1.3 

SSrdOlG.png

2/ with LH2O, closed cycle : much larger spaceplane with only 2 engines instead 4: 125T, 14200DV, TWR 0.90

   TWR is better because in high atmosphere, in RSS, once in LH2 there's no need to get high TWR. The plane is lighter to launch, but we need larger aircraft because with the "LFO" design we don't get enough LH2O in the tank to get similar DV

SIyp4ZD.png

Now 2 screens in low atmosphere on the base

1/ with LFO on airbreathing: more than 23000DV and TWR 1.81: we don't need that DV in Airbreathing, but it's the consequences of the TWR we need at launch in high atmosphere for a quick acceleration to Orbit. Lowering TWR don't give so much more DV and the 1.3 TWR is a good compromise.

M6Ubkf3.png

2/With LH2O in low atmosphere: only 7800 DV with TWR 1.26. This TWR is the consequence of the high atmosphere TWR

    We can see clearly that LH2O is not interesting in low atmosphere for DV

NUMNdL5.png

In conclusion:

1/LH2O must be use only in High atmosphere, the good thing being lighter spaceplane, and the dark side being much larger airplane, which is harder to launch with a Stratolauncher. But it could give more range!

2/I do not know if it is due to tweakscale mod, but if there's no choice on OPT engines between LH2O and LFO,  LFO remains the best option to launch spaceplane on RSS, because it's impossible to build a Stratolauncher on LH2O only

 

Share this post


Link to post
Share on other sites

@gilflo For lack of experience (I'm not a CryoTanks + CryoEngine person though I do enjoy somewhat the idea of having all my craft run on fuels that aren't so abstract like LF) I truly can't imagine how you're able to juggle LFO and LH2O, especially in OPT's already dual-mode engines. I don't have any hint that you can config your way beyond the stock limit of two modes per engine, so I can't imagine how I've unwittingly made things hard for you. :/ All i can suggest is to delete or crop the cryo configs in OPT_Reconfig/CRP/ ...

Share this post


Link to post
Share on other sites
12 hours ago, JadeOfMaar said:

@gilflo For lack of experience (I'm not a CryoTanks + CryoEngine person though I do enjoy somewhat the idea of having all my craft run on fuels that aren't so abstract like LF) I truly can't imagine how you're able to juggle LFO and LH2O, especially in OPT's already dual-mode engines. I don't have any hint that you can config your way beyond the stock limit of two modes per engine, so I can't imagine how I've unwittingly made things hard for you. :/ All i can suggest is to delete or crop the cryo configs in OPT_Reconfig/CRP/ ...

Not a problem, before trying, I duplicated my KSP game file, so that I could be able I could be able to throw it all if it did not work. 

But I wanted to know is if you are able to create OPT engines running on dual mode with LFO and others OPT engines running on dual mode in LH2O. That would be great!

Share this post


Link to post
Share on other sites
On 10/18/2019 at 6:21 PM, JadeOfMaar said:

@AlexPlaysKSP Does the loading bar say something like "SAGE Engine" when KSP hangs? If so then you're using OPT Reconfig and should need to install Community Resource Pack. If you're using KSP 1.8 then I can't help you but I can tell you that there's something unique to players in the EU that causes KSP to fail to start for them.

Thank you i'll try that.

 

I have recently updated to 1.8 ill try if it works without CRP or if it doesn't i'll install it.

 

 

Thank you for your Help!

Share this post


Link to post
Share on other sites

Just came back to the game after a long break and im having issues getting things to work.   OPT causes a Fatal error with tweakscale and not sure why.     it used to work.      currently using 1.6.1 for compatibility with most other mods.

Share this post


Link to post
Share on other sites

so i want this in 1.8 but im not as savy as most of the people here. can someone explain to me in lamens terms what i need to do for this to work in 1.8?

Share this post


Link to post
Share on other sites

I'm on 1.8.1.

Install the latest copy of all 3 OPT mods. For me, as of time of writing, those are:

  • OPT base | OPT_Space_Plane-v2.0.1.zip
    • Extract the OPT folder only.
    • Do not install the bundled Firespitter plugin.
      • Instead, get the latest Firespitter plugin. You only need the DLL. You can get rid of the other stuff bundled in the Firespitter ZIP file if you don't like the additional parts.
  • OPT legacy | Orbit_Portal_Technology_OPT_Spaceplane_Parts-1.4.1.zip
  • OPT reconfig | OPT_Reconfig-1.7.0.zip
    • Since I just want to use stock resources, I commented out the patch entries in OPT_Reconfig\CRP\OPT_PowerSphereFusionSelect.cfg that replace XenonGas with a bunch of non-stock resources.
    • The mod automatically disables those when PathFinder mod is present because PathFinder manages its own set of overrides.

Also, I'm using the latest ModuleManager version. So no need to copy the MM DLL bundled with all of the above ZIP files.

Share this post


Link to post
Share on other sites
3 hours ago, bcqJC said:

 

  • Since I just want to use stock resources, I commented out the patch entries in OPT_Reconfig\CRP\OPT_PowerSphereFusionSelect.cfg that replace XenonGas with a bunch of non-stock resources.

by commented out do you mean you just took out that file or do you mean something else?

Share this post


Link to post
Share on other sites

That CFG is comprised of 2 parts. The 1st is a bunch of stuff to replace XenonGas with a bunch of alternative resources for opt_powersphere1b and opt_powersphere2. I commented those out by placing "//" (w/o the quotes) at the start of each line.

The 2nd part, which is still needed, bumps up the "ratio" of resource conversion for opt_powersphere2 by multiplying the ratio by 18.

So you have 2 options. Modify the config directly like I did. Or take out the file and replace it with a CFG that just has the 2nd part:

@PART[opt_powersphere2]:NEEDS[!Pathfinder]
{
    @MODULE[ModuleResourceConverter],*
    {
        @INPUT_RESOURCE,0
        {
            @Ratio *= 18
        }
    }
}

Share this post


Link to post
Share on other sites
1 hour ago, bcqJC said:

So you have 2 options. Modify the config directly like I did. Or take out the file and replace it with a CFG that just has the 2nd part:

I wouldn't spare any bit of that config if I were you. The large power sphere has its 18x value of XenonGas (directly in its part config) already. What you're doing in effect is making it require 18x more xenon.

The way that portion of the patch makes sense is: The first portion that you delete will replace XenonGas then copy the converter module and change the input amounts (which then become identical) through both parts, then the second portion scales the input amounts to be correct for the large sphere. Since the first portion no longer applies, the second part blindly does so to the xenon converter.

Thanks for bringing this up. Since I'm making moves to stop forcing CRP (in order just to use OPT Legacy) I should add the appropriate needs to this patch.

Share this post


Link to post
Share on other sites

I'm so exited about this mod I've dreamt of it. But every time I save or load the game crashes! I've installed everything correctly, and i even tried the KSP 1.2.2 version. Help!!

Share this post


Link to post
Share on other sites

@yocracra Do not install the included MM and Firespitter. Those are ancient and broken by now. Get MM 4.0 for KSP 1.7 or older, or MM 4.1 for KSP 1.8. Instead of Firespitter you'll want OPT Reconfig and B9 Part Switch.

Share this post


Link to post
Share on other sites
On 11/10/2019 at 5:58 PM, JadeOfMaar said:

@yocracra Do not install the included MM and Firespitter. Those are ancient and broken by now. Get MM 4.0 for KSP 1.7 or older, or MM 4.1 for KSP 1.8. Instead of Firespitter you'll want OPT Reconfig and B9 Part Switch.

@JadeOfMaar thanks a million! Now I’m having another problem. I can’t configure tanks, and my plane is spawning about a klick above the ground. I’ve had to strap six solid fuel boosters to the wings to keep it from hitting the ground.

Share this post


Link to post
Share on other sites

@yocracra try installing World Stabilizer . You must have at least one of the OPT parts that has collider issues used in your craft, and that triggers a bug which causes spawned craft to launch 1km above the runway. World Stabilizer should temporarily fix at least *that* issue.

Edited by Stone Blue

Share this post


Link to post
Share on other sites
15 hours ago, Stone Blue said:

World Stabilizer should temporarily fix at least *that* issue.

Temporarily?

Share this post


Link to post
Share on other sites
2 hours ago, yocracra said:

Temporarily?

Uhhh... until *someone* finishes fixing the parts, Soon™, so they can make it into a future update :lol:

Share this post


Link to post
Share on other sites
On 11/19/2019 at 3:57 PM, Stone Blue said:

Uhhh... until *someone* finishes fixing the parts, Soon™, so they can make it into a future update :lol:

Ah. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.