Jump to content

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017


Recommended Posts

5 hours ago, stali79 said:

Yet i feel like the bad guy in this.

Please don't! I for one have the utmost gratitude for modders especially one's of this magnitude. You gave an accurate concise answer to a question, it's not your fault that someone else got offended over brevity.And in a world of forums and text messages were we don't have the nuances of facial expressions and tones to augment our communication we all must allow leway with each-other in getting offended or defensive.

 

Back on topic though have you taken a pass at the weight and drag of the stats? The parts are friggin beautiful but performance wise they feel a little heavier and draggier (is that a word?) than stock parts. It may just be my perception but I was wondering how you went about determining the values.

Link to post
Share on other sites
1 minute ago, Sresk said:

Please don't! I for one have the utmost gratitude for modders especially one's of this magnitude. You gave an accurate concise answer to a question, it's not your fault that someone else got offended over brevity.And in a world of forums and text messages were we don't have the nuances of facial expressions and tones to augment our communication we all must allow leway with each-other in getting offended or defensive.

 

Back on topic though have you taken a pass at the weight and drag of the stats? The parts are friggin beautiful but performance wise they feel a little heavier and draggier (is that a word?) than stock parts. It may just be my perception but I was wondering how you went about determining the values.

I am not sure how @K.Yeon based his numbers originally to be honest.

Link to post
Share on other sites

Sure, why not? When @K.Yeon comes back, will he bring back the L-size? Oooooooohhh I really hope so! Is there anything I can do to convince him to? They actually had IVAs, and they were pretty, and useful for deep space travel, and hauling heavy duty stuff. 

P.S. @stali79, don't beat yourself up, nothing that happened was your fault. Besides, toe-stepping is MY job, not to mention my PhD, and I'm not about to let you steal my job! :D Lighten up!

Link to post
Share on other sites

Ok guys please disregard my update from earlier. in fact do not download it. It was an incomplete version that shouldn't have been released but I released to try to appease the community because I felt really bad about what happened earlier on the forums.

 

I repeat Ignore the 1.8.5.9 update!

Link to post
Share on other sites

Ok guys.  I have updated things again and releasing the more complete version of what I released earlier today.  This version is for BOTH 1.2 AND 1.1.3.  For 1.2 users there is a RAR file included that you need to extract and overwrite the 1.1.3 OPT files. Doing this will set parts to the new categories.  Check the Changelog for the complete list of @Spanksh's bug stomping and hard work.

Link to post
Share on other sites
On 9/30/2016 at 5:07 AM, JadeOfMaar said:

Ahhh. Excellent. The kerbals building my flagship will be quite pleased. :P

Here's what I did.

The lifter has about 2000 dV in it for 640t weight. (Upscaled twin-boars: 3.75m + Eve Optimized Engines.) The main craft at 211t becomes able to fly for itself at 12km up, starting with 8000 dV, and makes 100km orbit with 5000+ dV remaining. With that much I could sacrifice some and add a second cargo bay and fill up with important stuff for a Gilly base or just to refuel to leave Eve SOI. It's prepared for re-entry but the CoM is rather far back due to engine weight alone, let alone cargo weight, and it's missing Yaw control. It currently will drift sideways out of control and explode.

15vvOJb.jpg

 

vkRvFar.jpg

 

Earlier screenshot but still valid. Forward stabilizers bring CoL too far forward given how far back CoM is. The problem remains though so the ship will need chutes or be redesigned as a rocket and do VTOL.

JBFQzVK.jpg

Out of curiosity, why did you add inflatable heat shields when you don't need them?

Link to post
Share on other sites

Because of Kurgan's message, and actually going back to verify how much of the OP I was mis-reading, I'll apologize to a point to you @stali79. I work in CSR, and one thing that got hammered into us, is never ever use short responses, because without voice and body language to modulate, very short text messages/posts can be taken wildly out of context because there isn't any. You don't need to use entire paragraphs, and honorifics that's just as bad as a tiny sentence that boils down to saying "you are mistaken." without clarifying how to fix that mistake.

 

 

If I may question, are you merely placeholding the mod and the original modder is eventually coming back? Or has he totally handed off and only really returns to update OP once in a while? The whole legacy portion is where I got the mistaken believe CKAN was a requirement, because the ===Legacy=== text is directly above some images, which led me to believe that it was one whole image of "Legacy parts that are coming/returning soon", which was followed by the "recommended mods" followed by Q&A.

Are those Q&A entirely out of date? Are they still somewhat valid and only need minor updates? Do other parts of the OP need to be updated or changed due to being out of date? Those don't need to be answered here, but they are, shall we say food for thought.

Link to post
Share on other sites

The version that Myself and several others have been curating is essentially a merging of all previously released versions of the mod. Parts that were scrapped by the OP were resurrected and reincorporated. The Mod Author is due back this month after having to take time off from modding. As for the content of the OP I am not 100% sure how valid/up to date it currently is, other than the Part that I pasted listing where the current download can be found. 

Link to post
Share on other sites
17 minutes ago, Somtaaw said:

Because of Kurgan's message, and actually going back to verify how much of the OP I was mis-reading, I'll apologize to a point to you @stali79. I work in CSR, and one thing that got hammered into us, is never ever use short responses, because without voice and body language to modulate, very short text messages/posts can be taken wildly out of context because there isn't any. You don't need to use entire paragraphs, and honorifics that's just as bad as a tiny sentence that boils down to saying "you are mistaken." without clarifying how to fix that mistake. 

Personally Somtaaw, i think you just explained why it is actually you who were wrong to react the way you did. KSP mods are not commercial products and this is not a customer support forum.  the short and simple phrase 'this mod is not on CKAN'  holds no emotion whatsoever, it is merely a piece of useful information put in a clear, concise and not to misunderstand way. Any additional emotions is what the reader puts into it. 

Link to post
Share on other sites
5 hours ago, stali79 said:

Out of curiosity, why did you add inflatable heat shields when you don't need them?

I had the inclination to test the ship's ability to return from whence it came. What better to test an Eve landing with than what can do an Eve liftoff (because I have no crafts designed for Eve).

Ohhhhh, a very bugged release? That's why Mycroft panicked and said the L/Humpback parts were gone? :0.0:

Link to post
Share on other sites
9 hours ago, stali79 said:

I am not sure how @K.Yeon based his numbers originally to be honest.

Hmmm I've only just begun (last couple of weeks) to look under the hood of mods and at the stats of config files. I know most of the stats are supposed to be based on the size of the part... i.e. the lift ratio and drag is supposed to be derived from the m^2 surface area of the part. But I don't know how big the parts are of stock or how big the parts are of OPT. And I asked the question the way I did because I kinda assumed you didn't have any input on those values, I didn't want to offend you if you had and didn't want to stress you if you hadn't.

And like I said I'm not sure the values are wrong... they just feel a little off I'm guessing that those values where derived before the major aero changes of 1.0 and no one has looked at them since. One thing that I've noticed is that every stock part has a few lines that look this (values vary slightly by part):

dragModelType = default
maximum_drag = 0.2
minimum_drag = 0.2
angularDrag = 1

Where  as most of the OPT parts do not have the lines right below the drag model type. And for these lines (my comments in green):

MODULE //area = xxxx Only for control surfaces
    {
        name = ModuleControlSurface
        useInternalDragModel = True
        dragCoeff =xxxx  stock has values between 0.4-0.6 real life has values between 0.001-0.02
        deflectionLiftCoeff = xxxx stock tends to have much lower values than opt
        ctrlSurfaceRange = xxxx these seem in line
        ctrlSurfaceArea = xxxx these seem in line
        transformName = obj_ctrlSrf
    }

MODULE // Only for lifting surfaces
{
name=ModuleLiftingSurface
deflectionLiftCoeff=xxxx Stock has much lower values but I think it becuase it has smaller parts and honestly I think that stock is much lower than real life
dragAtMaxAoA=xxx Stock has much lower value by a factor of 10x or more
dragAtMinAoA=xxxx Stock tends to have a value of 0.0-0.2 OPT is much higher
useInternalDragModel=False
}

I have absolutely no clue how changing these values affects the performance I've gone in and added the missing 3 lines and tweaked all of the values to some between the original values and stock values based on best guesses and bubblegum and I actually can't tell that much difference. The most obvious value is of course mass. Changing that has a pretty enormous impact on game play. From reading the comments in the code and the fact that stock values are rounded to the nearest x.x where as OPT values look like x.xxxxxxxxxxxxxxxxxxxxx, it's pretty clear that a script was used to auto-populate all of those values. I'd love to get my hands on that script and figure out what formula was used to derive those values.

So.... if someone could point me in the right direction of how to accurately determine those values I'd be more than happy to take a crack at a balance pass, Or thump me on the nose and tell me to keep my grubby paws off the code :P And again the mod is fantastic as is this is not a complaint, I'm just wondering if there is room for improvement.

 

 

Link to post
Share on other sites

@TheKurgan yeah that's listed in the known bugs. I'm at this very second trying to work that out, but can't promise anything. We can't edit meshes without the source meshes, so unless it can actually be fixed on the texture itself (which turns out to be more difficult than expected) there's no solution.

Link to post
Share on other sites
43 minutes ago, TheKurgan said:

Cool, thanks Spanksh, thanks for trying, in the meantime I just cover it up with another intake :)

Ok so I was able to fix the intakes, I'm still fighting with the juno engine mount. Somehow I always end up affecting part that shouldn't even be touching that area of the texture.

Link to post
Share on other sites

Ok funny enough it's easily fixed by simply using the textures from 1.8 v4, HOWEVER these are 4k instead of 2k, meaning in dds they are 22mb large, which is quite massive. However obviously the quality is better as well. For the Juno Engine Mount this issue seems to be unfixable otherwise, since editing the texture will always create massive artifacts, even if only the vents are altered.

 

@TheKurgan Ok so here are the temporary fixes for now OPT 1.8.6 HD - Texture Fixes. Mind you the textures are quite large now, but it'll have to do until we figure something out for the official fix.

Edited by Spanksh
Link to post
Share on other sites

Hey guys I think I found a bug with the cargo bays. Because a lot of the attachment nodes are reversed, ie. when you put something in the bay you have to flip it 180 degrees to make it appear inside the bay, its not applying physics and drag properly. The game things the object is in front of the bay not inside of it so it apply drag to everything inside. I just confirmed this with an SSTO I was using to launch a space station. If I attached the station inside the bay at the front but flipped. I was getting all kinds of weird Aero drag and the drag over lay arrows where nuts. Once I flipped the station over and attached it at an interior node at the back of the bay the drag worked fine. Note this didn't work if I attached it to the solid wall at the back of the bay my attachment point was literately floating in space.

Also I'm not sure but it's possible that the value for "lookupRadius =" may not be large enough to have the game calculate the interior space properly. 

Link to post
Share on other sites
27 minutes ago, Sresk said:

Hey guys I think I found a bug with the cargo bays. Because a lot of the attachment nodes are reversed, ie. when you put something in the bay you have to flip it 180 degrees to make it appear inside the bay, its not applying physics and drag properly. The game things the object is in front of the bay not inside of it so it apply drag to everything inside. I just confirmed this with an SSTO I was using to launch a space station. If I attached the station inside the bay at the front but flipped. I was getting all kinds of weird Aero drag and the drag over lay arrows where nuts. Once I flipped the station over and attached it at an interior node at the back of the bay the drag worked fine. Note this didn't work if I attached it to the solid wall at the back of the bay my attachment point was literately floating in space.

Also I'm not sure but it's possible that the value for "lookupRadius =" may not be large enough to have the game calculate the interior space properly. 

I'm 99.99% sure you're not using the latest version (1.8.6) since that is all fixed :wink:

Link to post
Share on other sites

I'm using OPT Space Plane Parts V1.8 test release 4, 1.8.5.1
... if I download and reinstall the most up to date version will I have to rebuild crafts from scratch or will the craft files get updated with the new parts?

Reinstalling the new version now... may have to go back and lower the masses and drag all over again to my likeing :P

Hmmm this... is a problem the game hangs up on loading the Avatar OPT_a_Cockpit is there something special about that part?

Edited by Sresk
Link to post
Share on other sites
2 hours ago, Spanksh said:

Ok funny enough it's easily fixed by simply using the textures from 1.8 v4, HOWEVER these are 4k instead of 2k, meaning in dds they are 22mb large, which is quite massive. However obviously the quality is better as well. For the Juno Engine Mount this issue seems to be unfixable otherwise, since editing the texture will always create massive artifacts, even if only the vents are altered.

 

@TheKurgan Ok so here are the temporary fixes for now OPT 1.8.6 HD - Texture Fixes. Mind you the textures are quite large now, but it'll have to do until we figure something out for the official fix.

Ah yeeeah!!  Thanks Spanksh!! My Ships look great again.

Cheers.

Link to post
Share on other sites

I have a question for you guys.

One thing that I always disliked about the ARI/ARIE engines was the long spool-up time on these engines... it makes them hard to use in a vertical landing situation. I was looking through the config files and I'm trying to figure out what determines this "spool-up" is it the line that says "useEngineResponseTime = True"? I know this is possibly a balancing thing, but I would like to change it for my own personal use.

I had changed it in the older ARI engine config file, but now I can't remember how to do it.

Thanks

Edited by TheKurgan
Link to post
Share on other sites
1 minute ago, TheKurgan said:

I have a question for you guys.

One thing that I always disliked about the ARI/ARIE engines was the long spool-up time on these engines... it makes them hard to use in a vertical landing situation. I was looking through the config files and I'm trying to figure out what determines this "spool-up" is it the line that says use engine response time = true? I know this is possibly a balancing thing, but I would like to change it for my own personal use.

I had changed it in the older ARI engine config file, but now I can't remember how to do it.

Thanks

You are better off hunting down on spacedock the TGOL vtol engines. They are what i use. Am typing from my phone so cant give a link at this point.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...