NathanKell

Realism Overhaul Discussion Thread

Recommended Posts

What mod shows the alternate engine configurations?

Share this post


Link to post
Share on other sites

I'm having a bunch of issues with contracts not being completed because the game doesn't recognize I've met the requirements, as well as science not being transmitted. It's a new issue that just cropped up after 17 years in my current career save. I'm posting here because I'm assuming it's an RSS/RO specific problem. The only change I made to the game was installing hyperedit to test probes and whatnot, but I removed it. Here;s an example:

http://i.imgur.com/NLHq6Gu.jpg

I clearly meet all the requirements but it's not recognizing it. It happens on other (but not all) contracts as well. I did a lunar lander + science from the surface of the moon. I landed successfully and transmitted the science but got no science and no notification that the contract was complete. I'm using 1.1.3 with all the correct versions of the mods, and this hasn't been a problem until now. I started a new career save and did a few sounding rockets and everything seems to be working ok so far

Here's a link to the log. If anyone can offer some help or insight I'd be grateful.

Share this post


Link to post
Share on other sites
6 hours ago, brooklyn666 said:

I'm having a bunch of issues with contracts not being completed because the game doesn't recognize I've met the requirements, as well as science not being transmitted. It's a new issue that just cropped up after 17 years in my current career save. I'm posting here because I'm assuming it's an RSS/RO specific problem. The only change I made to the game was installing hyperedit to test probes and whatnot, but I removed it. Here;s an example:

http://i.imgur.com/NLHq6Gu.jpg

I clearly meet all the requirements but it's not recognizing it. It happens on other (but not all) contracts as well. I did a lunar lander + science from the surface of the moon. I landed successfully and transmitted the science but got no science and no notification that the contract was complete. I'm using 1.1.3 with all the correct versions of the mods, and this hasn't been a problem until now. I started a new career save and did a few sounding rockets and everything seems to be working ok so far

Here's a link to the log. If anyone can offer some help or insight I'd be grateful.

From what it see in the picture, the vessel must stay in orbit for 4 days in order to complete the mission. 

Share this post


Link to post
Share on other sites
1 hour ago, Epox75 said:

From what it see in the picture, the vessel must stay in orbit for 4 days in order to complete the mission. 

yeah, but I think the other boxes should be checked (just like "Destination Earth" is checked)

Share this post


Link to post
Share on other sites
2 hours ago, rsparkyc said:

yeah, but I think the other boxes should be checked (just like "Destination Earth" is checked)

They should be. It checks off each requirement as you meet it. Also for the timed ones, once you've met all the other requirements, it starts a countdown. I was in orbit for 8 days with that one btw, and that doesn't explain the other issues like simple "transmit science from space around earth" not working.

Share this post


Link to post
Share on other sites

There is a testing release for 1.2.2 on the Git. I'm waiting until the full version is released though

Share this post


Link to post
Share on other sites
4 hours ago, Sol Invictus said:

Is there some reason why MechJeb would be preferred over Kerbal Engineer* in upcoming Realism Overhaul?

KER had several issues with RO. The most apparent and game-breaking is it does not show correct delta-V. I don't know these issues are solved in the 1.2.2 version.

Share this post


Link to post
Share on other sites
5 hours ago, rsparkyc said:

I thought mechjeb was always suggested

MechJeb has always been the preferred mod. Those of us who play with KER instead were ... different.

Anyway, as noted, it apparently has issues with RO so it's best to use MechJeb anyway. Doesn't mean you have to let it fly your stuff and you can kind of mimic the KER "sidebars" with custom windows.

Share this post


Link to post
Share on other sites

Hm, I know KER had some issue with the changes to KSP's ressource system and had to be updated, but I never had issues with KER. I was always using both in parallel anyway. In particular KER's tooltips in the hangar were always very useful, and the DV chart more readable/detailed (when it worked).

Share this post


Link to post
Share on other sites

Hi everyone :) 

I was wondering if there was a config file that I can put into my gamedata for the graduate power response on the engines ? I don't know how it's called, the delay when you ignite an engine .. 

thanks ! :) 

Share this post


Link to post
Share on other sites
5 minutes ago, Alex38 said:

I was wondering if there was a config file that I can put into my gamedata for the graduate power response on the engines ? I don't know how it's called, the delay when you ignite an engine .. 

RealFuels already takes care of the engine spoolup time. Are you looking for something even more "extreme"?

Edited by Phineas Freak

Share this post


Link to post
Share on other sites
8 minutes ago, Phineas Freak said:

RealFuels already takes care of the engine spoolup time. Are you looking for something even more "extreme"?

Thanks for the answer ! 

I have Real Fuel and Real fuel stockalike installed and my engines are igniting directly when I stage, there's no delay.. I just want them to ignite like in the Nathan Kell's videos :) 

 

edit: I don't even know why I installed the Real Fuel stockalike, I also installed the Real plume stockalike.. Is this good ? because for me, stockalike is when you don't have realism overhaul installed, isn't it ? I quite lost right now ^^

Edited by Alex38

Share this post


Link to post
Share on other sites

RFS probably does not define the following fields in it's global RF config:

%throttlingRate = 3.0
%throttlingClamp = 1.1

that RO defines. Sorry, i assumed that you used the RO suite that enables that by default.

Share this post


Link to post
Share on other sites

Yes I was using RO in 1.1.3 :) 

Can I copy and paste that field into the global RFS config if I found it, or anywhere to make it work ? I'm quite a noob in config files, i try to learn more about that 

also, Do I need to have these Stockalike folder to make RF works fine ? Or is this the only way I can play with RF without having R-O installed ? 

thanks for your help anyway :) 

Share this post


Link to post
Share on other sites
31 minutes ago, Alex38 said:

Thanks for the answer ! 

I have Real Fuel and Real fuel stockalike installed and my engines are igniting directly when I stage, there's no delay.. I just want them to ignite like in the Nathan Kell's videos :) 

 

edit: I don't even know why I installed the Real Fuel stockalike, I also installed the Real plume stockalike.. Is this good ? because for me, stockalike is when you don't have realism overhaul installed, isn't it ? I quite lost right now ^^

I believe you do not need real fuels stockalike or real plume stockalike.  Try removing those and seeing if it works right. :) 

Share this post


Link to post
Share on other sites
38 minutes ago, Mad Rocket Scientist said:

I believe you do not need real fuels stockalike or real plume stockalike.  Try removing those and seeing if it works right. :) 

Okay I was thinking about that too, I try and post here after 

Share this post


Link to post
Share on other sites
59 minutes ago, Mad Rocket Scientist said:

I believe you do not need real fuels stockalike or real plume stockalike.  Try removing those and seeing if it works right. :) 

No that's not working, by removing these two, I loose ignitions limits, and real plumes ^^ AND the graduate ignitions isn't working either 

Edited by Alex38

Share this post


Link to post
Share on other sites
17 minutes ago, Alex38 said:

No that's not working, by removing these two, I loose ignitions limits, and real plumes ^^ AND the graduate ignitions isn't working either 

Huh, that's odd.  I don't know much about how real fuels is installed, but the stockalike configs might overwrite something in real fuels.  You could try deleting the real fuels folder in gamedata, then redownloading and reinstalling realfuels.  BTW, what version of KSP are you using?  Make sure you have the right real fuels version.

Share this post


Link to post
Share on other sites
12 minutes ago, Mad Rocket Scientist said:

Huh, that's odd.  I don't know much about how real fuels is installed, but the stockalike configs might overwrite something in real fuels.  You could try deleting the real fuels folder in gamedata, then redownloading and reinstalling realfuels.  BTW, what version of KSP are you using?  Make sure you have the right real fuels version.

Yep I think I will try that, i'm in 1.2.2 

RF is 1.2 updated but i don't think that is a problem

on the RF thread, i found that : "Engine fuel settings are handled by the engine configs. Basically, either the RO configs or by the Stockalike configs" 

so there is a RO config or a stockalike (which i have ) So it appears that you can't just use RF alone in the stock ksp .. I'm trying to find this RO config but since the RO thread is no longer reachable .. :( 

edit: I tried to expose my issue on the RF thread before reinstalling 

Edited by Alex38

Share this post


Link to post
Share on other sites
4 minutes ago, Alex38 said:

Yep I think I will try that, i'm in 1.2.2 

RF is 1.2 updated but i don't think that is a problem

on the RF thread, i found that : "Engine fuel settings are handled by the engine configs. Basically, either the RO configs or by the Stockalike configs" 

so there is a RO config or a stockalike (which i have ) So it appears that you can't just use RF alone in the stock ksp .. I'm trying to find this RO config but since the RO thread is no longer reachable .. :( 

You could try installing RF via CKAN, it should still have the RO configs indexed and give you an option to install them when you install RF.

Share this post


Link to post
Share on other sites
1 minute ago, Mad Rocket Scientist said:

You could try installing RF via CKAN, it should still have the RO configs indexed and give you an option to install them when you install RF.

but i'm on mac, i can't have ckan, I tried ckan before, but it's not fonctionnal on mac (not the right version so all the mods like RO were not there ) :( so unlucky ! 

Share this post


Link to post
Share on other sites
2 minutes ago, Alex38 said:

but i'm on mac, i can't have ckan, I tried ckan before, but it's not fonctionnal on mac (not the right version so all the mods like RO were not there ) :( so unlucky ! 

Darn, that's frustrating.  I hope someone can help on the RF thread.

Share this post


Link to post
Share on other sites
8 minutes ago, Alex38 said:

but i'm on mac, i can't have ckan, I tried ckan before, but it's not fonctionnal on mac (not the right version so all the mods like RO were not there ) :( so unlucky ! 

What version of macos are you using? I have Sierra and ckan works for me if you use mono or wine to open it.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.