NathanKell

Realism Overhaul Discussion Thread

Recommended Posts

@PsyberMind It is impossible for the Aerobee parts to be compatible since they were never added to the RP-0 tech tree in the first place. If someone can submit a PR that adds compatibility for them then they will be.

Also, the "tree.yml" file is required only if you want to create a tech tree config from scratch (requires a Perl interpreter).

Edited by Phineas Freak
False info...

Share this post


Link to post
Share on other sites

@PsyberMind I would guess @Phineas Freak is referring to the Taerobee parts... only the A4/V-2 and X-1 parts from this mod were priced for RP-0 AFAIK. Nevertheless, there should be an Aerobee Sustainer engine from "stock" RO available in a correct install of RP-0.

Share this post


Link to post
Share on other sites

Meh...i completely forgot about the stock Aerobee engine :confused:.

It should be automatically unlocked as it is placed in the starting tech tree node. If not then something is wrong with either the stock parts or with the RP-0 tech tree config, as it is a cloned part of the stock "LV-1 Ant" engine (meaning that it is always available).

I have really dropped the ball lately...i have no idea why i thought that the Taerobee mod was the only provider of that engine...

Share this post


Link to post
Share on other sites

OK, since I didnt' get that far. I'll try re-installing everything and see if I missed a step somewhere.. will let you know

UPDATE: So far so good.. Stock RO (Just the Dependancies) with RP-0 install, the Aerobee is there.. Now I'm going to go through each of the Recommendations and Suggestions one at a time and see where it dissapears. I'm not using CKAN this time, Because that's what I did last time and it caused the issue.. I'm gonna be here a while lol

UPDATE 2: Recommended List Installed, Sans RSS, and I doubt that would be causing the issue - Still Looking good - The loader threw about 15 errors in relation to TestFlight But everything else loaded just fine. I'll post a full startup log once I'm done.. (Side Note:This is looking more and more like a loose nut behind the keyboard than something with one of the mod integrations.) Suggested mods Coming up next.

UPDATE 3: Suggested Mods Installed - The ones I wanted anyway..  And no issues.. So either it was a fault on my part, or CKAN did something dumb (I'm leaning towards the latter, from what I've been reading) The Aerobee is where it supposed to be, and I'm ready to try this for the first time.. Off I go!

FINAL UPDATE - Now I'm not getting any Contracts at all at the start of Career Mode :/ Gonna try deleting RP-0 and reinstalling.. I'll get this.. or die trying (just wish there was a way to reload without a complete restart - at 5+ mins for a start, it takes a while lol) 

Disregard my last.. forgot all the Dependancies for RP-0 :confused:

Edited by PsyberMind

Share this post


Link to post
Share on other sites

So, I'm working on a MM patch that would make the SXT engine that RO uses to model the J-2 also serve as a model for the HG-3 and HG-3-SL, but I'm getting some errors in the patch. Specifically, the output log is saying that you can't use the % symbol in the atmospheric curve section, which I find confusing. How do you add new configurations to a part?

Share this post


Link to post
Share on other sites
28 minutes ago, Fox62 said:

So, I'm working on a MM patch that would make the SXT engine that RO uses to model the J-2 also serve as a model for the HG-3 and HG-3-SL, but I'm getting some errors in the patch. Specifically, the output log is saying that you can't use the % symbol in the atmospheric curve section, which I find confusing. How do you add new configurations to a part?

don't use % for the curve use @

Edited by raidernick

Share this post


Link to post
Share on other sites
1 hour ago, raidernick said:

don't use % for the curve use @

Many thanks, that seems to have fixed it, although I am unable to test the functionality in the game to make sure due to having a glorified brick of a computer. Is there anyone I could send this to for testing?

Share this post


Link to post
Share on other sites
30 minutes ago, Fox62 said:

Many thanks, that seems to have fixed it, although I am unable to test the functionality in the game to make sure due to having a glorified brick of a computer. Is there anyone I could send this to for testing?

create a pull request on github and someone will review it there

Share this post


Link to post
Share on other sites
1 hour ago, raidernick said:

create a pull request on github and someone will review it there

Done.

Share this post


Link to post
Share on other sites

Hi, i'm experiencing a bug with RO for ksp 1.1.3 and i started a topic in the technical support forum, should i post it here? since i read that in some cases it is best to post in the mod thread.

Thanks for your time

Share this post


Link to post
Share on other sites
3 hours ago, Winston L said:

Hi, i'm experiencing a bug with RO for ksp 1.1.3 and i started a topic in the technical support forum, should i post it here? since i read that in some cases it is best to post in the mod thread.

Thanks for your time

since the new version for ksp 1.2.2 is ready to release already you are unlikely to get help with an older version in which the bugs may have already been fixed sorry.

Edited by raidernick

Share this post


Link to post
Share on other sites
56 minutes ago, raidernick said:

since the new version for ksp 1.2.2 is ready to release already you are unlikely to get help with an older version in which the bugs may have already been fixed sorry.

Ok i'll just update it then thanks

Share this post


Link to post
Share on other sites
22 hours ago, raidernick said:

since the new version for ksp 1.2.2 is ready to release

What? Where? When? How?  I want!!!!

Share this post


Link to post
Share on other sites
On 4/28/2017 at 10:14 PM, raidernick said:

since the new version for ksp 1.2.2 is ready to release already you are unlikely to get help with an older version in which the bugs may have already been fixed sorry.

Do tell us more :hyped:

Share this post


Link to post
Share on other sites

So I have a question that might be a little bit odd, is it possible to use realism overhaul but not use RSS?  I ask because I am getting ready to start a new career with Galileo's Planet Pack at 10x scale and I was just thinking it would be pretty neat to be able to use Realism Overhaul with it.

 

Oh and on a side note, if Kyle Laskowski from YouTube sees this, you make awesome videos man. They inspire me to play ksp in a more realistic and challenging fashion, and I learn a lot from watching. 

Share this post


Link to post
Share on other sites

I have a terrible question. Is the next release gonna be compatible with 1.3? It would be a bummer to release for 1.2.2 just when/after 1.3 is released.

 

Share this post


Link to post
Share on other sites

It appears RO changed how electricity works. So the solar panels cant charge Megajoules for KSPI-E parts. Anyway to fix this? I really need these two mods to be compatible

Share this post


Link to post
Share on other sites
On 4/30/2017 at 0:42 PM, g00bd0g said:

I have a terrible question. Is the next release gonna be compatible with 1.3? It would be a bummer to release for 1.2.2 just when/after 1.3 is released.

 

You can (and should / will need to if you're a user of many mods in general) simply tell steam to run an older version of KSP for a couple months. Not a big deal. You are not locked out of your current setup when an update occurs.

Edited by Crimeo

Share this post


Link to post
Share on other sites
On 4/30/2017 at 0:12 PM, Templar Knight said:

So I have a question that might be a little bit odd, is it possible to use realism overhaul but not use RSS?  I ask because I am getting ready to start a new career with Galileo's Planet Pack at 10x scale and I was just thinking it would be pretty neat to be able to use Realism Overhaul with it.

RO is balanced for RSS only. While it would technically work without it, the parts will not be optimized correctly for the planets and atmospheres.

Edited by raidernick

Share this post


Link to post
Share on other sites

Is there any ETA on a stable release to CKAN? Because it currently looks like by looking at the spreadsheet that only 3 of the required mods are having minor issues

Share this post


Link to post
Share on other sites

quick question? Ive installed RO from the github but i have no engine staging in the VAB? I presume that i have missed something blatently obvious but could some kind soul push me in the right direction :)

oh im running the latest version of KSP

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.