Sign in to follow this  
Angel-125

[Retired] Multipurpose Colony Modules for MKS/OKS (0.4.5)

Recommended Posts

Thanks!

The USI page is just a Github Pages site - you can add this to your repo and it's free. Google GitHub pages

Share this post


Link to post
Share on other sites
Thanks!

The USI page is just a Github Pages site - you can add this to your repo and it's free. Google GitHub pages

Neat! I've updated my signature to include a link to the page I created. Pretty basic but it gets the job done.

Share this post


Link to post
Share on other sites

New version 0.1.3 is up!

Release Notes:

0.1.3: Introduced The Foot, an asteroid grabber designed to attach to the bottom of the MBU. Fixed an issue preventing the science lab from cleaning lab experiments and processing lab data. Added SpareParts resources to modules.

Get the latest version on the front page, or download it here.

I'll post pics of The Foot tomorrow. Just got back from L.A. and checking out the Endeavour. It is HUGE!

On a personal note, I am gainfully employed once again! After about a year, I have work. :) No, that doesn't mean I'm abandoning my mods. In fact, coming up: rover assemblies for the MBU! land your MCM/MBU, pull out the rover assemblies, attach them to the MBU, and then drive to your colony site.

Edited by Angel-125

Share this post


Link to post
Share on other sites
New version 0.1.3 is up!

Release Notes:

0.1.3: Introduced The Foot, an asteroid grabber designed to attach to the bottom of the MBU. Fixed an issue preventing the science lab from cleaning lab experiments and processing lab data. Added SpareParts resources to modules.

Get the latest version on the front page, or download it here.

I'll post pics of The Foot tomorrow. Just got back from L.A. and checking out the Endeavour. It is HUGE!

On a personal note, I am gainfully employed once again! After about a year, I have work. :) No, that doesn't mean I'm abandoning my mods. In fact, coming up: rover assemblies for the MBU! land your MCM/MBU, pull out the rover assemblies, attach them to the MBU, and then drive to your colony site.

Sorry for the update. is there any progress?

Share this post


Link to post
Share on other sites
Sorry for the update. is there any progress?

Yup, definite progress!

Get the latest release here.

0.2: Updated The Foot's art assets. Introduced the Inflatable Multipurpose Warehouse. Fixed a problem with the MBU leaping into the air upon being deployed with legs out from the VAB/SPH- thanks nil2work! :) Fixed efficiency parts on kerbitat and greenhouse templates.

2EtxfWc.png

qbkjEfu.png

Hint about the next release: E.P.L.

On a personal note, two weeks into my new job and I'm kicking butt. :)

Share this post


Link to post
Share on other sites

hmm... 0.2 seems to be savegame breaking...

a vessel with the foot causes massive lags/fps drop... it seems the node of the asteroid grabbing device has new coordinates.

First step of my mun base, looks like this now...

Javascript is disabled. View full album

Share this post


Link to post
Share on other sites

Interesting. I am not seeing this issue. The worst I had in my mun base was to extend the landing legs on the MBUs. Did you completely replace the MCM directory? Recardless, the download page has the prior versoins on it so you can temporarily revert the files while I figure out what is going on.

also, what mods do you have? Do you have a copy of your log files available? Or for that matter your savegame?

Share this post


Link to post
Share on other sites

Downloading this now! As much as I love MKS/OKS, sometimes doing FinePrint contacts bases is a royal pain, especially if you're trying to setup "have a base supporting 17 kerbals" all at once. The slightly smaller form factor, and the fact that you don't clutter up the parts menu really makes this attractive.

If I may be so bold. Could you add support for EPL (extraplanetary launch pads) ? Rover did this in such a way as his orbital dock only shows up if EPL is installed. It would be really nice to get an entire colony setup with these modules, but I'm going to need EPL to make my own rockets and launch them off world.

Share this post


Link to post
Share on other sites
Downloading this now! As much as I love MKS/OKS, sometimes doing FinePrint contacts bases is a royal pain, especially if you're trying to setup "have a base supporting 17 kerbals" all at once. The slightly smaller form factor, and the fact that you don't clutter up the parts menu really makes this attractive.

If I may be so bold. Could you add support for EPL (extraplanetary launch pads) ? Rover did this in such a way as his orbital dock only shows up if EPL is installed. It would be really nice to get an entire colony setup with these modules, but I'm going to need EPL to make my own rockets and launch them off world.

Glad you'll be giving it a try. I am currently working on the next addition, which is indeed EPL support. I already have an MBU template configuration for RocketParts and a workshop template too, and I'm making an inflatable orbital drydock today as well.

Share this post


Link to post
Share on other sites
Parts are coming along nicely! Awesome work!

Thanks! I am continuing to hone my skills to come up with stock-like stuff. Lots of challenges but I'm getting there. :)

Share this post


Link to post
Share on other sites

Wait, so this sky dock works like the orbital launch pad from Extraplanetary Launch pad? And it works along with MKS/OKS? *squee*

Do you have plan for anything larger?

Edited by RainDreamer

Share this post


Link to post
Share on other sites
Interesting. I am not seeing this issue. The worst I had in my mun base was to extend the landing legs on the MBUs. Did you completely replace the MCM directory? Recardless, the download page has the prior versoins on it so you can temporarily revert the files while I figure out what is going on.

also, what mods do you have? Do you have a copy of your log files available? Or for that matter your savegame?

Sry I was busy yesterday. Here you can find my log file as well as a screenshot of my gamedata directory and the savegame: https://www.dropbox.com/sh/byeh9pg50gfnsf1/AABfuVWRdhsE9zJ7AC4VtZ9sa?dl=0

I've tested with the old release and both (vessel with the asteroid grabber and the mun base) are fine. I've added some before/after-screenshots to my imgur album above.

For the log... at first I switched to the vessel with the grabbing device, then to the mun base.

For the munbase it seems to search for correct coordinates.

If more information is needed, I'll try to help.

Nevertheless, pls keep up your good work, I love those parts!!!

Edited by funk

Share this post


Link to post
Share on other sites

@RainDreamer: yup, I have the rocket workshop template built, which uses the standard MKS colony converter. MKS/OKS already has an ore to metal converter via the Refinery. So baseline RocketParts making is supported. It may change when RoverDude creates his EPL adaption though. The new IMW will house RocketParts right alonside the MBUs, and I have plans for an orbital parts container as well. As for the skydock, the initial version is constrained by the KSOS Super 25 payload bay, but I see no issues with creating a version that fits the 3.75m form factor. Off the cuff you might get accomodations for 20m diameter ships that way. I couls see a wee (2.5m), not so wee (3.75m) and friggin huge (5m) sizes as a possibility.

@Funk: thanks for the updates. I will take a look. If it would be possible to have a copy of your save, that would be immensely helpful. Not sure why you have lag, I reduced the colliders on the MBU because my munbase is also getting a lot of lag. It might be something else though...

Edited by Angel-125

Share this post


Link to post
Share on other sites

I've uploaded the savegame to dropbox... look for funk101.sfs

Share this post


Link to post
Share on other sites

Awesome, thank you much. :) that should help me root out the problem.

Edit: I haven't forgotten about your issue, I tracked down and fixed a bug in the code, and am doing some refactoring. Once that's done I can look at the problems you're seeing.

Edited by Angel-125

Share this post


Link to post
Share on other sites

@funk:

I've been looking over your logs and especially your savegame- thanks for providing that and the mods you use, you rock! :) That has been very helpful. I've figured out some of the issues and am in the process of working the bugs out of my stuff. I can also see a bunch of NREs in the log file that come from Extraplanetary Launchpads:

[EXC 23:50:22.821] NullReferenceException: Object reference not set to an instance of an object

ExLP.ExWorkshop.Update ()

I thought it was because of the dynamic adding/removing of modules but the stock EPL workshop has this problem as well. You might see if there is an update to EPL that fixes this issue; it would definitely slow down your game as the log is constantly being filled with NREs during each update. If you find an update, let me know, I use EPL too. :)

Edited by Angel-125

Share this post


Link to post
Share on other sites
Thank you for this very useful addition to MKS /OKS mod.

Glad you like the mod. :) I built it to solve my problem of fitting MKS modules into the KSOS Super 25 and am happy to share. Once I fix the remaining bugs I'll be releasing the EPL adaption as well, though I may hold off a bit and wait for RoverDude's EPL adaption to remain compatible. At least my bug fixes solved the problems I had with the Skydock (now called the Skydock 250) as well.

Share this post


Link to post
Share on other sites

@funk I've gone through your savegame and tested Multipurpose Colony Modules with the fixes I made as well as the 0.1.3 release and in both cases, your base seems to leap into the air for some unexplained reason. That happens whether or not I use my new models for The Foot and MBU, or the prior ones. I don't have this problem with my own base though, so I'm not sure what's going on or even if it's my mod that causing the problem. Nonetheless, you've helped me figure out some issues in the current version and I'll have an update this weekend that fixes the bugs- and hopefully introduces the Skydock 250 as well! :)

Share this post


Link to post
Share on other sites

THX for looking into this...

I've looked into the log, too, and I've decided to delete EPL. But it doesn't help at all. For the MKS base: I guess it is between the kerbitat and the MBU, somehow the connection is lost, so KSP doesn't know where the parts are and they fly away. Perhaps it is something with the grabbing module or damper or anchor... I will try out some configurations and report... Strange thing is, that if I use the old release nothing happens.

Did you change the meshes of MBU or MCM between the versions?

Don't hesitate to contact me via pm if you need some help in testing. I like your parts and their easy handling and can't wait for EPL or Rovers fork implementation...

Edit: Small thing ... the new foot has 180 degrees rotated orientation, if you select control from here you'll have to aim/thrust to anti target/retrograde to reach your target.

Edited by funk

Share this post


Link to post
Share on other sites
THX for looking into this...

I've looked into the log, too, and I've decided to delete EPL. But it doesn't help at all. For the MKS base: I guess it is between the kerbitat and the MBU, somehow the connection is lost, so KSP doesn't know where the parts are and they fly away. Perhaps it is something with the grabbing module or damper or anchor... I will try out some configurations and report... Strange thing is, that if I use the old release nothing happens.

Did you change the meshes of MBU or MCM between the versions?

Don't hesitate to contact me via pm if you need some help in testing. I like your parts and their easy handling and can't wait for EPL or Rovers fork implementation...

Edit: Small thing ... the new foot has 180 degrees rotated orientation, if you select control from here you'll have to aim/thrust to anti target/retrograde to reach your target.

Yes, I changed the MBU and The Foot in 0.2.0. Funny thing is that I used my older 0.1.3 version and got the same problem, so I don't know what the issue is. I'll investigate the issue with the foot and get it oriented properly as well. Thanks for the feedback! :)

Share this post


Link to post
Share on other sites

I have to say I like the looks a lot more than MKS/OKS parts, they seem to fit the game a lot better and have that stocklike feel.

Do I need MKS/OKS for this to function?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this