Jump to content

Recommended Posts

I am working on my second ever part in KSP and am having a strange issue when importing my .blend into unity, as can be seen in the below images the mesh called engine body in blender isn't showing up at all when the .blend file is opened in unity. Has anyone else ever run into this problem or have an idea of what might be causing it? My first part used multiple meshes as well but worked fine, I have tried deleting some of the meshes and reimporting it to see if I hit some kind of cap on the number of separate meshes however that still didn't make the engine body mesh show up.

IGRqQya.png

nIyRK4e.png

Solved: Joining the Engine Body Mesh(which wasn't showing up in Unity) to the Attachment Plate Mesh (which was showing up in Unity) in Blender and then importing the .blend file again fixed the issue.

I've never come across this problem. Try joining it to a new mesh object.
Edited by Colseg
Link to post
Share on other sites

Flipping the normals doesn't seem to have any effect, the problem is the engine body mesh isn't appearing in Unity at all, not even in the Hierarchy list, even though it is in the same blend file as the others and all of the other meshes are showing up just fine in Unity both in the Scene Window and in the Hierarchy.

Link to post
Share on other sites
How are you importing the meshes into unity?

I usually expand the blend file under "Assets" and drag/drop individual meshes, unless I need precise placement or an animation.

I have been dropping the .blend file that has all of the meshes that make up the engine into a folder in assets and then in unity setting the import settings as shown in the below picture and applying those, then dragging the whole blend file from the lower window into the hierarchy and going from there, as shown in the below image the .blend file when expanded in unity is missing the mesh called "Engine Body" as shown in blender in my first post.

jaIZBjj.png
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...