MOARdV

[1.3.0] Distant Object Enhancement bis v1.9.1 (8 July 2017)

Recommended Posts

MOARdV    1318

DOEbis is now updated to 1.5.0. The long-requested support for the AppLauncher / stock toolbar is now implemented. I also disabled flare drawing in MapView, since the flares are in the wrong place. Get it on GitHub or KerbalStuff.

Share this post


Link to post
Share on other sites
Linear    213

Just installed the update and there's no toolbar icon and i don't think it's working, any kind of log you need? :-)

Share this post


Link to post
Share on other sites
Beetlecat    247

Thank you for updating! :D This is one of the best -- "Doesn't do much, but what it does is amazing" mods. :)

On the subject of migrating to the stock app launcher: what's going to be done when *everyone* migrates to it? At least Blizzy's wraps to additional lines and auto-hides.

Share this post


Link to post
Share on other sites
N10do64    6
Just installed the update and there's no toolbar icon and i don't think it's working, any kind of log you need? :-)

Seems like it only works if you have blizzy's toolbar installed as well.

Share this post


Link to post
Share on other sites
Linear    213
Seems like it only works if you have blizzy's toolbar installed as well.

Yes, you need to have it installed so you can open up the settings menu and only enable the default toolbar. Thanks. :-)

Share this post


Link to post
Share on other sites
N10do64    6
Yes, you need to have it installed so you can open up the settings menu and only enable the default toolbar. Thanks. :-)
Tried doing that, doesn't seem to work for me.

Share this post


Link to post
Share on other sites
MOARdV    1318

Okay, it looks like I messed up something in the 1.5.0 release. It still requires blizzy's toolbar. I'll see if I can get that fixed and re-updated this weekend.

EDIT: ... And, version 1.5.1 is now up (GitHub and KerbalStuff). Blizzy's Toolbar is no longer a requirement for Distant Object Enhancement.

Edited by MOARdV

Share this post


Link to post
Share on other sites
Errol    226

Does anybody know if this mod supports/conflicts with both/either star systems v.07 and any given telescope/camera part mod.......

..because reasons....

Share this post


Link to post
Share on other sites
nukeboyt    141
And, version 1.5.1 is now up (GitHub and KerbalStuff). Blizzy's Toolbar is no longer a requirement for Distant Object Enhancement.

Thank you for taking on the maintenance of this mod. It has always been one of my favorites, and you're doing a great job.

Share this post


Link to post
Share on other sites
Nitrous Oxide    109

Is there any way to disable the sky darkening? Kerbin looks horrendous when viewed from orbit because the background immediately and 100% without fail turns black the second I look at Kerbin (and the Sun). I tried the slider to no avail. Stars disappearing is completely immersion breaking (or just really ugly, I haven't decided). I guess it's "realistic", but last I checked, my camera wasn't another ship in orbit so I could care less for that. The stars look more comforting than a void, that's all...

Oh and hovering the mouse over vessel flares doesn't tell me that it is in fact a vessel, so as far as I'm concerned this mod doesn't work for 0.90 (at least not without issue)...

Edited by Nitrous Oxide

Share this post


Link to post
Share on other sites
ObsessedWithKSP    2262

Working perfectly for me in 0.90, must be something wrong your end. Also, you could've just asked how to disable skybox dimming, no need to complain so much...

Rather than muck about in game, in the settings file, change changeSkybox to False and showNames to True (make sure you have vessel flares enabled as well).

Share this post


Link to post
Share on other sites
vardicd    167

Is anyone else seeing a lot of map framerate stutter in the tracking station? My framerate drops horridly in the tracking station with this mod, and yes I have the latest version. I also am running a lot of mods, so it could easily be a mod conflict, but I notice when I remove this mod it goes away, so its either this mod, or this mod and another{s} that's causing it. I'm slowly pulling out mods one at a time to find out if there are other culprits but its a long process, so I thought id ask if anyone else is seeing this, or had it, so maybe I can narrow down the possible offending mods.

Share this post


Link to post
Share on other sites

You can track down offending mods faster by using a binary-search technique. Put half of your mods in "time-out" -- if the problem goes away, the problem was in that half, if not, it's in the half still remaining. Rinse and repeat until you've found the one. Result: only log(N) tests required instead of N.

Share this post


Link to post
Share on other sites
vardicd    167

actually I was wrong, I got the same issue in one test without this mod, so still trying to narrow this down.

Share this post


Link to post
Share on other sites
Nitrous Oxide    109
Working perfectly for me in 0.90, must be something wrong your end. Also, you could've just asked how to disable skybox dimming, no need to complain so much...

Rather than muck about in game, in the settings file, change changeSkybox to False and showNames to True (make sure you have vessel flares enabled as well).

And maybe I'm complaining because those are already set and they aren't doing what they should... and neither of you are Rubber Ducky, so it's not like either of you made those choices... don't take it personally, but I dislike the skybox dimming to the point where I'm considering removing the mod entirely.

With changeSkybox to false, Kerbin gets its stars back, but the sun still gets the awkward black void... showNames gives me planet names no problem, but my vessel flares don't give me anything when I hover over them (which are obviously enabled since I'm seeing them and hovering over them).

Edited by Nitrous Oxide

Share this post


Link to post
Share on other sites
MOARdV    1318
And maybe I'm complaining because those are already set and they aren't doing what they should... and neither of you are Rubber Ducky, so it's not like either of you made those choices... don't take it personally, but I dislike the skybox dimming to the point where I'm considering removing the mod entirely.

With changeSkybox to false, Kerbin gets its stars back, but the sun still gets the awkward black void... showNames gives me planet names no problem, but my vessel flares don't give me anything when I hover over them (which are obviously enabled since I'm seeing them and hovering over them).

Stock KSP dims the stars when the sun is visible (remove this plugin and look for yourself). If you've set the max brightness slider for Distant Object Enhancement to anything below 100%, the dimming is applied to that max brightness value, not to the 100% value.

Share this post


Link to post
Share on other sites
Nitrous Oxide    109
Stock KSP dims the stars when the sun is visible (remove this plugin and look for yourself). If you've set the max brightness slider for Distant Object Enhancement to anything below 100%, the dimming is applied to that max brightness value, not to the 100% value.

Yeah, there's a difference between dimming and removing them completely, however, so I'm going to go ahead and chalk it up as this mod is conflicting with another (PlanetShine possibly?)... Would it be possible to add another slider for a min brightness (ie so that the skybox dimming doesn't go lower than that point)?

And for the vessel names, my vessel names are full of backslashes and brackets and periods and stuff, so if it's throwing some kind of exception because my vessel names are too complex... well when you have upwards of 30 satellites and you've barely passed the Mun, you kind of need a serial system to keep track of them all... can't just give them "names"...

Edited by Nitrous Oxide

Share this post


Link to post
Share on other sites
Gryphon    113
I dislike the skybox dimming to the point where I'm considering removing the mod entirely.

I suppose you can try to make it look how you prefer, but here's something to consider:

The black sky was different, especially on the surface of the moon. Because from earth, the surrounding light is visible when looking at the night sky. In space, the sun is always affecting the night sky. But on the surface of the moon, the sun's light gave a pronounced velvet-like sheen, such that no stars were visible, especially in the vicinity of the earth. The stars were visible en route, but away from the sun, the stars were very visible, but on the surface of the moon, the ambient light enabled stars to be seen through the telescope but not through the visor cover on the eyes.

Share this post


Link to post
Share on other sites
deepfield    10

Any way to have settings changed within this mod stay? I get a horrible log flood with the below message about 8 times per second if I have any kind of flares on. I solved it by just turning them all off which is fine because I only want the darkened sky function. The only thing is, when i turn them off as soon as I reload KSP they are back on.

[EXC 20:22:37.493] ArgumentException: The thing you want to instantiate is null.

UnityEngine.Object.CheckNullArgument (System.Object arg, System.String message)

UnityEngine.Object.Instantiate (UnityEngine.Object original)

DistantObject.FlareDraw.DrawVesselFlare (.Vessel referenceShip)

DistantObject.FlareDraw.Update ()

Share this post


Link to post
Share on other sites
MOARdV    1318
Any way to have settings changed within this mod stay? I get a horrible log flood with the below message about 8 times per second if I have any kind of flares on. I solved it by just turning them all off which is fine because I only want the darkened sky function. The only thing is, when i turn them off as soon as I reload KSP they are back on.

The settings persist, provided you apply settings before closing the UI. If they're not reloading, it suggests the config file is not where DistantObject requires it.

Likewise, that NULL exception suggests DistantObject is installed incorrectly or incompletely - the only thing being instantiated in that method is a model found at GameData/DistantObject/Flare/model.

If DO is not installed in GameData/DistantObject, it will not function correctly.

Share this post


Link to post
Share on other sites
gzac95    5

Is there any way to fix the problem with this mod and tarsier space tech telescopes? Or I think telescopes in general. When the mod is active distane planets become black and patterned. When it is removed the telescopes work fine. Both mods are great and compliment each other nicely... So I'm hoping there is a fix.

Share this post


Link to post
Share on other sites
MOARdV    1318
Is there any way to fix the problem with this mod and tarsier space tech telescopes? Or I think telescopes in general. When the mod is active distane planets become black and patterned. When it is removed the telescopes work fine. Both mods are great and compliment each other nicely... So I'm hoping there is a fix.

The CactEye telescope has / will have a fix. The current version of DOE has some changed Raven requested to allow the two mods to play together. I don't know if the CactEye part of the fix is available yet. Beyond that, I don't know - I don't use any of the 'scope mods, and I don't have a huge amount of time to code for fun (and there are things ahead of this mod on my KSP mod to-do list).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now