MOARdV

[1.3.1] Distant Object Enhancement bis v1.9.1 (8 July 2017)

Recommended Posts

1 hour ago, The Jeb. said:

Is it possible to change this with KSP  settings? I mean not the in game settings panel :) Just askin'

 

What specifically are you looking to change?  The distance where KSP loads the model?  When DOE renders a flare?

Share this post


Link to post
Share on other sites

I love this mod. Glad to see it on CKAN again. Thanks for keeping it going!

Share this post


Link to post
Share on other sites
3 hours ago, The Jeb. said:

 

The distance where KSP loads the model

That's configurable (as part of KSP, not DOE).  I know it can be hand edited in (KSP install directory)/Physics.cfg - search for "load =" in that file, and you'll find the load / unload / pack / unpack ranges.  However, you'll want to be careful editing that file, since you can really jack up your game if the wrong values get tweaked.

Share this post


Link to post
Share on other sites

Physics in KSP are a bit confusing. You are either loaded(the active vessel basically and everything in the physics range (or in loading range) or on rails. The second means that the physics is basically limited to the trajectory (no woobling, no drag, no rotation etc.) .

When a vessel is getting closer, KSP has an intermediary state where the vessel is loaded but packed : not all capabilities are possible ( for example no trottle) but models are already loaded and some parts can be interfered with (ports can be targeted for instance). ;

When the vessel gets closer, KSP unpacks the vessel and its has full capabilities

Share this post


Link to post
Share on other sites

Regarding my earlier post about random crashes, it seems no longer an issue, everything works as is should starting from release.

Share this post


Link to post
Share on other sites

Minor update to DOE.  @Kerbas_ad_astra provided an update to the Blizzy's Toolbar interface code to take care of some exceptions that may pop up (Thanks! I haven't been keeping up with Blizzy's Toolbar, so I missed the change).  I removed the last remnants of Linq in this mod while I was touching code,  Version 1.8.1 is now up on GitHub.

Share this post


Link to post
Share on other sites

Hi, is there a way to make the skybox dim even more while looking at the sun? Now when I look at kerbin the skybox is pitch black but I can still see the stars while looking at the sun. I have tried to change the maximum brightness but it just makes the skybox too dark to see at night

Share this post


Link to post
Share on other sites
8 hours ago, orangewarning said:

Hi, is there a way to make the skybox dim even more while looking at the sun? Now when I look at kerbin the skybox is pitch black but I can still see the stars while looking at the sun. I have tried to change the maximum brightness but it just makes the skybox too dark to see at night

Skybox dimming when facing the sun is controlled by stock KSP, not DOE.  So, unfortunately, there's nothing DOE can do about that.

Share this post


Link to post
Share on other sites

I'm seeing Jool flare rendered as a darker dot against Sun flare. Looks as if it passes before Sun, while actually it is behind.

Debian testing, Intel i7-3540M.

Share this post


Link to post
Share on other sites
4 hours ago, Psycho_zs said:

I'm seeing Jool flare rendered as a darker dot against Sun flare. Looks as if it passes before Sun, while actually it is behind.

Debian testing, Intel i7-3540M.

Yeah, I had that fixed, but it's broken again.  Not sure exactly what happened yet.

Share this post


Link to post
Share on other sites
28 minutes ago, AndrewDrawsPrettyPictures said:

Is it possible to have DOE work with another star? If so, is it possible to change the distance that you would be able to see the flare from DOE?

It depends on your definition of "another star".  If you mean something that replaces Kerbol, yes.  If you mean one of the mods that adds additional "stars" to the game, no.

As far as the distance you can see the flare - for a planet/moon, it is a function of the size of the planet and its distance from Kerbol.  There are no hard limits saying "only show planets closer than X from the player".  But, like in our solar system, a small, dim world isn't going to be visible.  Past a certain distance, they simply are too dim to see.

As far as vessels, they are hard coded to be visible no more than 750km from the active vessel, and most vessels are small enough that they aren't visible at those distances.

Share this post


Link to post
Share on other sites
On 10/23/2016 at 6:24 AM, MOARdV said:

Skybox dimming when facing the sun is controlled by stock KSP, not DOE.  So, unfortunately, there's nothing DOE can do about that.

Shoot. It seems that behavior reverted or is much less effective now. 

Share this post


Link to post
Share on other sites

Not seeing anyone else post it, but thought I would give you a heads up, but it looks like this is having the issue with Contract Configurator and Toolbar. When it is installed the button disappears, and in list of what buttons to show it is replaced by question marks. If it is the same issue details of whats causing it is here. Most are saying its an easy update fix.

 

Edited by DigitalProeliator

Share this post


Link to post
Share on other sites

@DigitalProeliator :

On 10/20/2016 at 4:31 PM, MOARdV said:

Minor update to DOE.  @Kerbas_ad_astra provided an update to the Blizzy's Toolbar interface code to take care of some exceptions that may pop up (Thanks! I haven't been keeping up with Blizzy's Toolbar, so I missed the change).  I removed the last remnants of Linq in this mod while I was touching code,  Version 1.8.1 is now up on GitHub.

 

Share this post


Link to post
Share on other sites

Hi, i'm not sure to know what is the problem and if it's about distant objet : i can't see myu skybox while in KSC. Don't know with what mod option i have to play with to have beautiful star on kerbin ground. If you have an answer i tak it :wink: thanks !

 

Oups my bad, it works, it's just very dark.

Edited by msnbcorp

Share this post


Link to post
Share on other sites

Unfortunately, crashes have returned. Perhaps with 1.2.1 release. Tried to enable log flushing in debug menu, still no error messages at the end of the log. If debug mode is enabled in DOE, it just spams this repeatedly all the time:

Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- Update
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- Update
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

No change at the end, when crash occurs.

Spoiler

GameData listing:

000_USITools/
B9PartSwitch/
Blacklist.cfg
CommunityCategoryKit/
CommunityResourcePack/
CommunityTechTree/
CryoEngines/
CryoTanks/
DeployableEngines/
Diazo/
DistantObject/
EditorExtensionsRedux/
EvaFuel/
FP_DPSoundFX/
FuelTanksPlus/
HeatControl/
HideEmptyTechTreeNodes/
JSI/
KeepItStraight/
KerbalAtomics/
KerbalEngineer/
KerbNetController/
Kopernicus/
LETech/
ModularFlightIntegrator/
ModuleManager.2.6.25.dll
ModuleManager.2.7.1.dll
ModuleManager.2.7.3.dll
ModuleManager.2.7.4.dll
ModuleManager.ConfigCache
ModuleManager.ConfigSHA
ModuleManager.Physics
ModuleManager.TechTree
NavBallDockingAlignmentIndicator.dll
NearFutureConstruction/
NearFutureElectrical/
NearFutureProps/
NearFuturePropulsion/
NearFutureSolar/
NearFutureSpacecraft/
OrbitalSurveyPlus/
PartOverhauls/
PersistentRotation/
PlanetaryBaseInc/
PlanetShine/
PluginData/
Porkjet_Overhaul_Integration.cfg
RCSBuildAid/
RealPlume/
RealPlume-Stock/
rescale_fixes.cfg
ShipManifest/
Sigma/
SmokeScreen/
SpaceY-Lifters/
Squad/
StageRecovery/
StationPartsExpansion/
TimeControl/
TriggerTech/
UmbraSpaceIndustries/

 

Share this post


Link to post
Share on other sites
1 hour ago, Psycho_zs said:

Unfortunately, crashes have returned. Perhaps with 1.2.1 release. Tried to enable log flushing in debug menu, still no error messages at the end of the log. If debug mode is enabled in DOE, it just spams this repeatedly all the time:


Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- Update
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- FixedUpdate
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Distant Object Enhancement v1.8.1 -- Update
 
(Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

No change at the end, when crash occurs.

  Reveal hidden contents

GameData listing:

000_USITools/
B9PartSwitch/
Blacklist.cfg
CommunityCategoryKit/
CommunityResourcePack/
CommunityTechTree/
CryoEngines/
CryoTanks/
DeployableEngines/
Diazo/
DistantObject/
EditorExtensionsRedux/
EvaFuel/
FP_DPSoundFX/
FuelTanksPlus/
HeatControl/
HideEmptyTechTreeNodes/
JSI/
KeepItStraight/
KerbalAtomics/
KerbalEngineer/
KerbNetController/
Kopernicus/
LETech/
ModularFlightIntegrator/
ModuleManager.2.6.25.dll
ModuleManager.2.7.1.dll
ModuleManager.2.7.3.dll
ModuleManager.2.7.4.dll
ModuleManager.ConfigCache
ModuleManager.ConfigSHA
ModuleManager.Physics
ModuleManager.TechTree
NavBallDockingAlignmentIndicator.dll
NearFutureConstruction/
NearFutureElectrical/
NearFutureProps/
NearFuturePropulsion/
NearFutureSolar/
NearFutureSpacecraft/
OrbitalSurveyPlus/
PartOverhauls/
PersistentRotation/
PlanetaryBaseInc/
PlanetShine/
PluginData/
Porkjet_Overhaul_Integration.cfg
RCSBuildAid/
RealPlume/
RealPlume-Stock/
rescale_fixes.cfg
ShipManifest/
Sigma/
SmokeScreen/
SpaceY-Lifters/
Squad/
StageRecovery/
StationPartsExpansion/
TimeControl/
TriggerTech/
UmbraSpaceIndustries/

 

I don't have a crash here with 1.2.1.  Can you post the entire log somewhere (DropBox or something similar)?

Share this post


Link to post
Share on other sites

OK, I'll save it next time the crash occurs.

Share this post


Link to post
Share on other sites

Rare, but sudden thing. If my memory doesn't play tricks on me, it usually happens in orbit, with several vessels in the scene. But sometimes with single vessel too. Split second freeze, yet another frame, crash. Nothing on stdout or stderr.

https://yadi.sk/d/IfDtPCROwxPw4

 

Share this post


Link to post
Share on other sites
4 minutes ago, Psycho_zs said:

Rare, but sudden thing. If my memory doesn't play tricks on me, it usually happens in orbit, with several vessels in the scene. But sometimes with single vessel too. Split second freeze, yet another frame, crash. Nothing on stdout or stderr.

https://yadi.sk/d/IfDtPCROwxPw4

 

I see a lot of NullReference exceptions coming out of Kopernicus in that log, and a couple of other exceptions that look a lot like a out-of-date mod is lurking in your installation (RCSBuildAidToolbar is throwing exceptions during load).  At the very least, you need to look into the Kopernicus exceptions - they're not being caught, which means all bets are off with respect to other mods functioning correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now