MOARdV

[1.6.x] Distant Object Enhancement bis v1.9.1.1 (16 October 2018) - Free to a Good Home

Recommended Posts

Which alternate color config should I use with 6.4x kerbal system? Should I keep it stock?

Share this post


Link to post
Share on other sites

this is bugging me. Am I really just noticing it for the first time or is there an issue here?

iSgYZzs.png

oJ1aJqw.png

The left edge of the images is the left edge of my screen. Not sure why I have to move the sun so far over to get the stars to fully disappear. Skybox dimming is set to 75% where I've always had it...

Share this post


Link to post
Share on other sites

Anyone else had an issue with objects like minmus looking like they have a moon, due to the fact that Distant Object is adding a flare for it, but is mistakenly putting it to the side, even when the object is visible?

Share this post


Link to post
Share on other sites
this is bugging me. Am I really just noticing it for the first time or is there an issue here?

Yeah, it's super awkward... I flipped out about that last page, kinda sorta (not exactly, but the dimming could use a rework, eh). :blush:

Anyone else had an issue with objects like minmus looking like they have a moon, due to the fact that Distant Object is adding a flare for it, but is mistakenly putting it to the side, even when the object is visible?

Yeah, I've noticed that too. Most of the time it's just for a second or two until it refreshes, try changing the camera angle a bit maybe?

Also, no matter what I've tried, my vessel names never show up when I hover the flares. Yes, everything is set properly. It worked once... so I know it can happen... but either the area I have to hover over is so tiny that I never hit it... or it's not working for me... :( I see the flares fine, just no names when for my my satellites like when I hover over the planet flares...

Share this post


Link to post
Share on other sites
Yeah, it's super awkward... I flipped out about that last page, kinda sorta (not exactly, but the dimming could use a rework, eh). :blush:

Yeah, I've noticed that too. Most of the time it's just for a second or two until it refreshes, try changing the camera angle a bit maybe?

Also, no matter what I've tried, my vessel names never show up when I hover the flares. Yes, everything is set properly. It worked once... so I know it can happen... but either the area I have to hover over is so tiny that I never hit it... or it's not working for me... :( I see the flares fine, just no names when for my my satellites like when I hover over the planet flares...

These are all issues I will work on when I have time. Unfortunately, I've got two other mods that are higher priority for my modding time, and since I didn't write this mod initially, I don't have as good of a grasp on it as I otherwise would. I have ideas on the vessel names and the misplaced planet flare problem. I think vessel flares are sometimes visible when they shouldn't be, and the threshold for when the text shows up is set too high, as well. I have a partial fix on that locally, but it's not ready to post yet. You can also occasionally see other flares jumping - it's really obvious if your vessel is in polar orbit (I watched Jool jump several diameters every few seconds the other day). I haven't looked into the root cause on that one yet.

Share this post


Link to post
Share on other sites
These are all issues I will work on when I have time. Unfortunately, I've got two other mods that are higher priority for my modding time, and since I didn't write this mod initially, I don't have as good of a grasp on it as I otherwise would. I have ideas on the vessel names and the misplaced planet flare problem. I think vessel flares are sometimes visible when they shouldn't be, and the threshold for when the text shows up is set too high, as well. I have a partial fix on that locally, but it's not ready to post yet. You can also occasionally see other flares jumping - it's really obvious if your vessel is in polar orbit (I watched Jool jump several diameters every few seconds the other day). I haven't looked into the root cause on that one yet.

Good to hear mate, and thanks for the work you've done to keep this going. :)

2kUmNhV.png

I think that shot would be 100% less interesting without DOE. :D

Share this post


Link to post
Share on other sites
I think vessel flares are sometimes visible when they shouldn't be

Definitely this, IMO. I can clearly see, for example, that Minmus is being rendered as an object but the flare is still trying to overlay itself upon it

Share this post


Link to post
Share on other sites

I'm not sure I understand what all the options in this mod do. What I'm looking for is a way to keep the enhanced distance when viewing space stations and ships you are approaching without killing the skybox. What setting do I use to do that? I tried disabling dynamic sky dimming, but it didn't seem to do that (not sure what it did really).

Share this post


Link to post
Share on other sites
I'm not sure I understand what all the options in this mod do. What I'm looking for is a way to keep the enhanced distance when viewing space stations and ships you are approaching without killing the skybox. What setting do I use to do that? I tried disabling dynamic sky dimming, but it didn't seem to do that (not sure what it did really).

Disabling dynamic sky dimming is what you want (uncheck it in the dialog, hit apply, of course - I just double checked that it's working). That said, stock KSP has its own sky dimming when the sun is visible. There's nothing I can do about that - all this plugin does is to cause sky dimming when the day side of a planet / moon is visible and nearby.

Share this post


Link to post
Share on other sites

Maybe I didn't hit apply. I'll try again.

EDIT: Working now. Sorry for the confusion.

Edited by Alshain

Share this post


Link to post
Share on other sites
Maybe I didn't hit apply. I'll try again.

EDIT: Working now. Sorry for the confusion.

Not a problem. I've debated keeping the Apply button, versus making changes take effect immediately, so the effects they cause are obvious.

Share this post


Link to post
Share on other sites

I've had problems with dynamic skybox dimming option not setting as well. I'm not a fan of the dimming and it's annoying that it keeps coming back.

Share this post


Link to post
Share on other sites
I've had problems with dynamic skybox dimming option not setting as well. I'm not a fan of the dimming and it's annoying that it keeps coming back.

I plan on giving that code some attention next.

In the meantime, DOE v1.5.2 is available. Not really anything new from an end-user perspective, although I think I've got the "Minmus and its flare" bug fixed.

Share this post


Link to post
Share on other sites

I had a problem, "A Visual artifact when switching to Orbital Map view or zooming the view."

and another member pointed out he had the same problem and ID it as being caused by DOE v1.5.2 (When he rolled back to 1.5.1 the problem went away

Link to his thread IDing the problem with pictures.

http://forum.kerbalspaceprogram.com/threads/111715-Odd-artifact-while-zooming-map-randomly-flashing-in-flight

Share this post


Link to post
Share on other sites
I had a problem, "A Visual artifact when switching to Orbital Map view or zooming the view."

and another member pointed out he had the same problem and ID it as being caused by DOE v1.5.2 (When he rolled back to 1.5.1 the problem went away

I don't see that problem with DOE v1.5.2 - I made sure I put a large ship in orbit, in case that was the issue, and it still doesn't happen. I am going to need more information in order to try to help - at the very least, run the game and get the problem to happen, and then put your KSP_Data/output_log.txt somewhere where I can download it and inspect it.

Share this post


Link to post
Share on other sites

I also use the DDS4KSP and just to make sure replaced DOE 1.5.2 with a clean version (Not DDSed) and ran KSP again

Saw the same thing. The size of the ship does not matter. (I was seeing it on a little 15 part satellite probe. When zooming in and out on the active ship the "shockwave/flare appears.

Unfortunetly I have also already rolled it back to 1.5.1 but it is midnight here and I need to sleep. I will test it with 1.5.1 tomorrow. I I DID save my last KSP_Data/output_log.txt from 1.5.2 and will try to find some place to upload it tomorrow.

Share this post


Link to post
Share on other sites

Hmm I am having the flashes too never knew what was causing it. I also convert all my textures to dds.

Edited by Svm420

Share this post


Link to post
Share on other sites

Hello,

I just updated maybe I will revert to 1.5.1 I cant; actually...maybe I will run 1.5.2 but I dont know when I can get to troubleshooting the above anamoly; I am adding all my effects to the game and wanted to say this is a kool MOD thank you !

My Kerbal Space Engineers using their telescopes can find planets now !

I have made a few streams already showcasing this...later I will be using Astronomer Packs and E.V.E. and see if we can find planets on the ground (on live stream; I dont have a scope yet but maybe I can throw in Romfarer's Lazor pack... - as long as the clouds arent too obtrusive ...!

Cmdr Zeta

Edited by Cdr_Zeta

Share this post


Link to post
Share on other sites
Not a problem. I've debated keeping the Apply button, versus making changes take effect immediately, so the effects they cause are obvious.

Put me down for instant changes. I prefer live changes when sliding a slider so I can see what is going on.

Share this post


Link to post
Share on other sites

Would it be possible to make it so you can adjust the brightness of the flares, I find it absurd being able to see eeloo as a bright object from kerbin.

did I also mention that Gilly is visible with the naked eye on kerbin.

Edited by Dooz

Share this post


Link to post
Share on other sites

I got a weird bug after installing this mod.

all my Stayputnik Sats got bigger and swallowed the parts that were around them.

Using Realism overhaul with RSS

Not sure what happened this problem went away on its own

Edited by darqen27

Share this post


Link to post
Share on other sites

I had posted about this in the texture replacer mod thread once, but it didn't seem like it would be possible via that mod.

I'm looking for a mod that can make less of the skybox visible while on the surface of a body with atmosphere and you are on the night side. My original idea was to use texture replacer to add a second skybox behind the first. The first one would contain gas clouds, nebulas, galaxies and other phenomenon that are not normally visible from within atmosphere. That layer would have it's alpha level dropped as you plunge into atmosphere, and vice versa. It should never reach 100% either, so that you can always see the same stars behind/through it.

Seems that my idea would require a plugin of it's own, which I have no idea how to write. Perhaps this is a feature you may want to explore.

Share this post


Link to post
Share on other sites

Distant Object v1.5.3 is now live. This is a KSP 1.0 compatibility release. I don't think any existing issues were fixed, and there's a chance I introduced new ones. But at least I got the update posted on the day of release (for my time zone). :)

Git it on GitHub or KerbalStuff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.