MOARdV

[1.6.x] Distant Object Enhancement bis v1.9.1.1 (16 October 2018) - Free to a Good Home

Recommended Posts

Hm, CKAN seems to insist on installing astronomers pack with DOE. Perhaps I need to also install the default config?

EDIT: Yep, had to select the default config. Not before it finished downloading the 375 mb Astronomer package, though...

Edited by Mipe

Share this post


Link to post
Share on other sites
Hm, CKAN seems to insist on installing astronomers pack with DOE. Perhaps I need to also install the default config?

EDIT: Yep, had to select the default config. Not before it finished downloading the 375 mb Astronomer package, though...

I don't have anything to do with the CKAN config, so I don't know why it wanted to do that.

Share this post


Link to post
Share on other sites

I installed the update and I am getting a double icon over the resources icon.

91A4DF5C88E41553B4AF9C4A9F2BEFF0C6EEF675

Share this post


Link to post
Share on other sites
I installed the update and I am getting a double icon over the resources icon.

Argh. *Something* changed with KSP 1.0 and the way those buttons are managed, and I spent half of yesterday trying to get it working right again, and it looks like there's still something wrong. I'll put that on my to-do pile.

Share this post


Link to post
Share on other sites

Distant Object Enhancement does not play nice with Environmental Visual Enhancement. With both installed the night side textures on Kerbin get all messed up.

I've no idea which of the two is to blame.

Share this post


Link to post
Share on other sites
Distant Object Enhancement does not play nice with Environmental Visual Enhancement. With both installed the night side textures on Kerbin get all messed up.

I've no idea which of the two is to blame.

In what way messed up? I've got both installed in 1.0 and it looks fine to me.

Share this post


Link to post
Share on other sites

I've found the problem with the duplicate App Launcher button. DOE v1.5.4 is now available at the usual places.

Share this post


Link to post
Share on other sites
I've found the problem with the duplicate App Launcher button. DOE v1.5.4 is now available at the usual places.

Great stuff, MOARdV! :-)

Share this post


Link to post
Share on other sites
Distant Object Enhancement does not play nice with Environmental Visual Enhancement. With both installed the night side textures on Kerbin get all messed up.

I've no idea which of the two is to blame.

I had the same the same problem, but check this for a fix.

Share this post


Link to post
Share on other sites

DOE v1.5.5 is now live at the usual places. It contains a number of small fixes, an attempt at a fix for a bug I haven't been able to reproduce, and an option to display the DOE config button only in the Space Center from GitHub user Gribbleshnibit8View.

EDIT: Also, who uses the Distant Vessel rendering feature (not the flares, but the other one with the max distance that defaults to 750km)? I've never used it myself, and I remember there were bugs with it early in development that caused exploding vessels, so I've been thinking of removing the feature instead of possibly having to maintain it down the road. If people in general don't use it, I may deprecate it in the next release.

Edited by MOARdV
Added question

Share this post


Link to post
Share on other sites
...

EDIT: Also, who uses the Distant Vessel rendering feature (not the flares, but the other one with the max distance that defaults to 750km)? I've never used it myself, and I remember there were bugs with it early in development that caused exploding vessels, so I've been thinking of removing the feature instead of possibly having to maintain it down the road. If people in general don't use it, I may deprecate it in the next release.

Thanks for the update.

Concerning vessel rendering feature, I always used it with 0.90 (I wasn't aware it could cause issues actually ^^ ) never had a glitch, I even set "ignore debris" to false.

I use this option again with 1.0.2 but I restarted a career from scratch, so I must have something like one debris + one probe up there for now. ^^

;)

Is it working in 1.0.2?

Of curse ^^

Share this post


Link to post
Share on other sites
Is it working in 1.0.2?

According to the release notes at GitHub and at KerbalStuff, yes. I'll update the thread title to make it clear.

Share this post


Link to post
Share on other sites
Also, who uses the Distant Vessel rendering feature (not the flares, but the other one with the max distance that defaults to 750km)? I've never used it myself, and I remember there were bugs with it early in development that caused exploding vessels, so I've been thinking of removing the feature instead of possibly having to maintain it down the road. If people in general don't use it, I may deprecate it in the next release.

I don't use it much either but I haven't noticed any issues from it myself

Edited by Gaiiden

Share this post


Link to post
Share on other sites
EDIT: Also, who uses the Distant Vessel rendering feature (not the flares, but the other one with the max distance that defaults to 750km)? I've never used it myself, and I remember there were bugs with it early in development that caused exploding vessels, so I've been thinking of removing the feature instead of possibly having to maintain it down the road. If people in general don't use it, I may deprecate it in the next release.

I do, though I pain myself to admit that if this were nerfed or removed entirely, it wouldn't affect my gameplay substantially. I do run CactEye telescopes, though it's usually only toward T5 or T6 on the tech tree that I start actually running CactEye missions.

Also, I came here to possibly report an issue with v1.5.3, I just had a reproduceable crash on an install running a small suite of mods. To the best I can read the log, it crashed as a result of a lot of NRE spam. Since you've already migrated to 1.5.5, should I just delete these logs, or would you benefit from seeing them anyway? (I'm in the very earliest stages of a career, T3 tech, running a simple vertical launch and dead stick reentry test in an environment "simulated" by Kerbal Construction Time.)

Thanks for an awesome mod!

Share this post


Link to post
Share on other sites
I don't use it much either but I haven't noticed any issues from it myself

Exactly this. I don't have a telescope mod or anything (yet), so it's used about 0.1% of the time. But, yeah, never had a problem with it exploding vessels.

Share this post


Link to post
Share on other sites

This is one of my favorite mods, however I am noticing a problem in 1.02 where the skybox dimmer cannot be turned off, or scaled. It's not a matter of forgetting to hit the apply button. I also have planetshine and scatterer installed. Stars are not visible when a planet's surface is in frame regardless of whether the sun is in view or not.

Share this post


Link to post
Share on other sites

This is normal behavior.

To see the skybox you should be on planet darkside or free of sun / shiny planet's surface.

Share this post


Link to post
Share on other sites

I need some help interpreting my own error log here. I keep crashing to desktop, sometimes after a few minutes, sometimes after longer. This implies to me that there's some kind of NRE overflow action going on.

In previous attempts to interpret my error log, I saw lots and lots and lots of "DistantObject" FileNotFoundException errors. I then deleted the DistantObject folder inside GameData. But the crashes continue.

Can someone help me even understand which mod is causing this, since I've uninstalled DOE? Thanks.

https://www.dropbox.com/s/rb4q8vxjh9ioxte/output_log.txt?dl=0

Share this post


Link to post
Share on other sites
I need some help interpreting my own error log here. I keep crashing to desktop, sometimes after a few minutes, sometimes after longer. This implies to me that there's some kind of NRE overflow action going on.

In previous attempts to interpret my error log, I saw lots and lots and lots of "DistantObject" FileNotFoundException errors. I then deleted the DistantObject folder inside GameData. But the crashes continue.

Can someone help me even understand which mod is causing this, since I've uninstalled DOE? Thanks.

https://www.dropbox.com/s/rb4q8vxjh9ioxte/output_log.txt?dl=0

DistantObject is not installed in the log you provided. I'm guessing the problem is the CactEye Telescope's DistantObjectHook.dll is trying to access DistantObject. Try removing DistantObjectHook.dll

Share this post


Link to post
Share on other sites
DistantObject is not installed in the log you provided. I'm guessing the problem is the CactEye Telescope's DistantObjectHook.dll is trying to access DistantObject. Try removing DistantObjectHook.dll

It is, DistantObjectHook.dll is tied to the specific version of DOE, and will flood the logs if the wrong version of DOE is installed, or if DOE is not installed at all. DistantObjectHook.dll is only meant if both CactEye and DistantObject are installed. Right now, specifically CactEye BETA 5.2 and DOE 1.5.4.

Edited by Raven.

Share this post


Link to post
Share on other sites

Holy crap, I feel silly. Upon reading this, I looked in my folder where I store downloaded mod zipfiles, and yes indeed, there was a DOE patch for CactEye. I deleted and reinstalled CactEye without the patch.

If this eliminates the problem, I'll delete CactEye and run DOE for a while, and then if that works, I'll reinstall CactEye and run them both without the patch. While also keeping an eye out for new versions of either.

Thanks man! (Seriously, that was boneheaded of me!)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.