MOARdV

[1.6.x] Distant Object Enhancement bis v1.9.1.1 (16 October 2018) - Free to a Good Home

Recommended Posts

I don't really like the sky dimming option and can't disable it. I have unchecked the box with dynamic sky dimming, but it will still dim the stars when looking towards the sun. Any advice on this?

As mentioned 3 posts above yours, stock KSP dims the skybox when the sun is visible. Please check to see if you see the problem without DOE installed.

Share this post


Link to post
Share on other sites
I don't really like the sky dimming option and can't disable it. I have unchecked the box with dynamic sky dimming, but it will still dim the stars when looking towards the sun. Any advice on this?

I may be mistaken, but doesn't that happen in stock too?

Share this post


Link to post
Share on other sites

KSP without DOE: 2j5xnbq.jpg - doesn't dim stars

With DOE: depkxh.jpg

Do I have to mess around with some settings?

Share this post


Link to post
Share on other sites
Do I have to mess around with some settings?

Yes, change the Max Sky Brightnes to 100% - the "dimming" effect you're seeing without the box checked is more just a result of the sun flare graphic washing out the already-dim background because you have it set to 25%. That's a separate setting that doesn't tie into the dynamic dimming and affects the entire skybox all the time

Share this post


Link to post
Share on other sites
Yes, change the Max Sky Brightnes to 100% - the "dimming" effect you're seeing without the box checked is more just a result of the sun flare graphic washing out the already-dim background because you have it set to 25%. That's a separate setting that doesn't tie into the dynamic dimming and affects the entire skybox all the time

Seems to be pretty fine now. Thanks!

Share this post


Link to post
Share on other sites

So you say you prefer GitHub for bug submissions. I was gonna do a proper bug report tonight or tomorrow so... How do I do that? It's just flares from craft are not visible what so ever despite everything I'm trying. So I was going to put together a stock install with DOE in it and provide some logs. Not sure how to do that with GitHub.

Share this post


Link to post
Share on other sites
So you say you prefer GitHub for bug submissions. I was gonna do a proper bug report tonight or tomorrow so... How do I do that? It's just flares from craft are not visible what so ever despite everything I'm trying. So I was going to put together a stock install with DOE in it and provide some logs. Not sure how to do that with GitHub.

If you've got logs, post them on DropBox and put a link here. I am aware that flares are showing up in the wrong place, and they are not always visible. I've bashed my head against the keyboard for a few hours trying to figure out what changed in KSP 1.0.x to do this (since they used to be right, or at least much better, I thought), but Unity is not my coding specialty, so I've made little-to-no progress on that front.

Share this post


Link to post
Share on other sites
... I am aware that flares are showing up in the wrong place, and they are not always visible.

Ah! Thanks, good to know it is not just on my KSP.

Share this post


Link to post
Share on other sites
Hi

The log gets spammed with these:

Serious?

Exactly the same, but i'm thinking that it is not due to distant object enhancement.

Here my 24MB log from my last play :

https://www.dropbox.com/s/r3mjbeai6ptgrvu/KSP.log?dl=0

- - - Updated - - -

Exactly the same, but i'm thinking that it is not due to distant object enhancement.

Here my 24MB log from my last play :

https://www.dropbox.com/s/r3mjbeai6ptgrvu/KSP.log?dl=0

I think I know : this is due to the use of CactEye.

The version of the DOE that has compatibility with it is the older version... and lead to this problem.

And indeed, cacteye doesn't work fine with the actual version of DOE.

As workaround I guess we have to remove the DistantObjectHook.dll from plugin folder of cactEye.

Share this post


Link to post
Share on other sites

Is there a way to reduce the brightness of a flare? for some reason my Pluto analogue looks like a supernova

uwn4Zyuh.png

Share this post


Link to post
Share on other sites
Decrease the brightness of the color. Make it a bluish color, with lots of black.

I tried 0,0,0 didn't work

Share this post


Link to post
Share on other sites

Is there a way to exclude a body from being shown by DOE? I think the problem is that I have a fake planet with radius 1 and that for some reason gets a huge flare

Share this post


Link to post
Share on other sites
Is there a way to exclude a body from being shown by DOE? I think the problem is that I have a fake planet with radius 1 and that for some reason gets a huge flare

Currently, there is not. Are you using one of the planet-adding mods to create this planet? I would expect any mod that adds its planets to the database would just work, since the flare size is a function of planet diameter and distance.

Share this post


Link to post
Share on other sites
Is there a way to reduce the brightness of a flare? for some reason my Pluto analogue looks like a supernova

http://i.imgur.com/uwn4Zyuh.png

I know the feeling. The same issue occurs with Plock-Chirkin. Only their flare is even larger because of Styx analogue Gyx an Nix analog Nin adding to it. By the time a get all five done, I would not be surprised if it outshines the Mun.

Share this post


Link to post
Share on other sites

I feel the planet flares are too bright when you have very bright objects in your field of view (ie. Mun surface), so would be nice if the flares were automatically dimmed further depending on how bright the whatever thing you have in your view is.

This looks too obvious and unrealistic. I have even adjusted the flare size down a little, but that didn't help with it standing out too much.

q45d51q9o93cvrg6g.jpg

full res: http://www./view/q45d51q9o93cvrg/KSP_flare.png

Edited by ebigunso

Share this post


Link to post
Share on other sites
I feel the planet flares are too bright when you have very bright objects in your field of view (ie. Mun surface), so would be nice if the flares were automatically dimmed further depending on how bright the whatever thing you have in your view is.

This looks too obvious and unrealistic. I have even adjusted the flare size down a little, but that didn't help with it standing out too much.

https://www./convkey/085c/q45d51q9o93cvrg6g.jpg

full res: http://www./view/q45d51q9o93cvrg/KSP_flare.png

have you tried adjusting the sliders in the config panel of DOE? I don't know if that can do what you want, but it might

Share this post


Link to post
Share on other sites
have you tried adjusting the sliders in the config panel of DOE? I don't know if that can do what you want, but it might

Those adjust the parameters for the whole entire game, and as I like the way it looks for other situations it's not doing what I want here. Some additional configs would be needed for the purpose.

Share this post


Link to post
Share on other sites

I've published DOE v1.5.6 on GitHub and KerbalStuff.

Changes:

  • Big flares appearing for small/dim worlds is fixed. Issue #16.
  • A few changes to hopefully reduce memory footprint when some features are not used.
  • Sky dimming has been changed: Updates are shown immediately when "Apply" is pressed. Sky dimming now affects Tracking Station and Space Center views. Planet dimming near the sun has been tweaked.

Known Issues:

  • Flare dimming near the sun is not right. It's a problem with being unable to find out how much KSP's stock dimming effect is affecting the scene.
  • Vessel flares are still in the wrong place, and not always visible. If anyone has any insight on this issue that they're willing to share, I'd appreciate it.

Share this post


Link to post
Share on other sites
I've published DOE v1.5.6 on GitHub and KerbalStuff.

Changes:

  • Big flares appearing for small/dim worlds is fixed. Issue #16.
  • A few changes to hopefully reduce memory footprint when some features are not used.
  • Sky dimming has been changed: Updates are shown immediately when "Apply" is pressed. Sky dimming now affects Tracking Station and Space Center views. Planet dimming near the sun has been tweaked.

Known Issues:

  • Flare dimming near the sun is not right. It's a problem with being unable to find out how much KSP's stock dimming effect is affecting the scene.
  • Vessel flares are still in the wrong place, and not always visible. If anyone has any insight on this issue that they're willing to share, I'd appreciate it.

I don't know if it is a clue that helps at all but it seems to me that the vessel name tags and therefore also the mouse ray vector, when you seek and find a vessel (at any range), are indeed pointing to the correct position where the vessel flare should be being drawn. Also, when the camera recedes from a close range vessel showing a flare in the wrong position that when the camera reaches a point sufficiently distant the flare converges on the correct position.

Share this post


Link to post
Share on other sites
I've published DOE v1.5.6 on GitHub and KerbalStuff.

Known Issues:

  • Flare dimming near the sun is not right. It's a problem with being unable to find out how much KSP's stock dimming effect is affecting the scene.

By not right, does this mean that it's not working? Personally, I am getting no sky dimming when looking directly at the sun but it does dim when the lit side of a planet is visible. I am using scatterer, TR and the sunflare from ksprc, not sure if those have any effect on this.

Share this post


Link to post
Share on other sites
By not right, does this mean that it's not working? Personally, I am getting no sky dimming when looking directly at the sun but it does dim when the lit side of a planet is visible. I am using scatterer, TR and the sunflare from ksprc, not sure if those have any effect on this.

By "not right", I mean that if you watch the sky dimming when a planet is visible, they dim at different rates (the planet will abruptly disappear when the sun is near the middle of the screen).

If you're not seeing sky dimming when looking at the sun, I suspect one or more of the other mods you're using is affecting the stock behavior.

Share this post


Link to post
Share on other sites

Ok, so I seem to be getting something weird. I tried toggling the sky dimming option and changing scene to the ksc and back and thought that it was fixed. It seemed to be fine, until I was about 3/4 around the day side of the planet, where it just suddenly stopped dimming. No fade, just *bam* no dimming

evKjQoB.png
1vdvkQL.png
I'll have a got a removing some mods to see if there is any conflict

EDIT:

Ok so the problem seems to lie within kopernicus (I have it for the ksprc pack, from the ksprc thread) When I remove it the problem goes away.

Edited by Chimer4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.