CardBoardBoxProcessor

KOSMOS 3/14/2015 RD-170 Family Released!

Recommended Posts

I actually decided to manually fix all of the nodes for the SSPP since it's mostly what I loved about KOSMOS, if I'm allowed, I would gadfly post them here.

Share this post


Link to post
Share on other sites

I always use this mod. I usually only have the solar panels and monoprop tanks installed though (I usually prefer more stock-alike parts).

If I ever have free time again I might try making a stock-alike texture pack for this pack. (the original textures are very pretty though)

I think the only reason for the low download numbers is that the mod has been lagging behind the KSP versions a bit.

Share this post


Link to post
Share on other sites

Yeah I don;t really have time to work on it. it takes too long to develop each part. and looks alone do not seem to matter. sorry guys.

Been in the game since 2010?? Nothing I had hoped it'd become has come true in anyway... it's all been a big let down really. It is where it should have been 3 years ago.

Share this post


Link to post
Share on other sites
Yeah I don;t really have time to work on it. it takes too long to develop each part. and looks alone do not seem to matter. sorry guys.

Been in the game since 2010?? Nothing I had hoped it'd become has come true in anyway... it's all been a big let down really. It is where it should have been 3 years ago.

I don't know specifically what you hoped for when you found KSP, but I think I understand the sentiment. While I'm delighted to see the positive reviews following the official release... KSP (especially stock) is still so very far from realizing its potential, it can be depressing.

Maybe take a big break from modding and just try to play for fun? Or put the game down entirely for a few months. Walk away until you start feeling the KSP itch again. Maybe allow some other interested party to maintain the parts for awhile? Your work is so very very good, it would be a shame to see it lost forever.

Share this post


Link to post
Share on other sites

Just wanted to say that I too think Kosmos SSPP is a great mod, in fact one of my must haves.

It's just full of best in class parts - I'm thinking of obvious things like the RCS propulsion units and tanks and the Balka solar panels, but also easily overlooked gems like the LED lamps, which are perfect.

If it's not going forward, that's a real shame - but thank you CBBP for a great mod.

Share this post


Link to post
Share on other sites

Wow. Thanks guys. Glad people still like it. If anyine needs anything ti fix it or even carry it on I'll help and supply any data and files needed lol.

I dropped $5000 on a camera and lenses lol. any free time basically goes to that currently.

Share this post


Link to post
Share on other sites

Adding to the chorus of "KOSMOS is awesome and pretty and..." :)

Thanks for letting us play with it, and thanks for the kind offer. :)

Share this post


Link to post
Share on other sites
Wow. Thanks guys. Glad people still like it. If anyine needs anything ti fix it or even carry it on I'll help and supply any data and files needed lol.

Thanks allot. Oh do you still have the missing part for the RD-191V somewhere?

Share this post


Link to post
Share on other sites
Thanks allot. Oh do you still have the missing part for the RD-191V somewhere?

that is an easy fix. umm can you tell me the name of the file that is missing?

Share this post


Link to post
Share on other sites

With latest URMP.dll from https://github.com/MOARdV/UniversalRocketModulePlugin/releases I can run most the engines (except RD-191V), but they complain a whole lot:

[LOG 06:21:50.388] [SmokeScreen ModelMultiParticlePersistFX] Cannot find transform thrustTransform

[EXC 06:23:26.185] NullReferenceException: Object reference not set to an instance of an object
ModuleSurfaceFX.Update ()

[EXC 06:21:50.426] NullReferenceException: Object reference not set to an instance of an object
EngineEnhancement.GimbalHider.HideMyMenu ()
EngineEnhancement.GimbalHider.OnUpdate ()
Part.ModulesOnUpdate ()
Part.Update ()

Also, despite "LiquidFuel deprived" state on, say, RD-0146, engine exhaust effect continues to be shown.

I do not have other URM parts installed, except of strut which is nicer than stock one.

Oh yeah, and gimbals aren't animated at all it seems. :-(

And one more thing: for RD-0440 non-combos (NTR or LANTR, both with vernier thrusters) the nozzle won't extend. For NTR/LANTR combo w/o those verniers, it extends fine.

Edited by cipherpunks

Share this post


Link to post
Share on other sites

In addition to my previous post just above, here's another problem:

After entering VAB, placing NK-33, deleting it and placing RD-0146, latter starts to show running animation (exhaust plume) right in the VAB. In log I see:

[LOG 06:59:56.793] deleting part Kosmos.Angara.RD-33NK
[LOG 06:59:56.833] [SmokeScreen ModelMultiParticlePersistFX] OnDestroy
[LOG 06:59:58.074] Parsing vector2
[LOG 06:59:58.075] Parsing double
[ERR 06:59:58.078] [ModuleSrfFX]: No IThrustProvider module found at index 0!

[LOG 06:59:58.141] Updating Untitled Space Craft
[LOG 06:59:58.297] Voxelization Time (ms): 155
[LOG 06:59:59.721] deleting part Kosmos.RD-58SS
[LOG 06:59:59.754] [SmokeScreen ModelMultiParticlePersistFX] OnDestroy
[LOG 07:00:01.049] EE - OnStart
[ERR 07:00:01.051] EE - did not find animation

[EXC 07:00:01.053] NullReferenceException: Object reference not set to an instance of an object
EngineEnhancement.EngineAnimation.OnStart (StartState state)
Part.ModulesOnStart ()
Part+.MoveNext ()
[LOG 07:00:01.119] Updating Untitled Space Craft
[LOG 07:00:01.253] Voxelization Time (ms): 133
[LOG 07:00:26.075] Launcher here(in write): False
[LOG 07:00:30.494] [SmokeScreen ModelMultiParticlePersistFX] OnDestroy

(some identical lines coalesced by hand)

Share this post


Link to post
Share on other sites
In addition to my previous post just above, here's another problem:

After entering VAB, placing NK-33, deleting it and placing RD-0146, latter starts to show running animation (exhaust plume) right in the VAB. In log I see:

There are multiple independent problems in those log snippets. Did you add the extra configs, or did someone post them (I haven't been watching this thread too closely)?


[LOG 06:21:50.388] [SmokeScreen ModelMultiParticlePersistFX] Cannot find transform thrustTransform

None of cBBp's engines use thrustTransform, so the smoke screen config needs to be fixed. It should be engine_thrust, not thrustTransform.


[EXC 06:23:26.185] NullReferenceException: Object reference not set to an instance of an object
ModuleSurfaceFX.Update ()

I'll wager the same problem here. ModuleSurfaceFX is part of KSP 1.0.x, so someone added it to the engine. It's fragile in the way it's configured (thrustProviderModuleIndex must be the index of the ModuleEnginesFX module, counting from 0 as the 1st MODULE {} entry).


[EXC 06:21:50.426] NullReferenceException: Object reference not set to an instance of an object
EngineEnhancement.GimbalHider.HideMyMenu ()
EngineEnhancement.GimbalHider.OnUpdate ()
Part.ModulesOnUpdate ()
Part.Update ()

This is a bug on my part. Squad changed the gimbal code, and I still have updates I need to do. I made myself a note that GimbalHider was messed up, but I've been busy with RasterPropMonitor for the last month and a half. I'll try to get some time this week to nail this down.


[ERR 07:00:01.051] EE - did not find animation

[EXC 07:00:01.053] NullReferenceException: Object reference not set to an instance of an object
EngineEnhancement.EngineAnimation.OnStart (StartState state)
Part.ModulesOnStart ()
Part+.MoveNext ()

If this is happening on RD-0146, and you have the EE plugin that I posted right after KSP 1.0 dropped, then something must be messed up in the config. I am using the RD-0146 and EngineAnimation on my current craft.

Share this post


Link to post
Share on other sites

Why is the fuel conduit folder so huge? Several megabytes for a stupid little pipe.

Share this post


Link to post
Share on other sites

Well, You can use DDS4KSPcs to scale its textures down if You want it on a diet, but keep in mind that I had to add this to the ModsExceptions.txt:

// KOCMOC URM
KOSMOS\Parts\Engine\Kosmos_RD-0146\diff -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-0440\DIFF -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-275K\diff -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-33NK\diff -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-58SS\DIFF -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-170_Family\DIFF -nn -nr
KOSMOS\Parts\Engine\Kosmos_RD-0146\Emissive -nr
KOSMOS\Parts\Engine\Kosmos_RD-0440\emissive -nr
KOSMOS\Parts\Engine\Kosmos_RD-275K\Emissive -nr
KOSMOS\Parts\Engine\Kosmos_RD-33NK\Emissive -nr
KOSMOS\Parts\Engine\Kosmos_RD-58SS\emissive -nr
KOSMOS\Parts\Engine\Kosmos_RD-170_Family\Emissive -nr
// KOCMOC URM Normal maps:
KOSMOS\Parts\Engine\Kosmos_RD-0146\Nrm_NRM
KOSMOS\Parts\Engine\Kosmos_RD-275K\nrm_NRM
KOSMOS\Parts\Engine\Kosmos_RD-33NK\nrm_NRM
KOSMOS\Parts\Engine\Kosmos_RD-58SS\NRM
KOSMOS\Parts\Engine\Kosmos_RD-0440\NRM
KOSMOS\Parts\Engine\Kosmos_RD-170_Family\NRM

IOW, don't mess with TGA normal maps at all, and do not resize engine textures or they will be all messed up. YMMV.

- - - Updated - - -

Did you add the extra configs, or did someone post them (I haven't been watching this thread too closely)?
(shrugs)No I don't have, neither I've read all the posts...
None of cBBp's engines use thrustTransform, so the smoke screen config needs to be fixed. It should be engine_thrust, not thrustTransform.
Yeah, seems like it's here in MP_Nazari\launch_hotrockets.cfg:

@PART
[*]:HAS[@MODULE[ModuleEnginesFX]:HAS[@PROPELLANT[Oxidizer]]]:AFTER[HotRockets] {
@EFFECTS {
@powersmoke {
MODEL_MULTI_PARTICLE_PERSIST {
[snip]
transformName = thrustTransform

Share this post


Link to post
Share on other sites
that is an easy fix. umm can you tell me the name of the file that is missing?

Hmm. Maybe this one?

[ERR 21:47:53.207] PartCompiler: Cannot clone model 'KOSMOS/Parts/Engine/Kosmos_RD-0440/model_RD-191V_Nozzle' as model does not exist

- - - Updated - - -

Also I'd like to know what the hell ;-) model_N-1G_Engine_Hell.mu is doing inside KOSMOS\Parts\Engine\Kosmos_RD-33NK folder, and what this model is. Noone seems to reference it AFAIS.

- - - Updated - - -

ModuleSurfaceFX is part of KSP 1.0.x, so someone added it to the engine. It's fragile in the way it's configured (thrustProviderModuleIndex must be the index of the ModuleEnginesFX module, counting from 0 as the 1st MODULE {} entry).
Turned out it was unwanted interaction from AIES_Aerospace\SmokeFX.cfg which was posted in AIES thread by someone. It has this:
@PART
[*]:HAS[@MODULE[ModuleEnginesFX],!MODULE[ModuleSurfaceFX]]:Final {
MODULE {
name = ModuleSurfaceFX
thrustProviderModuleIndex = 0
fxMax = 0.5
maxDistance = 50
falloff = 1.7
thrustTransformName = thrustTransform
}
}

and it surely doesn't look good :-D I'll fix it somehow I think so it will work there and here too. Maybe.

Share this post


Link to post
Share on other sites

More lines:

[ERR 23:28:29.539] EffectList: Cannot find an effect type with node name of 'engage'
[ERR 23:28:29.539] EffectList: Cannot find an effect type with node name of 'flameout'

are thrown by:


[LOG 23:28:29.504] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-172/RD-172'
[LOG 23:28:29.737] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-175/RD-175'
[LOG 23:28:30.044] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-178/RD-178'
[LOG 23:28:30.230] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-180/RD-180'
[LOG 23:28:30.415] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-183/RD-183'
[LOG 23:28:30.578] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-191/RD-191'
[LOG 23:28:30.713] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-191V/RD-191V'
[LOG 23:28:30.863] PartLoader: Compiling Part 'KOSMOS/Parts/Engine/Kosmos_RD-170_Family/part_RD-193/RD-193'

What module generates them?

Share this post


Link to post
Share on other sites
Turned out it was unwanted interaction from AIES_Aerospace\SmokeFX.cfg which was posted in AIES thread by someone. It has this:
@PART
[*]:HAS[@MODULE[ModuleEnginesFX],!MODULE[ModuleSurfaceFX]]:Final {
MODULE {
name = ModuleSurfaceFX
thrustProviderModuleIndex = 0
fxMax = 0.5
maxDistance = 50
falloff = 1.7
thrustTransformName = thrustTransform
}
}

and it surely doesn't look good :-D I'll fix it somehow I think so it will work there and here too. Maybe.

Yeah, that's not a good change, since it applies that module to EVERY engine that doesn't have ModuleSurfaceFX. With a couple of tweaks, a copy of that could be used work with only KOSMOS engines.

Share this post


Link to post
Share on other sites

I have no idea what you guys are doing here, but I have a feeling that you're doing a cool thing.

Share this post


Link to post
Share on other sites
I have no idea what you guys are doing here, but I have a feeling that you're doing a cool thing.

If I recall correctly they are fixing the RD-170 family, since it's the only thing left to fix I think, I fixed the SSPP a while ago.

Share this post


Link to post
Share on other sites
If I recall correctly they are fixing the RD-170 family, since it's the only thing left to fix I think, I fixed the SSPP a while ago.

Oh, the RD-170 are the engines, right?

So you're telling me that the space station parts work? Oh goodie goodie goodie.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.