pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

Anyone else keep getting 403 errors for some mods?.

Hey, this is a known issue of GitHub throttling requests from specific IPs. There is sadly not much we can do, except offer you to use one of our official mirrors:


[URL]http://amsterdam.ksp-ckan.org/master.zip[/URL]
[URL]http://nurnberg.ksp-ckan.org/master.zip[/URL]

You can change your repo in the GUI's Settings dialog.

Share this post


Link to post
Share on other sites
Um... This is a support forum right?

Hey, Speedbird. Our contributors are from everywhere around the world, so we can't always reply immediately. You have a much better chance of getting prompt support if you post a well-detailed issue on our issues list.

Edited by nlight

Share this post


Link to post
Share on other sites

Is this, like, a mod manager? Or do you need a mod manager next to this?

Share this post


Link to post
Share on other sites
Is this, like, a mod manager? Or do you need a mod manager next to this?

It's your lucky day, you get me again :)

CKAN is the real deal, it's a complete, self- contained, cross- platform mod manager for KSP.

Share this post


Link to post
Share on other sites

You sound so much like a salesman :P

I'm going to give this a try... I'm a 70+ mod person myself, and with 0.90 had to get two different installs working (one for myself, one for a DMP server)... it's been a huge pain. I hope CKAN is what I'm looking for to alleviate that.

Share this post


Link to post
Share on other sites
You sound so much like a salesman :P

I'm going to give this a try... I'm a 70+ mod person myself, and with 0.90 had to get two different installs working (one for myself, one for a DMP server)... it's been a huge pain. I hope CKAN is what I'm looking for to alleviate that.

Conveniently, CKAN can manage multiple KSP installs with different mods or even different KSP versions in each one.

And if you want mods that aren't in the main repo, submitting them to the repo or even hosting your own repo is pretty easy.

I'm not quite as mod-heavy as you are but I'm using 40-odd mods these days and CKAN has made life a lot easier.

Share this post


Link to post
Share on other sites
It's your lucky day, you get me again :)

CKAN is the real deal, it's a complete, self- contained, cross- platform mod manager for KSP.

You keep bringing me good news, I am not complaining :)

Share this post


Link to post
Share on other sites

Hey everyone! I'm finally fine again :)

Hey I have a problem, I have a lot of supported mods including KWRocketry and interstellar, yet they don't show up on the installed mod list! This is on the latest version. PLEASE HELP!

EDIT: Also, a lot of mods which CKAN claims to be up-to-date are stated as incompatible with 0.25...

Hey Speedbird! Sorry for the slow replies, these are frantic days for us since it's obviously the first time we go through an update of KSP :)

So, is the issue still happening? Could you give us more details about ckan's version?

This might be a bit of a dumb question, but how do I actually *install* the mods? The "apply all changes" button is gone from the experimental version, replaced with a "go to changes" - and all that does is list the changes that are scheduled to be made.

I guess you have already figured it out by now, but there should be an "apply" button on the lower right corner after you press the "Go to changes" button :)

Is this, like, a mod manager? Or do you need a mod manager next to this?

I'd like to take this chance to tell everyone that we are not only open to contributions, but also to competition!

We'd love to see new applications that make use of our metadata, or our code: the metadata is in the public domain, and our code is under the MIT license. Amaze us! :)

Share this post


Link to post
Share on other sites

I've tried all three repository's for the "master.zip" thing , and I'm getting "Failed to connect to repository". It was working 5 min ago... Any idea's?

Share this post


Link to post
Share on other sites

I just want to say thank you, CKAN makes things so much simpler!

One little bug report: There seems to be a crash issue updating mods in '1.3.6-0-g05e7c52'... possibly while just installing new mods at the same time. (I haven't had enough mods update to properly test.) What happened: I selected a mod update and a mod to install. It downloaded and installed the update fine, but then downloaded the updated mod again and crashed.

Share this post


Link to post
Share on other sites
I've tried all three repository's for the "master.zip" thing , and I'm getting "Failed to connect to repository". It was working 5 min ago... Any idea's?

Hey rottielover, that means that a generic exception has occurred during the update. Try again in a while - in the meantime, I'll open an issue to see that error message improved :)

Share this post


Link to post
Share on other sites

Bug report:

Summary - Launching KSP v0.90 via CKAN's "Launch KSP" function results in ridiculous amounts of RAM usage even though no mods are actually installed. Launching via the usual KSP.exe does not do this.

Versions - KSP version 0.90.705 x86 ~ CKAN version 1.3.6 ~ System info

Details - Launching KSP via CKAN (no mods installed) results in memory limit being reached before it even finishes loading (image). Launching KSP via the stock launcher .exe (no mods installed) is successful and uses just over 2gb of RAM (image)

How to reproduce -

1) Install KSP v0.90.705

2) Install CKAN v1.3.6

3) Do not install any mods

4) Run KSP via stock launcher app or .exe

5) Note RAM usage

6) Close KSP

7) Launch CKAN

8) Click "Launch KSP"

9) Observe RAM usage throughout loading process. It should jump up to almost 3gb before any parts are loaded.

Share this post


Link to post
Share on other sites
...

Thank you for your flawless report! :)

I turned it into a github issue so it can be tracked more easily. Thanks!

UPDATE: nlight might already have the solution ready. See his response here, it might be caused by ckan launching KSP with opengl by default.

Edited by Ippo

Share this post


Link to post
Share on other sites

how do I log an issue?

Mod: KAX

Problem: missing a dependency

Normally when you install KAX (kerbal aircraft expansion) you have to install the firespitter plugin, but it also requires the resources.cfg from the firespitter mod. That apparently wasn't flagged in the meta-data, but I don't know how to fix

Edit: Specifically the Firespitter.cfg and it's container folder GameData\Firespitter\Resources

As it stands if you select KAX and let cKan install it you'll get a hang when starting the game when it tries to load the electric prop from the pack

I should expand on this a little further...

If you install the Firespitter Core pack that would be just the DLL, and if you installed the full Firespitter that would obviously come with the required file here.

SO... How do you resolve a dependency like that?

Edited by rottielover

Share this post


Link to post
Share on other sites
....

It worked! Thanks!

Edit: If this is a setting that is to remain in place, maybe throw an explanation or something next to the download instructions?

Edited by Ascension Islander

Share this post


Link to post
Share on other sites
Hey rottielover, that means that a generic exception has occurred during the update. Try again in a while - in the meantime, I'll open an issue to see that error message improved :)

Still having this issue. Is there anything I can do to work around it?

Edit: NM i'm doing a full wipe / reinstall of KSP and I'm getting the stable version of ckan now. I'm wondering if trying to switch between the staple and experimental did this?

Edited by rottielover

Share this post


Link to post
Share on other sites

No kOS? Booh, heretics! :P

Is that something I can fix, or do the mod makers need to do that?

Share this post


Link to post
Share on other sites
No kOS?

We've had kOS metadata for longer than we've had ckan.exe, indeed in our 1,172 commit history, kOS was commit number 17! That pre-dates the v0.01 release of the client. Right now you can install any version from 0.14 through to 0.15.3.0, as they've all been indexed, so if you're running 0.24.2 or 0.25, you're golden.

If you're running 0.90, then our bot hasn't indexed the latest kOS release because it's still marked as a "pre-release", and indeed isn't updated on KerbalStuff either. Since we've currently got our feed set to KerbalStuff, the easiest solution would be to ask erendrake or Dunbaratu nicely to upload the 0.90 release there when they're happy with it, and one of our bots will have it indexed within a matter of hours. (Faster if you hop on IRC and ask nice for us to do a bot-bump.)

~ Paul

Share this post


Link to post
Share on other sites

how do I log an issue?

If it's with the client itself, then here. If it's with a mod we index automatically, then here. Although in your particular case, I've just updated the metadata, so you'll see that fixed shortly after it passes code review. :) Thank you so much for reporting it!

~ Paul

Share this post


Link to post
Share on other sites

i've a sort of a problem:

when open kerbal with ckan i got something graphical glitches like:

-letter replaced with squares

-on built mode the corner is white instead of the normal color

And if i try to get screenshot it won't take screen from kerbal but from the desktop (like kerbal was been minimized)

if install some mods and launch kerbal from ksp.exe or from the launcher i haven't glitch but no parts :-\ (if launched with ckan i get the same glitches as before).

thanks for future help

Share this post


Link to post
Share on other sites
I use Mechjeb and FAR and so I tend to run the latest dev build and also the Optional MechJeb Modules for FAR. I also like ckan and like to set up new builds easily with it.

How easy (or hard) would it be to see if FAR and mechjeb have been selected by the user at the same time and then give the user the option of the dev build and Optional MechJeb Modules for FAR?

Totally agree. Running dev versions of MechJeb is very important. With this 0.90 release they are releasing needed updates every day. I would love to see a way to subscribe to the dev version in ckan.

Share this post


Link to post
Share on other sites

I am working on just that, http://munich.ksp-ckan.org/SCANsat-pre/mirror/ will hold the SCANsat... http://munich.ksp-ckan.org/MechJeb2-pre/mirror/ the MechJeb2 development builds...

A proper announcement will be made when I have the client side done as well ( follow https://github.com/KSP-CKAN/CKAN/pull/563 over at github if you want early notification)

Share this post


Link to post
Share on other sites
I am working on just that, http://munich.ksp-ckan.org/SCANsat-pre/mirror/ will hold the SCANsat... http://munich.ksp-ckan.org/MechJeb2-pre/mirror/ the MechJeb2 development builds...

A proper announcement will be made when I have the client side done as well ( follow https://github.com/KSP-CKAN/CKAN/pull/563 over at github if you want early notification)

That's fantastic. Thank you.

I have another doubt. I installed MechJeb2 with CKAN, and then, updated the .dll to a dev version manually.

After a ckan scan, it says my MechJeb2 is up to date. Wasn't supposed that ckan detects when a user has modified a mod? will it overwrite my changes in an upgrade?

Share this post


Link to post
Share on other sites

Yes, a "ckan upgrade" would overwrite your dll. As for now, CKAN only keeps a list of file names, but not of the contents (or hashes) of each file inside the mod.

But never fear, indexing sarbian's Jenkins server is just around the corner... I need to take vacation from work to finish all that CKAN stuff I have in mind :D

Share this post


Link to post
Share on other sites
i've a sort of a problem:

when open kerbal with ckan i got something graphical glitches like:

-letter replaced with squares

-on built mode the corner is white instead of the normal color

And if i try to get screenshot it won't take screen from kerbal but from the desktop (like kerbal was been minimized)

if install some mods and launch kerbal from ksp.exe or from the launcher i haven't glitch but no parts :-\ (if launched with ckan i get the same glitches as before).

thanks for future help

i've solved that problem; on "settings" the option "KSP command-line" was set -forceopengl.

i've deleted that strings and now it's working.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.