pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

12 minutes ago, blowfish said:

Educated guess at the problem: Windows won't let CKAN download stuff to a location in Program Files.

It's generally not a good idea to mod your steam install anyway (because steam auto-updates can suddenly break mods without warning).  My advice would be to copy the entire "Kerbal Space Program" folder to somewhere outside of Program Files and mod it there.  Some other stuff ends up being messed up from having KSP in Program Files too.

Alternate, bad, ugly solution that will let you use everything where it is but I highly do not recommend:

  Reveal hidden contents

Run CKAN as an administrator every time (i.e. right click -> "run as administrator"

 

I'll keep that in mind, and maybe change the permissions for that download folder - This didn't happen in 1.16, but I did clear out my CKAN directory for a fresh install.

This all said, maybe it would be better to run a permissions check on target directories on CKAN's startup, as to avoid unhandled exceptions?

Share this post


Link to post
Share on other sites

I'm a mac user, and so on the download page it asks me to ' mozroots --import --ask-remove'. Could you explain that? I get the feeling it's something to put in terminal, but I just want to make sure, because I'm probably wrong.

Share this post


Link to post
Share on other sites
5 hours ago, AugustWest said:

After update today, no longer runs in Ubuntu 14.04 64bit.....................................

Oh dear. Is this happening with the command-line as well as for the GUI? We recently discontinued support for Mono 3.2.8, as we were hitting a bunch of bugs in it, but I'm guessing 14.04 still ships with 3.2.8 by default.

You can upgrade mono by using the mono project's ppa , which cut'n'pasting is done with:
 

Spoiler

 

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

sudo apt-get update


 

And then upgrading as per normal.

Having said that, I'd personally love us to keep supporting Ubuntu 14.04 as it is a long term release, so if I get a chance I'll see if I can find what the 3.2.8 bugs were that we are hitting and if we can work around them.

Share this post


Link to post
Share on other sites

Not sure if this has been already discussed, but AVG flagged the latest ckan EXE as malicious.

Normally I'd just make an exception but I'm concerned because the detection signature included a specific name: IDP_ARES_Generic (see this link - and don't worry it's AVG's website)

Can someone confirm that this is NOT an actual virus? kthanx

Share this post


Link to post
Share on other sites
14 minutes ago, Auriga_Nexus said:

Not sure if this has been already discussed, but AVG flagged the latest ckan EXE as malicious.

Normally I'd just make an exception but I'm concerned because the detection signature included a specific name: IDP_ARES_Generic (see this link - and don't worry it's AVG's website)

Can someone confirm that this is NOT an actual virus? kthanx

It's false. Sophos Home detects nothing.

That and AVG seems to be extremely prone to these kinds of errors.

Edited by phoenix_ca

Share this post


Link to post
Share on other sites

Figures, as my version of AVG is the free version since I am a poor peasant who can't afford to pay for antivirus.

Share this post


Link to post
Share on other sites
14 hours ago, gobolinno said:

PS: I DID try to change the version number from 1.1.2 to 1.1.0 in readme.txt Kerbal folder....

but it still doesn't let me. 

Ah, yes. One of the updates in the new version is to start using BuildID.txt instead of Readme.txt as the primary source for KSP version. Rename that file as well as updating Readme and that will work.

Share this post


Link to post
Share on other sites

Hello, i'm having trouble with ubuntu 14.04i tried what pjf and i get this error messege:

Spoiler

System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionRange ---> System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionBound ---> System.NullReferenceException: Object reference not set to an instance of an object
  at System.String.FormatHelper (System.Text.StringBuilder result, IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at System.String.Format (IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at System.String.Format (System.String format, System.Object arg0) [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..ctor (CKAN.Versioning.KspVersion value, Boolean inclusive) [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..ctor () [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  --- End of inner exception stack trace ---
  at CKAN.GrasGameComparator.Compatible (CKAN.Versioning.KspVersion gameVersion, CKAN.CkanModule module) [0x00000] in <filename unknown>:0
  at CKAN.CkanModule.IsCompatibleKSP (CKAN.Versioning.KspVersion version) [0x00000] in <filename unknown>:0
  at CKAN.AvailableModule+<Latest>c__AnonStorey0.<>m__0 (CKAN.Version v) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.First[Version] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.FirstOrDefault[Version] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0
  at CKAN.AvailableModule.Latest (CKAN.Versioning.KspVersion ksp_version, CKAN.RelationshipDescriptor relationship) [0x00000] in <filename unknown>:0
  at CKAN.Registry+<Available>c__AnonStorey0.<>m__0 (CKAN.AvailableModule pair) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[CKAN.AvailableModule,CKAN.CkanModule].MoveNext () [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1E`1[CKAN.CkanModule].MoveNext () [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.ToArray[CkanModule] (IEnumerable`1 source) [0x00000] in <filename unknown>:0
  at CKAN.Registry.Available (CKAN.Versioning.KspVersion ksp_version) [0x00000] in <filename unknown>:0
  at CKAN.Main._UpdateModsList (Boolean repo_updated) [0x00000] in <filename unknown>:0
  at CKAN.Main+<UpdateModsList>c__AnonStorey13.<>m__0 () [0x00000] in <filename unknown>:0
  at CKAN.Util.Invoke[Main] (CKAN.Main obj, System.Action action) [0x00000] in <filename unknown>:0
  at CKAN.Main.UpdateModsList (Boolean repo_updated) [0x00000] in <filename unknown>:0
  at CKAN.Main.CurrentInstanceUpdated () [0x00000] in <filename unknown>:0
  at CKAN.Main.OnLoad (System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00000] in <filename unknown>:0

i will download a previous version but i want to keep updated. Thanks a lot!

Share this post


Link to post
Share on other sites

Seems to work great! I'm a mac user.

 

I just want to point out something quickly, though; the program is in a .exe file, which is incompatible with macs, so the download won't work for them. On the internet, some people advised that I go into terminal and paste 

cd Downloads

mono ckan.exe

Which will open the program, as long as you have monodevelop installed. This worked perfectly. I'd suggest, for mac users to download it easily, to add this into the installation guide.

Share this post


Link to post
Share on other sites
14 hours ago, Arieoreos said:

Seems to work great! I'm a mac user.

I just want to point out something quickly, though; the program is in a .exe file, which is incompatible with macs, so the download won't work for them. On the internet, some people advised that I go into terminal and paste 


cd Downloads
mono ckan.exe

Which will open the program, as long as you have monodevelop installed. This worked perfectly. I'd suggest, for mac users to download it easily, to add this into the installation guide.

We have a whole Installing CKAN on OSX page, linked from the user guide. Not sure what more we can do to make it easy for Mac OSX users.

15 hours ago, Luciano said:

Hello, i'm having trouble with ubuntu 14.04i tried what pjf and i get this error messege:

  Hide contents

System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionRange ---> System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionBound ---> System.NullReferenceException: Object reference not set to an instance of an object

i will download a previous version but i want to keep updated. Thanks a lot!

What version of Mono do you have currently installed?

Share this post


Link to post
Share on other sites
On 6/19/2016 at 1:57 PM, pjf said:

[NetKAN] Redirects to the download file are now resolved when using HTTP $krefs (#1696 by: dbent, reviewed: techman83)

If SpaceDock small CDN nodes were to redirect a download they don't (yet) have to a more complete CDN node, would this work for CKAN? I just made that suggestion in the SpaceDock thread following the frequent 404s lately for the node for my area, but then realised I didn't know if that may even work with CKAN.

 

On 6/19/2016 at 6:20 PM, politas said:

Report it in the Spacedock thread. They'll need to make space on the relevant server.

Another thing that comes to mind: can CKAN (be made to) handle multiple download links? As in, if the mod is made available on both SpaceDock and GitHub (and/or Curseforge, don't hit me), that CKAN entry can list all of those and try them in sequence?

Edited by swjr-swis
link to SpaceDock post

Share this post


Link to post
Share on other sites

Hi, the new version causes me some problems as well. When I try to select any mod (just click the tick-box), it prints this error message:

cVHCOMH.png

Do you know what might cause this?

Thanks,

Michal.don

 

Share this post


Link to post
Share on other sites

Please remove the Malemute Rover from CKAN, as I had no intention of putting that up at this time, it's not my metadata, and what you have there is going to break with the next patch and cause me a hefty pile of support issues.  This mod is manually installed for now.

And in the future, please do not list any of my mods unless the PR is from me - I will explicitly send you metadata if I wish a mod to be on CKAN.

Share this post


Link to post
Share on other sites
1 hour ago, KoolBreeze420 said:

Will manually adding mods that are not located in ckan effect anything?

Well, you will get one more desired mod in the game. If you ask if will that affect ckan then answer is - most probably no, ckan should work properly and if your desired mod become listed on CKAN it wil get "AD" marks instead of checkbox.

Now, for "Most probably" part: you should not have issues unless you overwrite some dependency mods packed with your desired mod. You need to be carefull with that, dependency mod might be already installed trough CKAN.

In case of standalone mod that does not have any dependency except MM, you should not have issues at all.

Share this post


Link to post
Share on other sites
7 hours ago, michal.don said:

Hi, the new version causes me some problems as well. When I try to select any mod (just click the tick-box), it prints this error message:

cVHCOMH.png

Do you know what might cause this?

Thanks,

Michal.don

 

Not without more information. What version of Windows do you have, what version of .Net framework do you have, and the full text of the message details. Can you raise an issue here

Share this post


Link to post
Share on other sites
1 hour ago, politas said:

It's four hours old. Give us a chance to process it.

Hey politas,

Sorry, that wasn't my intention...

I thought that when it has this CKAN-Icon on it, that it has already been on CKAN...

Share this post


Link to post
Share on other sites
3 hours ago, N3N said:

Hey politas,

Sorry, that wasn't my intention...

I thought that when it has this CKAN-Icon on it, that it has already been on CKAN...

No. it doesn't work that way (though it may in the future).

Share this post


Link to post
Share on other sites

I don't see it on here, but is anyone else seeing the latest CKAN reporting the wrong version of KSP? Even though it is residing in a 1.1.2 directory and has always reported the 1.1.2 version, not it reports KSP version as 1.05 and all mods prior to 1.1.2 show as compatible.

I didn't see anything in the notes/update about this so curious if there is a file that needs to be deleted (cache was already cleared) that might reset CKAN to only looking at the actual KSP version being used?

 

Thanks!

 

Update: Also just did a clean install of CKAN and it does the same thing as above, for some reason identified KSP as 1.05.

Edited by jmbailey2000

Share this post


Link to post
Share on other sites

@jmbailey2000, are you sure you don't have a 1.05 installation somewhere that CKAN is pointing to?  Check under the File > Select KSP Install... to confirm.  My CKAN correctly reports 1.1.2.1260 in the title bar but I have only one KSP installation for now.

Share this post


Link to post
Share on other sites

Hello, i have this weird issue, i installed ckan couple of days ago, yesterday i downloaded about 56 mods,  then 1.1.3 came, and now i have this issue, when i clicked apply changes it uninstalled a bunch of mods (b9 and interstellar) and now i cant reinstall then as there is no box for install, just a - where it should be .  even though those 2 mods are still compatible with 1.1.3 .  is it issue with my ckan? or am i missing something?

 

edit: seems like only incompatible mods do not show the box for install, even though several mods are still compatible as this 1.1.3 is purely bug fixes :c . anyway to allow ckan to download and install the incompatible mods?

Edited by Mytrenet
extra info

Share this post


Link to post
Share on other sites

I'm having a crash on launch problem with CKAN since I updated it to 1.18.0

Using Kubuntu 14.04LTS, I get the following when I try to run CKAN from the command line:

firepaw@catslair-K30BF-M32BF:~$ bin/ckan
System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionRange ---> System.TypeInitializationException: An exception was thrown by the type initializer for CKAN.Versioning.KspVersionBound ---> System.NullReferenceException: Object reference not set to an instance of an object
  at System.String.FormatHelper (System.Text.StringBuilder result, IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at System.String.Format (IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at System.String.Format (System.String format, System.Object arg0) [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..ctor (CKAN.Versioning.KspVersion value, Boolean inclusive) [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..ctor () [0x00000] in <filename unknown>:0
  at CKAN.Versioning.KspVersionBound..cctor () [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  --- End of inner exception stack trace ---
  at CKAN.GrasGameComparator.Compatible (CKAN.Versioning.KspVersion gameVersion, CKAN.CkanModule module) [0x00000] in <filename unknown>:0
  at CKAN.CkanModule.IsCompatibleKSP (CKAN.Versioning.KspVersion version) [0x00000] in <filename unknown>:0
  at CKAN.AvailableModule+<Latest>c__AnonStorey0.<>m__0 (CKAN.Version v) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.First[Version] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.FirstOrDefault[Version] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0
  at CKAN.AvailableModule.Latest (CKAN.Versioning.KspVersion ksp_version, CKAN.RelationshipDescriptor relationship) [0x00000] in <filename unknown>:0
  at CKAN.Registry+<Available>c__AnonStorey0.<>m__0 (CKAN.AvailableModule pair) [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[CKAN.AvailableModule,CKAN.CkanModule].MoveNext () [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1E`1[CKAN.CkanModule].MoveNext () [0x00000] in <filename unknown>:0
  at System.Linq.Enumerable.ToArray[CkanModule] (IEnumerable`1 source) [0x00000] in <filename unknown>:0
  at CKAN.Registry.Available (CKAN.Versioning.KspVersion ksp_version) [0x00000] in <filename unknown>:0
  at CKAN.Main._UpdateModsList (Boolean repo_updated) [0x00000] in <filename unknown>:0
  at CKAN.Main+<UpdateModsList>c__AnonStorey13.<>m__0 () [0x00000] in <filename unknown>:0
  at CKAN.Util.Invoke[Main] (CKAN.Main obj, System.Action action) [0x00000] in <filename unknown>:0
  at CKAN.Main.UpdateModsList (Boolean repo_updated) [0x00000] in <filename unknown>:0
  at CKAN.Main.CurrentInstanceUpdated () [0x00000] in <filename unknown>:0
  at CKAN.Main.OnLoad (System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00000] in <filename unknown>:0


Rolling back to 1.16.1 fixes the problem, so it isn't simply the KSP update causing it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.