pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

Using ckan 1.5.6 on linux (ubuntu), im trying to install a plugin. I downloaded the plugin (ive tried 2 to make sure it not the plugins fault), and installed via the menus in ckan. I get the following error on restarting ckan:


5830 [1] WARN CKAN.PluginController (null) - Failed to load assembly "\home\dale\.local\share\Steam\steamapps\common\Kerbal Space Program\CKAN\Plugins\KerbalStuffPlugin.dll" - Could not load file or assembly '\home\dale\.local\share\Steam\steamapps\common\Kerbal Space Program\CKAN\Plugins\KerbalStuffPlugin.dll' or one of its dependencies. The system cannot find the file specified.

Anybody have a quick-fix idea? Ive checked permissions on all the folders/files and they seem to be fine.

Share this post


Link to post
Share on other sites
The FAQ page seems to be empty. :P

FAQ page? You mean the wiki? If so did you notice the "moved here" link?

If not, I'll shut up and be thankful for a direct link to the page you mentioned so we can do something about it :P

Share this post


Link to post
Share on other sites

I'm also having issues installing the KerbalStuff and PartManager plugins on Ubuntu 14.10. I even tried using one of the nightly builds of CKAN to no avail. I'm not getting any errors and the *.dll is added to the CKAN/plugins folder, but neither plugin shows up in the activation interface at all.

Share this post


Link to post
Share on other sites

I'm getting an error saying to try ckan update...

How do I do this? :)

edit: nevermind... RTFM'd

edit: entering ckan.exe update in terminal opened in the CKAN (KSP) dir doesn't seem to work...

I'm a dope. the CLI is in CKAN not the linux terminal... is there a way to update CKAN from the GUI? I've tried the commandline in settings, that didn't do anything... what am I missing?

Edited by KerBlam

Share this post


Link to post
Share on other sites
FAQ page? You mean the wiki? If so did you notice the "moved here" link?

If not, I'll shut up and be thankful for a direct link to the page you mentioned so we can do something about it :P

Yes, I did. But the first post still links to the old wiki is what I'm saying.

Share this post


Link to post
Share on other sites
Yes, I did. But the first post still links to the old wiki is what I'm saying.

Aaaah, o.k., now I get you. I'll ping @pjf on this as he is the thread owner. Thank you for the notification.

- - - Updated - - -

is there a way to update CKAN from the GUI? I've tried the commandline in settings, that didn't do anything... what am I missing?

Sorry, no way to do that yet. We have an issue open to think about a way to do this, but no one found time to look into that yet.

Share this post


Link to post
Share on other sites

To update CKAN itself you will need separate exe that will only download latest CKAN, extract files and install latest version of CKAN.

So, from CKAN gui run the check and if there is update for CKAN available run that downloader exe and exit CKAN.

You need to exit CKAN because, otherwise OS will not alow it to delete/overwrite old exe on install.

Checking local current version and version on internet should be simple enough. Hope that this helps.

Share this post


Link to post
Share on other sites

Hi,

running CKAN 1.5.6-0-g

windows 7

KSP 32 bit

I tried doing an update of two mods at the same time I wanted to install a new mod.

CKAN had some sort of error. I don't think it actually did the updates, but now when I run it again, it says there are no updates available, even though I did do a refresh.

How can I force CKAN to check to see what version are actually installed?

Share this post


Link to post
Share on other sites

Request/Suggestion:

It may not be possible with all mods, but adding the mod change logs to the GUI would be useful for checking what exactly an update is going to do before you install it.

Share this post


Link to post
Share on other sites
To update CKAN itself you will need separate exe that will only download latest CKAN, extract files and install latest version of CKAN.

So, from CKAN gui run the check and if there is update for CKAN available run that downloader exe and exit CKAN.

You need to exit CKAN because, otherwise OS will not alow it to delete/overwrite old exe on install.

Checking local current version and version on internet should be simple enough. Hope that this helps.

I'm not sure what check you mean from the GUI, I see nothing. There's no notifications re: a CKAN update and I'm already several versions behind. EDIT: Never mind... I downloaded the latest version, and ran the .exe... I'm a dope. :D

On another note, the last two mod updates have been borked on me. Environmental Visual Enhancements (EVE) 7-4... just says removing... done. yet does nothing and the update still comes up as uninstalled...

DSuPsQI.png

edit: EVE is still doing nothing. Something's up there.

Edited by KerBlam

Share this post


Link to post
Share on other sites

EVE needed reconfiguring its metadata inside CKAN, also the same with Active Texture Management.

your best bet is to remove EVE (via CKAN) from your KSP installation and have it re-installed. Afterwards, updates should work flawlessly (o.k. make that "less flawed" :P )

Share this post


Link to post
Share on other sites

I haven't been playing KSP and were quite inactive in the forum for several months but now I'm slowly coming back to KSP again. Seeing something amazing like this happen is just making it even more evident that I really should start KSP again. I just wanted to say how awesome this is and give my thanks to everyone who contributed to it. Now not only KSP by also the modding scene will be beta than ever xD and also left some +rep at the OP^^

Share this post


Link to post
Share on other sites

When I try to uninstall EVE using CKAN, it does the same nothing it does when I update... The changes screen stays blank, with the progress bar scrolling across at the top, it says done at the bottom... hangs like that (I left it for a good few minutes to be sure), and if I hit cancel EVE is still installed.

edit: I backed up the EVE folder and tried removing it manually, restarted CKAN. It still tells me that it's installed.

woCu83V.png

Edited by KerBlam

Share this post


Link to post
Share on other sites

Hey guys, I seem to have encountered a problem with CKAN. I keep getting failed to connect to repository errors when I try to refresh it. After about a half hour of digging, I checked git-hub. The default git-hub repo CKAN-meta that the CKAN.exe looks for the master.zip doesn't contain an archive folder anymore. Maybe I'm missing something, software is not my forte, I deal with firmware and hardware so take that with a grain of salt, but from what I'm seeing, the master zip no longer exists on git-hub.

Share this post


Link to post
Share on other sites
Hey guys, I seem to have encountered a problem with CKAN. I keep getting failed to connect to repository errors when I try to refresh it. After about a half hour of digging, I checked git-hub. The default git-hub repo CKAN-meta that the CKAN.exe looks for the master.zip doesn't contain an archive folder anymore. Maybe I'm missing something, software is not my forte, I deal with firmware and hardware so take that with a grain of salt, but from what I'm seeing, the master zip no longer exists on git-hub.

Extremely unlikely :)

In fact, I fetched the master.zip just right now...

Share this post


Link to post
Share on other sites

Hmmm, wonder if the folder is hidden then. Still the symptom remains that my CKAN.exe can't access the master.zip. Any ideas why that might be?

Share this post


Link to post
Share on other sites
When I try to uninstall EVE using CKAN, it does the same nothing it does when I update... The changes screen stays blank, with the progress bar scrolling across at the top, it says done at the bottom... hangs like that (I left it for a good few minutes to be sure), and if I hit cancel EVE is still installed.

edit: I backed up the EVE folder and tried removing it manually, restarted CKAN. It still tells me that it's installed.

I'm having this exact same issue. I had issues updating EVE, so I tried to uninstall it. When I go to uninstall it, CKAN throws a Kraken error saying that there is no such mod installed. I've then gone back into the command line client and removed it via the command line (as I had to do with another mod and re-install earlier), but even once I've "removed" it via the command line, it still shows up on "CKAN list" in the command line as well as in the GUI. Trying to uninstall again from the GUI gives me this error:

CKAN.ModNotInstalledKraken: Module EnvironmentalVisualEnhancements is not installed!

at CKAN.ModuleInstaller.UninstallList(IEnumerable`1 mods)

at CKAN.Main.InstallMods(Object sender, DoWorkEventArgs e)

at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

ckan

Assembly Version: 0.0.0.0

Win32 Version: 0.0.0.0

CodeBase: file:///F:/Program%20Files%20(x86)/Steam/steamapps/common/Kerbal%20Space%20Program/ckan.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

Accessibility

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

Microsoft.GeneratedCode

Assembly Version: 1.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Transactions

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll

----------------------------------------

System.Numerics

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll

----------------------------------------

System.ComponentModel.DataAnnotations

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll

----------------------------------------

System.Runtime.Serialization

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll

----------------------------------------

System.Xml.Linq

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll

----------------------------------------

System.Data

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

System.EnterpriseServices

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Update: I re-tried removing it from the Command Line, and it now disappears from the Command Line client, but still shows as being installed in the GUI version.

Edited by Ignath
Update

Share this post


Link to post
Share on other sites

try "ckan scan" on the command line. Newer clients run the "scan" parts automatically on each update.

Share this post


Link to post
Share on other sites
try "ckan scan" on the command line. Newer clients run the "scan" parts automatically on each update.

The command line runs just fine and I can remove and install via it...the problem is that the GUI is out of synch w/the command line now...it continues to show I've installed EVE when I've uninstalled it from the Command Line and it will not uninstall or update from the GUI at all now w/out throwing the kraken error. I can use ckan scan from the command line, but it has no effect on the GUI that I see.

The GUI Error:

CKAN.ModuleNotFoundKraken: Can't upgrade EnvironmentalVisualEnhancements, it is not installed

at CKAN.ModuleInstaller.Upgrade(IEnumerable`1 modules, NetAsyncDownloader netAsyncDownloader)

at CKAN.Main.InstallMods(Object sender, DoWorkEventArgs e)

at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

ckan

Assembly Version: 0.0.0.0

Win32 Version: 0.0.0.0

CodeBase: file:///F:/Program%20Files%20(x86)/Steam/steamapps/common/Kerbal%20Space%20Program/ckan.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

Accessibility

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

----------------------------------------

Microsoft.GeneratedCode

Assembly Version: 1.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

System.Transactions

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll

----------------------------------------

System.Numerics

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll

----------------------------------------

System.ComponentModel.DataAnnotations

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll

----------------------------------------

System.Runtime.Serialization

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll

----------------------------------------

System.Xml.Linq

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll

----------------------------------------

System.Data

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

System.EnterpriseServices

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Is there some sort of metadata file or config that tells the GUI what is installed and what isn't? Any way to manually modify it or anything?

Share this post


Link to post
Share on other sites

Update on my problem: The problem also exists trying to use the CLI, and ckan.exe spits the following error out before crashing after i try ckan.exe update

Unhandled Exception: System.Net.WebException: Unable to connect to the remote se

rver ---> System.Net.Sockets.SocketException: An attempt was made to access a so

cket in a way forbidden by its access permissions 192.30.252.128:443

at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddre

ss socketAddress)

at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Sock

et s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state,

IAsyncResult asyncResult, Exception& exception)

--- End of inner exception stack trace ---

at System.Net.WebClient.DownloadFile(Uri address, String fileName)

at CKAN.Net.Download(String url, String filename, IUser user)

at CKAN.Net.Download(Uri url, String filename, IUser user)

at CKAN.Repo.UpdateRegistry(Uri repo, Registry registry, KSP ksp, IUser user,

Boolean clear)

at CKAN.Repo.Update(RegistryManager registry_manager, KSP ksp, IUser user, Bo

olean clear, Uri repo)

at CKAN.CmdLine.MainClass.Update(UpdateOptions options, RegistryManager regis

try_manager, KSP current_instance, IUser user)

at CKAN.CmdLine.MainClass.Main(String[] args)

Apparently I can't spoiler code, lol.

Edited by Lightfeather

Share this post


Link to post
Share on other sites
The error you're getting is because CKAN still registers the old ATM entry installed - just removing the folder isn't enough. I also uninstalled the mod via CKAN. That was a mildly annoying exercise because nothing I did got it to list in the GUI. From memory, running `ckan list` on the command line did list the currently-installed ATM mod though, and I used `ckan remove` on the commandline to remove it. Installation of the new mod went find after that.

Ran into this as well: thanks for the fix!

Share this post


Link to post
Share on other sites

THIS IS AWESOME :sticktongue:

Wait, no linux version :huh:

Just kidding, but will try it eventually.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.