pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

I would love to have a native OSX build of it. Don't use it just because of that. Mac is not the place for .exe. (i know i can run it with mono, but is not the right way to do it)

;)

I renamed ckan.exe to ckan and have it in my .local/bin on Linux, doesn't actually cause any pain...

Share this post


Link to post
Share on other sites
I also have this issue. I have narrowed it down and if you delete GUIConfig.xml from the CKAN folder then it will work. You will have to select whether to check for updates again but you will not have to reinstall all your mods.

Using windows 7 ultimate

You don't even have to do that, you just have to change this in \Kerbal Space Program\CKAN\GUIConfig.xml

<WindowLoc>

<X>0</X>

<Y>0</Y>

</WindowLoc>

When CKAN malfunctions the x and y values will be at -32000, looking like

<WindowLoc>

<X>-32000</X>

<Y>-32000</Y>

</WindowLoc>

Put them back to zero, and the window will now be able to display on screen.

This fix is from the github discussion here, https://github.com/KSP-CKAN/CKAN/issues/794

Share this post


Link to post
Share on other sites
Do you avoid any java software too? ;)

Not the same Ippo and Autochton. You have Mac?

Java is not emulated, is like a script and run native. (And by the way, even java has it's own secure problems, and always they launch a new version, but the holes keep coming. OSX block it from time to time, to protect the os integrity.

This one (EXE) is emulated via mono, or wine. Is like open an windows instance inside OSX. Is heavier, and not clean way to run a program in OSX.

Would be perfect to have a recompilation under mono, for OSX. That is the natural way to do it.

But ok if not. I just won't use it like other Mac users.

Is not a problem.

Cheers.

Edited by Climberfx

Share this post


Link to post
Share on other sites
Is like open an windows instance inside OSX. Is heavier, and not clean way to run a program in OSX.

Will never run Mac OS willingly, but you're right on with that observation.

Frankensteining programs to run in non native environments is never worth doing, except to merely prove the possibility.

It's like using separatrons to launch payloads

Share this post


Link to post
Share on other sites

Actually, all .NET languages run exactly like java. They are compiled to a portable low-level language and executed by a virtual machine. Mono just provides an alternative implementation of the.NET virtual machine. Even on windows it's not a native executable, exactly like java (that's why the same file can be run on all 3 systems).

See here: http://it.m.wikipedia.org/wiki/Common_Language_Runtime

Share this post


Link to post
Share on other sites
Actually, all .NET languages run exactly like java. They are compiled to a portable low-level language and executed by a virtual machine. Mono just provides an alternative implementation of the.NET virtual machine. Even on windows it's not a native executable, exactly like java (that's why the same file can be run on all 3 systems).

See here: http://it.m.wikipedia.org/wiki/Common_Language_Runtime

And this is precisely why I could change ckan.exe into a Linux executable by two commands:


mv Downloads/ckan.exe .local/bin/ckan
chmod a+x .local/bin/ckan

And done, I now had a ckan executable for Linux. Mac will do exactly the same.

Share this post


Link to post
Share on other sites

When I try to run it with Mono, the program closes after selecting KSP install path.

Terminal says:

jeb@jebtop:~$ mono ckan.exe

23660 [1] ERROR CKAN.ModuleInstaller (null) - WebException while accessing https://api.github.com/repos/KSP-CKAN/CKAN/releases/latest: System.Net.WebException: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. Error code: 0xffffffff800b010a

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.RemoteValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.ProcessAsTls1 () [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Process () [0x00000] in <filename unknown>:0

at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Process ()

at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHandshakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0

at System.Net.WebClient.GetWebResponse (System.Net.WebRequest request) [0x00000] in <filename unknown>:0

at System.Net.WebClient.ReadAll (System.Net.WebRequest request, System.Object userToken) [0x00000] in <filename unknown>:0

at System.Net.WebClient.DownloadDataCore (System.Uri address, System.Object userToken) [0x00000] in <filename unknown>:0

System.Net.WebException: Error getting response stream (Write: The authentication or decryption has failed.): SendFailure ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. Error code: 0xffffffff800b010a

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.RemoteValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertificate.ProcessAsTls1 () [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Process () [0x00000] in <filename unknown>:0

at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Process ()

at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHandshakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in <filename unknown>:0

at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

--- End of inner exception stack trace ---

at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0

at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0

at System.Net.WebClient.GetWebResponse (System.Net.WebRequest request) [0x00000] in <filename unknown>:0

at System.Net.WebClient.ReadAll (System.Net.WebRequest request, System.Object userToken) [0x00000] in <filename unknown>:0

at System.Net.WebClient.DownloadDataCore (System.Uri address, System.Object userToken) [0x00000] in <filename unknown>:0

Edited by Shurikeeen

Share this post


Link to post
Share on other sites
Not the same Ippo and Autochton. You have Mac?

Java is not emulated, is like a script and run native. (And by the way, even java has it's own secure problems, and always they launch a new version, but the holes keep coming. OSX block it from time to time, to protect the os integrity.

This one (EXE) is emulated via mono, or wine. Is like open an windows instance inside OSX. Is heavier, and not clean way to run a program in OSX.

Would be perfect to have a recompilation under mono, for OSX. That is the natural way to do it.

But ok if not. I just won't use it like other Mac users.

Is not a problem.

Cheers.

You are aware that KSP itself is a .NET program running under Mono?:sticktongue: The Unity engine itself uses .NET...

Share this post


Link to post
Share on other sites

Knowing all that is true, KSP appears on Mac, ass an .app folder and runs flawlessly, without the need of any command prompt or second way or second install of anything. Like it was an native one.

The Unity compilers, that make that for al sort of platforms, do that.

Why this one is not the same way so?

;)

p.s.: I believe is because this one was done on Visual Basic, and that program is for Windows. But to use it on Mac, if you go to download page for this one, you see this:

"Linux/Mac: Hotfix to allow installation of mods form KerbalStuff using new SSL ciphers. (KSP-CKAN/CKAN-support#107)"

And then you go there is and not clear what to do. And when you put the .exe on Mac system, it won't run directly, and even doing the Linux command that Autochton show above, it won't work. (and i have Unity and Monodevelop installed here, running, and Wine too, besides the fact i rate to use Wine).

So, is not just do this and do that. Is not the same as KSP executable, besides the fact it too use .NET code.

Edited by Climberfx

Share this post


Link to post
Share on other sites
things

The difference is that KSP (afaik) ships a native executable for every platform. The native executable is basically little more than a front-end to the underlying .NET code. CKAN instead ships directly (and only) the .NET executable.

OSX support is very lacking for the simple reason that we have no developer on OSX: if you could help us improve support for OSX, that would be great!

P.S: CKAN is not written in C#, not Visual Basic. Both are programming languages (not programs) that can be used on most platforms (including linux, where most of CKAN's development took and still takes place).

Share this post


Link to post
Share on other sites

I can. I'm not a programer myself, i do more visual parts, like my work, motion design and 3d. But i'm an old TI graduated.

But i'm studying myself C# with Tamarin studio (mono), and Unity 3D, and already did some test compilations...

What is the language it use? I may find a software OSX compatible and do some tests.

How can i help you?

Edited by Climberfx

Share this post


Link to post
Share on other sites

It looks like CKAN repository has some serious update lag. For example, Ship Manifest has been updated 16 hours ago, according to it's gihub. When I launch KSP, AVC-mod alerts me about outdated mod. I've tried update both from console and GUI, but CKAN still haven't noticed an update.

Share this post


Link to post
Share on other sites
[...]

How can i help you?

Well, it would be great if you could point us to what works and what doesn't on OSX, exactly. I understand your experience hasn't been that great: we'd like to know precisely why to see if we can do stuff about it. While you are at it, if you could find a little time to review the wiki page regarding OSX installation, that would be fantastic :)

As for "real" development, I'm really not sure what we are missing to be a "proper" OSX app, since to be honest I never used a mac for more than 5 minutes... :)

Share this post


Link to post
Share on other sites

So, first of all, a huge thank you to everyone who's supported me on patreon!

Time for me to catch up with as many questions as I can!

Knowing all that is true, KSP appears on Mac, as an .app folder and runs flawlessly, without the need of any command prompt or second way or second install of anything. Like it was an native one.

Why this one is not the same way [for the CKAN]?

The CKAN is a free and open source project that's run entirely by volunteers, but very few of the most active ones own Macs. I would *love* to see a more friendly implementation, and while I'm not at all familiar with what's required to make an `.app`, I'd absolutely appreciate any guidance you might have. I'd also love to see the CKAN installable via homebrew, which can ensure we've got all the dependencies required, too.

It looks like CKAN repository has some serious update lag. For example, Ship Manifest has been updated 16 hours ago, according to it's github. When I launch KSP, AVC-mod alerts me about outdated mod. I've tried update both from console and GUI, but CKAN still haven't noticed an update.

Gosh dang it. We're in the process of shifting infrastructure now that we have sponsorship from AWS, but I'm not 100% sure of where the indexing bot is at. I've shot nlight an email, as making sure my head is wrapped around the current state of play is pretty important for my coding sprint this weekend.

When I try to run it with Mono, the program closes after selecting KSP install path.

The resulting error from this looks like an SSL unhappiness, which is the big thing I'm working on fixing this weekend. Make sure you've got the latest client (1.6.6 at time of writing) and either apt-get install libcurl4-openssl-dev or yum install libcurl-devel as appropriate for your operating system. I know Ippo has made some mileage towards Debian packaging, but it seems like we're at the stage that we'd do well to get the CKAN incorporated into a few of the major Linux distros out there, which I hope shouldn't be too hard given how many folks play under Linux.

All the very best, and keep being amazing!

~ Paul

Share this post


Link to post
Share on other sites
Well, it would be great if you could point us to what works and what doesn't on OSX, exactly. I understand your experience hasn't been that great: we'd like to know precisely why to see if we can do stuff about it. While you are at it, if you could find a little time to review the wiki page regarding OSX installation, that would be fantastic :)

As for "real" development, I'm really not sure what we are missing to be a "proper" OSX app, since to be honest I never used a mac for more than 5 minutes... :)

Ok Man, count on me. This week i'm on a freelancer here, so next week i put my head in, on Monday. (You can remember me if i lost mind :P)

Sorry for the rush words, i do not express my self as kindly as i would like.

...The CKAN is a free and open source project that's run entirely by volunteers, but very few of the most active ones own Macs. I would *love* to see a more friendly implementation, and while I'm not at all familiar with what's required to make an `.app`, I'd absolutely appreciate any guidance you might have. I'd also love to see the CKAN installable via homebrew, which can ensure we've got all the dependencies required, too...

Will check for that too.

;P

Edited by Climberfx

Share this post


Link to post
Share on other sites

Sorry for the rush words, i do not express my self as kindly as i would like.

I know that feeling buddy. +1 ;)

Share this post


Link to post
Share on other sites

Looks like OSX supports BASH scripts, and will run them on ordinary double click with the extension .command. Anyone want to try this?

Something like (I don't know the name of the exe off hand, but you get the idea.):

cd $(dirname "$0")

mono CKAN.exe

Edited by Keldor

Share this post


Link to post
Share on other sites

Hey Keldor. It took a long time to open (like 4 minutes), but in the final, i got the program window( in windows layout, and not so fresh, i mean, it keep some trash on screen from move to move.

And i don't know if it do this, but it won't tick the mods i already had installed before.

But i think it worked. Still not what i mean to have here, and what i will try to help achieve.

And i got some error message in terminal. Still don't have time to see if it download the mods i tick, and everything else. I will keep you informed here when get more time to spare.

Here some print screen.

17076955332_3fac4d1eca_o.png

16890924540_df01220279_o.png

16892254439_9519ca9b40_o.png

Edit:

It create a subfolder on KSP folder, CKAN, and i try to install some mods (Adjustable landing gear and Tweakscale), goes until 12% and freeze.

After more then 3 minutes, it finished the download.

When i try to use the filter for mods, i need to type one caracter by 2 seconds, or else it miss the letter and duplicate the next or before one.

But it worked. The mods are installed!

:)

Edited by Climberfx

Share this post


Link to post
Share on other sites

This just crashes and gives a .net error when I try to use it(The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure.) so I click continue and then it crashes with this when I try to refresh the mod list(because it is blank)

************** Exception Text **************

System.NullReferenceException: Object reference not set to an instance of an object.

at CKAN.Main.UpdateRepo()

at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)

at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ToolStrip.WndProc(Message& m)

at System.Windows.Forms.MenuStrip.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************

mscorlib

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

----------------------------------------

ckan

Assembly Version: 0.0.0.0

Win32 Version: 0.0.0.0

CodeBase: file:///H:/Downloads/ckan.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System.Drawing

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Core

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

----------------------------------------

System.Configuration

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.GeneratedCode

Assembly Version: 1.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

Microsoft.CSharp

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll

----------------------------------------

System.Transactions

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll

----------------------------------------

System.Numerics

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll

----------------------------------------

System.ComponentModel.DataAnnotations

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ComponentModel.DataAnnotations/v4.0_4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll

----------------------------------------

System.Runtime.Serialization

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll

----------------------------------------

System.Xml.Linq

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll

----------------------------------------

System.Data

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll

----------------------------------------

System.EnterpriseServices

Assembly Version: 4.0.0.0

Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

Edited by darqen27

Share this post


Link to post
Share on other sites

For everyone who's reported that the CKAN index hasn't updated recently, you're right, it hasn't! I've tracked the problem down to the indexing bot looking for the new libcurl libraries that netkan uses for talking to KerbalStuff, and not finding them.

I've installed the libraries on our new server, and have sprung our indexing bot into action. All the updates are in place, but I'm still working on migrating the automatic updates over to the new server, so updates may be a little slower than usual for the next day or two.

Thanks again to all my patreon supporters, your support and well wishes in particular means I'm catching up on everything CKAN for this weekend's coding sprint, including filling in my knowledge of the infrastructure and its workings. :)

Many thanks, and all the best,

~ Paul

Share this post


Link to post
Share on other sites

Is there a way to force CKAN to update a Autodetected dll?

I manually installed a couple Mods that were not originally on CKAN in my first KSP game folder.

Later when they were I tried using CKAN to update them. CKAN says Nope not gonna do it.

So I tried to use CKAN to uninstall the mod, Ok, it tries then says there are to many dependencies with other mods and wont do it.

SO how am I going to update this mod. I dont want to have to do it manualy from now on.

CAN we get the ability to Force an update of a Autodetected Mod?

Share this post


Link to post
Share on other sites

Hello everyone! As pjf pointed out before, I've been (slowly and poorly) experimenting with deb packaging for ckan, with the long term goal of making ckan available through the repository system.

For the moment I'm still experimenting with the system (a *huge* thank you to Pinkbeast, who tolerated me this afternoon on IRC and helped me a lot): if you are brave and you know what you are doing, I'd like some feedback on the current build.

Please note that the versions of ckan and netkan offered through the package are obsolete: they are only meant for testing, for the moment.

Please report back! Github issues on the CKAN-deb repo are especially appreciated for this purpose :)

Share this post


Link to post
Share on other sites

Still there is something wrong with repository update. I've noticed, that Ven Stock-Revamp mod has version 1.7.2 as latest release since 7th of Febrary, but CKAN still shows a 1.7.1 version.

Does CKAN automatically update information about mods versions, or authors should do it manually?

Share this post


Link to post
Share on other sites

I also see a problem on CKAN. I uploaded a new mod about 7 hours ago, it built and was merged according to github:

GitHub pull request #922 of commit cd486b918429b0917a8e661647a810e062834165 automatically merged.

But it still isn't showing.

????

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.