pjf

The Comprehensive Kerbal Archive Network (CKAN) Package Manager; v1.18.0 [19 June 2016]

Recommended Posts

not sure if this has been asked but can bahatmo d's adjustable landing gear be indexed?

Share this post


Link to post
Share on other sites
not sure if this has been asked but can bahatmo d's adjustable landing gear be indexed?

It's in there as of this morning, refresh your repository :)

Share this post


Link to post
Share on other sites
It's in there as of this morning, refresh your repository :)

huzzah! sorry I am at work currently but i will check as soon as i get home :) thanks

Share this post


Link to post
Share on other sites

When I uninstalled infernal robotics with ckan, I got a disk error. I think I may have had ksp running at the time, and it probably was only able to partially delete the file.

Share this post


Link to post
Share on other sites

I'm not sure if it's related to the above post, but I am unable to install Magic Smoke's Infernal Robotics.... it continually gives an error in the attempt.

Thanks.

Share this post


Link to post
Share on other sites

I am getting the same issue but with the GUI. I went mucking about in the downloads folder and found that the archives in question were owned by root (I am on linux btw). When I tried to open the archive myself I got a "permission denied" message.

UPDATE: Just changed all the permissions on the cashed archives and tried again. Failed again on the same package at the same percentile: 32%. I don't know if that is relevant. Going to check the archive itself next.

UPDATE: Infernal Robotics archive is corrupted. Will need to wait till a clean copy is added to the repository.

UPDATE: Found the IR Dev's post in this thread asking for a force update Infernal Robotics in CKAN. Not quite sure what is involved with that (literally my first day back to Kerbal in several months). I think we will have to wait on it.

Screenshot-CKAN%20v1.6.13-0-g0000000%20beta%20-%20KSP%201.0.2.png

Edited by TheAlmightyOS

Share this post


Link to post
Share on other sites

Hi

The download for infernal robotics doesn`t work. wrong version? in ckan it`s v0.21, but here it`s already v0.21.2, if i try the downloadlink, i get a 404

Share this post


Link to post
Share on other sites

I've got an issue running it on linux. I can update the database just fine, but if I try to install any mod it says it's going to update the mod and then the progress bar just cycles through (ie not displaying any progress) and nothing happens. If I.run it from the command line, however, I get "System.DllNotFoundException: libcurl"

Curl is DEFINITELY installed, though obviously not in dll form. Do I need to find and download a windows curl dll? If so where do I put it? (also, why didn't I need this on old versions of CKAN?)

EDIT: Nevermind, I finally found the solution by going through the Wiki (two levels of links deep, not impossible to find, but not the most obvious location to find a required dependency), it needs a particular package of curl (namely libcurl4-openssl-dev). I suggest this requirement be placed in the first post, preferably right next to the download link

Edited by StarkRG

Share this post


Link to post
Share on other sites
I'm not sure if it's related to the above post, but I am unable to install Magic Smoke's Infernal Robotics.... it continually gives an error in the attempt.

Thanks.

I am getting the same issue but with the GUI. I went mucking about in the downloads folder and found that the archives in question were owned by root (I am on linux btw). When I tried to open the archive myself I got a "permission denied" message.

UPDATE: Just changed all the permissions on the cashed archives and tried again. Failed again on the same package at the same percentile: 32%. I don't know if that is relevant. Going to check the archive itself next.

UPDATE: Infernal Robotics archive is corrupted. Will need to wait till a clean copy is added to the repository.

UPDATE: Found the IR Dev's post in this thread asking for a force update Infernal Robotics in CKAN. Not quite sure what is involved with that (literally my first day back to Kerbal in several months). I think we will have to wait on it.

http://i1083.photobucket.com/albums/j393/thealmightyos/Screenshot-CKAN%20v1.6.13-0-g0000000%20beta%20-%20KSP%201.0.2.png

Hi

The download for infernal robotics doesn`t work. wrong version? in ckan it`s v0.21, but here it`s already v0.21.2, if i try the downloadlink, i get a 404

Temporary workaround for the IR issue should be to run the following in a terminal:


ckan install InfernalRobotics=0.21.2

Share this post


Link to post
Share on other sites

RCS build aid from v0.90 still works properly for KSP 1.0.x, it should be added to repository.

Share this post


Link to post
Share on other sites
RCS build aid from v0.90 still works properly for KSP 1.0.x, it should be added to repository.

no it doesn't. It works, but not properly.

Share this post


Link to post
Share on other sites

For whatever reason the bot isn't picking up that KIS was updated to 1.0.2

Share this post


Link to post
Share on other sites
no it doesn't. It works, but not properly.

Uuups. Sorry about misinformation.

Few people reported in dev thread that it works, I tried it by myself, haven't found any issues with it, so I put info here.

Question for CKAN, is it possible to alow install of old incopatible mods trough CKAN ?

Of course, with a big warning, that it might break game and to use it on your own risk. Also to check official dev thread if there is any additional dependency or some patch to make it work, like those B9 procedural parts.

B9 procedural parts was updated by another person, with permision from bac9 to maintain mod until he is able to continue development.

I understand that this kind of thing could make even more confusion for not so skilled people, so, big warning is needed.

For the rest of folks who understand what they doing it will be additional help.

Sorry, don't have github account to put request there.

Share this post


Link to post
Share on other sites

FAR download is broken. It requires ModularFlightIntegrator for work, which is not downloaded by default.

Share this post


Link to post
Share on other sites

Sorry for being slow, I'm in the process of moving and many of the others hang out primarily on github so sorry if I answer something that's already answered elsewhere.

I'm quoting a lot of Infernal Robotics questions below and let me just make clear that we are aware of the issue and will find a solution!

I have just run the update.

When Selecting TACLS TAC life support from the compatible list it then disables the "go to changes" button to allow it to install.

Any reason for this?

Actually if TACLS is selected it prevent any other mod from being installed... so just a error in that one mod that's upsetting Ckan?

See https://github.com/KSP-CKAN/CKAN-GUI/issues/95

Hi beautiful CKAN people! I'm on OSX and while CKAN works extremely well in most cases, I've been having some issues with installing a few different mods. I've checked that the mods I'm attempting to install are up to date and properly sourced, but I keep getting this "RecvError" notification in both CKAN and on the Terminal. The Terminal error looks like this

"183520 [1] ERROR CKAN.ErrorDialog (null) - Failed to download "https://kerbalstuff.com/mod/148/Modular Rocket Systems - Parts Pack/download/1.6.2" - error: RecvError"

I have a number of mods that I have installed that will not update thanks to this error, while others seem to update fairly easily.

Any ideas?

RecvErrors are notorious to track down, basically it can be the webpage just saying "no cookies for you", a temporary problem or just about anything else. I recommend trying again in a few hours and if you can reproduce it in a stable manner over many attempts spreadout through the day for a certain mod or set of mods open a github issue.

When I uninstalled infernal robotics with ckan, I got a disk error. I think I may have had ksp running at the time, and it probably was only able to partially delete the file.

Did CKAN not return your gamedata to its initial state so you could erase is safely after turning of KSP?

I'm not sure if it's related to the above post, but I am unable to install Magic Smoke's Infernal Robotics.... it continually gives an error in the attempt.

Thanks.

See start of post.

I am getting the same issue but with the GUI. I went mucking about in the downloads folder and found that the archives in question were owned by root (I am on linux btw). When I tried to open the archive myself I got a "permission denied" message.

UPDATE: Just changed all the permissions on the cashed archives and tried again. Failed again on the same package at the same percentile: 32%. I don't know if that is relevant. Going to check the archive itself next.

UPDATE: Infernal Robotics archive is corrupted. Will need to wait till a clean copy is added to the repository.

UPDATE: Found the IR Dev's post in this thread asking for a force update Infernal Robotics in CKAN. Not quite sure what is involved with that (literally my first day back to Kerbal in several months). I think we will have to wait on it.

http://i1083.photobucket.com/albums/j393/thealmightyos/Screenshot-CKAN%20v1.6.13-0-g0000000%20beta%20-%20KSP%201.0.2.png

We're working on it.

Hi

The download for infernal robotics doesn`t work. wrong version? in ckan it`s v0.21, but here it`s already v0.21.2, if i try the downloadlink, i get a 404

I've got an issue running it on linux. I can update the database just fine, but if I try to install any mod it says it's going to update the mod and then the progress bar just cycles through (ie not displaying any progress) and nothing happens. If I.run it from the command line, however, I get "System.DllNotFoundException: libcurl"

Curl is DEFINITELY installed, though obviously not in dll form. Do I need to find and download a windows curl dll? If so where do I put it? (also, why didn't I need this on old versions of CKAN?)

EDIT: Nevermind, I finally found the solution by going through the Wiki (two levels of links deep, not impossible to find, but not the most obvious location to find a required dependency), it needs a particular package of curl (namely libcurl4-openssl-dev). I suggest this requirement be placed in the first post, preferably right next to the download link

This information is part of, most, CKAN update messages but now that you mention I think it's not part of the instructions for people doing the first download. The installation instructions does however also contain pertinent information about mono requirements, could you point to a place where you think this information would be better placed?

Temporary workaround for the IR issue should be to run the following in a terminal:


ckan install InfernalRobotics=0.21.2

Thanks for adding this, if someone can confirm it working that'd be awesome!

RCS build aid from v0.90 still works properly for KSP 1.0.x, it should be added to repository.
no it doesn't. It works, but not properly.

There's an open issuereport on github about this. Does the author think it should be available for 1.0.x in CKAN?

For whatever reason the bot isn't picking up that KIS was updated to 1.0.2

Just merged a PR fixing this.

Uuups. Sorry about misinformation.

Few people reported in dev thread that it works, I tried it by myself, haven't found any issues with it, so I put info here.

Question for CKAN, is it possible to alow install of old incopatible mods trough CKAN ?

Of course, with a big warning, that it might break game and to use it on your own risk. Also to check official dev thread if there is any additional dependency or some patch to make it work, like those B9 procedural parts.

B9 procedural parts was updated by another person, with permision from bac9 to maintain mod until he is able to continue development.

I understand that this kind of thing could make even more confusion for not so skilled people, so, big warning is needed.

For the rest of folks who understand what they doing it will be additional help.

Sorry, don't have github account to put request there.

There is currently an open github Pull request in CKAN-core about this.

If someone updated a B9 thing we could update the metadata to reflect this if all parties would consider that ok and someone make sure there's a strictly responsible person that sends in a fix to revert the metadata back to B9 ownership once the official update is out.

FAR download is broken. It requires ModularFlightIntegrator for work, which is not downloaded by default.

This was fixed recently, I know it has caused some major grief and we're sorry for not having resolved it faster. Major, MAJOR, kudos to NathanKell who saved the day in the end aswell as to those who kept sending in PRs to fix it. Sorry we couldn't catch them fast enough.

EDIT: A word of warning that the influx of mods added by me (who have done most of the lately) from autogenerated KS requests will be zero, or very close to zero, in at the very least the coming week. Right now my new ISP is saying 15th at the earliest, I'm also attending some family stuff on that weekend and I'm quickly running out of mobile data just by doing this status update aswell as some emergency fixes on github.

Hope everyone is looking forward to pjf's hackathon tomorrow though, expecting great things!

Edited by Dazpoet

Share this post


Link to post
Share on other sites
This was fixed recently, I know it has caused some major grief and we're sorry for not having resolved it faster. Major, MAJOR, kudos to NathanKell who saved the day in the end aswell as to those who kept sending in PRs to fix it. Sorry we couldn't catch them fast enough.

Don't worry, we're here to find things out? Aren't we? :D

Share this post


Link to post
Share on other sites
What's the reason KAX isn't being catalogued as updated?

It's not updated on Kerbal Stuff.

Share this post


Link to post
Share on other sites
What's the reason KAX isn't being catalogued as updated?

Because it is not updated on kerbalstuff where we index it from.

edit: ninjad!

Share this post


Link to post
Share on other sites

There's an open issuereport on github about this. Does the author think it should be available for 1.0.x in CKAN?

I'm the author. The plugin works but it has some usability bugs, I don't think it would be fair to install it in 1.0.x without a warning at least.

Share this post


Link to post
Share on other sites
Because it is not updated on kerbalstuff where we index it from.

It is showing as available on CKAN now but fails to install when Firespitter is installed and vice versa due to:

The following inconsistencies were found:Firespitter wishes to install GameData/Firespitter/Resources/Firespitter.cfg, but this file is registered to KerbalAircraftExpansion

Installing KAX throws up this error message:

Oh no! We tried to overwrite a file owned by another mod!Please try a `ckan update` and try again.


If this problem re-occurs, then it maybe a packaging bug.
Please report it at:


https://github.com/KSP-CKAN/CKAN-meta/issues/new


Please including the following information in your report:


File : GameData/Firespitter/Resources/Firespitter.cfg
Installing Mod : KerbalAircraftExpansion v2.4.1
Owning Mod : Firespitter
CKAN Version : v1.6.13-0-g0000000 (beta)


Your GameData has been returned to its original state.

I've raised an issue.

Edited by Poodmund

Share this post


Link to post
Share on other sites

v1.6.14 aka Ganymede released

Changes since last version:

  • [bugfix] ckan show better escapes URLs (thanks mgsdk)
  • [Feature] ckan show now displays the cached filename (thanks mgsdk)
  • [bugfix] ckan upgrade --all no longer crashes when encountering unindexed mods (thanks RichardLake)
  • [internal] Version comparisons will no longer depend upon culture (thanks RichardLake)
  • [internal] The relationship resolver can now return more information as to why it failed (thanks RichardLake)
  • [internal] Updated SharpZipLib (thanks RichardLake)
  • [GUI] Users should be less able to install conflicting mods (thanks RichardLake)

EDIT: Some users have reported issues with the GUI not allowing mods to be installed or removed with this release. It's been marked as a 'pre-release' as we work on diagosing the issue. v1.6.15 will be out tomorrow, and you can safely backgrade to v1.6.14 if you experience issues.

Edited by pjf
Issues detected, added note.

Share this post


Link to post
Share on other sites

v1.6.14 installed here, the "go to changes" button stays disabled wether i add or remove or update mods (nothing will bring it up).

Share this post


Link to post
Share on other sites

Because of all the reports of IR being broken when installing via the CKAN, I've gone and fixed it. If it's still causing issues, let me know. :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.