Nertea

[1.6.x] Community Tech Tree (January 21)

Recommended Posts

3.3.6

  •  Added German translation (Three_Pounds)
  • OP is less ugly
  • Like 3

Share this post


Link to post
Share on other sites

Very useful feedback, I'm still editing the post :|

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Nertea said:
  • OP is less ugly

Don't be so hard on yourself.

  • Like 1

Share this post


Link to post
Share on other sites

Justa  small heads-up @Nertea :) the Tertiary download link (GitHub) in the OP is linking to HeatControl and not CTT...

Share this post


Link to post
Share on other sites

Community Tech Tree doesn't seem to be working with Module Manager 4.0.0. The Latest version of Module Manager That I could get to work was 3.1.3. If you're like me and can't live without this mod I recommend you don't update module manager. 

  • Like 2

Share this post


Link to post
Share on other sites

The CTT missing after updating ModuleManager to 4.0 using CKAN

KmMVRSE.png

No change after reinstall Module Manager and CTT, after downgrade to ModuleManager 3.1.3 CTT worked

RvJzRNL.png

 

  • Like 2

Share this post


Link to post
Share on other sites

I have the same bug as Dr Gaming and garound_ran. I didn't know it was due to MM updating, though; I had just updated my R&D facility, and I thought that's what borked it. :lol:

Edited by Sidereus

Share this post


Link to post
Share on other sites

It took me a while though, I reinstall MM and also all mods (with MM as depedency). I also check CCT depedency (it was MM 4.0.0 on CKAN). Then I rollback the MM, *poof* problem solved.

27 minutes ago, Sidereus said:

I have the same bug as Dr Gaming and gaoraound_ran. I didn't know it was due to MM updating, though; I had just updated my R&D fascility, and I thought that's what borked it. :lol:

 

Share this post


Link to post
Share on other sites

Heh, I just released a mod. Then fired my 'real' game up to kind of a VAB disaster. Still sweating...

Share this post


Link to post
Share on other sites

Does anybody know which mod  to fill this nodes in CTT:

-Specialized Landers

-Specialized Command Centers

-Advanced Colonization

Share this post


Link to post
Share on other sites

Thank you for sharing this with the community. My mod wouldn't be possible without it! :)

Share this post


Link to post
Share on other sites

I am curious about the tech tree node co-ordinate system. I noticed, when looking at the CTT code, that the tech tree uses a co-ordinate system which is unusual to me in two ways: firstly, that it is a three-dimensional system for a two-dimensional screen, and secondly, that writing a patch to move a node to co-ordinates (0,0,0) places it so far below the screen that it is impossible (with otherwise-stock settings) to zoom out far enough to see it. I am struggling to find any documentation that explains these co-ordinates, so I am wondering if you could direct me to some.

Share this post


Link to post
Share on other sites

Awesome mod! Thanks! :D

Question: Will you be updating it to support your other mod, Mk4 Spaceplane Parts? :)

Thanks in advance! ;)

Share this post


Link to post
Share on other sites
5 hours ago, Kerble said:

Question: Will you be updating it to support your other mod, Mk4 Spaceplane Parts? 

It's actually done the other way around: Mods need to support the Community TechTree (CTT) and in this case, MK4 Spaceplane Parts already got a config for this, which should be applied as soon as you install CTT ;)

Edited by 4x4cheesecake
typo

Share this post


Link to post
Share on other sites
34 minutes ago, 4x4cheesecake said:

It's actually done the other way around: Mods need to support the Community TechTree (CTT) and in this case, MK4 Spaceplane Parts already got a config for this, which should be allpied as soon as you install CTT ;)

Ah, I see! 

Thanks for the info! :)

Share this post


Link to post
Share on other sites
Posted (edited)

I could use some Troubleshooting help I have CTT mod installed as well as many of your near future mods but the parts don't show up on the modded tech tree. any suggestions on how to fix this @Nertea

Edited by BigBGuse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now