Jump to content

[1.11.x] Alcubierre Warp Drive (Stand-alone)


RoverDude
 Share

Recommended Posts

I just want to mention that the USI suite has the solution you need built in. K+ offers the efficiency you need to practically deal with the rediculous dV requirements after warping with a KSPI or USI alcubier style drive. It's great because now we get to have an mks/oks alike answer to KSPI!

Link to comment
Share on other sites

You need to be at 600 000m for the 2.5m drive and at 900 000m for the 0.625m drive. You don't need to start charging exotic matter if the drive is full of it, though I'd recommend you recharge your stores before you go for a space jaunt.

Than you ! And sorry for my ignorance x) ...

Link to comment
Share on other sites

Is the ship supposed to break up when the drive is initiated inside a local system like Jool or Kerbal? The drive works fine if I use it when orbiting the sun, but as soon as I enter a local system, it breaks my ship into a bunch of debris. Thanks for the help.

Link to comment
Share on other sites

Is the ship supposed to break up when the drive is initiated inside a local system like Jool or Kerbal? The drive works fine if I use it when orbiting the sun, but as soon as I enter a local system, it breaks my ship into a bunch of debris. Thanks for the help.

When I tried to use the drive, I found that it only did that if you had it at (or near) full throttle while you were aiming roughly at something massive (like Kerbin/the sun for example). I'm not sure if it's a bug or not though.

I have another issue as well; for some situations using the drive causes the ship to rotate for no apparent reason (in particular while deep in a gravity well). Is that intended or is it a bug? The mods I had installed (most via CKAN) during testing:

Blizzy's toolbar

USI Tools

Active Texture Management

ART

Better Buoyancy

Community Resource Pack

Deadly Reentry

Enhanced Navball

Extraplanetary Launchpads (regolith adaptation)

FAR

Firespitter

InFlightWaypoints

IntakeBuildAid

KAS

KER

KIDS

Kerbal Stats

Infernal Robotics

ModuleRCSFX

Precise Node

ProceduralDynamics

ProceduralFairings

RealChute

Regolith

RemoteTech

SCANsat

Stage Recovery

Stock Bug Fix Modules

Texture Replacer

Trajectories

KAC

Alternate Resource Panel

Transfer Window Planner

TweakScale

USI Exploration Pack

FTT

Karbonite

KarbonitePlus

Sounding Rockets

USI Survival Pack

Alcubierre Warp Drive (this one)

Vanguard EVA parachutes

There's also an occasional issue with the Navball, but that could be something completely different :(

Issues aside, I do love the mod :D

Link to comment
Share on other sites

Is the ship supposed to break up when the drive is initiated inside a local system like Jool or Kerbal? The drive works fine if I use it when orbiting the sun, but as soon as I enter a local system, it breaks my ship into a bunch of debris. Thanks for the help.

Not normally :P Though it's based on how hard you push it, if you try to turn with the drive engaged, fragility of your ship (use struts!), etc.

The "bubble" should actually just be the distortion of light from the background... Just saying. (Hopefully it's able to be done)

Not easily, but I take pull requests :P

I have another issue as well; for some situations using the drive causes the ship to rotate for no apparent reason (in particular while deep in a gravity well). Is that intended or is it a bug?

More an unintended consequence that I let ride ;)

The drive is risky and scary and will sometimes eat things. And I am ok with that.

Link to comment
Share on other sites

More an unintended consequence that I let ride ;)

The drive is risky and scary and will sometimes eat things. And I am ok with that.

I'm mostly inclined to agree, but the rotation thing is just plain irritating :(. I don't suppose you know if there's anything that can be done to work around it, besides getting far enough out of the gravity well? No amount of SAS/torque etc seems to work :(

Link to comment
Share on other sites

Oh - I've had it rotate after leaving warp but SAS immediately corrected it (it was more of a minor annoyance). I have not had a case where you could not stop the spinning...

The spinning in my case occurs during warp. Naturally that means you don't go in the direction you intended :P

Link to comment
Share on other sites

http://i.imgur.com/g25Oera.png

Animated warp effect:

Inroducing a new, stand-alone Alcubierre drive for KSP!

What does it do?

The Alcubierre drive works by moving space around your ship, not through accelleration. In KSP we do this by changing your vessels position based on the engine throttle controls for the warp engine. Speeds of up to 1.6 times the speed of light are possible.

How does it work?

Use massive amounts of electric charge to create Exotic Matter. Point at your target. Use Exotic Matter and Xenon Gas (the latter is for the maneuver thrusters) to go straight to the target. Note that since your velocity does not change, only your location, you will have to compensate for any orbital speed differences. This can be excessive (15K+ DV) or, with proper planning, next to zero.

To be clear. This is NOT just a fast, efficient engine. There is no acceleration (other than a tiny amount from the maneuver thrusters). It works through translating the ship's position (simulating how a real Alcubierre drive might work).

What's the catch? How is this not OP?

You will still need either very careful navigation or excessive DV changes to achieve orbit. Also, because of the destructive nature of the warp bubble, parts outside of it (both on your own ship and others) will be destroyed. Warp bubble collapses are also destructive, and maneuvering at excessive warp speeds can be very dangerous (everything from losing control through parts of your ship slipping outside of the bubble and exploding).

What other mods do I need?

None. Really. The only dependency is Regolith which is needed for it's converter (used to make Exotic Matter from EC).

What other parts do I need to support this?

Stock only. Really. Near Future Technologies reactors, or reactors from the USI mods will make some things easier, but you can get away with a completely stock warp ship with just the addition of this part.

Can this support [mod X]?

If you want integration with other mods, tell your favorite modders to ping me. I am very open to collaboration :)

LICENSE:

CC 4.0 BY SA NC

DOWNLOAD HERE

Source can be found here

I'm not able to power up the engines once everything is charged and full of exotic matter. I made a craft with one large drive. launched it into space and started exotic matter once full I try to activate engine and it starts then stops. what am I missing here?

Link to comment
Share on other sites

I'm not able to power up the engines once everything is charged and full of exotic matter. I made a craft with one large drive. launched it into space and started exotic matter once full I try to activate engine and it starts then stops. what am I missing here?

With such an overflow of pertinent information troubleshooting should be easy. Or maybe reading back down the thread would have helped. Without more information I cannot be sure but I am thinking post #373 is relevant to you.

Link to comment
Share on other sites

I don't appreciate the sarcastic tone goldenpsp, but I'll check the post you mentioned to see if that fixes my problem."

I'm not sure what more information I could give. I build a craft much like int he video and it didn't work. do I need more than just the one part and lots and lots of solar panels to make it work?

Thanks for your help.

P.S. I did read through 12 pages to try to find the problem but this is such a long thread I was really hoping that someone would just be able to help.

- - - Updated - - -

http://s13.postimg.org/yf5hn5353/Screenshot_2015_01_07_21_59_19.png

here is a pic of my ship if this helps.

Link to comment
Share on other sites

I don't appreciate the sarcastic tone goldenpsp, but I'll check the post you mentioned to see if that fixes my problem."

I'm not sure what more information I could give. I build a craft much like int he video and it didn't work. do I need more than just the one part and lots and lots of solar panels to make it work?

Thanks for your help.

P.S. I did read through 12 pages to try to find the problem but this is such a long thread I was really hoping that someone would just be able to help.

- - - Updated - - -

http://s13.postimg.org/yf5hn5353/Screenshot_2015_01_07_21_59_19.png

here is a pic of my ship if this helps.

You have to understand, especially in the last few weeks there has been a huge uptick in posts that not only don't give any useful information to help in troubleshooting, and have already been answered within 1 page prior. Your previous post was akin to you calling your mechanic and saying "my car isn't working" to which he would likely reply "umm ok, can you be a bit more specific"

Pictures help. I might suggest using the in game screenshot key (F1 or F2?) as the one you posted is badly pixelated with your multiple monitor setup. That being said it looks like the alitude is 187XXX?

If that is the case I would kindly highlight the important parts of the post I had recommended you read.

You need to be at 600 000m for the 2.5m drive and at 900 000m for the 0.625m drive.
Link to comment
Share on other sites

thank you goldenpsp that is very helpful. I'm new to the forums, so forgive my ignorance.

- - - Updated - - -

also CTRL and F1 takes in game screen shot. only took me a few min. of button mashing to find it he he

- - - Updated - - -

altitude was my issues.... feel like an idiot but it works ^^

Link to comment
Share on other sites

Out of curiosity, got a screenshot of the ship?

Sadly, no. It was basically a minimalistic ship with the mk1-2 capsule, heat shield (for "emergencies"), decoupler, 2.5m reaction wheel, warp drive, hydrogen tank and the 2.5m nuclear engine from FTT (disabled during warp, obviously :D). It was just to try out the drive. I would post screenshot/logs etc, but my computer's cpu fan died a couple days ago (shortly after my last post) and tbh, I'm not going to replace it since the failure left the 9 year old hard disks intact and I'd like to keep them that way until I can replace the rig :). For the moment I'm stuck with a chromebook :(

Edited by armagheddonsgw
Link to comment
Share on other sites

Hi, I downloaded this awesome mod, and I have a problem. When I activate/engine operation, the ship starts to shake, especially noticeable on 5-40%. When flying on "Duna" even at full power (about 30-40 seconds), I will notice a significant deviation from the course (and it is not connected with the movement of the planets). Please help solve this problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...