Jump to content

[1.11.x] Alcubierre Warp Drive (Stand-alone)


Recommended Posts

On 2/16/2020 at 6:33 AM, budda said:

is it possible to g get a cfg to use a warpdrive in mk2 part ?

I usually take the Mk1 sized one (1.25m?) and stick it in a Mk2 Cargo bay.  Works splendidly, and you've got some space to stick other stuff in that need protection from aero forces.

Link to post
Share on other sites
  • 1 month later...
On 4/13/2020 at 12:14 PM, pierrot69stf said:

I'm running ksp 1.3.1 vanilla (except for hyperedit)

Are you using v0.7 or 0.8 of this mod? The newest/latest version of it is NOT to be expected to work in KSP 1.3.1. Also be sure that it is installed correctly (Example: Do not have another GameData folder in your GameData folder).

Link to post
Share on other sites
On 4/15/2020 at 11:27 AM, έķ νίĻĻάίή said:

Neat mod you got going there, will 100% use this to be lazy do science

 

Don't kid yourself - navigating with this thing is trickier than it sounds.

Edited by capi3101
Link to post
Share on other sites
  • 4 weeks later...

Been using this mod with GregoxMun's Whirligig World planet pack and I found that I can lower speeds and dV costs by slingshotting around stars and planets until I get the desired dV. Still pretty compliated.

Link to post
Share on other sites
  • 1 month later...

I have a a few questions:

Is there a tutorial or guide on how to use the drive to properly jump to other planets?  I found some videos but nothing official.

One referenced a failsafe guide chart.  Where can I find that?

Edited by SkiRich
Link to post
Share on other sites
3 hours ago, SkiRich said:

I have a a few questions:

Is there a tutorial or guide on how to use the drive to properly jump to other planets?  I found some videos but nothing official.

One referenced a failsafe guide chart.  Where can I find that?

Nothing official, but a lot of discussion in this thread.  

Link to post
Share on other sites
7 hours ago, SkiRich said:

I have a a few questions:

Is there a tutorial or guide on how to use the drive to properly jump to other planets?  I found some videos but nothing official.

One referenced a failsafe guide chart.  Where can I find that?

Received a question on this topic via YouTube notifications just this morning; I'm assuming you're referring to the video I made from 2017. I'll have to spelunk the thread to find it again. As far as being "official", the video is probably as close as it's going to get...

The guide itself only contains the velocities needed to attain orbit at one / 1.5 planetary radii (what was failsafe when the video was made - at this point failsafe is 0.5 radii, but I've found that planning to warp to one planetary radius usually gives you a comfortable screw-up margin). If you pause the video when it comes on screen, it's the same information. Are you wanting numbers for a different planetary pack?

EDIT: Found it. Post on page 48.

Edited by capi3101
found it...
Link to post
Share on other sites
10 minutes ago, SkiRich said:

Can someone tell me when or if I would ever alter these two variables of the drive?

Turbo Factor

T-Start

What do they mean?

Not seeing these variables in any of the mod's configuration files; if I may ask, where are you seeing them?

Were I to guess (in light of the above sentence), I'd say these have to do with the maximum speeds the drive can attain. I'd only fiddle around with them if you were using a planetary pack with two or more star systems; there is a configuration file in the mod that handles scaled-up systems already, and in my experience the 6c limit works pretty well for the stock Kerbol system (if anything my issues with the drive come from the minimum top speed of 0.001c, which as slow as that is becomes dangerously fast once you get below the braking altitude of the smaller bodies of the system - seriously, I can't tell you how many times I've almost driven a ship right into Bop and had to burn my way to safety...).

Link to post
Share on other sites
19 hours ago, capi3101 said:

Not seeing these variables in any of the mod's configuration files; if I may ask, where are you seeing them?

Were I to guess (in light of the above sentence), I'd say these have to do with the maximum speeds the drive can attain. I'd only fiddle around with them if you were using a planetary pack with two or more star systems; there is a configuration file in the mod that handles scaled-up systems already, and in my experience the 6c limit works pretty well for the stock Kerbol system (if anything my issues with the drive come from the minimum top speed of 0.001c, which as slow as that is becomes dangerously fast once you get below the braking altitude of the smaller bodies of the system - seriously, I can't tell you how many times I've almost driven a ship right into Bop and had to burn my way to safety...).

There have been some threads related to KSPI and other mods discussion taking about these variable.  You are on the right track, they were all around planetary addition packs, etc.

I'd like to know for sure.  Something definitive.  Being an engineer myself, my OCD prevents me from letting it go.

These vars are showing when you right click the drive in the VAB.

RoverDude, I have one feature request for all the drives.

In addition to showing the sample bubble in the VAB, please allow us to extend the drive so we know the area of the space we should not build in.

The bubble is nice and a decent effort can be made to fill the thing to the fringes with a craft but I need to see the engine extended.

Link to post
Share on other sites
  • 2 months later...
6 hours ago, Sarxis said:

I wonder how easy it would be to slow down the part unfolding animations.  They are so nicely done, but happen rather quickly in-game. 

Is that all controlled inside the .dll files?  

Not sure off the top of my head if it's something we can mess with via the configs or not (it's one of the stock modules).

Link to post
Share on other sites
  • 3 weeks later...

@wkwied Try changing the value of GravFactor inside the USI_ModuleWarpEngine{} node in the part config. Expect side-effects to happen like increase power demand near the planet, continued inability to use the engine, itchiness, dryness, nausea and vomiting, or rash. Do not actually try this if you're allergic to MM, ExoticMatter or have a strong aversion to magnetic fields.

Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

@wkwied Try changing the value of GravFactor inside the USI_ModuleWarpEngine{} node in the part config. Expect side-effects to happen like increase power demand near the planet, continued inability to use the engine, itchiness, dryness, nausea and vomiting, or rash. Do not actually try this if you're allergic to MM, ExoticMatter or have a strong aversion to magnetic fields.

Thank you :)

Link to post
Share on other sites
  • 3 weeks later...

I'm trying to use this mod, but the drive isn't working. I can get into orbit and have enough power, but the exotic matter bar is already full and when i turn the warp drive on it just flashes the orange bubble for half a second then immediately turns itself off.

Link to post
Share on other sites
1 hour ago, Heno Mori said:

I'm trying to use this mod, but the drive isn't working. I can get into orbit and have enough power, but the exotic matter bar is already full and when i turn the warp drive on it just flashes the orange bubble for half a second then immediately turns itself off.

What's your altitude when you try to turn it on? Usually when this happens, folks are below the failsafe altitude, which is half a planetary radius for all bodies in the system. For Kerbin, that's 300,000 meters ASL.

Link to post
Share on other sites
21 hours ago, capi3101 said:

What's your altitude when you try to turn it on? Usually when this happens, folks are below the failsafe altitude, which is half a planetary radius for all bodies in the system. For Kerbin, that's 300,000 meters ASL.

Ah, didn't realize there was a failsafe altitude. I was at about 80k meters. Thank you.

Link to post
Share on other sites
47 minutes ago, Heno Mori said:

Ah, didn't realize there was a failsafe altitude. I was at about 80k meters. Thank you.

No problem.

Also note that when you go to use the drive, you need to make sure to not have the Exotic Matter generator turned on at the same time the drive is active - that power requirement of 10,000 EC/s for the XM generator is no typo. I can usually pull that amount of power with eight Gigantor solar panels in close proximity to Kerbol around 1.6 Gm. The drive itself doesn't require all too much power; several active Fuel Cell Banks ought cover it. This is assuming you don't have access to more advanced (read: non-stock) power supplies; if you do, the power requirements are much higher. 

If you need help with navigation later, I've got you covered there too. The video may be old but it's still mostly valid.

Link to post
Share on other sites

So, previous issue was fixed, just fine. It turns out I'm just stupid. But there's a new issue, that I don't think is related me being me. 

The first minute or so is me demonstrating the glitch, what it does and it fixing itself with no apparent provocation. The last few minutes are me retrieving Jebediah. 

This occurred after trying to land on an asteroid, sending me on an accelerating course across the Kerbol system and leaving the asteroid spinning at a massive rate. My acceleration eventually slowed down after reaching about 9km/s relative to target. This has happened before, where I have been sent away from the asteroid and the asteroid started spinning, but the glitch I am referring to here didn't occur. As shown in the video, it fixed itself, but I am wondering if it will happen again, if it's preventable on my end or if you can fix it. 

Link to post
Share on other sites
  • 4 weeks later...

I do understand that this mod is fairly difficult to use, but is there any way to make it so that the dive has an 'auto circularize' feature? I do know that the alcubierre drive in the interstellar mod has this, but I've taken a look at the configs and have no clue how I could port the function from one to the other.

 

I think I have figured out how this works well enough :)

 

However there appears to be an issue.. if my craft runs out of xenon and I try to use the drive, instead of just not working, it explodes.

And another, is it possible to get this to work with persistent thrust? Trying to do time warp while the drive is running... warps reality and turns the craft into a few pixels. Time warp works fine, if a bit slow

Edited by wkwied
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...