Jump to content

[1.10.1+] Contract Configurator [v1.30.5] [2020-10-05]


Recommended Posts

Is making Tourist blackout a new stock requirement or a mod? The one that came up is for Tokamak Industries, but there seems to be no contract configs in that mod tree and I don't see mention of it in the CC Tourism.cfg.

Link to post
Share on other sites

Can you, please, make CC take contracts of types WorldFirstContract and ExploreBody and change their type to ExplorationContract?

This will allow painless career transition from 1.1.3 to 1.2.

Edited by RealGecko
Link to post
Share on other sites

Just in case anyone else in the future comes along and can't figure out why a contract that requires your vessel to have an antenna isn't completing, you probably need a relay antenna.  I can't speak for all combinations of contract packs and other mods, namely remotetech, but after some testing the relay antennas seem to be the only ones to complete the job for me.

For mod authors out there, the "partModuleType = Antenna" line appears to be the offending line, but I'm not skilled enough to figure out how to change this to apply to all antennas.

Link to post
Share on other sites
6 hours ago, Vorg said:

Is making Tourist blackout a new stock requirement or a mod? The one that came up is for Tokamak Industries, but there seems to be no contract configs in that mod tree and I don't see mention of it in the CC Tourism.cfg.

I don't understand the question.

6 hours ago, RealGecko said:

Can you, please, make CC take contracts of types WorldFirstContract and ExploreBody and change their type to ExplorationContract?

This will allow painless career transition from 1.1.3 to 1.2.

Nope, that's a 100% stock thing that I can't change in Contract Configurator.

5 hours ago, kormer said:

Just in case anyone else in the future comes along and can't figure out why a contract that requires your vessel to have an antenna isn't completing, you probably need a relay antenna.  I can't speak for all combinations of contract packs and other mods, namely remotetech, but after some testing the relay antennas seem to be the only ones to complete the job for me.

For mod authors out there, the "partModuleType = Antenna" line appears to be the offending line, but I'm not skilled enough to figure out how to change this to apply to all antennas.

Might be worth raising a bug request on github and I can look to fix/change that in future releases.

Link to post
Share on other sites

There is a tourism contract offered to take 3 kerbals on a sub orbital flight and make them black out from G forces. The contract is listed as from Tokamak Industries which is the corp name used in one of the mods. But that mod doesn't seem to have any contract cfg's. Since the game will pick names from the list of corps and put it to a contract, I don't know if this was added by a mod or is now stock since kerbals blacking out is new with 1.2.

Link to post
Share on other sites

Hi,

Noticed an issue with scanning contracts (not using the Scansat contract pack mod). Usually, if the contracts ask for a percentage scanned, the current value is also displayed (like: Low res altimetry: 12/85%). Now, the current percentage is almost never displayed in any of the different views (contract icons in toolbar from VAB, KSC, etc.). The only way to see it is to go to Mission Control and view the Active tab. It seems like I would see it when the scanner starts, and the contract first recognizes that it is in progress, but goes away after scene changes.  Does that sound like an issue?

Thanks

Link to post
Share on other sites
1 minute ago, Gilph said:

Noticed an issue with scanning contracts (not using the Scansat contract pack mod). Usually, if the contracts ask for a percentage scanned, the current value is also displayed (like: Low res altimetry: 12/85%). Now, the current percentage is almost never displayed in any of the different views (contract icons in toolbar from VAB, KSC, etc.). The only way to see it is to go to Mission Control and view the Active tab. It seems like I would see it when the scanner starts, and the contract first recognizes that it is in progress, but goes away after scene changes.  Does that sound like an issue?

Can you show me a screenshot of what you mean?

Link to post
Share on other sites

I seem to be having some problems with Contract Configurator. 


1) Select contracts in Mission Control
2) Leave to KSC. Check tab...have contracts.
3) Enter VAB, Check contracts tab...no contracts.

Log:

https://www.dropbox.com/s/hczrngqciaa4znz/output_log 1NOV2016.txt?dl=0

Also: the mission control page has a few graphical issues.

7kr18eu.png

Thanks, and I hope this helps.

Link to post
Share on other sites
22 minutes ago, Sudragon said:

I seem to be having some problems with Contract Configurator. 


1) Select contracts in Mission Control
2) Leave to KSC. Check tab...have contracts.
3) Enter VAB, Check contracts tab...no contracts.

Log:

https://www.dropbox.com/s/hczrngqciaa4znz/output_log 1NOV2016.txt?dl=0

Also: the mission control page has a few graphical issues.

7kr18eu.png

Thanks, and I hope this helps.

Are you using Kerbal Atomics or Cryogenic Engines? And if so are you using the most up to date version? There was a bug in these mods that was causing this. 

If you are, get the latest version of the mods. If not... then there's another issue out there somewhere! :)

Link to post
Share on other sites
12 minutes ago, Malich said:

Are you using Kerbal Atomics or Cryogenic Engines? And if so are you using the most up to date version? There was a bug in these mods that was causing this. 

If you are, get the latest version of the mods. If not... then there's another issue out there somewhere! :)

Yup. Latest versions of both of those. 

Link to post
Share on other sites

@Sudragon - There's tons and tons of errors in that log, so it's safe to say you have problems with mods that don't work in 1.2.  For Contract Configurator, you have at least two copies installed, which is causing it to fail to load.

I'd suggest starting with a clean install here, and adding 1.2 supported mods back in from there.

Link to post
Share on other sites
2 hours ago, nightingale said:

@Sudragon - There's tons and tons of errors in that log, so it's safe to say you have problems with mods that don't work in 1.2.  For Contract Configurator, you have at least two copies installed, which is causing it to fail to load.

I'd suggest starting with a clean install here, and adding 1.2 supported mods back in from there.

You may be right...I'm getting something interesting where i delete the contract configurator directory, start the game and a new ConConfig directory appears out of nowhere, but only has log files in it.

 

Edited by Sudragon
Link to post
Share on other sites
49 minutes ago, Sudragon said:

You may be right...I'm getting something interesting where i delete the contract configurator directory, start the game and a new ConConfig directory appears out of nowhere, but only has log files in it.

Probably this one that will be the one you want to get rid of. :)

AssemblyLoader: Loading assembly at F:\Kerbal Space Program 1.2\GameData\RealPlume-Stock\ContractConfigurator\ContractConfigurator.dll
 

Link to post
Share on other sites
On 10/31/2016 at 10:17 AM, nightingale said:

Can you show me a screenshot of what you mean?

Hi,

1. Received scan contracts. Started the scan mun for resources with the m700

pPOtdmN.png

2. Sent scanner to mun, notice contract view on right. Topmost one shows no progress, which is correct

UuhgU4u.png

3. Started scan. Opened map to adjust proper orbit.  You see that it has scanned a part, but the contract status shows no progress (topmost contract)

44eRwqx.png

4. Immediately change to KSC. Contract shows no progress

ui0AUIs.png

5. Immediately change to Mission Control to look at contract status, shows it to be 28% completed

6c9rIVp.png

Please let me know if you need anything else

Thanks

Link to post
Share on other sites
5 hours ago, nightingale said:

Probably this one that will be the one you want to get rid of. :)

AssemblyLoader: Loading assembly at F:\Kerbal Space Program 1.2\GameData\RealPlume-Stock\ContractConfigurator\ContractConfigurator.dll
 

Yup. found that 10 minutes after I read your reply. Works fine now. 

Link to post
Share on other sites

New release here with lots of good stuff!  Got a new workaround for the "toolbar" issue in place - other mods no longer need to change their code for compatibility (although it's still a good idea).  Kerbal Konstructs support is also back in this release.

Contract Configurator 1.21.0

  • Found new workaround for GetExportedTypes reflection issue (the "toolbar" issue).
  • Added NextUnreachedBody() and NextUnreachedBodies() methods.
  • Added Part.MassDry() and Part.MassWet() methods.
  • Added CelestialBody.CanHaveSynchronousOrbit() method.
  • Recompile Kerbal Konstructs integration.
  • Fixed contract window text not updating for dynamic text (duration timers, etc.).
Link to post
Share on other sites

Just wondering if Contract packs need v1.2 updates or are they OK used anyway.

Some on CKAN are marked v1.99 while same and others are v1.1.3 on spacedock.

I could try them out but I am in a hotel room for a few days so while I am bored of cable TV I am getting all my downloads ready for when I get back :D and hopefully the ultimate v1.2.1 career.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...