nightingale

[1.8.x+] Contract Configurator [v1.28.0] [2019-10-17]

Recommended Posts

@nightingale Thanks for the tip about the Remote Tech, it worked great.

Is there any way to force a player to have to make an EVA in space and travel a certain distance away from the ship? I tried looking into IsVesselType = EVA which will work for part of it. If I create a Rendezvous Parameter with an invertRequirement = true and a distance of say 200, would that require the EVA vessel to be 200 meters away from the ship to accomplish the contract?

Share this post


Link to post
Share on other sites
5 hours ago, ultraviolet150 said:

I'm having some strange error popups that I can't explain. Any assistance as to what it could be?

More than likely module manager think that StationScience is installed, but it really isn't.  I've heard of CKAN leaving directories behind - perhaps you installed/uninstalled via CKAN and the directory is still there?

30 minutes ago, pap1723 said:

@nightingale Thanks for the tip about the Remote Tech, it worked great.

Is there any way to force a player to have to make an EVA in space and travel a certain distance away from the ship? I tried looking into IsVesselType = EVA which will work for part of it. If I create a Rendezvous Parameter with an invertRequirement = true and a distance of say 200, would that require the EVA vessel to be 200 meters away from the ship to accomplish the contract?

You can't use invertRequirement, because it's for parameters.  You could do it like this though:

PARAMETER
{
    type = Not
    title = Be far away
    hideChildren = true

    PARAMETER
    {
        type = Rendezvous

        ...
    }
}

 

Share this post


Link to post
Share on other sites
3 hours ago, nightingale said:

More than likely module manager think that StationScience is installed, but it really isn't.  I've heard of CKAN leaving directories behind - perhaps you installed/uninstalled via CKAN and the directory is still there?

...snip/

I've never used CKAN (I prefer to do things manually and on my own then I know I've done them properly) in my life and there's definitely no folder left behind. Granted StationScience was installed previously in the install of kSP but on a completely different save, Is there a cache for MM where it may have left a trace?

Share this post


Link to post
Share on other sites
17 minutes ago, ultraviolet150 said:

I've never used CKAN (I prefer to do things manually and on my own then I know I've done them properly) in my life and there's definitely no folder left behind. Granted StationScience was installed previously in the install of kSP but on a completely different save, Is there a cache for MM where it may have left a trace?

MM does have a cache, but it's pretty good about detecting changes.  I'd need to see the full log to be able to say much else on this one.

Share this post


Link to post
Share on other sites
14 minutes ago, nightingale said:

MM does have a cache, but it's pretty good about detecting changes.  I'd need to see the full log to be able to say much else on this one.

I deleted the MM cache and errors persist. I have a crap ton of mods, (all running pretty smoothly) so my log is like 9mb... not  going to bother with it. it doesnt seem to break anything, so not too stressed about it. :)

 

Edit: Seems to be KerbinSpaceStation contract packs. Removed them and all is well with errors... going to look into it further. I'm sure the mod creator has just left out a MM "!" operator or something. Will check it now

Edited by ultraviolet150

Share this post


Link to post
Share on other sites

I am struggling with figuring out the logic of this situation.

I have a planet with multiple moons. I want to return the moon with the largest mass

DATA
{
	type = List<CelestrialBody>
	theMoons = @targetBody.Children()
}
      
DATA
{
	type = CelestrialBody
	massiveMoon = @theMoons.Where(cb > cb.Mass()).First() ?????????????????????????
}

This is where I am stuck. As far as I can tell, the Where function cannot sort by a value like Mass. This might not be possible and I will have to attack the problem from a different angle.

Share this post


Link to post
Share on other sites

This keeps showing up on resuming save

http://prntscr.com/bnm9me

I can ignore it then go into VAB SPH and other scenes it will show up again. After I have ignored in each scene it will no longer show.

Remote tech, anomoly, and scansat contracts installed. Just go the new configurator today.

Share this post


Link to post
Share on other sites
43 minutes ago, pap1723 said:

I am struggling with figuring out the logic of this situation.

I have a planet with multiple moons. I want to return the moon with the largest mass


DATA
{
	type = List<CelestrialBody>
	theMoons = @targetBody.Children()
}
      
DATA
{
	type = CelestrialBody
	massiveMoon = @theMoons.Where(cb > cb.Mass()).First() ?????????????????????????
}

This is where I am stuck. As far as I can tell, the Where function cannot sort by a value like Mass. This might not be possible and I will have to attack the problem from a different angle.

Don't think it's possible without me implementing some new special methods.  Raise an enhancement if this is something you'd like to see, although the implementation of the Where() method is a bit ugly, so I'm not too keen on making other similar methods like Select() or Max() (although I can definitely see some cases where it would be nice).

26 minutes ago, LTL King said:

This keeps showing up on resuming save

http://prntscr.com/bnm9me

I can ignore it then go into VAB SPH and other scenes it will show up again. After I have ignored in each scene it will no longer show.

Remote tech, anomoly, and scansat contracts installed. Just go the new configurator today.

I'd need to see a log.  Sounds like some stuff in the save got messed up somehow.  Actually, seeing the save would probably be good here too.

Share this post


Link to post
Share on other sites
24 minutes ago, nightingale said:

I'd need to see a log.  Sounds like some stuff in the save got messed up somehow.  Actually, seeing the save would probably be good here too.

A log is very general. You need to be more specific.
You tell me a step by step method on how you can see it. I will be able to do that.

Edited by LTL King

Share this post


Link to post
Share on other sites

I notice that when I update this mod via CKAN I loose all my accepted and completed contracts. I've tried searching for a solution to this problem to no success. Could someone tell me what files or sections of code I might need to duplicate/save prior to updating? Thanks!

Edit: It appears if I load my quicksave file, the contracts are fixed.

Edited by nerf_hurrdurr

Share this post


Link to post
Share on other sites
5 hours ago, LTL King said:

http://prntscr.com/bnn7qe

The numbers keep climbing until it runs out of memory and crashes the game

Still need a log to help here - start game, get errors, close game, send log - those are the only steps needed.  If you need more, please check out this thread:

 

3 hours ago, nerf_hurrdurr said:

I notice that when I update this mod via CKAN I loose all my accepted and completed contracts. I've tried searching for a solution to this problem to no success. Could someone tell me what files or sections of code I might need to duplicate/save prior to updating? Thanks!

Edit: It appears if I load my quicksave file, the contracts are fixed.

I have no idea - this shouldn't happen.  What version were you upgrading from/to?

Share this post


Link to post
Share on other sites
17 hours ago, nightingale said:

Still need a log to help here - start game, get errors, close game, send log - those are the only steps needed.  If you need more, please check out this thread:

Which log. Where is the log. What is the log name. Be a little more specific. How do I send you a log. Do I go outside and chop down a tree and make logs then send it in the mail.

"Need a log" is to general.

Edited by LTL King

Share this post


Link to post
Share on other sites
1 hour ago, LTL King said:

Which log. Where is the log. What is the log name. Be a little more specific. How do I send you a log. Do I go outside and chop down a tree and make logs then send it in the mail.

"Need a log" is to general.

Read thread linked above.

Share this post


Link to post
Share on other sites

hi.

lately i get some problems with contracts added by contract packs: it seems the contracts dont register achieved hieghts/Situations (sub orbital, orbit....) however, this effects only one or two contract packs, while it works fine for others.

so if i pick up the "achieve 18.000m" contract from initial contrackts pack, and the "achieve 2000m" from the sounding rocktes contracts pack, and launch a rocket (that fullfills all the part requirements for the SR contract), to 20.000m the 18.000m contract gets finished, the 2000m wont -> the achieve 2000m line never turns green.

Yesterday i saw contracts from the historic missions contract pack effectet by this bug

Output log: https://www.dropbox.com/s/3kpc9vpvsgh4snu/output_log.txt?dl=0

KSP log: https://www.dropbox.com/s/wq1as71m05zcuz0/KSP.log?dl=0

Mod List:

Spoiler

KSP: 1.1.3 (Win64) - Unity: 5.2.4f1 - OS: Windows 10  (10.0.0) 64bit
Filter Extensions - 2.6
Toolbar - 1.7.12
USI Tools - 0.7.2.1
ABookCase Orbital Reference System - 0.3
B9 Animation Modules - 1.0.3
B9 Part Switch - 1.4.3
B9 Aerospace - 6.1.2
B9 Aerospace - 6.1.2
B9 Aerospace HX Parts - 6.1.2
B9 Aerospace Procedural Parts - 0.40.7
Chatterer - 0.9.90.1289
Community Resource Pack - 0.5.4
Connected Living Space - 1.2.1.5
Contract Configurator - 1.14
Contract Pack: Anomaly Surveyor - 1.6
CC-CP-SCANSat - 0.6.0.1
Contract Pack: Clever Sats - 1.1.0.1
Contract Pack: Field Research - 1.1.7
Contract Pack: Giving Aircraft a Purpose - 1.2.6
Contract Pack: Initial Contracts - 1.1.2
Contract Pack: Kerbal Academy - 1.1.3
Contract Pack: Bases and Stations - 3.2.2.1
Contract Pack: RemoteTech - 2.0.2
Contract Pack: Sounding Rockets - 1.0.3
Rover Missions - 0.1.4
Contract Pack: Unmanned Contracts - 0.3.20
Contract Pack: Tourism Plus - 1.4.2
CustomBarnKit - 1.1.9
Deadly Reentry - 7.4.5
DMagic Orbital Science - 1.3.0.2
CapCom Mission Control On The Go - 1.0.2.3
Contract Parser - 1.0.4
Contracts Window Plus - 1.0.6.4
Progress Parser - 1.0.5
Dynamic Deflection - 1.2.1
Engine Lighting - 1.4.5
EVA Struts - 1.0.2
EVA Transfer - 1.0.4
Ferram Aerospace Research - 0.15.7.2
Firespitter - 7.3
Fuel Tanks Plus - 1.10
Haystack Continued - 0.5.1
HeatControl - 0.3.2
Interstellar Fuel Switch - 2.1
In Flight Flag Switcher - 1.0.2
JSIAdvTransparentPods - 0.1.7
RasterPropMonitor - 0.27
Kerbal Attachment System - 0.5.9
Kerbal Construction Time - 1.3.4
Kerbal Engineer Redux - 1.1.1
Kerbal Joint Reinforcement - 3.2
Graphotron - 0.4
MFS - 0.3.2
Kerbal Inventory System - 1.2.12
KRASH - 0.5.18.1
Historian Extended - 1.2.4.12
KSP-AVC Plugin - 1.1.6.1
KWRocketryRedux - 3.0.11
LaserDist - 0.9.2
Lithobrake Exploration Technologies - 0.3.5
MissionController 2 - 1.3.8
ModularFlightIntegrator - 1.1.6
ORIGAMI Antennas - 0.9.5
NavHud - 1.3.1
Docking Port Alignment Indicator - 6.4
NearFutureConstruction - 0.6.4
NearFutureElectrical - 0.7.5
NearFuturePropulsion - 0.7.3
NearFutureSolar - 0.6.2
NearFutureSpacecraft - 0.5.1
EVAHandrailsPackContinued - 0.2.1.1
Final Frontier - 1.0.10.2467
NRAP - 1.5.1.1
OPT Spaceplane Parts - 1.8.1.2
PartCommander - 1.1.1
Pilot Assistant - 1.12.5
Kerbal Planetary Base Systems - 1.1
PlanetShine - 0.2.5
Procedural Parts - 1.2.4
RCS Build Aid - 0.8
RealChute - 1.4.1.1
RealFuels Stockalike Configs - 3.2.1
RealPlume - Stock - 0.10.7
Real Scale Boosters - 0.14.5
Real Scale Boosters Stockalike - 0.3
RemoteTech - 1.7.1
AmpYear - 1.3.4
DeepFreeze Continued... - 0.22.3
ResearchBodies - 1.7.2
SCANsat - 1.1.6.3
SmartParts - 1.8
SolverEngines - 2.2
Spacetux - 0.3.10.1
SpaceY Expanded - 1.1.9
SpaceY Lifters - 1.13
StageRecovery - 1.6.4
Strategia - 1.2.4
TAC Fuel Balancer - 2.8
TakeCommand - 1.4.1
TarsierSpaceTechnology - 6.3
TextureReplacer - 2.4.13
TAC Life Support - 0.12.1
Kerbal Alarm Clock - 3.7.1
Alternate Resource Panel - 2.8.1
Transfer Window Planner - 1.5.1
TweakScale - 2.2.13
USI Core - 0.2.4
Freight Transport Tech - 0.5.4
Konstruction - 0.1
Malemute Rover - 0.1.4
Sounding Rockets - 0.4.4
USI Survivability Pack - 0.5.4
VenStockRevamp - 1.9.2
Waypoint Manager - 2.5.3
OSE Workshop - 0.14
[x] Science! - 4.20

 

 

PS: i wish i had your awesome skills in log reading

Share this post


Link to post
Share on other sites

@Filigan - The contracts from @inigma tend to have lots and lots of components to it - so you'll need to read over it carefully that your vessel is meeting all the other parameters before the altitude stuff gets checked off.  At a high level, it'll only fire off for a sounding rocket, which needs the launch stick, sounding rocket core and a specific sounding rocket motor.

EDIT - As for the historic mission contracts... I'd have to know which contract that is causing the issue (and possibly a screenshot of the contracts app).  As far as I can tell there's no issues related to Contract Configurator in the log.

Edited by nightingale

Share this post


Link to post
Share on other sites

i did a quick check on the requirements, but this is not the cause of the problem, as you can see on this screenshot, all requirements are met:

Spoiler

3A6AC583DB8B9B340387C2DACCCDC8458B78543E

Maybe this is some sort or weird incompatibility with a mod you would not expect to be related with this?

i'm about to go nuts if i have to play the "install one mod at a time" game once again :confused:

Edited by Filigan

Share this post


Link to post
Share on other sites
26 minutes ago, Filigan said:

i did a quick check on the requirements, but this is not the cause of the problem, as you can see on this screenshot, all requirements are met:

  Hide contents

3A6AC583DB8B9B340387C2DACCCDC8458B78543E

Maybe this is some sort or weird incompatibility with a mod you would not expect to be related with this?

i'm about to go nuts if i have to play the "install one mod at a time" game once again :confused:

I think I know what it is - it's because of the way @inigma set up the contracts with the vessel tracking.  I'm willing to bet that it's tracking some old vessel (maybe one that doesn't exist any more).  I'd suggest cancelling and re-accepting the contract.  Let me know if that fixes it.

Share this post


Link to post
Share on other sites

Yep, this solved it.  thanks! =)

I will leave i t there for today, and check on the historic missions pack tomorow, 

Share this post


Link to post
Share on other sites
On 7/1/2016 at 10:29 PM, nightingale said:

I have no idea - this shouldn't happen.  What version were you upgrading from/to?

This happened when I went from 1.12.1 to 1.13. I just upgraded to 1.14 this evening and have not run into issues. I'm not really sure what happened, but if I can get it to happen again, I'll get my log, upload it, and let you know.

Share this post


Link to post
Share on other sites
8 minutes ago, nerf_hurrdurr said:

This happened when I went from 1.12.1 to 1.13. I just upgraded to 1.14 this evening and have not run into issues. I'm not really sure what happened, but if I can get it to happen again, I'll get my log, upload it, and let you know.

If I had to take guess, I'd say you loaded up 1.12.x in KSP 1.1.3 - I could see that causing the type of issue you described.

Share this post


Link to post
Share on other sites
1 hour ago, nightingale said:

If I had to take guess, I'd say you loaded up 1.12.x in KSP 1.1.3 - I could see that causing the type of issue you described.

Ah yes, I did run 1.1.3 with 1.12.1 running. Wanted to check the compatibility of my mod load! Thanks for your responses!

Share this post


Link to post
Share on other sites
40 minutes ago, nerf_hurrdurr said:

Ah yes, I did run 1.1.3 with 1.12.1 running. Wanted to check the compatibility of my mod load! Thanks for your responses!

Yeah, best bet in that situation is KSP-AVC, as it'll tell you on the main menu what's out of date (so you don't need to load up the save).  Of course CKAN can tell you before you load up the game, but it can take a bit longer to get updated.

Share this post


Link to post
Share on other sites

Ok, Historic missions work just fine. Maybe something just got screwed up during the previous install.

 

Sorry for the false alarm, i just assumed the problem persisted the reeinstall after i had something similar going on with SR

 

Edited by Filigan

Share this post


Link to post
Share on other sites

@nightingale

I'm looking at my rover missions contract pack, and it's very strange;

For the RoverExplore contracts (file is iteratorRover.cfg), it works, but the completedmessage is not displayed, even when the contract is completed.

I see the following in the log file:

Contract (Rover Expedition): Research complete!  Good work.

<b><color=#8BED8B>Completion Rewards:</color></b> 
<color=#B4D455>£  10,000   </color>
<color=#E0D503>¡ 1   </color>

Here is a link to both log files:  https://www.dropbox.com/s/ebe4jymj9jlyk4e/RoverLog.zip.zip?dl=0

While this install has a number of mods installed, this happens when only the minimal number of mods is installed also.

CC installed via CKAN, version: 1.14.0

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.