Jump to content

[1.10.x] Mark IV Spaceplane System (August 3)


Nertea
 Share

Recommended Posts

59 minutes ago, Agustin said:

Why does this mod come with so many folders? Are they all neccesary?

IS B9PartSwitch neccesary?
Aso what is .DS_Store ?

.DS_Store is not necessary.  Everything else in the zip's GameData is required (those are other mods upon which this one depends).

Link to comment
Share on other sites

This Mod doesn't work with KSP 1.2.2. the MK-4 fuel tank texture(long and short) is all glitchy, and all fuel tanks don't carry fuel and cannot be configured.

Edited by imkrazy
NEVERMIND. I DELETED ALL OF THE MOD FOLDERS EXCEPT FOR THE ACTUAL MOD...
Link to comment
Share on other sites

Hello everybody, I have started this (almost) fully reusable mun mission, and I have finished part 1 of a 3 part mission. It uses these awesome Mk-4 parts on my super shuttle (they are very pretty and stock-a-like, @Nertea you have done an amazing job with them!) so I'd thought I better show it off.

Here is the album: http://imgur.com/gallery/ROVmo 

Link to comment
Share on other sites

Here is part 2 of the almost fully reusable mun mission, this time I am launching a kerbin departure stage made with sstu parts to hook up with the lander/habitat that is in LKO. Once again the shuttle is used to lift it to LKO, so i thought it be best to post it here as well.

The album: http://imgur.com/gallery/7lqHy

Edited by SpaceBadger007
Link to comment
Share on other sites

I'm getting some seriously nasty drag with these parts. Riding at the sound barrier, I'm getting over 400kN of drag on a basic LF fuselage, even though it's supposedly occluded by the cockpit, which is itself getting over 150kN. Note that a Mk2 Mk3 craft built almost identically gets about 12kN on both. I mean, I get that the parts are bigger, but thirty times more drag? Something screwy going on here. I see there was some drag discussion a few pages back, but other than "strap on more broadswords" it doesn't seem to have been resolved.

Edited by Jarin
wrong size
Link to comment
Share on other sites

15 minutes ago, Agustin said:

It does work for me...

And you can corroborate this with logs to establish that there aren't silent errors being thrown?  Or are you instead (helpfully, of course) simply reporting that you use it either alone or with some list of other mods with no user-visible ill effects?

Link to comment
Share on other sites

Just now, MisterFister said:

And you can corroborate this with logs to establish that there aren't silent errors being thrown?  Or are you instead (helpfully, of course) simply reporting that you use it either alone or with some list of other mods with no user-visible ill effects?

I don't really know tha it doesn't throw silent errors no. But I can tell you I am using over 70 mods besides this and it does work everything fine.

Link to comment
Share on other sites

9 hours ago, MisterFister said:

@Nertea do I understand correctly that though the OP in this thread (and a metadata visible to SpaceDock or CKAN) indicate that this mod v2.3.3 is keyed to KSP v1.2.1, it'd still work well on KSP v1.2.2?

 

7 hours ago, MisterFister said:

And you can corroborate this with logs to establish that there aren't silent errors being thrown?  Or are you instead (helpfully, of course) simply reporting that you use it either alone or with some list of other mods with no user-visible ill effects?

 

Geez.. if you're gonna be this particular, why not just install the damn thing and check the error logs yourself? Then you'll have empirical evidence.

Sorry if I've offended, but I'm getting sick of all the "Does X work with X?" posts on the forums.. Has everybody gotten too flamin' lazy to just test things themselves and see what happens? In any other game, I'd ascribe it to lack of imagination and/or intelligence, but with KSP, the player is pretty much assumed to have those already, or they wouldn't keep playing it. So I figure it must be laziness.

Link to comment
Share on other sites

On 12/30/2016 at 10:47 AM, Nertea said:

Screenshots are helpful for use in reproducing this. 

Okay, I vaguely copied the plane from the SpaceDock header for a testbed:
lpWToOE.png

All tests are performed at mach 0.97; or 345m/s at sea level. Autopilot used to maintain constant flight for consistent readings.

Spoiler

kFTfHID.png 45MHDek.png

Not quite as bad as before. The "snoopy" mimics the stock aerodynamic nose cone pretty closely, but that's still something like 5x more drag than I'd expect on the cockpit.

m8Arbbx.png

The service bay has weirdly little drag. That only goes up to about 3.5 even with the hatches open.

sf0G7fH.png

And back to lots of drag.

Incidentally, the intakes seem to be getting the same drag multiplier as the fuselage segments. Compare shoulder intake to stock shock cone. About 5x drag again.

iysBJMU.png HisRwla.png

The 2.5m shock cone is at 15kN, but I have nothing to directly compare that to, lacking stock intakes at that size.

Hope that's helpful. Let me know if I can test further.

Edit: should state for the record, no FAR or any other mod that modifies atmospheric physics.

Edit2: Just noticed, those body segments are getting more lift than your average wing. That might have something to do with it. Maybe I should just make flying fuselages. o.o

Edited by Jarin
Link to comment
Share on other sites

On 11/20/2016 at 9:22 AM, TheReadPanda said:

But I was seeing some rather large (huge) drag arrows for parts that should have been 'protected' like the fuel tanks etc. Now I was told that the weight is part of the math and this might be why.

On 11/21/2016 at 1:21 AM, Michaelo90 said:

The drag problem seems to affect the crew cabin too, a tank behind it gets way too much drag just like behind a cargo bay.

I've recently been having this problem also, but I don't believe it's due to mass. I've created a plane that gets into orbit quite easily with a cargo bay. If I swap it out for the crew cabin (making the plane lighter, by the way) the plane refuses to go supersonic, even in a dive. There definitely seems to be an issue with the crew cabin regarding drag.

Link to comment
Share on other sites

4 hours ago, Rayder said:

I've recently been having this problem also, but I don't believe it's due to mass. I've created a plane that gets into orbit quite easily with a cargo bay. If I swap it out for the crew cabin (making the plane lighter, by the way) the plane refuses to go supersonic, even in a dive. There definitely seems to be an issue with the crew cabin regarding drag.

In the meantime, the proper strategy seems to be "use enough engines to make a brick wall go supersonic".

 

Edited by Jarin
Link to comment
Share on other sites

6 hours ago, gilflo said:

Stellaris 1380T Mark IV SSTO - 6000DV in orbit - I do not have any drag problem....

 

Considering that you're headed for the sound barrier while in a 45 degree climb, I suspect you're well into "supersonic brick wall" territory. :P

 

Link to comment
Share on other sites

I am running this under 1.2.2 with a number of other mods, to include Near Future Tech and Community Tech Tree.

I thought there were two manned cockpit parts?  I am only seeing one (the rounder one without a docking port).  As far as I can tell, I see all the other Mk IV parts and have the requisite tech trees unlocked.

Any idea what might be causing this?

Link to comment
Share on other sites

The vulture cockpit is higher up in the tech tree

3 hours ago, BainDrago said:

I am running this under 1.2.2 with a number of other mods, to include Near Future Tech and Community Tech Tree.

I thought there were two manned cockpit parts?  I am only seeing one (the rounder one without a docking port).  As far as I can tell, I see all the other Mk IV parts and have the requisite tech trees unlocked.

Any idea what might be causing this?

 

Link to comment
Share on other sites

I DID IT! I FINALLY DID IT!

I have been trying to develop a reliable Mk IV SSTO that could deliver a 40T payload to Minus consistently for a long time. I know there are other designs and people have done it before but I wanted to build my own. Well with the help of KSPIE I have cracked the code. Pics soon to come...

2 Antimatter initiated fusion reactors, with thermal turbo jets and 2 turbo fans from this mod pack. A touch of clipping wizardry for aesthetics and weight distribution and viola! Works like a charm. Note: procedural wings were also used but probably not necessary.

Harpy Mk IV Google Drive

Sorry can't insert images from my google drive directly to the post. I have made the folder public though so anyone can view them. I saved quite a few of the vessel loaded and not, on the runway, on decent, and in orbit. Note: the KER display

It takes off hard and fast launching off the end of the runway, but quickly climbs to a ~45 deg pitch and holds that to about 35-40kM before starting a slight and gentle gravity turn. In this example I made a 69,300kM x 102kM orbit without a maneuver node (no nodes to orbit, it's kinda my thing) without any heating or shock effects. This has taken some practice and I still have room to improve, but either of those conditions means you are wasting fuel fighting the atmosphere and gravity.

I don't start the reversible turbo fans (forward mode) until about 5kM and don't got full throttle until 10kM. TWR drops to ~1.0 at 22kM where I shutdown the turbo fans, close intakes, and switch turbo jets over to liquid fuel; they run on atmosphere alone until this point. With the 41,305kg payload in this example, not to mention 13 Kerbals, the Turbo jets provide 1.95 TWR on liquid fuel even at 23kM. At orbit I still have 2,000dV to play with as you will note in the KER window, but the front take on the crew cabin still has 1200 LF, ~600dV more. This is done to keep the CoM in front of the CoL, and preserve emergency fuel for returning and landing.

If you have further questions don't hesitate to ask, here or in PM I will respond. BTW, the reversible turbo fans are useful for landing and stopping without drag chutes.

Edited by Aaron Also
Pics or it didn't happen!
Link to comment
Share on other sites

Is the arcadia-539 turbofan engine from this mod? If so,, I would like to report an issue with this part. Just put it in the SPH and open the log. It throws the number 4 constantly, and maybe it is also throwing red messages when flying with it.

Edited by Agustin
Link to comment
Share on other sites

  • 2 weeks later...
On 1/14/2017 at 4:26 PM, Agustin said:

Is the arcadia-539 turbofan engine from this mod? If so,, I would like to report an issue with this part. Just put it in the SPH and open the log. It throws the number 4 constantly, and maybe it is also throwing red messages when flying with it.

I think this is fixed with the latest build of my deployable engine plugin, but I will test and check. 

@Jarin: I've opened up an investigative ticket on GitHub. I'll see what I can do to fix it. Can I get the craft file you have there?

Link to comment
Share on other sites

3 hours ago, Nertea said:

I think this is fixed with the latest build of my deployable engine plugin, but I will test and check. 

@Jarin: I've opened up an investigative ticket on GitHub. I'll see what I can do to fix it. Can I get the craft file you have there?

This should be pretty close. Though I think it'll happen to any Mk4 craft. If it doesn't, I'd love to see how to avoid it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...