Nertea

[1.6.x] Mark IV Spaceplane System (January 21, 2019)

Recommended Posts

2 minutes ago, HebaruSan said:

In fact all the recent comments say the opposite, people are using this mod on 1.2.2 and waiting for an update for 1.3, which Nertea has begun working on.

Ooohhh, that does make more sense. Thanks for the quick reply.

Share this post


Link to post
Share on other sites

I've replaced all dependency libraries with newer ones from other mods & it works OK for me in 1.3

But I'd prefer to see something new & sweet (as always) in update from Nertea :) 

Share this post


Link to post
Share on other sites
On 6/7/2017 at 6:28 PM, limofs said:

To fix crashes on 1.3 I suggest deleting subfolder of parts called engines. Not sure about you, but I have not ever used these engines and without them this mod works just fine for me with 1.3

 

11 hours ago, NomenNescio said:

Based on these other comments here, it would seem people have got this mod working with v1.3, could anyone share how they did this, because I get a crash every single time I try to load up the game with this mod. Like are you omitting any of the additional folders that come with this mod?

According to the post I quoted above your quoted post, try deleting the subfolder of parts called "Engine", to get it to work with KSP 1.3. I'm currently waiting for Nertea to update this mod, but might try this myself too.

The subfolder is as follows...

GameData\MarkIVSystem\Parts\Engine

I'm guessing that one or all the engine parts are not compatible with the new KSP 1.3, so as long as you don't mind not using the engines from this mod for now, the rest of the mod may work. Hope this helps.

Edited by GJNelson

Share this post


Link to post
Share on other sites

This post is not to ask for status update, nor to hurry up. This work understandably  takes time, and many thanks for putting it in .

Glad the other parts are working, but patiently waiting for engines to get updated. frankly that's what I use mostly from this mod - awesome lift fans embedded into OPT wings for an awesome VTOL craft.

 

Regards!

Share this post


Link to post
Share on other sites

The update from June 30, 2016 mentions that there is now a USI Life Support compatibility patch for the MarkIV, but I cannot seem to locate it in the latest version 2.3.6. Consequently, non of the pods offer any life support. Is it possible to obtain this patch somehow?

Share this post


Link to post
Share on other sites
8 minutes ago, trias702 said:

The update from June 30, 2016 mentions that there is now a USI Life Support compatibility patch for the MarkIV, but I cannot seem to locate it in the latest version 2.3.6. Consequently, non of the pods offer any life support. Is it possible to obtain this patch somehow?

This mod isn't in 1.3 yet, so that's probably why it's not working for you.

Unless you're in 1.2.2, then maybe you're running life support at 1.3? I dunno.

EDIT: Unless the life support patch is an extra folder, I don't know, I haven't downloaded it yet, since I'm patiently waiting for compatibility :D

Share this post


Link to post
Share on other sites

Love this mod with OPT parts. Those two mods have replaced B9 for me. Cant wait for this to be fully updated. No rush though. Just wanted to say I love this mod. :D

Share this post


Link to post
Share on other sites

C'mon, folks. Mod makers hate pushing for updates and has pushed some modders out of the community altogether. Be patient, sit back, and use 1.2.2 for now or move through 1.3 without for a while longer.

Share this post


Link to post
Share on other sites

Paradoxically, people asking for updates make me want to work on it less.

In fact, they make me want to stop making mods for the game. Who'da thought!

Every time someone asks me for an update, I insert another FFT model (4-6 hours of work ) before I touch Mk4 again!

Edited by Nertea

Share this post


Link to post
Share on other sites
50 minutes ago, Nertea said:

Paradoxically, people asking for updates make me want to work on it less.

In fact, they make me want to stop making mods for the game. Who'da thought!

Every time someone asks me for an update, I insert another FFT model (4-6 hours of work ) before I touch Mk4 again!

Correct me if I'm wrong, but shouldn't the KSP 1.2.2 version of Mk4 work just fine with KSP 1.3? Mk4 contains no compiled code, just parts files, patches, and art assets. It contains dependencies to the following modules:

- B9PartsSwitch

- Community Resource Pack

- Deployable Engines

- Firespitter

- Near Future Props

All of which have already been updated for 1.3. Assuming you have all of those installed for 1.3, then Mk4 should work perfectly under 1.3, no?

Share this post


Link to post
Share on other sites
52 minutes ago, trias702 said:

Correct me if I'm wrong, but shouldn't the KSP 1.2.2 version of Mk4 work just fine with KSP 1.3? Mk4 contains no compiled code, just parts files, patches, and art assets. It contains dependencies to the following modules:

- B9PartsSwitch

- Community Resource Pack

- Deployable Engines

- Firespitter

- Near Future Props

All of which have already been updated for 1.3. Assuming you have all of those installed for 1.3, then Mk4 should work perfectly under 1.3, no?

Hence why I'm not too bothered about update speed. 

Share this post


Link to post
Share on other sites
3 hours ago, Nertea said:

Hence why I'm not too bothered about update speed. 

One question - it says above one of the dependencies is Deployable Engines, but I don't see a link for that here and the links I do find take me to Kerbal Atomics. Is KA a replacement for Deployable Engines?

Share this post


Link to post
Share on other sites
2 minutes ago, vossiewulf said:

One question - it says above one of the dependencies is Deployable Engines, but I don't see a link for that here and the links I do find take me to Kerbal Atomics. Is KA a replacement for Deployable Engines?

KA and several of the NFT mods come with Deployable Engines included.

Share this post


Link to post
Share on other sites
9 hours ago, Nertea said:

Hence why I'm not too bothered about update speed. 

My install did have a Plugins folder with 2 dll's, AnimatedIntakes.dll and TweakableAnimator.dll. One or both of them may be a problem as 1.3 crashes for me if I have MarkIVSystem folder in the GameData tree. I just moved the folder to a temp storage on another drive for now as a note to one I'm waiting for.

Share this post


Link to post
Share on other sites
10 hours ago, Nertea said:
11 hours ago, trias702 said:

Correct me if I'm wrong, but shouldn't the KSP 1.2.2 version of Mk4 work just fine with KSP 1.3? Mk4 contains no compiled code, just parts files, patches, and art assets. It contains dependencies to the following modules:

- B9PartsSwitch

- Community Resource Pack

- Deployable Engines

- Firespitter

- Near Future Props

All of which have already been updated for 1.3. Assuming you have all of those installed for 1.3, then Mk4 should work perfectly under 1.3, no?

Hence why I'm not too bothered about update speed. 

Haha! I feel rather stupid now! How did I not notice this! :D

@Nertea Are there any craft or save breaking changes planned for the next release of MkIV?

Share this post


Link to post
Share on other sites
10 hours ago, canisin said:

@Nertea Are there any craft or save breaking changes planned for the next release of MkIV?

No.

11 hours ago, Vorg said:

My install did have a Plugins folder with 2 dll's, AnimatedIntakes.dll and TweakableAnimator.dll. One or both of them may be a problem as 1.3 crashes for me if I have MarkIVSystem folder in the GameData tree. I just moved the folder to a temp storage on another drive for now as a note to one I'm waiting for.

Neither of those plugins are supposed to be used anymore. 

Share this post


Link to post
Share on other sites

@Nertea I am just a random nobody that just sort of exists here and there and I do not post much or ever, as it is a pain and a hassle (I am sure some can relate)  However, I just wanted to express my thanks to you, for every single amazing mod that you work on. The time and effort that is put into them and how much of your free time it must consume. Patience is a virtue that most lack, I can only hope you have a great day and be safe and thank you for everything you have created, are creating, and plan to create. I am sure it will be amazing. 

Share this post


Link to post
Share on other sites
On 17.7.2017 at 8:43 PM, Nertea said:

No.

Neither of those plugins are supposed to be used anymore. 

Well, I have the same problem. With MKIV in Game Data the Game (1.3) crashes. I tried to remove AnimatedIntakes.dll and TweakableAnimator.dll. But the game crushes anyway.

Share this post


Link to post
Share on other sites

FWIW: I just installed this mod in 1.3 and it seems to be working fine.  I built a test plane using MkIV fuselage parts and tried out several of the engines (Scimitar, Broadsword, Valkyrie, Arcadia), and they're all working correctly (including mode switching on the dual-mode engines, and the Arcadia's thrust reverser).

I omitted the MarkIVSystem/Plugins folder since Nertea said those plugins aren't actually used anymore.  I also omitted all the other top-level folders besides MarkIVSystem (e.g. NearFutureProps, DeployableEngines, etc.), and instead used the newer versions of those things that are bundled with Nertea's other mods.  It looks like MkIV itself works fine in 1.3, and the problems people've had are just from the outdated bundled dependencies.

Share this post


Link to post
Share on other sites
7 hours ago, Wyzard said:

FWIW: I just installed this mod in 1.3 and it seems to be working fine.  I built a test plane using MkIV fuselage parts and tried out several of the engines (Scimitar, Broadsword, Valkyrie, Arcadia), and they're all working correctly (including mode switching on the dual-mode engines, and the Arcadia's thrust reverser).

I omitted the MarkIVSystem/Plugins folder since Nertea said those plugins aren't actually used anymore.  I also omitted all the other top-level folders besides MarkIVSystem (e.g. NearFutureProps, DeployableEngines, etc.), and instead used the newer versions of those things that are bundled with Nertea's other mods.  It looks like MkIV itself works fine in 1.3, and the problems people've had are just from the outdated bundled dependencies.

My experience has been the same. MkIV is very much usable in 1.3.

Share this post


Link to post
Share on other sites
Spoiler
18 hours ago, Wyzard said:

FWIW: I just installed this mod in 1.3 and it seems to be working fine.  I built a test plane using MkIV fuselage parts and tried out several of the engines (Scimitar, Broadsword, Valkyrie, Arcadia), and they're all working correctly (including mode switching on the dual-mode engines, and the Arcadia's thrust reverser).

I omitted the MarkIVSystem/Plugins folder since Nertea said those plugins aren't actually used anymore.  I also omitted all the other top-level folders besides MarkIVSystem (e.g. NearFutureProps, DeployableEngines, etc.), and instead used the newer versions of those things that are bundled with Nertea's other mods.  It looks like MkIV itself works fine in 1.3, and the problems people've had are just from the outdated bundled dependencies.

 

As mentioned above Mk. IV Systems are very much usable in 1.3 with the 1.2.2 version. It is a nice hold over until @Nertea has the time to give an official update, Till then I will enjoy it with all of the other amazing mods they have made.

 

one of my major goals as a Twitch Streamer and Youtube Content Creator is to give back to all the amazing mod Devs once I actually start making something from this adventure. Till then all I can do is just express the love, gratitude, and patience that all Mod Devs deserve for all the tireless hard work they do, coding, developing, and modeling. <3

 

have a good day Ner and everyone else ^_^

Share this post


Link to post
Share on other sites

After removing the plugin folder with the dll's, I tried again and it still crashed. Tried removing the engines folder mentioned above and that does seem to fix it. But I couldn't find any dll's in that folder. Anyone figure out if it is all the engines are just one or 2? Only thing in those folders are .cfg, .dds and .mu

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.