Nertea

[1.6.x] Mark IV Spaceplane System (January 21, 2019)

Recommended Posts

7 minutes ago, Vorg said:

After removing the plugin folder with the dll's, I tried again and it still crashed. Tried removing the engines folder mentioned above and that does seem to fix it. But I couldn't find any dll's in that folder. Anyone figure out if it is all the engines are just one or 2? Only thing in those folders are .cfg, .dds and .mu

You don't have to delete anything, just use the updated versions of the bundled mods. I think firespitter is the only one not bundled with any of nerteas other mods.

Share this post


Link to post
Share on other sites
1 hour ago, Vorg said:

Tried removing the engines folder mentioned above and that does seem to fix it. But I couldn't find any dll's in that folder.

1 hour ago, HoveringKiller said:

You don't have to delete anything, just use the updated versions of the bundled mods.

In particular, DeployableEngines comes with Cryogenic Engines, which has been updated for 1.3.  And it does contain a DLL.  (Or did you mean some other "engines folder"?)

Share this post


Link to post
Share on other sites

I was talking about the Engines folder in "MarkIVSystem" folder. The MarkIVSystem is the only folder I am pulling from the zip, rest of the stuff I have from other mods.

Firespitter is being maintained by Roverdude now and I have the latest main parts that mods use. As far as I can tell, the Firespitter mod as a whole hasn't been updated for awhile, at least the posted version hasn't changed. RoverDude is going through it and updating all the parts.

Removing the Engine folder from MarkIVSystem allows it to run. So something in that sub folder tree is the problem. I have 84 mods listed by AVC with MarkIVSystem installed and don't see any other problems with the Engine folder removed. With it in, the game crashes during startup.

 

Think this will get you the logs from the last crash: https://www.dropbox.com/s/b86p3a2dna5dbgv/2017-07-24_191718.zip?dl=0

Edited by Vorg

Share this post


Link to post
Share on other sites

I have the whole MarkIVSystem/Parts/Engine folder and my game doesn't crash.  I even tested flying planes with several of the engines.

Maybe you have an outdated version of a plugin that's used by the engines?  Loading the engine configs could trigger the plugin to crash even though it's not really the engine's fault.

Share this post


Link to post
Share on other sites

don't know what it would be, everything else got updated by other mods and most everything uses AVC. The only thing saying there is an update is ground construction included with Roverdudes mods.

Share this post


Link to post
Share on other sites

Redownload all the NTF mods and Firespitter, delete them from your GameData and reinstall, it should work perfectly well.

Share this post


Link to post
Share on other sites

I have been trying to keep all the parts updated by going to the sources. The module manager dll still being included is 2.8.0, but the current version 2.8.1 

I found the problem though, it was a secondary folder in GameData called "DeployableEngines". It seems the MarkIV mod is the only Nertea mod that uses it, so it wasn't getting updated and was outside the MarkIVSystem folder so I missed it.

Share this post


Link to post
Share on other sites
2 hours ago, Vorg said:

I found the problem though, it was a secondary folder in GameData called "DeployableEngines". It seems the MarkIV mod is the only Nertea mod that uses it, so it wasn't getting updated and was outside the MarkIVSystem folder so I missed it.

That's the one I mentioned earlier when I didn't know what "engines folder" you were referring to.  Cryogenic Engines has a 1.3 version of DeployableEngines.

Share this post


Link to post
Share on other sites
28 minutes ago, Trekkie148 said:

Can this mod work for 1.3? I really want this mod for ksp 1.3 please?

Please read the last two pages of this thread.

Share this post


Link to post
Share on other sites
23 minutes ago, Merkov said:

Please read the last two pages of this thread.

I know how to install this but this crashes or stops when 3/4th the way done. If you have a KSP 1.3 version of MKIVsystem then please leave a download?

Share this post


Link to post
Share on other sites
7 minutes ago, Trekkie148 said:

I know how to install this but this crashes or stops when 3/4th the way done. If you have a KSP 1.3 version of MKIVsystem then please leave a download?

Crash log, perhaps?

Seriously, read the last two pages, the community has found a workaround until Nertea completes working on the update for MarkIV.

And remember, patience is a virtue. If we wait quietly and patiently, giving Nertea puppy dog eyes, he'll probably cave and throw us a tasty treat.

Share this post


Link to post
Share on other sites

It works fine for me as long as you have the 1.3.0 deployable engines plugin installed.

 

Would be super nice to have modular fuel tanks compatibility though.  My planes fly on hydrazine and I can't put that in these parts, currently.

Share this post


Link to post
Share on other sites

@paneledberry Hi, and a very warm welcome to the community! We would appreciate it very much if you could read back a few posts (or even a couple of pages) before asking that question. Thanks :)

Share this post


Link to post
Share on other sites
14 hours ago, ss8913 said:

It works fine for me as long as you have the 1.3.0 deployable engines plugin installed.

 

Would be super nice to have modular fuel tanks compatibility though.  My planes fly on hydrazine and I can't put that in these parts, currently.

Might be a good time to learn how MFT works and contribute a patch then!

8 hours ago, paneledberry said:

when will this be updated for 1.3?

Two days later than it was before.

Edited by Nertea

Share this post


Link to post
Share on other sites
Just now, Nertea said:

+2 days from the last planned update time.

I guess it will happen in the Near Future

Share this post


Link to post
Share on other sites

... badumpsh.

In all seriousness it's getting fairly close. Just a few bugs to solve.

Share this post


Link to post
Share on other sites
6 hours ago, Deddly said:

@paneledberry Hi, and a very warm welcome to the community! We would appreciate it very much if you could read back a few posts (or even a couple of pages) before asking that question. Thanks :)

 thanks, sorry about that

Edited by paneledberry

Share this post


Link to post
Share on other sites
18 hours ago, MaverickSawyer said:

If we wait quietly and patiently, giving Nertea puppy dog eyes, he'll probably cave and throw us a tasty treat.

2 hours ago, Nertea said:

... badumpsh.

In all seriousness it's getting fairly close. Just a few bugs to solve.

 

See? Told you it'd work. :wink:

Share this post


Link to post
Share on other sites
On 8/8/2017 at 9:34 AM, Nertea said:

Might be a good time to learn how MFT works and contribute a patch then!

Two days later than it was before.

@Nertea - OK.  I'd like to let you look at this before I submit it to the MFT author for inclusion in that mod, since it contains MM patches for several other part mods... here it is:

 

@PART[mk4fuselage-1] {
	MODULE {
		name = ModuleFuelTanks
		volume = 16000
		type = Fuselage
		basemass = volume * 0.000714
	}
}

@PART[mk4fuselage-2] {
	MODULE {
		name = ModuleFuelTanks
		volume = 8000
		type = Fuselage
		basemass = volume * 0.000714
	}
}

@PART[mk4fuselage-3] {
	MODULE {
		name = ModuleFuelTanks
		volume = 4000
		type = Fuselage
		basemass = volume * 0.000714
	}
}

@PART[mk4adapter-1] {
	MODULE {
		name = ModuleFuelTanks
		volume = 3400
		type = Fuselage
		basemass = volume * 0.000714
	}
}

@PART[mk4adapter-2] {
	MODULE {
		name = ModuleFuelTanks
		volume = 3400
		type = Fuselage
		basemass = volume * 0.000714
	}
}

@PART[mk4servicebay-1] {
	MODULE {
		name = ModuleFuelTanks
		volume = 600
		type = Fuselage
		basemass = volume * 0.000714
	}
}

If you want to try this, put it as a .cfg file inside your GameData/ModularFuelTanks/ folder with the other .cfg files, and good to go.  Looks like it even works with the mesh switch.

Share this post


Link to post
Share on other sites

I'll wait a few days for comments on it;  I'll incorporate any requested changes and then send it to the MFT guys for inclusion.

Share this post


Link to post
Share on other sites
1 hour ago, ss8913 said:

I'll wait a few days for comments on it;  I'll incorporate any requested changes and then send it to the MFT guys for inclusion.

I don't use MFT so don't really have the chops to test it. If it's working fine for you it's probably good to submit to them!

Share this post


Link to post
Share on other sites

Hello!

I just wonder, since 1.3 is out if/when this mod will be updated. I don't know how much time creating a mod consumes, don't anything of modding, that's why I ask, I would have no problem playing on an older version, but it's always more intersting to play updated games, but if it's not going to happen, I know I need to make my modpack for 1.2 :P

I realy want to play this mod, but I also know patience!

Thx,

Plegeus o7

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.