Nertea

[1.6.x] Mark IV Spaceplane System (January 21, 2019)

Recommended Posts

6 hours ago, Gorzideudeus said:

 

I would guess that's intentional. If you look at the rapier or some other stock engines, their centers of mass are also offset. I believe it's meant to simulate where the actual center of mass of a realistic jet engine would be. In ksp, most of the 'jet engines' are more like nozzles. The offset center of mass assumes the nozzle will be attached to a turbine or precooler or fuel tank.

That's my understanding...I just realized this today while desperately trying to figure out why my COM was so high on my VTOL.

OK that's sounds right to me.

Share this post


Link to post
Share on other sites
On 11/4/2017 at 7:48 PM, Nertea said:

Yay, I'll investigate that.

I also had this issue, but strangely:

 

i just built a new spaceplane using OPT parts instead of MK4 using the Broadsword engines, and TWR & DV report correctly.  maybe something goofy with the mounts?

Share this post


Link to post
Share on other sites
On 11/5/2017 at 11:21 AM, Gorzideudeus said:

 

I would guess that's intentional. If you look at the rapier or some other stock engines, their centers of mass are also offset. I believe it's meant to simulate where the actual center of mass of a realistic jet engine would be. In ksp, most of the 'jet engines' are more like nozzles. The offset center of mass assumes the nozzle will be attached to a turbine or precooler or fuel tank.

That's my understanding...I just realized this today while desperately trying to figure out why my COM was so high on my VTOL.

Exactly this -- The "part" we get to use in KSP is simply the aft-most part. There was intention of including the rest of the models in the part-building to actually show how big these things were, but people complained because it broke the look of VTOLs, etc. :wink:

Share this post


Link to post
Share on other sites
6 hours ago, agrock said:

Would latest release be okay for KSP 1.3 (not 1.3.1)?

Install it and let us know. @Nertea has too much to do to concern himself with backwards compatibility.

Share this post


Link to post
Share on other sites

Fair enough. I am a Python maintainer and learned to not care about backwards compatibility myself. Thanks Jade.

Edited by agrock

Share this post


Link to post
Share on other sites
On 11/4/2017 at 6:47 PM, MrFancyPL said:

Hello, I have got problem with this mod. Every bi-modal engine (like broadsword, also fans) dont show count of Delta V, TWR and thrust in mods like kerbal engineer or other similar .

Somewhat of a workaround, used TextPad to compared the *.cfg files for the engines vs. version 2.3.6 *.cfg files, and commented the two lines with primaryEngineModeDisplayName  and  secondaryEngineModeDisplayName. After that Kerbal engineer showed Delta V, TWR and thrust, so far nothing has broken.

Share this post


Link to post
Share on other sites
2 hours ago, docthaspok said:

Somewhat of a workaround, used TextPad to compared the *.cfg files for the engines vs. version 2.3.6 *.cfg files, and commented the two lines with primaryEngineModeDisplayName  and  secondaryEngineModeDisplayName. After that Kerbal engineer showed Delta V, TWR and thrust, so far nothing has broken.

Yes that's the reason, I just haven't got around to actually releasing the fix... Bug in squad s stuff, doesn't work as documented.

Share this post


Link to post
Share on other sites

I confirm that current 2.4 works properly with KSP 1.3 even tho its certified for 1.3.1. You could mention that in changelog so that when people browse spacedock for a release matching 1.3 they will know its safe. Just saying. :)

Also I am too experiencing problems with deltav/thrust/etc not being computable. Note its not working in editor mode. In flight mode the redux does show some deltav and other stats, tho obviously I cant tell if those are accurate, but I think they are.

Share this post


Link to post
Share on other sites

Ahem, are you hinting that Thunderbird will be added into KSP mod?

Edit: I noticed Thunderbird 2 has a detachable pod... hangar? :D on struts!

Edited by agrock

Share this post


Link to post
Share on other sites

I have a lot of additional parts, and been playing with Mark 2 and Mark IV and OPT J and OPT K a bit, and noticed there are some parts that exist for some fuselages but not others. I have a hard time keeping track which had which so let me give you a list. Please forgive if some already exist.

I would like to request adding parts for:

  • mk4 decoupler (there is mk2 decoupler)
  • mk4 inline RCS/SAS (there is OPT J part)
  • mk4 inline ramp (like cargo ramp but not as tail, so cargo can be unloaded by ramp but engine mount still be attached onto it)

 

Edited by agrock

Share this post


Link to post
Share on other sites
1 minute ago, JadeOfMaar said:

Yes. It does.

Thanks

Edited by HZ1

Share this post


Link to post
Share on other sites

I'm using in 1.3 without problems. I only receive an alert when opening the game, telling me that is and unsupported version, and to use 1.3.1. Is possible to simple disable it?

Thanks for the awesome mod.

Share this post


Link to post
Share on other sites

My first SSTO with the mod. It's funny the very short body, but I like it. Wet and dry CoM stay at the same point. Get to orbit extremely fast and can dock easily. The Vulture cockpit is exactly what I was looking for, 7 kerbals and a docking port, but would be nice to switch the mono-prop for other resources.

Used only MK4, OPT for the wings and MK2 Expansion for the RCS ports, only 25 parts in total. The only stock part is a hidden fuel cell. Any tips about aerodynamics, air intakes, control surfaces, etc? Since I use a life support mod there isn't much point making it go further than Kerbin SOI.

lN6KMxs.jpg 

Edited by kerbalfreak

Share this post


Link to post
Share on other sites

I haven't dug into the parts files yet, but I think the bottom stack node of the S.C.I.M.I.T.A.R. is mis-aligned. Had to invert an OMS engine from NFSpacecraft, then use rotation shenanigans, to get it to attach.

Share this post


Link to post
Share on other sites
10 hours ago, grungar3x7 said:

I haven't dug into the parts files yet, but I think the bottom stack node of the S.C.I.M.I.T.A.R. is mis-aligned. Had to invert an OMS engine from NFSpacecraft, then use rotation shenanigans, to get it to attach.

Good find, you were right. Slated for next version fix. 

Share this post


Link to post
Share on other sites

Good day

Just checked out the mod and loving it so far. I'm having a small issue with the propellers, as they were the ones that drew me to the mod in the first place. The props change from ''visible'' to ''blurry'' at 30% thrust. It's nothing more than a nuisance as it doesn't seem to affect their performance, but it looks strange in flight as prop RPM shouldn't change that much at lower thrust, as these seem to be more advanced, variable pitch props. It almost looks like I'm viewing them through a camera lens. I'm wondering if there's a way for me to change the "visible" threshold to a much lower number, or get rid of it completely once the ''startup'' animation is complete. 

Thank you

Share this post


Link to post
Share on other sites

Mark IV 2.4.1

  •  Updated B9PartSwitch to 2.1.0
  •  Updated NFProps to 0.2.1
    •  Fixed an issue with localization of multimode engines, worked around KSP issue for KER fix
  • Fixed flipped normal map on 3.75m lift fan
  •  Fixed bottom stack node of SCIMITAR
  •  Some tweaks to IVAs
  •  Added RPM support back in
    •  Provided by Dragon01
    •  RPM support requires the installation of RPM and ASET props

Share this post


Link to post
Share on other sites

If text in cfg files is case sensitive then, mk4turbofan-25-2.cfg line 558 has the first letter in the wrong case for thrustTransform. Inside same cfg all other refs are ThrustTransform.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.