Astronomer

[0.25] Astronomer's Visual Pack - Interstellar V2

Which features do you like the most?  

1,314 members have voted

  1. 1. Which features do you like the most?

    • Semi-Procedural Auroras
      147
    • Clouds for Eve & Jool
      216
    • 29MB Lightning
      112
    • Lens Flare
      111
    • Snow
      152
    • Sandstorms and Surface Dust
      250
    • Atmospheric Scattering
      197
    • Interstellar Music Replacement
      100
    • New Sun
      109
    • Surface Glow
      148


Recommended Posts

I cannot get Jool's clouds to load - Eve's clouds, however, seem to work perfectly fine. Nothing crashes, there just aren't any clouds on Jool.

I'm on Linux x64, runing 64bit KSP with 32GB of RAM - so I doubt memory is the issue. Additionally, I've reduced my mod list down to just HyperEdit and Astonomer's (and its dependencies.)

If I go to Jool and load up the cloud menu (Alt+N) I can select the Jool clouds config file and see layers listed; however, nothing appears to change regardless of how I manipulate them.

Any ideas on what is going wrong?

Log file: http://pastebin.com/76f9Nu6D

Screenshot: http://i.imgur.com/aCMioQO.png

is not an issue

Would you mind telling me why this isn't an issue? I'm not sure what you mean.

Share this post


Link to post
Share on other sites
Would you mind telling me why this isn't an issue? I'm not sure what you mean.

tkw posts out of context gibberish. Ignore them.

Share this post


Link to post
Share on other sites

Anyone got this working with KSP 1.02?

I haven't touched any of the graphics overhaul mods since beta, so I've got a pretty clean install to work with.

Share this post


Link to post
Share on other sites
Anyone got this working with KSP 1.02?

I haven't touched any of the graphics overhaul mods since beta, so I've got a pretty clean install to work with.

It works just fine. You may need to convert the 3 small textures to dds under clouds. But I am running this and all the auroras sun flair (modded into current asset file) and outer planet clouds. Let me know if you need help getting this running. I am using EVE 4.7 by the way, not the overhaul.

Share this post


Link to post
Share on other sites

Awesome, I'll have to give it a whirl this afternoon.

Share this post


Link to post
Share on other sites

I expect this to have already been said, but Interstellar V2 crashes my game every time I start up, even on the lowest possible settings, the most aggressive texture management and regardless of mods installed. Any fixes/whatevers?

Share this post


Link to post
Share on other sites

What are your system specs? I am running interstellar v2 eve 4.7 and a around 25 mods with no ATM. Now I hacked my install to run in 64 bit mode. But I did run interstellar before doing that.

My specs are an intel i7 4790K GeForce gtx 970 and 32gb ram. And I can hit around 120 fps on a 100 part ship

Just pm me if you need more help. I don't want to clutter up Astronomers thread.

Share this post


Link to post
Share on other sites

Having issues installing this mod. I only installed steps 1-3 and it crashes on startup. It doesn't seem to be a memory issue, though. Missing code or something? I get a crash error.

Before installing the mod I save a copy of my GameData folder without it, and restoring that works just fine.

Share this post


Link to post
Share on other sites
Having issues installing this mod. I only installed steps 1-3 and it crashes on startup. It doesn't seem to be a memory issue, though. Missing code or something? I get a crash error.

Before installing the mod I save a copy of my GameData folder without it, and restoring that works just fine.

I was just talking about this with mousethethird

Step 1 but skip Planetshine. It's a minimal gain and it will save you ram anyway.

Step 2 I suggest low res clouds and you can move up from there.

Step 3 don't copy Planetshine, Chatterer or even Distant Object unless you really want one of them.

Next Go to (BoulderCo/Clouds/Textures) move the 4 textures you find there out somewhere else and launch the game. If it works (without clouds) then go download the .dd conversion tool linked below. Convert those 4 textures to .dds be sure to uncheck "flag as normal" put the .dds textures with the same names as before in the folder and try it again - this worked for me before I switched to 64bit (64bit wont help youunless you have the ram to burn 16-32gb) Also if you run a different skybox in texture replacer, convert those files to .dds It'll save you some more ram

.dds conversion tool

http://forum.kerbalspaceprogram.com/threads/98672-WIN-KSP-to-DDS-texture-converter

Hey I've got one,

Anybody get the lightning to work in 1.0.2? It flashes super fast, and I can't figure out how to slow it down to a realistic pace.

Edited by V8jester

Share this post


Link to post
Share on other sites
Next Go to (BoulderCo/Clouds/Textures) move the 4 textures you find there out somewhere else and launch the game.

In BoulderCo/Clouds/Textures I've got more than four textures there. I took that as being in the zip folder, where there are only four.

EDIT: Getting "Unknown file format A8L8, skipping conversion."

Edited by Pingonaut

Share this post


Link to post
Share on other sites

EDIT: Getting "Unknown file format A8L8, skipping conversion."

Make sure the image is in true RGBa and not indexed color.

Share this post


Link to post
Share on other sites
Make sure the image is in true RGBa and not indexed color.

It is. Besides, why would it be different? I got it from the same download.

Share this post


Link to post
Share on other sites

I'm confused by the most recent chatter. How should I treat this mod? 1.0.2 compatible? Incompatible? Partially compatible, but get ready to dig into it and change a lot of things? Partially compatible but a few tweaks needed?

Share this post


Link to post
Share on other sites
I'm confused by the most recent chatter. How should I treat this mod? 1.0.2 compatible? Incompatible? Partially compatible, but get ready to dig into it and change a lot of things? Partially compatible but a few tweaks needed?

It works but you need a decent video card. As well as do a little file bashing. Fallow my last post and if you get lost, pm me

Share this post


Link to post
Share on other sites
It works but you need a decent video card. As well as do a little file bashing. Fallow my last post and if you get lost, pm me

The way I see it it's incompatible. Partially compatible if you're willing to go through some stress.

Share this post


Link to post
Share on other sites

Every time I tried to run the game with this pack installed, it crashed. While watching Quill18's latest video, I saw he was using this mod with no problems. In his mod list he showed that he is forcing the game to run with openGL. I have now tried it and it works, the game loads with this pack installed.

How to force openGL: http://forum.kerbalspaceprogram.com/threads/84203-Less-memory-usage-by-using-OpenGL

I hope this helps and see you chaps in space!

Share this post


Link to post
Share on other sites
The way I see it it's incompatible. Partially compatible if you're willing to go through some stress.

For me, that stress is something I'm not willing to deal with. For the last 2 week, I have been trying to get all my mods to co-exist and play nicely with each other after 1.02. Until there is an update, I am afraid I don't have the patience.

... and this is such a BEAUTIFUL mod... I've been playing it since .2?... it's been on my "must have list" for some time. Scatterer is even more beautiful, and it's still in dev... but right now, it kills my RAM. This was a perfect visual mod for me.

I have to leave this mod behind for now because, beautiful or not, I need to continue exploring the Kerbalverse.

Share this post


Link to post
Share on other sites

I'm still using a highly personalized soup of settings that I've used forever and it still works great, so I'd be perfectly happy... BUT... I simply MUST have those daytime city buildings and streets shown in the "upcoming Paradise" screenshots. Were those ever released in any form? I'm willing to do a lot of tweaking to get them to work, if necessary, but are the textures, at least, available?

Share this post


Link to post
Share on other sites
I was just talking about this with mousethethird

Step 1 but skip Planetshine. It's a minimal gain and it will save you ram anyway.

Step 2 I suggest low res clouds and you can move up from there.

Step 3 don't copy Planetshine, Chatterer or even Distant Object unless you really want one of them.

Next Go to (BoulderCo/Clouds/Textures) move the 4 textures you find there out somewhere else and launch the game. If it works (without clouds) then go download the .dd conversion tool linked below. Convert those 4 textures to .dds be sure to uncheck "flag as normal" put the .dds textures with the same names as before in the folder and try it again - this worked for me before I switched to 64bit (64bit wont help youunless you have the ram to burn 16-32gb) Also if you run a different skybox in texture replacer, convert those files to .dds It'll save you some more ram

.dds conversion tool

http://forum.kerbalspaceprogram.com/threads/98672-WIN-KSP-to-DDS-texture-converter

Hey I've got one,

Anybody get the lightning to work in 1.0.2? It flashes super fast, and I can't figure out how to slow it down to a realistic pace.

Is there a .dds conversion tool that works on Mac?

Share this post


Link to post
Share on other sites

I love this pack. But sadly, I can't use it. Means of memory reduction are out the window too. OpenGL, ATM, even attempts for DDS conversion failed. (BTW, I'm running this on a good HP laptop, it can run most of my mods with ease.)

Share this post


Link to post
Share on other sites

Got the same issue with this pack crashing the game after installing optional features. As I understood from the previous comments it's mostly due to the textures being png and not dds, but DDS converter also says me "Unknown file format A8L8, skipping conversion." when I try to convert this textures as it did for Pingonaut.

Can please someone manually convert them into dds, please?=) I'm not sure about all that possible "color profile" options...

Share this post


Link to post
Share on other sites
Is there a .dds conversion tool that works on Mac?

I am not aware of one.

and for those of you looking to make this pack work. It does work for for me 1.0.2 win 7 x64 so I do have more memory to play with. But I did have it running on a 32 bit install with OpenGL initially.

So all I did was convert the textures in clouds/particles to dds. Also I believe I converted the aurora textures to dds and that's it. I left everything else alone. The other thing is this only works with EVE not EVE Overhaul. The extras folder isn't all usable. Lightning doesn't work but the aurora dust and snow all work (non of which I converted) I have not seen astronomer in a while so I am willing to share my working, modified zip file with updated lens flares and main menus logo. But I don't want to step on anyone's toes or cause any issues.

Share this post


Link to post
Share on other sites

V8jester I have x64 windows too and it works fine with only core mod installed. I also managed to convert files from the "particles" to the dds ones. But as I try to install something exept the aurora from the "optional" folder it starts to crash=(

Share this post


Link to post
Share on other sites

Hmmmm, another thing I did was increase the size of my page file in windows. To allot more space for my virtual memory. Usually your page file is set to around 8gb and I hover around 7gb just for KSP. So honestly I am starting to think the virtual memory is just as much an issue for everyone as the physical memory. Google page file size increase. It 'a pretty easy. I set mine to 32 GB and I run 32GB of pc 1866 ram. Do you have a memory usage monitor installed, so you can see just how much you are using?

My mod list is up on my thread linked below, so it can handle a ton of mods in this configuration.

Share this post


Link to post
Share on other sites

I'm testing it on the completely new install, so it can't be any memory issue. It also works with OpenGL but I don't want to use that.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.