Astronomer

[0.25] Astronomer's Visual Pack - Interstellar V2

Which features do you like the most?  

1,313 members have voted

  1. 1. Which features do you like the most?

    • Semi-Procedural Auroras
      146
    • Clouds for Eve & Jool
      216
    • 29MB Lightning
      112
    • Lens Flare
      111
    • Snow
      152
    • Sandstorms and Surface Dust
      250
    • Atmospheric Scattering
      197
    • Interstellar Music Replacement
      100
    • New Sun
      109
    • Surface Glow
      148


Recommended Posts

I'm testing it on the completely new install, so it can't be any memory issue. It also works with OpenGL but I don't want to use that.

I don't use OpenGL any more either since I converted to 64bit. But the page file increase may have some merit. Give it a shot and see if that helps you out. You can always put it back.

Share this post


Link to post
Share on other sites

Little update.

After a couple of hours of careful testing it figured out that it's the dust thing that breaks game for me.

Changing pages file is too much for me=) I'll better wait for someone who knows what he does to fix that somehow=)

Error log - here

UPD: I did nothing and it occasionally loaded. And when next five times it didn't. Weird.

Edited by Riverey

Share this post


Link to post
Share on other sites

detail1.png seems to be what's causing all my crashes. And none of the online .dds converters I've been trying seem to work on it. :huh:

Share this post


Link to post
Share on other sites

Mitchz95 yes, it looks like it. But the detailaurora file is also very big and looks like it also crashes the game.

Share this post


Link to post
Share on other sites

I halved the size of the file and successfully converted it, but the clouds don't appear at all when I load up the game. Not sure what I did wrong.

Edited by Mitchz95

Share this post


Link to post
Share on other sites
I halved the size of the file and successfully converted it, but the clouds don't appear at all when I load up the game. Not sure what I did wrong.

If you are using the dds converter found on the forums. Make sure 'flag as normal" is unchecked. That got me the first time

Share this post


Link to post
Share on other sites
If you are using the dds converter found on the forums. Make sure 'flag as normal" is unchecked. That got me the first time

That one doesn't work on Macs. I used an online converter.

EDIT: I got it to load, but ...

35b7amh.jpg

Edited by Mitchz95

Share this post


Link to post
Share on other sites
That one doesn't work on Macs. I used an online converter.

EDIT: I got it to load, but ...

http://oi62.tinypic.com/35b7amh.jpg

Try this. I don't mean to break any rules just trying to help out. I will remove the download if there are any issues with permission.

https://drive.google.com/file/d/0B8xWfykJ5pY_N0Z1N3o5bHN2eW8/view?usp=sharing

Share this post


Link to post
Share on other sites

That is the exact file I am using right now.... OpenGL? Nvidia, Radeon or onboard graphics? Also how much ram do you have / are you using? I have a walk through on my forum thread under "how to hit 60-120fps"

Also I'm going to ask again. Anyone get the lightning to work? I'm taking another shot at it right now.

edit: It looks like you are using some other texture for the visors at least. is this with a fresh install of texture replacer?

Share this post


Link to post
Share on other sites
That is the exact file I am using right now.... OpenGL? Nvidia, Radeon or onboard graphics?

Not sure. I'm playing on a Mac, so it could be any or none of those.

EDIT: According to "About This Mac":

Graphics Intel HD Graphics 3000 512 MB

Also how much ram do you have / are you using? I have a walk through on my forum thread under "how to hit 60-120fps"

I have 8GB of Ram on my computer. Not sure how much I'm using, but the game seems to perform no differently than when I had 4GB a few months ago.

Which thread?

edit: It looks like you are using some other texture for the visors at least. is this with a fresh install of texture replacer?

Not a fresh install, but I'm not sure what difference that would make. I tried it without TR installed and the problem persisted.

Edited by Mitchz95

Share this post


Link to post
Share on other sites
Not sure. I'm playing on a Mac, so it could be any or none of those.

EDIT: According to "About This Mac":

Graphics Intel HD Graphics 3000 512 MB

I have 8GB of Ram on my computer. Not sure how much I'm using, but the game seems to perform no differently than when I had 4GB a few months ago.

Which thread?

Not a fresh install, but I'm not sure what difference that would make. I tried it without TR installed and the problem persisted.

In my honest but not wanted opinion. I think your issue is trying to run this on onboard graphics unfortunately. I have an Nvidia GTX970 with 4GB of dedicated ram, along with 32GB of physical ram, and another 32GB for my page file aswell as im running a 64bit hack for windows. This sounds as though it is just the limit of your rig.

Edit: I figured out the lightnig.

CLOUDS_SETTINGS{
GUI_KEYCODE = N
}
CLOUD_LAYER_PACK
{
CLOUD_LAYER
{
SAVED
{
body = Kerbin
altitude = 7500
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -2.5E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.0133333
y = 0.1
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Duna
altitude = 10000
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -3E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.1333333
y = 0.2
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Laythe
altitude = 6250
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -1E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.1333333
y = 0.2
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Eve
altitude = 7750
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -5E-07
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.1333333
y = 0.2
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
}


Edited by V8jester

Share this post


Link to post
Share on other sites
In my honest but not wanted opinion. I think your issue is trying to run this on onboard graphics unfortunately. I have an Nvidia GTX970 with 4GB of dedicated ram, along with 32GB of physical ram, and another 32GB for my page file aswell as im running a 64bit hack for windows. This sounds as though it is just the limit of your rig.

I'm not sure why that would affect my clouds the way they do. Wouldn't it just crash the game?

And I got the AVP to work on an earlier game, a year or so ago. I didn't stick with it long, but it worked.

Share this post


Link to post
Share on other sites

For lightning adjust the alpha layers transparency. A while back somebody posted the .cfg with all the alphas adjusted to 1. I still found it a bit to high and put mine around 0.35, A little more on "stormy" planets.

Share this post


Link to post
Share on other sites

Gonna try this now (I am currently running KSPRC with x64)

Next Go to (BoulderCo/Clouds/Textures) move the 4 textures you find there out somewhere else and launch the game. If it works (without clouds) then go download the .dd conversion tool linked below. Convert those 4 textures to .dds be sure to uncheck "flag as normal" put the .dds textures with the same names as before in the folder and try it again - this worked for me before I switched to 64bit (64bit wont help youunless you have the ram to burn 16-32gb)

I've got 8 textures in BoulderCo/Clouds/Textures (fresh EVE 7.4 install) aside from the 3 textures under ./particle. Which ones are necessary to convert, all of them?


detail1.png
detaileve1.png
duna1.png
eve1.png
jool1.png
joolLayers1.png
joolLayers2.png
kerbin1.png

Also I assume you keep the additional textures from the astronomers install as they are (.png), and only convert them if you need to reduce RAM allocation, right? I've got 32gb on this machine btw, so no need for RAM savings.

Share this post


Link to post
Share on other sites
Gonna try this now (I am currently running KSPRC with x64)

I've got 8 textures in BoulderCo/Clouds/Textures (fresh EVE 7.4 install) aside from the 3 textures under ./particle. Which ones are necessary to convert, all of them?


detail1.png
detaileve1.png
duna1.png
eve1.png
jool1.png
joolLayers1.png
joolLayers2.png
kerbin1.png

Also I assume you keep the additional textures from the astronomers install as they are (.png), and only convert them if you need to reduce RAM allocation, right? I've got 32gb on this machine btw, so no need for RAM savings.

Hey sorry about the confusion. When I wrote that I noted the wrong folder. So convert the 3 images under "particles" to dds, also convert the aurora textures to dds and that's it. I have everything running on my computer at home with 512 clouds and 8k auroras. If you get hung up just let me know what issues you're having. Also copy and past the config I posted for the lightning if you want to run that. I didn't update the lightning for any planet but kerbin. I'll repost a final version once I tinker a little more.

Share this post


Link to post
Share on other sites

I compared both variations (with dds converted textures and without), but I didn't notice any benefit besides some memory saving, so just skip the conversion step with KSP x64. I guess you only need that if you don't use KSP x64 and therefore only have about 3.5gb memory. With all optional stuff included and 8K/max textures KSP allocates ~6gb after loading (no other mods included).

Some important info (maybe) for people having problems:

  • convert the 3 textures in BoulderCo/Clouds/Textures/particle after you've finished the AVP installation, because they get replaced
  • install the mod DDSLoader if you don't have it already
  • rename/backup your existing GameData folder and install AVP in a new GameData folder, including the 3 required mods (PlanetShine is optional). It's easier to solve any problems without other mods, and you can merge your GameData folder afterwards (careful with duplicated files from your backup folder)

I also merged AVP with Proots KSPRC (TextureReplacer, DDSLoader, KittopiaSpace), so you have the best of both visual packs, and it works perfectly together. To replace the KSPRC skybox with the AVP one you need to delete the (KSPRC) GalaxyTex*.dds files from \TextureReplacer\Default.

If you get hung up just let me know what issues you're having. Also copy and past the config I posted for the lightning if you want to run that.

I removed the lightning effects, don't really like them. Everything works except the sun glare (not lens flare), it's just the default visual and not detailed like the screenshot from Astronomers Imgur album. Or is that some additional mod?

Share this post


Link to post
Share on other sites
I compared both variations (with dds converted textures and without), but I didn't notice any benefit besides some memory saving, so just skip the conversion step with KSP x64. I guess you only need that if you don't use KSP x64 and therefore only have about 3.5gb memory. With all optional stuff included and 8K/max textures KSP allocates ~6gb after loading (no other mods included).

Some important info (maybe) for people having problems:

  • convert the 3 textures in BoulderCo/Clouds/Textures/particle after you've finished the AVP installation, because they get replaced
  • install the mod DDSLoader if you don't have it already
  • rename/backup your existing GameData folder and install AVP in a new GameData folder, including the 3 required mods (PlanetShine is optional). It's easier to solve any problems without other mods, and you can merge your GameData folder afterwards (careful with duplicated files from your backup folder)

I also merged AVP with Proots KSPRC (TextureReplacer, DDSLoader, KittopiaSpace), so you have the best of both visual packs, and it works perfectly together. To replace the KSPRC skybox with the AVP one you need to delete the (KSPRC) GalaxyTex*.dds files from \TextureReplacer\Default.

I removed the lightning effects, don't really like them. Everything works except the sun glare (not lens flare), it's just the default visual and not detailed like the screenshot from Astronomers Imgur album. Or is that some additional mod?

The lens flare does work but is more involved to install. You need to edit "sharedasset9.assets" You need to pull the "sunflare.tex" from (AVP Interstellar v1) and then merge it into the sharedasset9 from ksp 1.0.2 as the old asset file will not work with 1.0.2 but the flare will. You need unity asset explorer to accomplish this.

Edited by V8jester

Share this post


Link to post
Share on other sites

ok thanks, will try.

I wonder, what is sharedasset10.assets in the pack then for if not for the lens flare? I didn't notice any difference with it.

//edit

Nevermind, I figured it out (I guess). you need to extract the sun_flare.tex from sharedasset10.assets (the one included in the pack) and replace the original sun_flare in \KSP_Data\sharedasset9.assets. This is the current (1.0.2) asset file with the sun flare.

Edited by Inchoately

Share this post


Link to post
Share on other sites

I'm certain without any reasonable doubt that detail1 is the reason my game won't work with AVP. I try shrinking it (changing the dimensions to 4096x4096), but that prevents the clouds from loading. Removing other RAM-heavy mods has no effect. Is there any other way to reduce the impact of the file without shrinking it or converting to dds (which doesn't work unless I change the size beforehand)?

As it stands now the game usually loads all the way, but crashes just as it's about to go to the menu screen.

Share this post


Link to post
Share on other sites
I'm certain without any reasonable doubt that detail1 is the reason my game won't work with AVP. I try shrinking it (changing the dimensions to 4096x4096), but that prevents the clouds from loading. Removing other RAM-heavy mods has no effect. Is there any other way to reduce the impact of the file without shrinking it or converting to dds (which doesn't work unless I change the size beforehand)?

As it stands now the game usually loads all the way, but crashes just as it's about to go to the menu screen.

I threw ya a PM. You also may want to try reducing it to 2048x2048. The clouds still look great at that resolution. (albeit with slightly less pop)

Share this post


Link to post
Share on other sites

simple question way ppls say: "to install the mod DDSLoader" > in 1.0.2 DDS texture are load by default soo way to add other thing what game know to doo by default ?!?!?!?!

Share this post


Link to post
Share on other sites
ok thanks, will try.

I wonder, what is sharedasset10.assets in the pack then for if not for the lens flare? I didn't notice any difference with it.

//edit

Nevermind, I figured it out (I guess). you need to extract the sun_flare.tex from sharedasset10.assets (the one included in the pack) and replace the original sun_flare in \KSP_Data\sharedasset9.assets. This is the current (1.0.2) asset file with the sun flare.

You beat me to it. Last time I tried to explain this, someone jumped on my post and tried to tell me how wrong I was. I figured someone smart enough would figure it out and back me up :) Correct, the old "sharedasset10.assets" from interstellar v1 has the "sun_flare.tex" files in them for each of the different sun flares. You just need to extract the one you want with unity asset explorer. Open a copy of "sharedasset9.assets" in your ksp_data directory. Import the extracted sun flare into the copied asset and save. (I only write this to help those that don't know how to use asset explorer yet. It's a little tricky to use the first time. But once you figure out the sequence, its actually pretty easy. And if you guys need help with it don't hesitate to ask.

Unity Asset Explorer: http://zenhax.com/viewtopic.php?t=36

I'm certain without any reasonable doubt that detail1 is the reason my game won't work with AVP. I try shrinking it (changing the dimensions to 4096x4096), but that prevents the clouds from loading. Removing other RAM-heavy mods has no effect. Is there any other way to reduce the impact of the file without shrinking it or converting to dds (which doesn't work unless I change the size beforehand)?

As it stands now the game usually loads all the way, but crashes just as it's about to go to the menu screen.

This is why I really Like x64 Currently the only textures I have converted are my 8k planet textures I found from another pack. And the only reason they are converted to .dds is to reduce loading time.

I would suggest you install a memory monitor like the one linked bellow. and see just how much ram you are using. And match that against what you have installed. if you are well bellow the limit. Try my page file suggestion I posted. if you are still stuck post your system specs and we will go from there.

Memory Usage Monitor: http://forum.kerbalspaceprogram.com/threads/99494-0-90-MemoryUsage-v1-20-2015-02-19

simple question way ppls say: "to install the mod DDSLoader" > in 1.0.2 DDS texture are load by default soo way to add other thing what game know to doo by default ?!?!?!?!

Correct, You do not need ddsloader anymore as, dds textures load natively now.

Edited by V8jester

Share this post


Link to post
Share on other sites
This is why I really Like x64 Currently the only textures I have converted are my 8k planet textures I found from another pack. And the only reason they are converted to .dds is to reduce loading time.

I would suggest you install a memory monitor like the one linked bellow. and see just how much ram you are using. And match that against what you have installed. if you are well bellow the limit. Try my page file suggestion I posted. if you are still stuck post your system specs and we will go from there.

Memory Usage Monitor: http://forum.kerbalspaceprogram.com/threads/99494-0-90-MemoryUsage-v1-20-2015-02-19

The monitor doesn't work on Mac. And which "page file suggestion"? I didn't see you link anything in your previous posts.

Here are my specs, I think.

Processor 2.4 GHz Intel Core i5

Memory 8 GB 1600 MHz DDR3

Graphics Intel HD Graphics 3000 512 MB

Serial Number C1MHJF98DV13

Software Mac OS X Lion 10.7.5 (11G63)

Edited by Mitchz95

Share this post


Link to post
Share on other sites

It looks like that integrated graphics card is likely the culprit. I really doubt it'll be able to handle AVP, even if you killed the texture sizes.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.