Astronomer

[0.25] Astronomer's Visual Pack - Interstellar V2

Which features do you like the most?  

1,314 members have voted

  1. 1. Which features do you like the most?

    • Semi-Procedural Auroras
      147
    • Clouds for Eve & Jool
      216
    • 29MB Lightning
      112
    • Lens Flare
      111
    • Snow
      152
    • Sandstorms and Surface Dust
      250
    • Atmospheric Scattering
      197
    • Interstellar Music Replacement
      100
    • New Sun
      109
    • Surface Glow
      148


Recommended Posts

A couple of ignorant questions if folks are willing to help:

1) In an effort to get this running smoothly with all my other mods, I manually converted all of the PNG files in /Clouds/Textures and /Clouds/Particles to DDS files (using Paint.net, saved as DXT5). And the game loaded great! But there's some very squirrely behavior, like clouds suddenly disappearing or reappearing as I pass them, or what appear to be dust storms blowing through KSC. Is this something inherent to converting the files to DDS, or did I just screw something up here? Anybody encountered similar?

2) Does it make more sense, if my goal is saving RAM / avoiding crashes, to try the DDS route, or try reducing the resolution of the PNGs?

3) I've seen some references to reducing the PNGs to half-resolution, which I assume means resizing them on a 50% scale (which should result in a file that's 25% the total area of the original). Since I'm graphically illiterate, does it have to be a 50% scale? Could I, for example, resize them on a 60% scale? 70% scale? 75% scale?

Many thanks in advance for any edification y'all can provide.

Well before you crush your texture resolution. Out I curiosity, what are your specs as well as how many mods are you running? If you managed to convert all the textures I'm not sure the impact there. As I only converted three textures with the ksp dds tool. I now just run 64 bit mode and have a kitchen sink mentality with mods :) but before I say "just convert" lets really see what we can do with your current setup. Did you experience this issue before you converted the textures?

Share this post


Link to post
Share on other sites

3) I've seen some references to reducing the PNGs to half-resolution, which I assume means resizing them on a 50% scale (which should result in a file that's 25% the total area of the original). Since I'm graphically illiterate, does it have to be a 50% scale? Could I, for example, resize them on a 60% scale? 70% scale? 75% scale?

Many thanks in advance for any edification y'all can provide.

You would want your textures to be constrained by powers of 2, IE 1024x2048, 512x512, 256x64, etc...

Per your 1), I also had odd popping when I converted the cloud textures to DXT5 (all of them, not just the particles), I just ended up compressing the PNGs and keeping their resolution the same. I also liked the Better Atmosphere Clouds over Astonomers and currently use a mix of Astronomers, Better Atmospheres, and KillAshley's New Horizons clouds.

Share this post


Link to post
Share on other sites
Well before you crush your texture resolution. Out I curiosity, what are your specs as well as how many mods are you running? If you managed to convert all the textures I'm not sure the impact there. As I only converted three textures with the ksp dds tool. I now just run 64 bit mode and have a kitchen sink mentality with mods :) but before I say "just convert" lets really see what we can do with your current setup. Did you experience this issue before you converted the textures?

I share your "kitchen sink" approach, unfortunately (or in my case, more like a disease).

The specs aren't where I want themâ€â€4 GB RAM, so 64-bit is fairly pointless (I'm working on an upgrade, but it'll be a while). Intel i5, Windows 7 Professional (64-Bit, for whatever point that has). Radeon R9 200, or thereabouts.

Mods? I don't think I could name them all even if I were looking in my GameData folder, but I'll give it a try.

  • [*]Outer Planets

[*]EVE

[*]Interstellar (Hopefully!)

[*]Active Texture Management

[*]Chatterer

[*]Community Resource Pack

[*]Community Tech Tree

[*]Contract Configurator, and various packs

[*]Custom Barn Kit

[*]DDS Loader

[*]Distant Object

[*]Planetshine

[*]Precise Node

[*]Firespitter

[*]HeatControl

[*]HGR

[*]Interstellar Fuel Switch

[*]JDiminishingRTG

[*]KAS, KAX, KIS, KCT, KER, KJR

[*]Kopernicus

[*]KW Rocketry

[*]Near Future Construction/Electrical/Props/Propulsion/Solar/Spacecraft

[*]Final Frontier

[*]TextureReplacer, with PimpMyKerbals

[*]Critical Temperature Gauge

[*]SCANsat

[*]Science Alert

[*]SETI (Tech Tree, Contracts, Greenhouse)

[*]Station Parts Expansion

[*]StationScience

[*]DMagic Orbital Science

[*]TakeCommand

[*]Transfer Window Planner

[*]USI (Not all of it, but just assume all of it)

[*]Universal Storage

[*]Ven Stock Revamp

[*]Field Scientist Pack

For what it's worth, I can miraculously run all of that except Interstellar, although I force DirectX11 in order to do so (I hate OpenGL). I have used Edge of Oblivion successfully, and I confirmed that if I convert the AVP-INT clouds textures to .DDS that I can run the game as wellâ€â€with odd visual effects. I also confirmed that if I half-res them (I half-res'd all of them, "just to be safe"), I can run the game. I'm just curious what the most effective "compromise" is on quality and actually-running-the-game, and to make sure I go about it properly.

(All of that said, just to repeat, I am planning a system upgrade at some point this summer... just have to get motivated enough to start doing the research and acquisition.)

You would want your textures to be constrained by powers of 2, IE 1024x2048, 512x512, 256x64, etc...

Per your 1), I also had odd popping when I converted the cloud textures to DXT5 (all of them, not just the particles), I just ended up compressing the PNGs and keeping their resolution the same. I also liked the Better Atmosphere Clouds over Astonomers and currently use a mix of Astronomers, Better Atmospheres, and KillAshley's New Horizons clouds.

Ah, good to know.

I did look at Better Atmospheres as well... I don't think I'm adept enough to merge several packs seamlessly, but I do like the look of it. Particularly if it's less demanding on the system, I'd happily use Better Atmosphere's atmospheres (I'm indifferent about Joolian asteroids), Interstellar's auroras, and just "some good-enough clouds".

What did you use for .PNG compression? That's an area that I'm not yet familiar with (read above, "graphically illiterate")

Edited by Landwalker

Share this post


Link to post
Share on other sites
I share your "kitchen sink" approach, unfortunately (or in my case, more like a disease).

The specs aren't where I want themâ€â€4 GB RAM, so 64-bit is fairly pointless (I'm working on an upgrade, but it'll be a while). Intel i5, Windows 7 Professional (64-Bit, for whatever point that has). Radeon R9 200, or thereabouts.

Mods? I don't think I could name them all even if I were looking in my GameData folder, but I'll give it a try.

[*]Outer Planets

[*]EVE

[*]Interstellar (Hopefully!)

[*]Active Texture Management

[*]Chatterer

[*]Community Resource Pack

[*]Community Tech Tree

[*]Contract Configurator, and various packs

[*]Custom Barn Kit

[*]DDS Loader

[*]Distant Object

[*]Planetshine

[*]Precise Node

[*]Firespitter

[*]HeatControl

[*]HGR

[*]Interstellar Fuel Switch

[*]JDiminishingRTG

[*]KAS, KAX, KIS, KCT, KER, KJR

[*]Kopernicus

[*]KW Rocketry

[*]Near Future Construction/Electrical/Props/Propulsion/Solar/Spacecraft

[*]Final Frontier

[*]TextureReplacer, with PimpMyKerbals

[*]Critical Temperature Gauge

[*]SCANsat

[*]Science Alert

[*]SETI (Tech Tree, Contracts, Greenhouse)

[*]Station Parts Expansion

[*]StationScience

[*]DMagic Orbital Science

[*]TakeCommand

[*]Transfer Window Planner

[*]USI (Not all of it, but just assume all of it)

[*]Universal Storage

[*]Ven Stock Revamp

[*]Field Scientist Pack

For what it's worth, I can miraculously run all of that except Interstellar, although I force DirectX11 in order to do so (I hate OpenGL). I have used Edge of Oblivion successfully, and I confirmed that if I convert the AVP-INT clouds textures to .DDS that I can run the game as wellâ€â€with odd visual effects. I also confirmed that if I half-res them (I half-res'd all of them, "just to be safe"), I can run the game. I'm just curious what the most effective "compromise" is on quality and actually-running-the-game, and to make sure I go about it properly.

(All of that said, just to repeat, I am planning a system upgrade at some point this summer... just have to get motivated enough to start doing the research and acquisition.)

So it sounds like you are already fairly mod heavy I'm honestly impressed you got that much to run on 32 bit. And dx11 I've heard of causing funny visual issues (not blaming just a thought) you also run active texture management (Really no choice with your mod list and a 32 bit setup) I wonder if you wrote a MM file to have ATM ignore all of the astronomers folder since it is converted to dds. And sacrifice a little more memory for smoother graphics. But how close to the 4GB ceiling are you currently? Besides the fact the system needs some of that memory to run already. Have you tried adjusting the size of your page file to make up for the lack of memory? Instructions are 5 posts up. I set mine to 32GB a long time ago (Overkill I know but I have 2TB of HDD to play with and 16GB of RAM)

Edited by V8jester

Share this post


Link to post
Share on other sites

Pretty mod-heavy indeed!

I haven't monkeyed around at all with ModuleManager or ATM, and wouldn't really know how to off-hand.

Right now my virtual memory is set at about 6.5GB. I have about 17.5 GB "free" on my "main" HDD, but also have a total of 3 TB in two other HDDs (1TB internal, 2TB external), of which about 2.5TB is "free".

At this precise moment, after loading the game and sitting at the main menu, and bearing in mind that I'm using DX11 and (at the moment) half-sized Astronomer PNGs, KSP is eating about 2.6GB. I'll occasionally see it sneak up to the 2.9GB neighborhood, but since moving to DX11 it's never gotten higher than that despite piling mods on top of mods on top of mods.

I've noticed the very occasional, and generally very minor, visual hiccup with DX11 (for example, when using overlapping deployed parachutes, things get weird), but for the most part it's surprisingly... workable. Which certainly doesn't mean that it isn't contributing to my weird magical-disappearing-clouds-and-Kerbin-dust-storms issue when I was trying to DDS conversion, but using half-sized PNGs and no other changes has avoided that, so at least that part seems to have something to do with them being .DDS files. I'm not attached to the DDS route, I just want things to look pretty (without preventing the game from running altogether) because once I start down the path of graphics snob, for whatever reason I can't stop. :P

-------------------

Edit: Speculative "Am I Potentially Doing This Right?" Questions:

1) If I wanted to tell ATM not to mess with the BoulderCo files, would that just entail going into /ActiveTextureManagerConfigs/BoulderCo.cfg and making changes to the lines under BoulderCo/Clouds/.*? What would be the appropriate changes to make?

ACTIVE_TEXTURE_MANAGER_CONFIG

{

folder = BoulderCo

enabled = true

OVERRIDES

{

BoulderCo/Clouds/.*

{

compress = true

mipmaps = true

scale = 1

max_size = 0

make_not_readable = false

}

BoulderCo/Atmosphere/.*

{

compress = true

mipmaps = true

scale = 1

max_size = 0

make_not_readable = false

}

}

}

2) I do have GIMP, and could use it for compressing the Astronomer PNG files... The question then becomes how much compression?

Edited by Landwalker

Share this post


Link to post
Share on other sites
Pretty mod-heavy indeed!

I haven't monkeyed around at all with ModuleManager or ATM, and wouldn't really know how to off-hand.

Right now my virtual memory is set at about 6.5GB. I have about 17.5 GB "free" on my "main" HDD, but also have a total of 3 TB in two other HDDs (1TB internal, 2TB external), of which about 2.5TB is "free".

At this precise moment, after loading the game and sitting at the main menu, and bearing in mind that I'm using DX11 and (at the moment) half-sized Astronomer PNGs, KSP is eating about 2.6GB. I'll occasionally see it sneak up to the 2.9GB neighborhood, but since moving to DX11 it's never gotten higher than that despite piling mods on top of mods on top of mods.

I've noticed the very occasional, and generally very minor, visual hiccup with DX11 (for example, when using overlapping deployed parachutes, things get weird), but for the most part it's surprisingly... workable. Which certainly doesn't mean that it isn't contributing to my weird magical-disappearing-clouds-and-Kerbin-dust-storms issue when I was trying to DDS conversion, but using half-sized PNGs and no other changes has avoided that, so at least that part seems to have something to do with them being .DDS files. I'm not attached to the DDS route, I just want things to look pretty (without preventing the game from running altogether) because once I start down the path of graphics snob, for whatever reason I can't stop. :P

I have a MM file to ignore textures in my 64GB folder of old and currents mods at home :) I'll dig it up for you and post it later this evening

Share this post


Link to post
Share on other sites

Ok I couldn't find my olf file. So I wrote a new one, and provided I got it right this should prevent ATM from doing anything to your EVE / Astronomers files

ACTIVE_TEXTURE_MANAGER_CONFIG{
folder = BoulderCo
enabled = true

OVERRIDES
{
BoulderCo/CityLights/Textures/.*
{
compress = false
mipmaps = false
scale = 1
max_size = 0
make_not_readable = false
}
}

{
folder = BoulderCo
enabled = true

OVERRIDES
{
BoulderCo/Clouds/Textures/.*
{
compress = false
mipmaps = false
scale = 1
max_size = 0
make_not_readable = false
}
}

{
folder = BoulderCo
enabled = true

OVERRIDES
{
BoulderCo/Clouds/Textures/particle/.*
{
compress = false
mipmaps = false
scale = 1
max_size = 0
make_not_readable = false
}
}

}


Share this post


Link to post
Share on other sites

Spent a long time making this cinematic using your pack, enjoy!

Share this post


Link to post
Share on other sites

Can someone please point me to some install instructions for this mod on the Mac?

Share this post


Link to post
Share on other sites

That download page on Curse is almost unusable - too much going on. Might I suggest that any animations are made somethiing that you have to click on to see, rather than their simply firing off just because you've visited the page? That aside - outstanding work, people! Esme

- - - Updated - - -

Is there any way to be able to get just the aurora or just the dust storms or just the snow? Having now downloaded this I can see I'm going to need to set up a separate instance of KSP to see whether I can run the thing on my system. It'd be nice to be able to just use bits of it in isolation (if that's possible) as well as the whole thing. I'm stunned at how much I can see in teh downloaded archive file though... wow!

Share this post


Link to post
Share on other sites

Is there any way to be able to get just the aurora or just the dust storms or just the snow? Having now downloaded this I can see I'm going to need to set up a separate instance of KSP to see whether I can run the thing on my system. It'd be nice to be able to just use bits of it in isolation (if that's possible) as well as the whole thing. I'm stunned at how much I can see in teh downloaded archive file though... wow!

CKAN allows that afaik.

Share this post


Link to post
Share on other sites

So I REALLY want to use this mod pack. I have one parts pack installed and a few science/game play mods. I installed, using CKAN, clouds medium, DO, PS, atmos. scattering, clouds eve/jool 2k, and snow. The game gets stuck every single time on loading boulderco/clouds/textures/detail1. When I remove it, everything works fine. Any solutions to this? I'm not jumping up and down for openGL because it seems to go hand in hand with reduced frame rate. I'm using an AMD 280x with 8GB of RAM and an Intel i5 3.10GHz

EDIT: Is this some kinda sick joke KSP? http://imgur.com/xQgIefw

Edited by sneff30

Share this post


Link to post
Share on other sites
So I REALLY want to use this mod pack. I have one parts pack installed and a few science/game play mods. I installed, using CKAN, clouds medium, DO, PS, atmos. scattering, clouds eve/jool 2k, and snow. The game gets stuck every single time on loading boulderco/clouds/textures/detail1. When I remove it, everything works fine. Any solutions to this? I'm not jumping up and down for openGL because it seems to go hand in hand with reduced frame rate. I'm using an AMD 280x with 8GB of RAM and an Intel i5 3.10GHz

EDIT: Is this some kinda sick joke KSP? http://imgur.com/xQgIefw

I had the same problems. Try using the detail1.png from the default EVE install instead of the one from AVP. That solved it for me.

Share this post


Link to post
Share on other sites
I had the same problems. Try using the detail1.png from the default EVE install instead of the one from AVP. That solved it for me.

The clouds look a bit sparse but I suppose beggars can't be choosers eh? Much obliged, sir!

Share this post


Link to post
Share on other sites

I absolutely love this mod, but I see a lot of very low altitude clouds on Kerbin, also when I'm in the Main screen (the one with the buildings). Is there a way to remove those and just have high altitude, realistic clouds?

I use ATM (Active Texture Management) but got no render problems. Might this be one?

Share this post


Link to post
Share on other sites
I absolutely love this mod, but I see a lot of very low altitude clouds on Kerbin, also when I'm in the Main screen (the one with the buildings). Is there a way to remove those and just have high altitude, realistic clouds?

I use ATM (Active Texture Management) but got no render problems. Might this be one?

Low altitude clouds? Could you post a screenie. I'm not sure I grasp what you mean. I've been avoiding ATM since .25 as I had more issue trying to make it work and not kill the resolution of IVA's and buttons. Don't get me wrong it's great and irreplaceable when trying to reduce your memory footprint for certain machines. But if you have the hardware for it. It's often better to just drink the coolaid and run 64 bit to open up the memory limit. - I know I'm a broken record on this one for those that have seen me post this before, but hey it just works.

Share this post


Link to post
Share on other sites
Absolutely, here you go.

http://imgur.com/a/oTA4Q#0

They're low and they move REALLY fast. Especially annoying when flying planes (not space-planes).

They start at around 100m and they end around 5km.

This is my config file, just in case. (https://gist.github.com/anonymous/d6afe5e0d6178db52122)

Also I installed the mod using CKAN.

Ok that is weird! Do you use any kind of rescaling mod? Like 64K or what not? It's as though the planet is too big for the clouds. Or are you possibly using EVE WIP? This really works best with EVE 7-4. I have this working on my machine at home with Scatterer and all kinds of extras. I will check my cfg's and if I need to send you some stuff I can.

Also did you happen to see my post with tips and tricks 2 pages back?

http://forum.kerbalspaceprogram.com/threads/102145-0-25-Astronomer-s-Visual-Pack-Interstellar-V2?p=2064915&viewfull=1#post2064915

Share this post


Link to post
Share on other sites

Ok thanks! I am trying to follow your tips to the letter. I have as many mods as you and without ATM the game just crashes while loading.

Share this post


Link to post
Share on other sites
Ok thanks! I am trying to follow your tips to the letter. I have as many mods as you and without ATM the game just crashes while loading.

Yeah like I said ATM has it's place. If you want to run 32 bit it's a necessity!

Share this post


Link to post
Share on other sites

Ok I'm running the 64-bit version now without ATM and the problem seems to be disappeared. Will run some tests and will let you know in case something doesn't work.

Many many thanks for your support man!

Share this post


Link to post
Share on other sites

Ok everything seems to be working perfectly apart from two little things that unfortunately are annoying me a lot.

1 - Whenever I change screen or the game is loading something, there is a pink rectangular box in the bottom right of the screen. It disappears when the new screen loads but I'm afraid that it's consuming more memory than it should because of that.

2 (Possibly related) - The IVA cams in the bottom right whenever I control a manned ship are EXTREMELY laggy and it looks like they run at 4 fps.

The strange thing is that everything else in the game runs perfectly smoothly and also using the debug menu (performance) I have constant 40 fps +.

Do you maybe know what that could be?

I can provide you the list of my mods if needed.

Thanks a lot again for your help.

Share this post


Link to post
Share on other sites
Ok everything seems to be working perfectly apart from two little things that unfortunately are annoying me a lot.

1 - Whenever I change screen or the game is loading something, there is a pink rectangular box in the bottom right of the screen. It disappears when the new screen loads but I'm afraid that it's consuming more memory than it should because of that.

2 (Possibly related) - The IVA cams in the bottom right whenever I control a manned ship are EXTREMELY laggy and it looks like they run at 4 fps.

The strange thing is that everything else in the game runs perfectly smoothly and also using the debug menu (performance) I have constant 40 fps +.

Do you maybe know what that could be?

I can provide you the list of my mods if needed.

Thanks a lot again for your help.

Ok when you installed AVP did you drop in a lens flare or the main menu logo? The asset files are compiled for KSP .25 and won't work with 1.0.4. I had pink boxes all over the place when I was still learning and tried to put a lens flare in .90. The Pink box in the lower right is the animated loading prompt. It has been corrupted. And the IVA cams I thought were always laggy like that? I have instructions on that post 2 pages back for the flares if that's the case.

And as far as 40fps, did you use my instructions on how to hit 60-120 fps?

Edited by V8jester

Share this post


Link to post
Share on other sites

Has anyone gotten Edge of Oblivion to work? I install it but inevitably the memory creeps up and crashes like a memory leak. Simply re-installing EVE (without AVP) stops the problem from occurring.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.