Astronomer

[0.25] Astronomer's Visual Pack - Interstellar V2

Which features do you like the most?  

1,314 members have voted

  1. 1. Which features do you like the most?

    • Semi-Procedural Auroras
      147
    • Clouds for Eve & Jool
      216
    • 29MB Lightning
      112
    • Lens Flare
      111
    • Snow
      152
    • Sandstorms and Surface Dust
      250
    • Atmospheric Scattering
      197
    • Interstellar Music Replacement
      100
    • New Sun
      109
    • Surface Glow
      148


Recommended Posts

Does this mod still work with 1.0.4?

Check here:

http://forum.kerbalspaceprogram.com/threads/128113-%28KSP-1-0-4%29OuterPlanetsMod-Clouds-Standalone

Despite the title, you can just install it in your KSP, and it will work just fine. After installing, install a visual pack, such as Better Atmospheres, KSP renaissance compilation or Astronomer's visual Pack (Interstellar, Interstellar V2 or Edge of Oblivion)

TextureReplacer is already updated, I'm using it in my game. As for PlanetShine, I'm not sure.

Hope this helps

The White Guardian

Share this post


Link to post
Share on other sites

Hi all,

Can someone please help me with installation instructions for Kerbal running on Mac OSX?

Share this post


Link to post
Share on other sites

I saw the bioluminescent Laythe clouds in the imgur gallery, but they are not present in the pack. How do I get them?

Share this post


Link to post
Share on other sites
Hi all,

Can someone please help me with installation instructions for Kerbal running on Mac OSX?

pretty sure its the wrong thread for that ;)

I saw the bioluminescent Laythe clouds in the imgur gallery, but they are not present in the pack. How do I get them?

im afraid you are speaking of the "still in Progress-update" that is not public yet...

Share this post


Link to post
Share on other sites
Has anyone gotten Edge of Oblivion to work? I install it but inevitably the memory creeps up and crashes like a memory leak. Simply re-installing EVE (without AVP) stops the problem from occurring.

Ironically I'm having the same issues, but with AVP Interstellar V2, so I have to use Edge of Oblivion. To answer your question: yes, it is possible to run Edge of Oblivion.

I am using:

- KSP 1.0.4

- E.V.E

- AVP Edge of Oblivion

Hardware:

Intel i3 core

8GB RAM

Intel Graphics HD 4000

If your hardware is better than that, it should be able to run Edge of Oblivion.

Share this post


Link to post
Share on other sites
Ironically I'm having the same issues, but with AVP Interstellar V2, so I have to use Edge of Oblivion. To answer your question: yes, it is possible to run Edge of Oblivion.

I am using:

- KSP 1.0.4

- E.V.E

- AVP Edge of Oblivion

Hardware:

Intel i3 core

8GB RAM

Intel Graphics HD 4000

If your hardware is better than that, it should be able to run Edge of Oblivion.

The integrated graphics as long as they are intel HD 4000 or above, can usually handle it. What I have been seeing is people trying to run a kitchen sink of mods along with graphics improvement mods. Really the only way to do this is to run x64. I run over 50 mods with EVE AVP and Scatterer. I have more details on tips and tricks a few pages back or on my thread linked bellow.

Share this post


Link to post
Share on other sites

i am back to ksp - just installed 104. - will this mod work with KSP 1.0.4?

i had astronomer`s pack on older version it was great.

Share this post


Link to post
Share on other sites
i am back to ksp - just installed 104. - will this mod work with KSP 1.0.4?

i had astronomer`s pack on older version it was great.

Someone else asked this already, this is what I replied:

Check here:

http://forum.kerbalspaceprogram.com/...uds-Standalone

Despite the title, you can just install it in your KSP, and it will work just fine. After installing, install a visual pack, such as Better Atmospheres, KSP renaissance compilation or Astronomer's visual Pack (Interstellar, Interstellar V2 or Edge of Oblivion)

TextureReplacer is already updated, I'm using it in my game. As for PlanetShine, I'm not sure.

Hope this helps

The White Guardian

However, I've tried to install AVP Interstellar V2 and my KSP keeps crashing claiming that it 'ran out of memory'. I advise you to only install the clouds, because part of the mod replaces some stock files, and this part of the mod was designed for 0.25, so I don't think installing that in 1.0.4 would be a good idea.

Other than that, I've successfully installed AVP Edge of Oblivion, and it works just fine.

Hope this helps

The White Guardian

Share this post


Link to post
Share on other sites
Someone else asked this already, this is what I replied:

However, I've tried to install AVP Interstellar V2 and my KSP keeps crashing claiming that it 'ran out of memory'. I advise you to only install the clouds, because part of the mod replaces some stock files, and this part of the mod was designed for 0.25, so I don't think installing that in 1.0.4 would be a good idea.

Other than that, I've successfully installed AVP Edge of Oblivion, and it works just fine.

Hope this helps

The White Guardian

i am back to ksp - just installed 104. - will this mod work with KSP 1.0.4?

i had astronomer`s pack on older version it was great.

I spent a few hours the other day trying to figure out the crash problem with interstellar v2. for me it was one texture file that was the issue. the Kerbin1 file in boulderco/clouds/textures is an 8k image, and as soon as i switched it out with a 4k version it was no problem. theres a bunch of other 8k image files in there, but for some reason that one caused the crashes for me. Could have just been my computer specifically though. these things never seem to be universal lol.

Share this post


Link to post
Share on other sites
Someone else asked this already, this is what I replied:

However, I've tried to install AVP Interstellar V2 and my KSP keeps crashing claiming that it 'ran out of memory'. I advise you to only install the clouds, because part of the mod replaces some stock files, and this part of the mod was designed for 0.25, so I don't think installing that in 1.0.4 would be a good idea.

Other than that, I've successfully installed AVP Edge of Oblivion, and it works just fine.

Hope this helps

The White Guardian

You can make AVP with all the game data add ons work. I had instructions pasted a few pages back as well as on my thread linked in my signature.

Share this post


Link to post
Share on other sites
I had the same problems. Try using the detail1.png from the default EVE install instead of the one from AVP. That solved it for me.

Using the detail1.png from the default EVE install worked for me also. It seems like a big difference in file size. I wonder what I'm not getting by using the EVE file?

Share this post


Link to post
Share on other sites

Astronomer's Interstellar V2 for KSP 1.0.4 (OpenGL recommended if you running this on Windows).

Picture here.

Step 1:

Download Astronomer's Interstellar V2

Download and install Eve, Planet Shine, Texture Replacer (for good sky box) and Distant Object latest versions.

Step 2:

Install the folder "Volumetric Clouds"

Step 3:

Install the folder "Core Mod" except "Chatterer" (not tested with last version of this mod).

Step 4: (optional but recommended)

In the folder "Essential Features": install all without Lens Flare.

In the folder "Extra Features": install Lightings. You can use this file (edited by myself) if you want frequency more realistic according to me.

Step 5: (very optional):

You can install a Sky box more realistic than vanilla (I love Oinker's sky box).

Also, you can install Endraxial Planet Conversions.

Step 6:

Enjoy! :cool:

And sorry if my english is not perfect.

Edited by Misucat

Share this post


Link to post
Share on other sites

Can somebody show me how to incorporate the Edge of Oblivion clouds to only affect Kerbin? I find the atmosphere to be too sparse. I tried replacing the kerbin.png file but it came out odd. Moreover, Jool/Eve/Laythe etc were adversely affected by the change.

Moreover, I would love to be able to get the old sunflare back that I saw in 0.25. Has anybody got a fix for that yet?

Thanks

Share this post


Link to post
Share on other sites

Try editing BoulderCo/Clouds/cloudLayers.cfg and deleting the bits referencing other bodies.

Share this post


Link to post
Share on other sites

Misucat, is PlanetShine required for the pack to work? Or does it just look better that way?

Share this post


Link to post
Share on other sites
Misucat, is PlanetShine required for the pack to work? Or does it just look better that way?

It just looks better. :)

Share this post


Link to post
Share on other sites

You can install a Sky box more realistic than vanilla (I love Oinker's sky box).

Point to note, Oinkers dropbox link returns 404 now so it's been removed or something.

Share this post


Link to post
Share on other sites
Point to note, Oinkers dropbox link returns 404 now so it's been removed or something.

The updated version can be found here.

Share this post


Link to post
Share on other sites
This is awesome, but why doesn't the new sun work in 1.0.4?

You need to edit in the texture using asset explorer. Instructions are in one of my posts a few pages back or on my thread linked in my sig

Share this post


Link to post
Share on other sites

Hey im having problems installing AVP because of the clouds, i did a fresh install of KSP 1.0.4 and installed AVP.

When im going to open the game, it crashes on the end of loading... But if i delete de Clouds.dll in EVE folder, i can load the game.

System Specs: 8GB RAM, NVIDIA GTX 650 2GB, Intel Core i5 3.4Ghz, Windows 8.1, 2 22" Monitor (don't know if it matters)

Error_log: http://pastebin.com/uXDh3c97

Share this post


Link to post
Share on other sites

As mentioned above try this first

My system specs

intel i7 4790K 4.4 GHZ

GeforceGTX 970 4 GB

16GB of pc 1866 ram

Raid 1 on 2 7200 rpm drives

KSP doesn't like fast switching (alt-Tabing). To make it fast switch smoothly as well as gain a minor FPS boost. -popupwindow allows you to run in borderless windowed mode. You'll need to turn off "full Screen Mode" in game. Be sure to set your screen resolution to your monitor / TV's native resolution, or the window won't fit. To run in Borderless windowed mode add " -popupwindow" to the end of your shortcut target field.

A trick that often helps computers with good dedicated graphics cards (sometimes onboard graphics) but not so great processors, is OpenGL. OpenGL allows you to transfer more of the work load from your processor to the video card. Be aware that this is affected by the amount of dedicated memory and the speed of your graphics card. Mods will affect this limit. To run in OpenGL mode add " -forceopengl" to the end of the shortcut target field.

Now Popupwindow and OpenGL can run together. Just don't forget the spaces, your target field should look like this (KSP.exe -popupwindow -forceopengl)

Lastly I do not use it but many people have had good luck forcing DirectX 11, to bring down there memory footprint. KSP Natively runs using DirectX 9 which is more universally accepted by everyone's hardware. But if you want to give this a try place -force-d3d11 in the shortcut target field in place of OpenGL.

KSP Settings

Max physics delta time per frame: 0.03 - This helps a ton

Max Persistant debris: 25- This helps a bit when you don't have the memory to burn

Terrain detail: High

SM3 Terrain Shaders: Enabled

Scatter Density 100%

Render Quality: Fantastic

Texture Quality: Full Res

Fallback Parts Shader: True

Aerodynamic FX Quality: Normal

Edge Highlighting (PPFX): Enabled

Surface FX: Enabled

Screen Resolution: 1920x1080 - Set to native res

Full Screen: Disabled

Anti Aliasing: x2

V-sync: Don't Sync - This is the biggest performance hog

Frame Limit: 180FPS

Pixel Light Count: 8

Shadow Cascade: 4

Windows 7 Page File Settings - Mine is set to 32GB

http://windows.microsoft.com/en-us/windows/change-virtual-memory-size#1TC=windows-7

Configure Memory Usage Monitor to auto start with -opengl and or -popupwindow using one shortcut. - Only works up to 1.0.2

Create a shortcut for memory usage monitor. (Memory monitor linked in mod list)

in the shortcut target field apply either / both (KSP.exe -popupwindow -forceopengl)

When opened, Memory usage will automatically search for "KSP.exe" to auto run the game. If you have hacked KSP to run in 64 bit mode the file you will have created will still be named "KSP.exe" So this still works with the x64 hack

Then you can rename and re icon the memory usage shortcut if you so desire.

You will now have a single icon to launch memory usage and KSP with OpenGL enabled all at once, with one shortcut.

64 Bit Windows

If you want to run massive amounts of part / visual mods, and you have at least 16GB of RAM and a 64bit system (majority are). 64 bit mode will allow you to surpass your 4GB memory limit imposed by a standard 32 bit install. Now when you convert to 64 bit, Do not inundate the mod Devs with bug reports from your 64 bit install. Keep a 32 bit install around to test mod issues before submitting a bug report. I have yet to truly find a bug that was not repeatable in 32 bit with a properly updated mod. There is a reason Squad held back a 64 bit release this time around, and that's because bug tracking was a nightmare. As far as stability, I can play for hours without any issues. But when you start building 250+ part ships and bouncing in and out of the VAB and flight. It will crash eventually, but so will 32 bit under the same circumstances. v1.0.x x64 is far more stable than v.90 x64 ever was. If you want a kitchen sink mentality with mods, as well as not compress your textures to the resolution of a postage stamp. This is by far the best option.

Now that that's out of the way. Linked bellow is a walkthrough on how to convert to 64 bit. As well as a mod utility that will remove the 64 bit block from mods (warning I haven't used Unfixer as the mods I use don't require it - and Sarbian will hate you)

64bit Hack http://forum.kerbalspaceprogram.com/threads/117224-Windows-64-bit-community-workaround

64bit Unfixer http://forum.kerbalspaceprogram.com/threads/113069-KSP-x64-Total-Unfixer

Environmental Visual Enhancement 7-4

I've been getting a ton of questions about how to get EVE running on 1.0.x. Plain and simple x64 Windows runs with no modifications. In 32 bit I only converted the three images under Boulderco/Clouds/Particles to .dds And it ran just fine. Integrated graphics are having a really hard time running EVE. This is due to the fact that KSP is a CPU hog. And when you want your CPU doing double duty running the game and better visuals. At some point it just can't keep up. So far from what I have seen, anything bellow intel HD 4400 won't cut it.

Also if you are running a large amount of mods already you may be hitting the 4GB ceiling. Hence the 64 bit fix above. You can also try increasing the size of your page file to allot more virtual ram as that may be another barrier you are encountering.

First try installing some kind of memory monitor to see just how much RAM and virtual ram you are in fact using. If you are hovering around 3.5 - 3.7GB on a 32 bit install a crash is immanent.

Memory Usage Monitor http://forum.kerbalspaceprogram.com/threads/99494-0-90-MemoryUsage-v1-20-2015-02-19 - Only works up to 1.0.2

GC Monitor http://forum.kerbalspaceprogram.com/threads/92907-1-0-x-GCMonitor-1-2-6-A-graphic-Memory-monitor-(June-18th) - I Haven't used this before

You can also try increasing the size of your page file

Win 7 Page File Adjustment: http://windows.microsoft.com/en-us/windows/change-virtual-memory-size#1TC=windows-7

If you are bellow the memory limit and you have integrated graphics intel HD 4400 (preferably a dedicated graphics card) or better, and are still having issues. Then message me and I will try and help you out as well as further revise this help file.

Astronomers Visual Pack Interstellar v2

AVP takes a little (but not a ton) of tweaking.

The core mod works with EVE 7-4 I converted the three images under Boulderco/Clouds/Particles to .dds as well as the aurora .pngs to .dds and it loaded in 32 bit.

To get the lens flares working in 1.0.x you will need to extract the sun_flare.tex files one at a time from there old .25 asset files and place them in the new 1.0.x asset files one at a time in the KSP_Data folder using Unity asset explorer.

DDS Converter http://forum.kerbalspaceprogram.com/threads/98672-WIN-KSP-to-DDS-texture-converter

Back up your original asset file first!

Unity Asset Explorer http://www.nexusmods.com/pillarsofeternity/mods/27/?

Using Unity asset explorer 1.3 or newer

First open "sharedassets10.assets" from the astronomers visual "jj Abrams" Lens flare. Right click "sun_flare.tex"

click "extract" this is the file you will need.

Rename Folder created by unity asset explorer from "sharedassets10" to "sharedassets9"

(folder will be automatically created in the same directory as the asset explorer .exe file)

Now back up and open "sharedassets9.assets" from your ksp_data Directory. In Asset Explorer Right click "Sun_flare.tex" and click 'Import"

(It will Import from the folder you already created and renamed)

Save the changes and, boom the asset9 file in your ksp_data folder has now been modified with the new lens flare.

The same process can be used for the AVP main menu logo from interstellar V1. Repeat the above process with "sharredasset2.assets" and the file you are looking for is "logoFullRed_alt.tex"

Lightning

The lightning does not work in 1.0.x without cfg editing. Here is an updated .cfg file, just replace everything in the lightning .cfg with this. Using notepad++ or equivalent.

Notepad++ https://notepad-plus-plus.org/download/v6.7.8.2.html


CLOUDS_SETTINGS{
GUI_KEYCODE = N
}
CLOUD_LAYER_PACK
{
CLOUD_LAYER
{
SAVED
{
body = Kerbin
altitude = 7500
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -2.5E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.0133333
y = 0.1
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Duna
altitude = 10000
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -2.5E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.0133333
y = 0.1
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Laythe
altitude = 6250
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -2.5E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.0133333
y = 0.1
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
CLOUD_LAYER
{
SAVED
{
body = Eve
altitude = 7750
volume = False
color
{
r = 20
g = 20
b = 25
a = 10
}
main_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = -2.5E-05
y = 0
}
}
detail_texture
{
file = BoulderCo/Clouds/Textures/lightning
scale = 0.1
offset
{
x = 0.3052678
y = 0
}
speed
{
x = 0.0133333
y = 0.1
}
}
scaled_shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 1
}
shader_floats
{
falloffPower = 4
falloffScale = 3.5
detailDistance = 0
minimumLight = -0.4
fadeDistance = 5
rimDistance = 0.0001
}
}
}
}

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.