DuoDex

Crowd Sourced Science-Biome Reports Everywhere! (May 31st) [4.1]

What do you want next?  

651 members have voted

  1. 1. What do you want next?

    • Expand, with an eye towards support for other science mods.
      321
    • Make contributing easier!
      105
    • Add support for the planet pack mods.
      215


Recommended Posts

For those that may not follow the Repo: I've gone ahead and, at this point, sorted all but the Kerbin System by Experiment (and where applyable by biome, some CB entries have direct successors)

I intend to finish this up within the Year Including setteling on a final layout (1440 files is quite a lot)

I have one Question tho: As for the structure if the Files themselvse they at this point still contain the MM Instructions. I think they should be removed, however I wonder what - if any - they should be replaced by.

So, the source files still contain the ModuleManager instructions? I'm not going to weigh in on this until you've finished up with your repo and have a pull request going.

Share this post


Link to post
Share on other sites
I'll think of something on that end.

Also I ment to include a link to my repo: https://github.com/harryyoung/CrowdSourcedScience

I wanted to test your science reports but they don't work. I just placed the folder the KSP folder, NOT in GameData because the folder said so. It didn't work when I placed it in the Resources folder either. What am I doing wrong?

Share this post


Link to post
Share on other sites

Nothing, as I indicated I'm still in the sorting phase. This is just a folder layout at this point. I intend to do some research later today and sort off the Kerbin System. If everything goes as I hope it will A running version should be available within the year, probably earlier than monday evening (UTC)

Share this post


Link to post
Share on other sites
does this work now?

What would be preventing it from working...FOOL?

Share this post


Link to post
Share on other sites

I finally completed my research of the 0.90 biomes:

All science logs in one file or in 11 files

These files only shows the new biomes, if you want to use this you can download the file(s) and add your own description after the "=" and add them into your GameData folder.

In these files is also a MM config included so that the new logs automatically are added by the stock ones.

Share this post


Link to post
Share on other sites
I finally completed my research of the 0.90 biomes:

All science logs in one file or in 11 files

These files only shows the new biomes, if you want to use this you can download the file(s) and add your own description after the "=" and add them into your GameData folder.

In these files is also a MM config included so that the new logs automatically are added by the stock ones.

10/10 mate! Can you make a pull request with this?

Share this post


Link to post
Share on other sites

Hey, stupid question alert!

How do you make this work? I've placed the folder i got from github in gamedata (like the first post says) and nothing, it ain't working.

I did search this thread (a few pages) for the solution but im still at a loss.

Help?

Edited by code99

Share this post


Link to post
Share on other sites
10/10 mate! Can you make a pull request with this?

With one file or 11? I will make some science logs for the new biomes to help the fans to make their own one.

Share this post


Link to post
Share on other sites
With one file or 11? I will make some science logs for the new biomes to help the fans to make their own one.

Doesn't matter :)

- - - Updated - - -

Hey, stupid question alert!

How do you make this work? I've placed the folder i got from github in gamedata (like the first post says) and nothing, it ain't working.

I did search this thread (a few pages) for the solution but im still at a loss.

Help?

Are you sure that you have the latest version of ModuleManager installed?

Share this post


Link to post
Share on other sites

Positive. If by latest you mean 2.5.6 then yes. Ill go check if there is a newer one altho i dled all of my mods for ksp 0.90 not too long ago (and everything works fine except this)

Share this post


Link to post
Share on other sites
Positive. If by latest you mean 2.5.6 then yes. Ill go check if there is a newer one altho i dled all of my mods for ksp 0.90 not too long ago (and everything works fine except this)

What mods are you using, and are you using the pre-release on the Github page? Edit: Marked as a release now.

Share this post


Link to post
Share on other sites

Yes ive got the pre release version (1.4.0).

Now i was going to list the mods im using but this morning I've decided to start a new game with different mods this time and out of curiosity I've tried to see if the new logs worked.

I've put a capsule on the launch pad and did a crew report and finally jebediah said something new (it was the first log from the cfg file of this mod).

I then went and created 2 more rockets and landed them in 2 different biomes (grassland and highlands) and i did the crew report. The results were the same, it was the same line i got on the launchpad.

Thats 3 different crafts in 3 different biomes with the same log.

From what i understand, shouldn't i get different logs?

Share this post


Link to post
Share on other sites

This is going to sound weird but having this mod installed summons the Kraken for me. I can't possibly imagine why, though.

Here's my save: https://dl.dropboxusercontent.com/u/15458284/Kerbal/MoMoneyLessProbs.zip - I have a station in orbit around Kerbal, with no mods installed I can switch to it without it exploding.

If I install CSS (no other mods needed to reproduce this), when I switch to the space station it explodes into a million bits once physics loads.

Share this post


Link to post
Share on other sites
This is going to sound weird but having this mod installed summons the Kraken for me. I can't possibly imagine why, though.

Here's my save: https://dl.dropboxusercontent.com/u/15458284/Kerbal/MoMoneyLessProbs.zip - I have a station in orbit around Kerbal, with no mods installed I can switch to it without it exploding.

If I install CSS (no other mods needed to reproduce this), when I switch to the space station it explodes into a million bits once physics loads.

can you provide a log file when you installed CSS and after the ship explodes.

Share this post


Link to post
Share on other sites

Also for all who have svntortise.

svn it.(get ze files)

Do some edits

The do a svn commit

It shpuld create a pull request.

*totally have npt tried it :P*

Share this post


Link to post
Share on other sites
can you provide a log file when you installed CSS and after the ship explodes.

https://dl.dropboxusercontent.com/u/15458284/Kerbal/KSP%20-%20with%20CSS.log

could this be something?

[EXC 17:14:54.690] ArgumentException: An element with the same key already exists in the dictionary.
System.Collections.Generic.Dictionary`2[System.String,ScienceExperiment].Add (System.String key, .ScienceExperiment value)
ResearchAndDevelopment.loadExperiments ()
ResearchAndDevelopment.GetExperiment (System.String experimentID)
ModuleScienceExperiment.OnStart (StartState state)
Part.ModulesOnStart ()
Part+.MoveNext ()

And here's the same steps done without CSS installed. The exception seems to be the only thing that's different (except for the explosions).

https://dl.dropboxusercontent.com/u/...hout%20CSS.log

Edited by tutike2000

Share this post


Link to post
Share on other sites
https://dl.dropboxusercontent.com/u/15458284/Kerbal/KSP%20-%20with%20CSS.log

could this be something?

[EXC 17:14:54.690] ArgumentException: An element with the same key already exists in the dictionary.
System.Collections.Generic.Dictionary`2[System.String,ScienceExperiment].Add (System.String key, .ScienceExperiment value)
ResearchAndDevelopment.loadExperiments ()
ResearchAndDevelopment.GetExperiment (System.String experimentID)
ModuleScienceExperiment.OnStart (StartState state)
Part.ModulesOnStart ()
Part+.MoveNext ()

And here's the same steps done without CSS installed. The exception seems to be the only thing that's different (except for the explosions).

https://dl.dropboxusercontent.com/u/...hout%20CSS.log

You're using an antiquated version of CSS. You've got 1.2.1 currently, so please use 1.4.

Share this post


Link to post
Share on other sites
You're using an antiquated version of CSS. You've got 1.2.1 currently, so please use 1.4.

Ah, hadn't noticed. That fixed it, thanks.

Share this post


Link to post
Share on other sites

Here's the List for KSC Location Biomes: https://github.com/harryyoung/CrowdSourcedScience/blob/master/planets/kerbin/ksc/locationslist.txt

I'll send it over with the next pull (I'll do some content first)

There's one issue that cropped up: I cannot adress any of the R&D Biomes correctly. All lines that are considered for this get redirected to default. I'm assuming this is due to the "&"-Symbol in the adress part, I'm just not sure if it is MM or the game itself that locks up here.

Share this post


Link to post
Share on other sites
Here's the List for KSC Location Biomes: https://github.com/harryyoung/CrowdSourcedScience/blob/master/planets/kerbin/ksc/locationslist.txt

I'll send it over with the next pull (I'll do some content first)

There's one issue that cropped up: I cannot adress any of the R&D Biomes correctly. All lines that are considered for this get redirected to default. I'm assuming this is due to the "&"-Symbol in the adress part, I'm just not sure if it is MM or the game itself that locks up here.

I know, I was 3 days busy with finding all the new biomes AND creating reports for them but never got the R&D to work. I took some time off, because I'm helping with the BioMass mod, but will look into it in some spare time.

Share this post


Link to post
Share on other sites

I just did: it's MM.

I've tried to create a report for R&D in a pure stock install directly in the ScienceDefs.cfg and it triggered correctly reliably. I'll take this over to the MM thread, however since sarbian signed off ;.; I'm not expecting this to work soon if ever

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.