Jump to content
  • 0

"Couldn't switch to requested monitor resolution"


harbingerx81
 Share

Question

On launch I get the following dialog box:

Couldn't switch to requested monitor resolution

Switching to resolution 0x0 failed, trying lower one

All resolution switches have failed

Screen: could not switch resolution (0x0 fs=0 hz=0)

This is running the Windows 32-bit and 64-bit version immediately after the .90 update

I am running NVIDIA Surround on a 2x SLI GTX 780's under Windows 8.1, all drivers are up to date, 8GB RAM, AMD FX-8370 @ 4 GHz.

I have deleted all local files and done a fresh install.

I have tried launching the game through Steam, Directly with the Launcher.exe, KSP.exe, and KSP_x64.exe.

I have tried manually setting the starting resolution to many different options using Launcher.exe.

I have tried launching in Fullscreen and Windowed mode at varying resolutions.

I have tried disabling SLI, Surround, and running just on a single monitor.

All of these steps have given the same non-results.

EDIT: Adding relevant info

Version number: build id = 00705 2014-12-15_13-42-05 Branch: master

output_log.txt------------->

Initialize engine version: 4.5.5f1 (7684ad0c5a44)GfxDevice: creating device client; threaded=1

Direct3D:

Version: Direct3D 9.0c [nvd3dum.dll 9.18.13.4411]

Renderer: NVIDIA GeForce GTX 780

Vendor: NVIDIA

VRAM: 2949 MB (via DXGI)

Caps: Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=0 INTZ=1 RAWZ=0 NULL=1 RESZ=0 SlowINTZ=0

Begin MonoManager ReloadAssembly

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\UnityEngine.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\UnityEngine.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-CSharp.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-CSharp.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-UnityScript.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.Mdb.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.Mdb.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.Pdb.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\Mono.Cecil.Pdb.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\xmldiffpatch.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\xmldiffpatch.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\XmlDiffPatch.View.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\XmlDiffPatch.View.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\TDx.TDxInput.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\TDx.TDxInput.dll into Unity Child Domain

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\MiscUtil-r285.dll (this message is harmless)

Loading C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_Data\Managed\MiscUtil-r285.dll into Unity Child Domain

- Completed reload, in 0.241 seconds

<RI> Initializing input.

<RI> Input initialized.

desktop: 4622x2560 59Hz; virtual: 4622x2560 at 0,0

D3D device reset failed [E_INVALIDARG]

(Filename: Line: 357)

Switching to resolution 0x0 failed, trying lower one

All resolution switches have failed

Screen: could not switch resolution (0x0 fs=0 hz=0)

Crash!!!

Crash in winutils::ProcessInternalCrash(PEXCEPTION_POINTERS pExInfo)SymInit: Symbol-SearchPath: '.;C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program;C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'Harbinger'

OS-Version: 6.2.9200 () 0x100-0x1

C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP.exe:KSP.exe (00950000), size: 12214272 (result: 0), SymType: '-exported-', PDB: 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP.exe', fileVersion: 4.5.5.37569

C:\Windows\SYSTEM32\ntdll.dll:ntdll.dll (77150000), size: 1470464 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\ntdll.dll', fileVersion: 6.3.9600.17278

C:\Windows\SYSTEM32\KERNEL32.DLL:KERNEL32.DLL (75460000), size: 1310720 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\KERNEL32.DLL', fileVersion: 6.3.9600.17056

C:\Windows\SYSTEM32\KERNELBASE.dll:KERNELBASE.dll (74F00000), size: 851968 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\KERNELBASE.dll', fileVersion: 6.3.9600.17278

C:\Windows\SYSTEM32\HID.DLL:HID.DLL (73FD0000), size: 40960 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\HID.DLL', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\WS2_32.dll:WS2_32.dll (76BE0000), size: 315392 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\WS2_32.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\USER32.dll:USER32.dll (769F0000), size: 1359872 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\USER32.dll', fileVersion: 6.3.9600.17344

C:\Windows\SYSTEM32\VERSION.dll:VERSION.dll (74AD0000), size: 32768 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\VERSION.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\ole32.dll:ole32.dll (76D40000), size: 1097728 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\ole32.dll', fileVersion: 6.3.9600.17042

C:\Windows\SYSTEM32\SHLWAPI.dll:SHLWAPI.dll (75170000), size: 266240 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\SHLWAPI.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\ADVAPI32.dll:ADVAPI32.dll (76770000), size: 491520 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\ADVAPI32.dll', fileVersion: 6.3.9600.17031

C:\Windows\SYSTEM32\GDI32.dll:GDI32.dll (751C0000), size: 1077248 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\GDI32.dll', fileVersion: 6.3.9600.17246

C:\Windows\SYSTEM32\SHELL32.dll:SHELL32.dll (755B0000), size: 18575360 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\SHELL32.dll', fileVersion: 6.3.9600.17331

C:\Windows\SYSTEM32\OPENGL32.dll:OPENGL32.dll (58CF0000), size: 868352 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\OPENGL32.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\WINMM.dll:WINMM.dll (74730000), size: 131072 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\WINMM.dll', fileVersion: 6.3.9600.17078

C:\Windows\SYSTEM32\OLEAUT32.dll:OLEAUT32.dll (76B40000), size: 610304 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\OLEAUT32.dll', fileVersion: 6.3.9600.17403

C:\Windows\SYSTEM32\MSACM32.dll:MSACM32.dll (73070000), size: 86016 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\MSACM32.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\IMM32.dll:IMM32.dll (74FD0000), size: 151552 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\IMM32.dll', fileVersion: 6.3.9600.17031

C:\Windows\SYSTEM32\DNSAPI.dll:DNSAPI.dll (73420000), size: 507904 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\DNSAPI.dll', fileVersion: 6.3.9600.17039

C:\Windows\SYSTEM32\IPHLPAPI.DLL:IPHLPAPI.DLL (74210000), size: 122880 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\IPHLPAPI.DLL', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\WINHTTP.dll:WINHTTP.dll (74230000), size: 606208 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\WINHTTP.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\msvcrt.dll:msvcrt.dll (74DC0000), size: 778240 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\msvcrt.dll', fileVersion: 7.0.9600.16384

C:\Windows\SYSTEM32\NSI.dll:NSI.dll (74B70000), size: 28672 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\NSI.dll', fileVersion: 6.3.9600.16384

C:\Windows\SYSTEM32\RPCRT4.dll:RPCRT4.dll (750C0000), size: 720896 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\RPCRT4.dll', fileVersion: 6.3.9600.17216

C:\Windows\SYSTEM32\combase.dll:combase.dll (752D0000), size: 1368064 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\combase.dll', fileVersion: 6.3.9600.17031

C:\Windows\SYSTEM32\sechost.dll:sechost.dll (76E60000), size: 253952 (result: 0), SymType: '-exported-', PDB: 'C:\Windows\SYSTEM32\sechost.dll', fileVersion: 6.3.9600.16384

Edited by harbingerx81
Link to comment
Share on other sites

Recommended Posts

  • 0

Tried rebooting multiple times depending on the changes I have been trying...And no, no extra arguments...Since the last call shown in the log was a support DLL for unity followed by a Direct 3D device error, I also tried reinstalling my display drivers, but to no avail.

Link to comment
Share on other sites

  • 0

Alright, I can't remember the cause of this but it has come up before on Windows, quite a few times actually, have you got other software running besides the browser? There's some stuff that is supposed to give more graphics options but just locks up the card and stops you running KSP.

Link to comment
Share on other sites

  • 0

I would recommend (if you haven't) copy over an old settings.cfg file. It may be that KSP is failing to detect your resolutions for some reason while trying to generate a config file.

If you did copy it over, try deleting it.

Cheers,

~Claw

Link to comment
Share on other sites

  • 0

The first time I ran in after a fresh install it crashed without generating a config file, after that I ran Launcher.exe, used the 'minimum' graphics settings and made sure that it was running in 32-bit and windowed...After running the launcher, I checked the config file it generated to make sure that the proper settings were saved into it...

I just deleted the config again, ran it, got the same crash with no new config generated...Whatever is causing it must come before it tries to read the config.

Link to comment
Share on other sites

  • 0

Okay, I see you already refreshed your video drivers. See if you can get into your NVIDIA panel and revert to a previous version of your drivers. Sometimes when they update, they break things.

Also, Unity received an update on this KSP release. So hopefully that isn't causing your issue because that's a bit harder to fix...

Link to comment
Share on other sites

  • 0

Yeah, that is my next step after I get off work...I am going to try previous versions and maybe the newest beta of my drivers...I am leaning towards the Unity update being the cause, but it is odd that I have not seen anyone else report the same problem...My display/hardware setup is a little unique, but not unconventional enough that I should be a rare exception...Not to mention that I have reverted to something much more 'normal' and still experience the same issues.

Link to comment
Share on other sites

  • 0

SOLVED!

I had to go play around in the registry...

\HKEY_CURRENT_USER\Software\Squad\Kerbal Space Program

The resolutions in there were stuck on ZERO for some reason...Changing them to something else (in this case I went with a windowed 1600x1200) allowed the game to launch and from there I set my fullscreen res back to 4622x2560 with no issue.

Link to comment
Share on other sites

  • 0
SOLVED!

I had to go play around in the registry...

\HKEY_CURRENT_USER\Software\Squad\Kerbal Space Program

The resolutions in there were stuck on ZERO for some reason...Changing them to something else (in this case I went with a windowed 1600x1200) allowed the game to launch and from there I set my fullscreen res back to 4622x2560 with no issue.

I'm having this exact problem. What exactly did you change? I've found the registry but I'm unsure as to what to change

Link to comment
Share on other sites

  • 0

Found a solution to this:-

I did the above registry changes and this didn't change a thing for me. I still couldn't get 1.0/1.0.1/1.0.2 to work with opengl mode whether it was with mods or without. The strange thing was that it still worked in 0.90 so it wasn't anything to do with my system drivers. I didn't think it had anything to do with Unity either as it was only v1.0+ that was having the difficulty with it. By mere accident(and probably my fat fingers) I found out that with 2 '-' in front of the word 'force' it worked. So instead of "-force-opengl" I typed in "--force-opengl" and it started up straight away.

Over the past few days of trying whatever I could to fix this I have noticed a lot of people having this trouble in the past with past versions and they all used the registry fix to correct it. This wasn't the case for me and if it's not the case for you then please try this method.

Hope this helps anyone else who may have this trouble in the future.

It would appear this is wrong information. Not solved

Edited by ClLaw
Link to comment
Share on other sites

  • 0

The above solution seems to turn off OpenGL mode- I successfully started the game with the correct resolution (1920x1080) but it crashed during loading due to hitting the 3.5gb memory limit.

On my computer, at least, it loads fine in OpenGL as long as I'm under 1600x900 resolution.

Link to comment
Share on other sites

  • 0
The above solution seems to turn off OpenGL mode- I successfully started the game with the correct resolution (1920x1080) but it crashed during loading due to hitting the 3.5gb memory limit.

On my computer, at least, it loads fine in OpenGL as long as I'm under 1600x900 resolution.

You are right :(. After trying this again it would appear that opengl mode is being turned off. I guess I was just too hasty and hopeful in believing this might be a solution. Although I have found that even lowering the resolution is not working for me either. I still get the same message coming up. I'm linking my output_log if someone could please help me in identifying the cause then maybe a solution could be found :)

https://www.dropbox.com/s/ccc1wfo50uwnpxu/output_log.txt?dl=0

EDIT - Finally got it working for sure this time. Turned out it didn't want to work through my HDMI cables, only my DVI cables. Switched my main display screen to one of my other screens and it worked. Switched main display to my other DVI screen and it worked again. Switched back to my middle screen(HDMI) and it didn't work. Changed out one HDMI for another HDMI(keeping it to the same middle screen to try and isolate if it was a dodgy cable) and still didn't work but worked on both my DVI screens. So this time I switched a DVI and HDMI cable around so the middle screen was now DVI and KSP opengl mode now works on my middle(main display) screen. So the issue is the HDMI cables.

Seems this problem is solved for me..... for now

Edited by ClLaw
Link to comment
Share on other sites

  • 0

Alright, so I tried the suggested solution above here, and for me this finally fixed my problem launching the game on a higher resolution than 1680x1050 (running at 1920x1080 normally).

OpenGL is definately running, KSP with alot of mods installed runs at an initial load of 1.5Gb.

Point to note: You have to use a DVI/DVI cable. Plugging a DVI end into the GPU and the HDMI end of the DVI/HDMI cable into the monitor does not work (atleast it didn't for me).

And the other way around didn't register the monitor at all. :sticktongue:

So for me, this has solved the problem .... for now.

Hope this works for eveyone else aswell.

Link to comment
Share on other sites

  • 0
You are right :(. After trying this again it would appear that opengl mode is being turned off. I guess I was just too hasty and hopeful in believing this might be a solution. Although I have found that even lowering the resolution is not working for me either. I still get the same message coming up. I'm linking my output_log if someone could please help me in identifying the cause then maybe a solution could be found :)

https://www.dropbox.com/s/ccc1wfo50uwnpxu/output_log.txt?dl=0

EDIT - Finally got it working for sure this time. Turned out it didn't want to work through my HDMI cables, only my DVI cables. Switched my main display screen to one of my other screens and it worked. Switched main display to my other DVI screen and it worked again. Switched back to my middle screen(HDMI) and it didn't work. Changed out one HDMI for another HDMI(keeping it to the same middle screen to try and isolate if it was a dodgy cable) and still didn't work but worked on both my DVI screens. So this time I switched a DVI and HDMI cable around so the middle screen was now DVI and KSP opengl mode now works on my middle(main display) screen. So the issue is the HDMI cables.

Seems this problem is solved for me..... for now

Update for anyone else with multiple monitors having this problem:

No need to physically unplug your monitor(s) as long as one of them is DVI/DisplayPort. Just change your primary monitor to the non-HDMI one and launch KSP in windowed mode.

Can then drag it over to your primary monitor even if it's HDMI. I use BorderlessGaming to run it in full-screen windowed as well.

Link to comment
Share on other sites

  • 0

Thanks, the monitor primary/secondary was the issue.

It also worked for me to keep the priorities with the monitors and changing it in the Game Settings to fullscreen, quitting, and editing the settings.cfg back to 1920x1200.

I find fullscreen less troublesome then switching my whole desktop setup upside down (startmenu, desktop content).

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...