Jump to content

[1.2.2] Realistic Progression Zero (RP-0) - Lightweight RealismOverhaul career v0.53 June 12


Recommended Posts

Hi Guys, I seem to have problem with RP-0.

I've reinstalled my KSP and istalled all the mods I had (exported into .ckan and reimported also using CKAN) and everything is fine but ... I do not see any contract. Looks like they are all inactive:
 

Spoiler

 


3fYO63W.jpg

 

 

 

Available and Active tabs are totally empty. I've pinpointed that RP-0 is a weak link. Without RP-0 all works fine - I see all the default contracts for the KSP but when I install RP-0 I see this. AS far as I can tell they are there but are not offered to me. Maybe something is broken with requirements but I am not an expert enough to know where to look
Any ideas?

Edited by przybysz86
Link to post
Share on other sites

@przybysz86 - Nothing bad in the log.  Can you try going to the Contract Configurator debug menu (alt-f10) and hitting the "Force Generate Contracts" button and see if that does anything?

If not, please add the following config into a .cfg file (anywhere in GameData, as long as it ends in .cfg), grab the dev dll here and replace the one in GameData/ContractConfigurator (this will enabled verbose logging).

CC_DEBUGGING
{
	// Possible LogLevel: VERBOSE, DEBUG, INFO, WARNING, ERROR
	logLevel = DEBUG
	
	ADD_LOGLEVEL_EXCEPTION
	{
		// Type name
		type = ContractPreLoader
		// Possible LogLevel: VERBOSE, DEBUG, INFO, WARNING, ERROR
		logLevel = VERBOSE
	}
	
	ADD_LOGLEVEL_EXCEPTION
	{
		// Type name
		type = ContractType
		// Possible LogLevel: VERBOSE, DEBUG, INFO, WARNING, ERROR
		logLevel = VERBOSE
	}
	
	ADD_LOGLEVEL_EXCEPTION
	{
		// Type name
		type = MissionControlUI
		// Possible LogLevel: VERBOSE, DEBUG, INFO, WARNING, ERROR
		logLevel = VERBOSE
	}
}

Once that's done, please provide a new log file (KSP.log is preferred for this, as it's a little bit more condensed).

Link to post
Share on other sites
23 hours ago, przybysz86 said:

Hi Guys, I seem to have problem with RP-0.

I've reinstalled my KSP and istalled all the mods I had (exported into .ckan and reimported also using CKAN) and everything is fine but ... I do not see any contract. Looks like they are all inactive:
 

  Reveal hidden contents

 


3fYO63W.jpg

 

 

 

Available and Active tabs are totally empty. I've pinpointed that RP-0 is a weak link. Without RP-0 all works fine - I see all the default contracts for the KSP but when I install RP-0 I see this. AS far as I can tell they are there but are not offered to me. Maybe something is broken with requirements but I am not an expert enough to know where to look
Any ideas?

I seem to be having the same problem. I tried using 1.1.2 and 1.1.3 RP-0 to no avail. I also tested to see if world firsts still worked, however they don't. I have been removing mods and putting them back for a good few hours now ( I now hate that loading screen) and it seems that RP-0 seems to be the problem.

Hope this helps you

Thanks

Link to post
Share on other sites

thank you guys for the help. I watched the sounding rockets video and was able to build my own. Unfortunately the rocket will overturn while in flight when the fuel will be consumed.. However, with some additional rockets attached, I was able to reach space with it.

I would like to know if it is really necessary to have RSS installed. Being on 1.3.3, most visual mods will work fine with stock solar system, but with RSS it becomes a bit tricky.. RVE, SVE etc.

 

Link to post
Share on other sites
3 hours ago, NaturalHeadphone said:

I seem to be having the same problem. I tried using 1.1.2 and 1.1.3 RP-0 to no avail. I also tested to see if world firsts still worked, however they don't. I have been removing mods and putting them back for a good few hours now ( I now hate that loading screen) and it seems that RP-0 seems to be the problem.

Hope this helps you

Thanks

I had this exact problem with Contract Configurator 1.16.0 but versions 1.16.1 and 1.16.2 got all my available/active contracts back. Are you guys definitely up to date with that mod?

EDIT - Also, are you guys manually updating Contract Configurator or updating through ckan? I find that ckan doesn't delete the entirety of the folders needed and you end up with files left over which can mess up an updated mod 

Edited by ClLaw
Link to post
Share on other sites
1 hour ago, Estebanium said:

thank you guys for the help. I watched the sounding rockets video and was able to build my own. Unfortunately the rocket will overturn while in flight when the fuel will be consumed.. However, with some additional rockets attached, I was able to reach space with it.

I would like to know if it is really necessary to have RSS installed. Being on 1.3.3, most visual mods will work fine with stock solar system, but with RSS it becomes a bit tricky.. RVE, SVE etc.

 

PM me - it looks like you have problem with relative placement of CoM and CoL (centre of mass and centre of lift) this is not caused by RP-0 so let's not clutter this thread :)

1 minute ago, ClLaw said:

I had this exact problem with Contract Configurator 1.16.0 but versions 1.16.1 and 1.16.2 got all my available/active contracts back. Are you guys definitely up to date with that mod?

I had issues in 1.16.1 and have them now after updating (via ckan) today to 1.16.2


BTW for easy comparison related to the RP-0 issue I attach my .ckan. All mods up to date (as per ckan) at this very moment:
https://app.box.com/s/evfytyc27l0yqa3c9lddbmvp4pffh2id

Edited by przybysz86
Link to post
Share on other sites
3 hours ago, NaturalHeadphone said:

I seem to be having the same problem. I tried using 1.1.2 and 1.1.3 RP-0 to no avail. I also tested to see if world firsts still worked, however they don't. I have been removing mods and putting them back for a good few hours now ( I now hate that loading screen) and it seems that RP-0 seems to be the problem.

Hope this helps you

Thanks

I had a problem with no contracts appearing too. When I quit to main menu, not the game, then reopened the career, the contracts reappeared. This worked twice for me.

 

Link to post
Share on other sites

@ClLaw

I have been using ckan to update it, however i will go and update it manually now.

@EliasDanger

I think I might have already done this, but I will test again as soon as possible. Thanks

@przybysz86

Thanks I will upload mine when I next can so that we can compare.

 

 

Link to post
Share on other sites
22 hours ago, Estebanium said:

I would like to know if it is really necessary to have RSS installed. Being on 1.3.3, most visual mods will work fine with stock solar system, but with RSS it becomes a bit tricky.. RVE, SVE etc.

Well, of course you can choose to not install RSS
… but then everything will be terribly unbalanced, if it works at all. 

Stock tanks, for example, are very very heavy compared to their real world counterparts, and the stock engines are very heavy for their thrust.  Stock needs about 3,400 m/s to orbit, RSS needs ~9,400 m/s.  Thanks to the rocket equation, a rocket with ~3 times larger DeltaV is not just 3 times as heavy, it's exponentially more heavy.

So in the Kerbin system the RSS engines and tanks are vastly overpowered, similar to racing a bicycle (stock w/stock parts or RSS w/RSS parts) against a Concorde (stock solar system with RSS parts) across the US.  Who will arrive first?

So yes, for a laugh you can try it --- it's a single player game, so you can at worst "cheat" yourself out of fun, unlike cheating in (especially competitive) multiplayer games to get an advantage over other players --- but I don't think shooting fish in a barrel will turn out to be that much fun, after all …

And of course, things may depend on RSS or stuff it pulls, so some things may just not work.

Link to post
Share on other sites
On 1.08.2016 at 1:00 AM, EliasDanger said:

I had a problem with no contracts appearing too. When I quit to main menu, not the game, then reopened the career, the contracts reappeared. This worked twice for me.

 

I can confirm that this fixes the problem. Contracts are broken when you create new career but when you resume it (either exit to menu and resume or exit game all together, restart and resume) contracts ("world's firsts") appeared. We will see if new contracts will get unlocked normally from now on.


EDIT: switching space centre also works. I am using RSS and I've switched from Canaveral to Kourou and it activated my contracts

Edited by przybysz86
Link to post
Share on other sites
7 minutes ago, Nightside said:

Does upgrading VAB level actually do anything aside from changing what it looks like? Maybe some effect in KCT?

It affects the number of unlocked build queues in KCT. One queue per level.

Link to post
Share on other sites
10 hours ago, Nightside said:

Does upgrading VAB level actually do anything aside from changing what it looks like? Maybe some effect in KCT?

VAB builds faster at higher levels, too. (1 upgrade point is worth more points/day)

Link to post
Share on other sites
1 hour ago, przybysz86 said:

Do it affect already spent points or just new/future points spent?

 

Yes it applies retrospectively as well. After you upgrade your VAB you notice that production rate is boosted.

Link to post
Share on other sites

Is there a more appropriate place to post suggestions for this mod (If I may be so bold :P)? I had an idea about surface samples, but don't want to clutter the thread if it's meant for bug fixing and info. Is there a dev thread somewhere?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...