pjf

[1.2.2] Realistic Progression Zero (RP-0) - Lightweight RealismOverhaul career v0.53 June 12

Recommended Posts

Just tried to do the "Weather Network" contract.  The contract asks me to launch three satellites, each with slightly different EC resource requirements but otherwise with identical orbit requirements.  I built a satellite that had enough EC for all three contracts because I planned to just build three copies of the rocket.  I launched the first copy, got it into the correct orbit and completed the mission.  Never had to build, let alone launch, the other two satellites.  I'm assuming this is a bug but I'm not sure how a single contract is supposed to use three separate rockets to be completed.  Maybe this "Weather Network" contract should be a single satellite, but you have to run the contract three times before the milestone is completed.  Not sure if that can be done or not.

And though I haven't run it yet, I'm guess the same problem is going to be true of the "Geostationary Weather Network" contract.

Share this post


Link to post
Share on other sites

Hi all, just found this: WHICH IS A HUGE RAM/LAGG SAVER

which basicly allows the creation of a part pruner list for all parts in your mods NOT SUPPORTED by rp0, removing them but allowing you to keep any "shared" textures (ie no blacked out models) see below:

How to create the rp0 list:

1) install ksp with rp0 and all mods you like
2) launch ksp (unpruned) at least once (so there is a module manager cache file)
3) launch partfinder.exe
  - specify location of ksp (not game data)
  - specify a prune list (any (empty) text file) say "default.prnl"
  - press Create list>Create nonRP0
4) [optional] go to the folder of your prune list file, there
   are three new files "default.rp0_nocost.prnl", "default.non_rp0.prnl" and "default.non_ro.prnl"
   rename them (or they will be overwritten by partfinder if you do it again later)  
5) Apply: Open apply window and add these lists (on the left) and Press "Aplly all" (or "Prune")

To create the non-rp0/...etc prune lists again you need to unprune (everything) and start from (2)

---------------------------------------------------------------------------

To repair the textures/resources:

 (which is caused by some prune lists from the autopruner, because if you prune all folders with tanks, there might be some

textures used by other parts from other mods)

1) launch partfinder.exe
  - specify location of ksp (not game data)
  - specify a prune list (any (empty) text file) say "default.prnl"
  - press Create list>Create resource repair
2) [optional] go to the folder of your prune list file, there
   are three new files "default.res.prune.prnl", and "default.res.unprune.prnl"
   rename them (or they will be overwritten by partfinder if you do it again later)  

3) Apply: Open apply window and

  • unprune default.res.unprune.prnl (add it to the right)
  • [optional] prune custom.res.prune.prnl  (to the left)
  • Press "Apply all"

 

Important: Leave all prune files you want to have pruned checked or the effects will be undone.

The workflow is: unpruen everything, prune files on the left, unprune file on the right

Share this post


Link to post
Share on other sites
On 10/31/2016 at 5:05 PM, chrisl said:

Just tried to do the "Weather Network" contract.  The contract asks me to launch three satellites, each with slightly different EC resource requirements but otherwise with identical orbit requirements.  I built a satellite that had enough EC for all three contracts because I planned to just build three copies of the rocket.  I launched the first copy, got it into the correct orbit and completed the mission.  Never had to build, let alone launch, the other two satellites.  I'm assuming this is a bug but I'm not sure how a single contract is supposed to use three separate rockets to be completed.  Maybe this "Weather Network" contract should be a single satellite, but you have to run the contract three times before the milestone is completed.  Not sure if that can be done or not.

And though I haven't run it yet, I'm guess the same problem is going to be true of the "Geostationary Weather Network" contract.

Known bug, hasn't been fixed.  I also ran into it months ago.

Share this post


Link to post
Share on other sites
8 hours ago, Maxsimal said:

Known bug, hasn't been fixed.  I also ran into it months ago.

I know the early unscrewed Lunar Impactor, Lunar Flyby and Lunar Orbit have a setting that they can only be run a set number of times.  I wonder if the Weather Network contracts could be setup the same way and if there is a way to require a certain contract to be run x number of times before the next contract can be run.  I.E., require that "Weather Network" be completed three times before "Geostationary Weather Network" becomes available.

Share this post


Link to post
Share on other sites

I've got a concern with the "WeatherGOES" (aka, "Geostationary Weather Network") RP-0 contract.  This contract requires that you launch a satellite that includes "deployable solar panels".  But without additional parts modes, you need "Electrics" before you'll get your first deployable solar panel.  You can complete the previous RP-0 satellite contract just with "Basic Avionics" but to complete "WeatherGOES" you'll need to research "Stability/Early Probes", "Improved Instrumentation" and "Electrics".  That's 135 research points and around 4 years of research (depending on how you spend your KCT points, of course).  It's not that I have a problem with the research requirement or the requirements for this contract.  My concern is that you have no other satellite contract you can run in the mean time.  In my game I've been relying heavily on continuously rerunning the "(1/LEO)" contract along with some of the doable, stock "Position satellite in a specific orbit of Earth" contracts (with sounding rocket, "X-Planes (Suborbital)" and "Scence dataf rom space around Earth" thrown in where possible) just to cover the entry costs for new parts.  But at this point I'm up to my 14th Mercury launch (10th Mercury-Atlas) and I've completed at least 20 of the "Position..." contracts.  And I've still got a minimum of 2 years of research left assuming I stop my research on Gemini (Mature Orbital Rocketry & General Construction) and focus on Electrics.  I know I could decrease my research time by buying more KCT points but first you need funds for that which means you need contracts.  And second, my game is already at least 3 years ahead (It's 3 Dec 1959 in my game and MA-9 flew on 15 May 1963).  Speeding up my research just puts me even further ahead.

We need some repeatable RP-0 satellite contracts that fit between "WeatherGOESSMS" and "WeatherGOES".

Share this post


Link to post
Share on other sites

@chrisl

I agree RP0 in general needs more contract variety.  At the point you're at, your repeatable cash comes from either the manned flights RP0 provides (1 to 3/LEO and eventually 1 to 3/LLO) or from the stock-derived satellite contracts.  Note that if you get your reputation higher, you'll get more of the geosynchronous/tundra/Molniya contracts that award more money. 

However, the first geostationary weather satellite wasn't actually launched until 1965, so RP0 is not behaving ahistorically in this particular case.  Also, you can download RaiderNick's US probes pack, which gives you access to the actual Tiros Satellite before you unlock Electrics, if you want to do it that way.

One thing that really affect's RP0's historicity, also, is that building spacecraft is just faster, even with a little money invested, than it was in reality.  Partially this is because, unless you're skipping around to different bases, all your construction is concentrated in one VAB.  Whereas in history, hundreds of sounding rockets got produced in a short span, but at lots of different VAB's across the world, so then when it comes time to build larger, one off craft, that faster speed is applied to them as well.  Not much you can do about that other than not invest in the VAB too much.

One thing you CAN do, though, is turn off the KCT's part inventory.  Historically, spacecraft were never reused until the space shuttle (maybe with a couple of exceptions?).  Where as KCT is always reusing your mercury capsules, and cutting out much of the construction time of your next mercury launch.

Share this post


Link to post
Share on other sites

One suggestion I'd have for new missions for RP0:

Define a new resource called 'payload' that's around .5kg/L

Create missions that override the stock satellite contracts, adding a 'payload' resource requirement, and scale reward based off of payload.  

This would add variation to satellite contracts, as you'd no longer be launching the exact same rocket configuration (with whatever science instruments) for a particular mission.  It's a big difference if you need to put 2000kg into GSO vs 50kg.

I'd also add payload requirements to more advanced versions of the sounding rocket contracts, to add more variety to those too.

Share this post


Link to post
Share on other sites
31 minutes ago, Maxsimal said:

One suggestion I'd have for new missions for RP0:

Define a new resource called 'payload' that's around .5kg/L

Create missions that override the stock satellite contracts, adding a 'payload' resource requirement, and scale reward based off of payload.  

This would add variation to satellite contracts, as you'd no longer be launching the exact same rocket configuration (with whatever science instruments) for a particular mission.  It's a big difference if you need to put 2000kg into GSO vs 50kg.

I'd also add payload requirements to more advanced versions of the sounding rocket contracts, to add more variety to those too.

not a bad idea but we have various satellite cores so why not use those as part requirement? some are rather large and I never used them (unless I was up for realistic mission) because it was always possible to achieve the same with much lighter craft.
another option is to add requirement for RCS and at least n-units of RCS fuel left (measured in fuel unit of dV left) to simulate that contractor want a satellite with option to change orbit in future.

Share this post


Link to post
Share on other sites

RP-0 isn't ever going to be completely historically accurate and I don't really think that's the intent anyway.  That's fine since there are contract packs and parts packs that let you be (more) historically accurate already.  I'm not looking for complete historic accuracy.  I'd just like to see more satellite contracts in RP-0.  Even if it's just running the same couple of contracts over and over, that would still be better than what we have right now (IMO, anyway).  And I know there are parts packs you can use to complete some RP-0 contracts (and even some stock contracts) "earlier" than you can with RP-0 alone.  I'd just like to see a couple recurring satellite contracts, especially for the early (post-sounding rocket, pre-Gemini) spaceflight era, so there isn't quite so much repetition when you're not using extra parts or contract packs. 

 

Share this post


Link to post
Share on other sites

Hi, I was just wondering if all the "empty nodes" in the techtree, esp the lower right section, were being worked on and if i can get a group of users together to brainstorm on this?

Making suggestions on hammering out the final nodes in the techtree, placing parts from currently supported mod packs, then doing a part pruning pass to remove duplicates, unsupported and unneeded parts (to clean up parts lists/nodes...ie tons of tanks that could all be replaced with procedural tanks and some added textures) ... is something the user community could actively start assisting with... then moving on to filling any remaining gaps in needed functionality

Dont get me wrong i know many users are currently making suggestions and helping already, but if efforts are focused into 1 or 2 issues at a time we should be able to get some speedy progress on this issue.

 

To that point i suggest and invite others to help brainstorm on the opening issue:  aka "Working with what we have"

1 .parts from currently supported mod pack that are unplaced/unpriced in nodes >> suggestions of where to place them in the techtree

2. then a quick pass to make suggestions to remove the duplicates/unneeded/unsupported parts from tech tree via a prune list 

Doing this should be a big improvement in form and tidiness of the part lists in vab/sph alone, ant then these suggestions can be passed along to dev's/maintainers of RP0 for a check and balance look over then hopefully, implemented. 

once that is done we can tackle any suggestions for "What are we missing that we really need"  An example being "long term habitation/colonization" and "offworld mining"...Porkjets habitat pack (sort of supported??) and thrimms planetary domes (not yet supported??) should take care of most "structures" needed for planetary/orbital bases and the seti greenhouse (not yet supported??) could help make "long term habitation" more feasible.

 

If there are any people that want to help tackle this with me please pm me. 

Share this post


Link to post
Share on other sites
On 11/10/2016 at 7:24 AM, przybysz86 said:

not a bad idea but we have various satellite cores so why not use those as part requirement? some are rather large and I never used them (unless I was up for realistic mission) because it was always possible to achieve the same with much lighter craft.
another option is to add requirement for RCS and at least n-units of RCS fuel left (measured in fuel unit of dV left) to simulate that contractor want a satellite with option to change orbit in future.

That's not bad either - but some of the satellite cores are relatively deep in the tech tree, I'd hope for something that adds variability earlier in the RP0 career.  Plus, there's not THAT much weight variety in the satellite-oriented cores.  You could possibly do the same thing with something like the procedural test weight mod though.  What I'd like is for there to be a range of targets, everywhere from a 10 kg mini sat to some 5 ton behemoth spy sat or heavier.

Share this post


Link to post
Share on other sites

I'm experiencing a bug of mild annoyance when loading up a save game. At random times as I'm thrown into the Space Center the camera just hangs low over the buildings at a very shallow angle looking towards the runway. I cannot change the view, click any building of even exit to the main menu.

It doesn't always happen, but sometimes I have to close and restart the game up to 4 times until it suddenly decides Im now allowed to start playing.

The Alarm Clock window lets me jump to some ship but the camera is stuck there as well and coming back to SC doesn't fix it.

Is that behaviour known to anyone? Think it started back in 1.1.2 and now I'm on 1.1.3 ( with RP-0 and the whole shebang)

Edited by Gannaf

Share this post


Link to post
Share on other sites

@Gannaf yes, it is a stock bug (but haven't encountered it in KSP 1.2.1 yet). One way to fix it from the Space Center view is to:

  • Open the debug menu (Mod + F12).
  • Go to the "Cheats" tab.
  • Press the "Show Input Lock Stack" button.
  • Press the "Clear Input Lock Stack" button.

After that the camera should be set to it's correct position.

Share this post


Link to post
Share on other sites
15 hours ago, przybysz86 said:

is there a mod that does pics like that?

Its a blue print image background, KVV mod and gimp for image editing...all free

Updated blueprint with corrections, breakdown and more details

27aJYnt.png

Edited by Aazard

Share this post


Link to post
Share on other sites
5 hours ago, Gannaf said:

I'm experiencing a bug of mild annoyance when loading up a save game. At random times as I'm thrown into the Space Center the camera just hangs low over the buildings at a very shallow angle looking towards the runway. I cannot change the view, click any building of even exit to the main menu.

It doesn't always happen, but sometimes I have to close and restart the game up to 4 times until it suddenly decides Im now allowed to start playing.

The Alarm Clock window lets me jump to some ship but the camera is stuck there as well and coming back to SC doesn't fix it.

Is that behaviour known to anyone? Think it started back in 1.1.2 and now I'm on 1.1.3 ( with RP-0 and the whole shebang)

I normally encounter this problem when I start KSP, choose to resume my last save, then tab out of KSP while that save is loading.  If I leave KSP in the foreground and wait until the load completes before tabbing out, it loads up correctly.

Share this post


Link to post
Share on other sites

Hi guys,

Dont know if this is the right way to ask, but after quite some time on KSP, I'm trying to install RP-0. First time with CKAN too.

When installing, I get following error:

 

Quote


It looks like you're trying to install a mod which is already installed,
or which conflicts with another mod which is already installed.

As a safety feature, the CKAN will *never* overwrite or alter a file
that it did not install itself.

If you wish to install FerramAerospaceResearch 3:0.15.7.2 via the CKAN,
then please manually uninstall the mod which owns:

Ships/@thumbs/VAB/FAR Shuttle 'Montauk'.png

and try again.

Your GameData has been returned to its original state.

 

I understand what all this means, but do not know how to solve it without installing all mods manually. Any advice?

Share this post


Link to post
Share on other sites
28 minutes ago, Garlik said:

Hi guys,

Dont know if this is the right way to ask, but after quite some time on KSP, I'm trying to install RP-0. First time with CKAN too.

When installing, I get following error:

 

 

I understand what all this means, but do not know how to solve it without installing all mods manually. Any advice?

I think you can remove the problematic file (delete it or move to another folder outside KSP ) and it should go. Basically CKAN do not "add or replace" for all required files but just "add" and if it sees file already exists it exits with error - at least that's my understanding.

Share this post


Link to post
Share on other sites
On 13.11.2016 at 8:10 PM, Phineas Freak said:

@Gannaf yes, it is a stock bug (but haven't encountered it in KSP 1.2.1 yet). One way to fix it from the Space Center view is to:

  • Open the debug menu (Mod + F12).
  • Go to the "Cheats" tab.
  • Press the "Show Input Lock Stack" button.
  • Press the "Clear Input Lock Stack" button.

After that the camera should be set to it's correct position.

Thank you for the clarification. I'll see if that helps next time :)

Share this post


Link to post
Share on other sites

is there a tool to display RCS Dv and TWR? rcs build aid doesnt seem to have this function in rss/ro/rp0

Share this post


Link to post
Share on other sites

Hi,

On 15/11/2016 at 6:33 AM, Aazard said:

is there a tool to display RCS Dv and TWR? rcs build aid doesnt seem to have this function in rss/ro/rp0

This is a known bug in RCS build aid (issue #13), this happens with all other propellant than stock monopropellant, and I'm not sure that will be soon fixed.

 

Else, people who want to fix the Weather Satellite Contracts before the release of the next RP-0 version, download this file :

https://raw.githubusercontent.com/hargn/RP-0/fix/GameData/RP-0/Contracts/Satellite/WeatherContracts.cfg

And replace the WeatherContracts.cfg in you GameData/RP-0/Conctracts/Satellite folder.

Edited by hargn

Share this post


Link to post
Share on other sites

hi folks, I have a problem/question(/bug?)

I have RP-0 installed with its dependencies (including RemoteTech, I disabled signal delay and enabled the antenna control 'cheat')

I build a rocket with the mk1-2pod, and for unmanned tests, I added an octo probe core.

That worked for the mk1-pod (mk1-pod + octo probe core).

But now it doesn't: I have control as long as it is connected to the launch clamps, I start the engines everything ok.

But when I decouple the clamps, I loose control. In The topleft it says "connected".

I checked the log, it only says "Liftoff". I have enough avionics.

The throttle is set to 0 (as I set it up in remote tech) and I cannot pitch/yaw/roll (no movement in the topleft).

vecV0CW.jpg

ksp 1.1.3

RT 1.7.1

RO 11.3.2 (everything is as new as ckan letz me with ksp1.1.3)

 

Any idea, Thank you

Edit: I tried disabling RemoteTech (ingame) then I can not control it either, this bugs me. I guess its not about RemoteTech then.

Edited by nablabla
more info

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.