Sign in to follow this  
Duracelle

[0.90] Working Multiple Star Systems(WITH PLANETS!)

Recommended Posts

Im having a ton of issues with conflicts of other mods. Im running windows 8.1. I can get planet factory to work, but at the cost of not being able to use a lot of other mods. Using CKAN mod manager or even installing mods manually, this mod breaks the game on certain mods. As of now, when I install Mech Jeb, KW rocketry to name a few, the game breaks. I installed this mod first, then loaded up one or two mods, started the game, and once everything loads, its CTD. Im not complaining, just letting you know that this mod is not playing nice with a lot of other mods on my computer. Ive spent about 3 hours installing mods one at a time and trying many different things and to no luck.

Good to know. I've only tested with a limited range, and unfortunately don't know enough to do mod compatibility.

it does work with b9, ATM, interstellar, and better atmospheres. That's all I know for sure :(

Share this post


Link to post
Share on other sites
Good to know. I've only tested with a limited range, and unfortunately don't know enough to do mod compatibility.

it does work with b9, ATM, interstellar, and better atmospheres. That's all I know for sure :(

Its really weird though... Say with KW and MechJeb, It was crashing really badly, but then reloading the game a few times, it finally clicked.... I dunno what to tell you other than I have had a ton of issues with this mod playing with others. Wish I could help more with problem solving but these types of issues are really hard to narrow down.

Share this post


Link to post
Share on other sites

I had problems installing this for some reason, but now that I finally got it to work, and to play nicely with the other mods I have, it works fine.

Great mod, good job.

Share this post


Link to post
Share on other sites
I had problems installing this for some reason, but now that I finally got it to work, and to play nicely with the other mods I have, it works fine.

Great mod, good job.

Thanks!

What at have you issues? I've seen a few people have install issues that eventually got fixed. I'd love to try and address the problem if possible!

Share this post


Link to post
Share on other sites

The install itself was easy enough (since KSP is so easy to mod), and ATM worked fine when I first started to boot it up, but after that initial hour-long boot up process I checked the map and didn't see any of the other planets. I went to the VAB and launched a stock ship and then reverted to see if it just needed to boot up the universe but that didn't fix it.

Then I re-installed this mod, leaving the ATM intact, and I got a CTD error.

I tried to load again just to see if it needed the initial failure to load and got another CTD.

I re-installed this mod again and removed ATM and then started again, and I got another CTD.

I then removed all of my mods and added only this mod, which caused the game to load with a stock system.

I found another download source (I started with the Curse download I think, but don't quote me on that) and re-downloaded the file, which apparently was a different file (WinRar named it the same, but didn't put a (1) after it to indicate a copy of the same file), and loaded the system, which was then the new version.

I added back all of my mods except the 'Near Future' set of mods, since I haven't played with Near Future enough to vouch for their stability, and loaded the system, getting into the game successfully.

Finally I re-installed the 'Near Future' set and loaded the modded system successfully.

Honestly, I think that the problem was a combination of a bad download/install (I'm not going to discount user error) and Near Future acting up. I can PM you the crash files if you'd like, but I doubt they would tell you much.

Share this post


Link to post
Share on other sites
The install itself was easy enough (since KSP is so easy to mod), and ATM worked fine when I first started to boot it up, but after that initial hour-long boot up process I checked the map and didn't see any of the other planets. I went to the VAB and launched a stock ship and then reverted to see if it just needed to boot up the universe but that didn't fix it.

Then I re-installed this mod, leaving the ATM intact, and I got a CTD error.

I tried to load again just to see if it needed the initial failure to load and got another CTD.

I re-installed this mod again and removed ATM and then started again, and I got another CTD.

I then removed all of my mods and added only this mod, which caused the game to load with a stock system.

I found another download source (I started with the Curse download I think, but don't quote me on that) and re-downloaded the file, which apparently was a different file (WinRar named it the same, but didn't put a (1) after it to indicate a copy of the same file), and loaded the system, which was then the new version.

I added back all of my mods except the 'Near Future' set of mods, since I haven't played with Near Future enough to vouch for their stability, and loaded the system, getting into the game successfully.

Finally I re-installed the 'Near Future' set and loaded the modded system successfully.

Honestly, I think that the problem was a combination of a bad download/install (I'm not going to discount user error) and Near Future acting up. I can PM you the crash files if you'd like, but I doubt they would tell you much.

Yeah, that won't tell me much, I wouldn't understand them, lol.

I'll check the downloads. Maybe curse uploaded weird.

Share this post


Link to post
Share on other sites

So....I've been keep intermitant tabs on star systems for a while now, but I've been out of the loop for a while. There is still a v.07 thread kicking around. Is this an official continuation of that project? Is this a repeat of the agustus take over attempt?

Share this post


Link to post
Share on other sites
So....I've been keep intermitant tabs on star systems for a while now, but I've been out of the loop for a while. There is still a v.07 thread kicking around. Is this an official continuation of that project? Is this a repeat of the agustus take over attempt?

Medsouz has taken over star systems, he's updated it for 0.90 and is maintaining it. This is just an aggregate mod that takes some Planet factory stuff, builds up some solar systems and distributes it as a single package, with edited .cfgs

people were looking for a single instal package, so I took the two(with creator permission, Medsouz even helped me) and pushed this out. Content is still PF+Star systems. This is just a distribution of my configuration

Share this post


Link to post
Share on other sites

So a few questions;

I take it what I gain by downloading this over medsouz v.07 is that it has some solar systems with their own planets? Are these planets your original creations? Are they the stock solar system + two new ones to explore?

And if I were to download this distro and follow this thread would I be safe in assuming that it will continue to use the latest version of the star systems plugin?

I appreciate your effort, as I don't even know how to do what you've done so far. I'm asking all the questions because I'm trying to craft myself the perfect career experience for .90 with all the recently updated mods. I'm running 60+ mods most of which are pluggins only. So far I'm pretty stable, in win 8.1 32 bit. I am not using NFT or KSPIneterstellar. I am mainly stick with roverguy's suite of mods and others to enhance playablity, difficulty and such. I'll be using his warp and fusion drives for interstellar travel. I'd like to still remain with the stock solar system to start though, as there are many tools and guides available to help the intrepid explorer.

Thank you for your time.

Edited by Errol
spelling

Share this post


Link to post
Share on other sites
So a few questions;

I take it what I gain by downloading this over medsouz v.07 is that it has some solar systems with their own planets? Are these planets your original creations? Are they the stock solar system + two new ones to explore?

tgat is what will happen, however plant art is from Kragathea(All of corbos planets) and Dooz(all of Dolas' planets) the characteristics orbits and layouts have been modified by me. My only real contribution was managing to get it working with the career mode

And if I were to download this distro and follow this thread would I be safe in assuming that it will continue to use the latest version of the star systems plugin?

yes. I will keep that plug in up to date. Also down the road, port the planets to kopernicus when it seems stable enough for a hack like me to muck in

I appreciate your effort, as I don't even know how to do what you've done so far. I'm asking all the questions because I'm trying to craft myself the perfect career experience for .90 with all the recently updated mods. I'm running 60+ mods most of which are pluggins only. So far I'm pretty stable, in win 8.1 32 bit. I am not using NFT or KSPIneterstellar. I am mainly stick with roverguy's suite of mods and others to enhance playablity, difficulty and such. I'll be using his warp and fusion drives for interstellar travel. I'd like to still remain with the stock solar system to start though, as there are many tools and guides available to help the intrepid explorer.

Thank you for your time.

this retains the stock system untouched, so the changes are all late game. You may find roverdude's warp drive a touch slow, but it is a fantastic mod. You can edit its warp factor up to I think 10 or 11 before it starts scattering you across deep space. If you are running close to your RAM limit after this, I'd recommend conventional rocketry and a 60year long voyage instead of burning a warp drive the whole way. Even interstellar's drive takes a day and a half at top speed to reach the closest star

i hope you enjoy it though!

Share this post


Link to post
Share on other sites

I kind of like that rover's warp is a touch slow.....I think it would be fun to plan a generational kolonization mod that has the resources to stop, recharge the exotic matter and then keep going on the same course. I'll be using karborundum for my dV changes after getting there in a bit less time then a conventional burn. I'm going to download this and add it to a cloned ksp .90 install to try out. I'm going to start with a simple voyager style exploration mission, which should be fiendishly difficult with KCT, RT, TACLS, FAR and DR. At least if I make it I'll be able to simulate from those SOIs with KCT....I hope...

Share this post


Link to post
Share on other sites
I kind of like that rover's warp is a touch slow.....I think it would be fun to plan a generational kolonization mod that has the resources to stop, recharge the exotic matter and then keep going on the same course. I'll be using karborundum for my dV changes after getting there in a bit less time then a conventional burn. I'm going to download this and add it to a cloned ksp .90 install to try out. I'm going to start with a simple voyager style exploration mission, which should be fiendishly difficult with KCT, RT, TACLS, FAR and DR. At least if I make it I'll be able to simulate from those SOIs with KCT....I hope...
sounds awesome! post pictures!

Share this post


Link to post
Share on other sites

Just need to find a mod that adds gold plated records to ksp....

But on a serious note, those pics might not be for a little bit. I'm playing through career now with all these mods, and I'm not too inclined to spend game time not advancing my career by playing sandbox. I am interested in perhaps posting a few pics of a stock install with distant object enhancement, this mod and some telescope mods installed and see if I can catch a glimpse of a planet around another sun. That would be both relevant and interesting. Just need to figure out if all three work together...

Edited by Errol
spelling

Share this post


Link to post
Share on other sites

I do love this mod, but I seem to have stability issues with it. I was playing with it just fine in career mode, when suddenly I CTDed when clicking on the VAB to go build a rocket. After that, I tried to start it again several times but CTDed on startup. Removing the mod stopped the CTDs, and re-adding it started them again.

I'm not sure what about the mod + 5 or 6 hours playtime causes CTDs, but it does happen to me for some reason.

I will keep an eye on this mod since I love it, but I'm going to have to remove it to play :P

I do have the following other mods installed- ATM, Crossfeed Enabler, Enhanced Nav Ball, FAR, Kerbal Engineer, My mod (Only Flags), KW rocketry, Navyfish docking port alignment indicator, Near Future Construction/Electrical/Propulsion/Solar,

Taurus Capsule, Stage Recovery

Stage Recovery was the most recent mod added (and it was the only mod added after multiple star systems was installed)

Thanks for the great work, and I hope I'll be able to use it in the future.

Share this post


Link to post
Share on other sites

This mod works fine for Module Manager 2.5.4, but the other stars just disappear when I use 2.5.6.

Anyone else getting this problem?

(Using 64 bit ksp on linux)

Share this post


Link to post
Share on other sites
This mod works fine for Module Manager 2.5.4, but the other stars just disappear when I use 2.5.6.

Anyone else getting this problem?

(Using 64 bit ksp on linux)

Yes, I'm having the the same issue with MM 2.5.6 on windows an 32 bit.

Took me some time to find out it was MM that caused this issue.

Havent tested it further but if I encounter any problems with MM 2.5.4 I'll let you know.

Share this post


Link to post
Share on other sites

I can't get this mod to work. I did everything the install instructions told me to do. I have active texture mangment mod already, I put it in my game folder. It loaded on the load screen. I made sure it was checked but when it loaded only the kerbin system showed up and on the tracking station when I zoomed out to try and find it, it was like I hit a wall, it started flashing. Anyone have any idea why it didn't work?

Share this post


Link to post
Share on other sites
I can't get this mod to work. I did everything the install instructions told me to do. I have active texture mangment mod already, I put it in my game folder. It loaded on the load screen. I made sure it was checked but when it loaded only the kerbin system showed up and on the tracking station when I zoomed out to try and find it, it was like I hit a wall, it started flashing. Anyone have any idea why it didn't work?

Thats related to the MM Issue _SeanF_ described two posts above yours.

You need to use the ModuleManager Version 2.5.4 that comes within the pack.

Share this post


Link to post
Share on other sites

I just added another star system to Planet Factory Revived, if anyone wants working multiple stars, planets, and an updated ModuleManager...

Share this post


Link to post
Share on other sites

As soon as I hit launch from the VAB it puts my ship at 13599059239.8587 from blacky karman with no controls whatsoever and I have tried reverting to launch and VAB but it still deposits me in the void of blacky karman. How can i fix this.

Share this post


Link to post
Share on other sites
As soon as I hit launch from the VAB it puts my ship at 13599059239.8587 from blacky karman with no controls whatsoever and I have tried reverting to launch and VAB but it still deposits me in the void of blacky karman. How can i fix this.

I think this is a common problem, but I think I may have found a solution (at least, it's working for me with this and 2 dozen other mods installed, so it seems stable enough):

When loading the game, before you enter the VAB or SPH or launch anything, open up the Tracking Station and just look at that for the second it takes it to center on Kerbin. Close out of that and then go into the VAB or whatever else. And any other time you start to repeat-launch into Blacky Karman, go back to the Space Center and open the Tracking Station from the Center (ie don't use a quick button or just open the Map, actually go back to the full Space Center and then go to the Tracking Station). That has worked for me so far.

@Duracelle: With this in mind, is it possible that info could help point out why the bug exists in the first place? Maybe sometimes the game sees Blacky Karman as the center of the universe and focuses on that instead of on Kerbin as a default location and spawns the ships inside of it, but opening the Tracking Station reminds the game that Mission Control on Kerbin should be the focus, which fixes it?

Share this post


Link to post
Share on other sites

I have a strange problem now, at first this mod worked, but i made a mistake with EVE and i had to reinstall the game.

Now i can't get this mod to work, i have the absolute same other mods as before!

When i now go into map view and scroll out, the screen will just start to shake more and more but there are no other planets. What do i do wrong now? i just can't get it to work again :(

Edit: I don't have EVE now, but it is not needed, right?

The Game also does not use more RAM with this mod active, what is quite strange, but the Plant factory window pops up with both systems in it.

Edit:Fixed it now, for whatever reason i now need Modulemanager 2.5.4, it won't work with only .8

Next Problem, the texture reduction mod doesn't work for the Planet Factory folder (there's no cache folder for it), so the mod needs ~1GB Ram alone. All my other mods use not even half of that, despite beeing over 1,5GB together and this mod only having 150MB. Any way to make it work for the PF folder too?

Edited by coolmodi

Share this post


Link to post
Share on other sites

I'm having the same problem as FatherLawrence. I install the mod, and I launch fine. But as soon as I do a second launch I'm deposited into the orbit of 'ol Blacky. Throttle controls work, but no pitch, yaw, rotation, staging or eva. I can still revert, though.

Suggestions?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this