Sign in to follow this  
Duracelle

[0.90] Working Multiple Star Systems(WITH PLANETS!)

Recommended Posts

In case anyone is playing with Boris Interstellar 0.90 Mod and it playing this Mod as well and having issues with Radaition generating exceptions, I made a KSPI Extended patch which fixes this problem is and add other configuration setting and options as well.

Edited by FreeThinker

Share this post


Link to post
Share on other sites
@Duracelle: With this in mind, is it possible that info could help point out why the bug exists in the first place? Maybe sometimes the game sees Blacky Karman as the center of the universe and focuses on that instead of on Kerbin as a default location and spawns the ships inside of it, but opening the Tracking Station reminds the game that Mission Control on Kerbin should be the focus, which fixes it?

After a bit of testing, I can confirm that this is the case. The bug is caused by the game setting "Focus: Blacky Karman", but opening the Tracking Station (temporarily) resets "Focus: Kerbin". Moving between different buildings can change it back to Blacky Karman (e.g. Astronaut Center->Mission Control) but as long as you open the Tracking Station immediately before launching you will be okay (i.e. Build ship in VAB, exit to Space Center, open Tracking Station, go back to Space Center, and use the Launchpad to launch your ship).

I've done this in career and sandbox with about forty other mods and by itself, with at least a couple hundred launches and the only time I drop into the Black Hole is when I forget to visit the Tracking Station first.

Share this post


Link to post
Share on other sites

This mod can become BIG, if it only had a Github branch. People would commit and help with code and bug fixes.

Share this post


Link to post
Share on other sites
This mod can become BIG, if it only had a Github branch. People would commit and help with code and bug fixes.

This mod is just a combination of 3 mods. The real Star Systems mod is here. And that has a source on GitHub.

Share this post


Link to post
Share on other sites

This seems like an interesting mod....should I be able to get it to work. Regardless, thanks for the effort.

I'm almost certain it's installed correctly. I get the systems checkbox on startup. In the Tracking Station or when flying a mission, I can zoom way out. Then the stars shake. However, none of the systems show up when I do. Maybe I'm missing some necessary component?

Looking at this thread (and at the .zip) seems ModuleManager is included....

I have a lot of other mods installed, though a fresh install with none of them would make me die a little inside, but I might do it, but only if I have to. Current mods:

ATM

BoulderCo (nice place, I did my grad school there) which was included in this mod

Impossible Innovations

KW Rocketry

Landing Height

MechJeb

NASAMission (this was part of KW?)

PlanetFactory (I believe this was also included in this mod)

Protractor (I could dump this, MechJeb does a better job of everything here)

Star Systems (again, included)

TechManager

TreeLoader

TweakScale

WarpPlugin

Some of these are pretty obviously part of KSPI.

One thing I did notice was multiple versions of ModuleManager.dll in my GameData directory, and it looks like 2.5.4 was included in WMSS. Not sure if there's some contention there.

ModuleManager.2.5.0.dll

ModuleManager.2.5.4.dll

ModuleManager.2.5.6.dll

ModuleManager.ConfigCache

ModuleManager.ConfigSHA

ModuleManagerREADME.md

Thoughts? Tips? Humiliation directed at me?

Cheers,

-BS

Share this post


Link to post
Share on other sites
This seems like an interesting mod....should I be able to get it to work. Regardless, thanks for the effort.

I'm almost certain it's installed correctly. I get the systems checkbox on startup. In the Tracking Station or when flying a mission, I can zoom way out. Then the stars shake. However, none of the systems show up when I do. Maybe I'm missing some necessary component?

Looking at this thread (and at the .zip) seems ModuleManager is included....

I have a lot of other mods installed, though a fresh install with none of them would make me die a little inside, but I might do it, but only if I have to. Current mods:

ATM

BoulderCo (nice place, I did my grad school there) which was included in this mod

Impossible Innovations

KW Rocketry

Landing Height

MechJeb

NASAMission (this was part of KW?)

PlanetFactory (I believe this was also included in this mod)

Protractor (I could dump this, MechJeb does a better job of everything here)

Star Systems (again, included)

TechManager

TreeLoader

TweakScale

WarpPlugin

Some of these are pretty obviously part of KSPI.

One thing I did notice was multiple versions of ModuleManager.dll in my GameData directory, and it looks like 2.5.4 was included in WMSS. Not sure if there's some contention there.

ModuleManager.2.5.0.dll

ModuleManager.2.5.4.dll

ModuleManager.2.5.6.dll

ModuleManager.ConfigCache

ModuleManager.ConfigSHA

ModuleManagerREADME.md

Thoughts? Tips? Humiliation directed at me?

Cheers,

-BS

delete al your ModuleManager.dll 's and install 2.5.9

Share this post


Link to post
Share on other sites
Thanks, tried that, but no dice. Other systems still aren't there.

Cheers,

-BS

Well then I'll need the output_log. This file is found in the folder 'KSP_Data'

Share this post


Link to post
Share on other sites
Well then I'll need the output_log. This file is found in the folder 'KSP_Data'

Hmm....that file doesn't seem to exist under my KSP installation, but the folder does. I did a 'find . -name "*.log"' under my KSP root, and only came up with KSP.log in the root folder. Looking at it I'm going to assume it's the same thing.

I'm on Linux Mint 17.1, using x86_64 binaries.

One other possible relevant piece of information that might affect logging: I installed the game through Steam, but I no longer launch it that way. Pain launching Steam every time I wanted to play the game so I just created a 'ksp' alias that points to KSP.x86_64 under ~/.local/share/Steam/SteamApps/common/Kerbal Space Program

Originally the KSP.log was dated 12/16, but I tried launching it through Steam again, and got an updated KSP.log.

Okay, I'm an idiot. How do you include an attachment that's not a link, image, video, or SketchFab? I tried to use the CODE tag, but it choked on the 4.2MB log.

Cheers,

-BS

- - - Updated - - -

One other thing, is there a MM version mismatch here?


[LOG 16:00:49.531] Load(Assembly): /ModuleManager.2.5.9
[LOG 16:00:49.532] AssemblyLoader: Loading assembly at /home/user/.local/share/Steam/SteamApps/common/Kerbal Space Program/GameData/ModuleManager.2.5.9.dll
[LOG 16:00:49.553] AssemblyLoader: KSPAssembly 'ModuleManager' V2.5

...

[EXC 16:00:51.472] FileNotFoundException: Could not load file or assembly 'ModuleManager.2.5.4, Version=2.5.4.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

It looks like it's loading MM 2.5.9, but something is looking for 2.5.4.

Thanks,

-BS

Share this post


Link to post
Share on other sites

I'm getting the exact same error with completely different mods:

Toolbar

USITools

ATM

BoulderCo

CommunityResourcePack

Engineer

EVE

ExtraplenetaryLaunchpads

Firespitter

KAS

MagicSmokeIndustries

NASAMission (that's the 3.75m parts that came with the asteroid update btw)

NavyFish

PlanetFactory

Regolith

StageRecovery

StarSystems

TriggerTech

TweakScale

UmbraSpaceIndustries

ModuleManager 2.5.9

I'm also getting that line of error in my output though

FileNotFoundException: Could not load file or assembly 'ModuleManager.2.5.4, Version=2.5.4.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

Here's a link to my whole file though:

http://www./view/7xys1q14js7scub/output_log(2).txt

Edited by Syhrus

Share this post


Link to post
Share on other sites

I restarted KSP, and got mostly similar, but slightly different errors this time. Looks like it choked on one of the planets in both instances, namely, Ablate. The MM version errors are still there.


[LOG 23:42:37.767] Loading System:Kaiser
[LOG 23:42:37.767] Loading Body:Kaiser
[LOG 23:42:37.767] Loading Body:Kunar
[LOG 23:42:37.768] Loading Body:Don
[LOG 23:42:37.768] Loading Body:Polo
[LOG 23:42:37.768] Loading Body:Jabin
[LOG 23:42:37.769] Loading Body:CZF30
[LOG 23:42:37.771] Error creating planet Ablate
[LOG 23:42:37.771] Exception:The given key was not present in the dictionary.
[EXC 23:42:37.771] NullReferenceException: Object reference not set to an instance of an object
PlanetFactory.PlanetFactory.OnLevelWasLoaded (Int32 level)
[LOG 23:42:37.776] AddonLoader: Instantiating addon 'ActiveTextureManagement' from assembly 'ActiveTextureManagement'
[LOG 23:42:37.809] The SpaceNavigator driver is a Windows-Only feature at the moment.
[LOG 23:42:38.701] Agent: Found 18 agent mentality types
[LOG 23:42:38.702] AgentList: 27 agents parsed and loaded.
[LOG 23:42:38.705] getObtAtUT result is NaN! UT: 0
[LOG 23:42:38.706] ObT : NaN
M : NaN
E : NaN
V : NaN
Radius: NaN
vel: [NaN, NaN, NaN]
AN: [0.20791169081776, 0.978147600733806, 0]
period: Infinity


[EXC 23:42:38.708] NullReferenceException: Object reference not set to an instance of an object
ActiveTextureManagement.ActiveTextureManagement.SetupLoaders ()
ActiveTextureManagement.ActiveTextureManagement.Start ()
[EXC 23:42:38.709] FileNotFoundException: Could not load file or assembly 'ModuleManager.2.5.4, Version=2.5.4.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

-BS

Share this post


Link to post
Share on other sites

FIXED:

Installed module manager 2.5.4 and everything works fine now.

It sounds like something is hard coded to be dependent on that version, so using 2.5.9 causes issues

Share this post


Link to post
Share on other sites
Hmm....that file doesn't seem to exist under my KSP installation, but the folder does. I did a 'find . -name "*.log"' under my KSP root, and only came up with KSP.log in the root folder. Looking at it I'm going to assume it's the same thing.

I'm on Linux Mint 17.1, using x86_64 binaries.

For future reference, the Linux version of the output log is called “player.log†and is located in /home/user/.config/unity3d/Squad/Kerbal Space Program

Share this post


Link to post
Share on other sites
FIXED:

Installed module manager 2.5.4 and everything works fine now.

It sounds like something is hard coded to be dependent on that version, so using 2.5.9 causes issues

glad that fixed it for you, weird that some mod uses a hardcoded MM file

Share this post


Link to post
Share on other sites

Thanks for the location of the log file. Unlike KSP.log, though, the log entries aren't timestamped, so I'm not sure when they were generated.

I think the offending file for requiring 2.5.4 is GameData/StarSystems/Plugins/StarSystems.dll - seems to have the text in there. I did try editing that (binary file) to 2.5.9 where the text appeared, but didn't help. I got more error messages about both 2.5.4 and 2.5.9.

I tried replacing the ModuleManager dll with 2.5.4. Same problem, no new systems show up. Running through Steam, it doesn't look like it's choking on any specific planet anymore, though. But it hangs. See link to KSP.log below for Steam version

https://drive.google.com/file/d/0ByKJkpmLjsbmNkZUY2tjOUdxRHM/view?usp=sharing

Oddly, when I run it through Steam, it hangs after it's loaded everything. If I just use my alias to run the executable directly, it doesn't hang, but no star systems. The log is different when I run it directly rather than through Steam, direct it chokes on Ablate again. Some environment thing? See below for non-Steam execution.

https://drive.google.com/file/d/0ByKJkpmLjsbmR3RTbzRMRzVXUlE/view?usp=sharing

Scratching my head,

-BS

Share this post


Link to post
Share on other sites
Well when ksp can use unlimited RAM, i will be getting this!!!!

I've been praying someone could find a way to make multiple solar systems in the fashion this mod does using KopernicusTech. We could have a handful of solar systems with dozens of new planets and moons! :D

*hype intensifies*

Share this post


Link to post
Share on other sites

Well, I got desperate, and installed everything from scratch (saving off the old installation).

I can see the other star systems now after installing just ATM and WMSS. Looks like Kerbol and the other two systems orbit the black hole?

I'll have to start loading the other mods I deem necessary and see if it breaks somewhere therein.

Cheers,

-BS

Share this post


Link to post
Share on other sites

duracelle, you've gone from humble, interesting little mod to full-flung coolness with this sh*t. awesome to see the progress

Share this post


Link to post
Share on other sites

First off, thanks so much for creating this mod. It's a great addition when you get tired of the Kerbol system. Needs a little polishing, but once you get the mod actually working, it certainly adds to the exploration side of things.

As far as the launch leaving the vessel in some sort of weird, space-like limbo, I had to go back to the VAB, exit the VAB, go to Tracking Station, then go back to VAB and launch again. Simply reverting to the VAB didn't work. YMMV.

A few other questions/comments:

1) Is there some sort of Wiki or other documentation for the stars and planets around the other systems? Like the information on the KSP Wiki for the default celestial bodies? Or is that something that we're supposed to discover? Or read the config files? I'm not aware of any in-game way to determine this.

2) An oddity, around some of the planets in the extra systems, a further out orbit by a vessel seems to sometimes overtake an inferior orbit. I'm making an educated guess that the spacecraft orbit is determined by game physics, but the orbits of celestial bodies are part of the static config? I dunno, I see the six orbital parameters plus the epoch reference in the .cfg, I suppose those plus the mass of the parent body should determine the orbit through physics. Am I imagining things?

I suppose surface textures for DEFAULT are at some point planned....

Again, great mod.

Cheers,

-BS

Share this post


Link to post
Share on other sites

I really would love for this to happen in kopernicus.

I just simply don't have the time, skill or patience to take it much further than this.

if people want to port it PLEASE, PLEASE, PLEASE do. I would love you forever, and used it every day.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this